15:00:08 <bswartz> #startmeeting manila
15:00:09 <openstack> Meeting started Thu Jul 27 15:00:08 2017 UTC and is due to finish in 60 minutes.  The chair is bswartz. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:13 <openstack> The meeting name has been set to 'manila'
15:00:22 <bswartz> hello all
15:00:23 <tbarron> hi
15:00:24 <gouthamr> hello o/
15:00:31 <xyang2> hi
15:00:33 <vponomaryov> Hello
15:00:40 <ganso> hello
15:00:52 <dustins> \o
15:00:55 <bswartz> #topic announcements
15:01:13 <bswartz> hopefully it's not news to anyone that today is the feature freeze
15:01:29 <bswartz> there's a few things left to wrap up, more on those later
15:01:59 <bswartz> reminder that next week, Wednesday 2 August is our bug squash day
15:02:37 <bswartz> the official schedule has our RC-1 target in 2 weeks
15:02:43 <bswartz> #link https://releases.openstack.org/pike/schedule.html
15:03:12 <bswartz> so without further ado, let's dive into the agenda
15:03:15 <toabctl> hi
15:03:23 <bswartz> #agenda https://wiki.openstack.org/wiki/Manila/Meetings
15:03:29 <bswartz> #topic Feature Freeze
15:03:36 <bswartz> #link https://launchpad.net/manila/+milestone/pike-3
15:03:55 <bswartz> so LP is unfortunately not caught up to date with reality
15:04:03 <bswartz> many of these BPs are implemented
15:04:08 <bswartz> I haven't had time to go through them all and fix them
15:04:36 <bswartz> aside from IPv6 and ensure share, what is still left to be workflowed?
15:05:45 <gouthamr> https://review.openstack.org/#/c/468899/ failed at the gate..
15:05:46 <gouthamr> ^ that's the last of share groups stuff
15:06:25 <tbarron> https://etherpad.openstack.org/p/pike-manila-code-review-focus s/b up to date
15:06:26 <bswartz> what's py27dj19 and py27dj110?
15:06:40 <tbarron> django versions
15:07:13 <tbarron> not too long ago these passed so the question is whether the
15:07:18 <tbarron> failure is due to the patch
15:07:28 <zhongjun> Could we continue to work on ensure share feature
15:07:30 <vponomaryov> failure is due to django ==1.11
15:07:48 <bswartz> smh
15:07:55 <tbarron> vponomaryov: so we would fail w/o the patch
15:07:58 <bswartz> why does the django version matter so much?
15:08:03 <vponomaryov> tbarron: I suspect yes
15:08:13 <vponomaryov> bswartz: major version has been changed
15:08:51 <tbarron> we get caught by this stuff in UI b/c CI is patch driven and patches are sparse over time
15:09:14 <bswartz> 1.10 -> 1.11 isn't a major version, it's a minor version
15:09:20 <bswartz> why didn't they call it 2.0?
15:09:49 <vponomaryov> bswartz: not sure, I know that mnor versions are third part
15:09:57 <vponomaryov> s/mnor/minor/
15:10:10 <vponomaryov> like in latest django version which 1.11.3
15:10:17 <bswartz> why does django feel okay with breaking users on a version update?
15:10:53 <vponomaryov> bswartz: actually, it is expected that some features appear and some disappear
15:11:00 <vponomaryov> we support 1.9 and 1.10
15:11:04 <vponomaryov> but not 1.11 yes
15:11:08 <vponomaryov> s/yes/yet/
15:11:21 <bswartz> maybe I'm just old fashioned, but I remember when backwards compatibility was something people cared about
15:11:48 <bswartz> okay well what does u-c for pike say about django?
15:12:21 <vponomaryov> bswartz: Django>=1.8,<2.0
15:12:44 <vponomaryov> https://github.com/openstack/requirements/blob/cd180a84/global-requirements.txt#L35
15:13:41 <bswartz> so this is something we have to fix then right?
15:13:49 <vponomaryov> yes
15:14:02 <bswartz> does anyone know how significant the breakage is?
15:14:33 <vponomaryov> i guess, it is better to ask Horizon guys
15:14:36 <bswartz> I see 22 error out of 174 tests
15:14:40 <tbarron> presumably this is being fixed as well in main horizon code
15:14:51 <tbarron> or was recently fixed
15:15:03 <bswartz> AttributeError: 'module' object has no attribute 'ChoiceFieldRenderer'
15:15:23 <bswartz> NoReverseMatch: None is not a registered namespace
15:15:26 <vponomaryov> looks like our master works -> http://logs.openstack.org/00/487900/1/check/gate-manila-ui-python27-ubuntu-xenial/eecaf7e/
15:15:36 <vponomaryov> and it is question of only my patch then
15:15:37 <bswartz> those are the only 2 errors I see
15:15:53 <bswartz> repeated several times
15:16:26 <bswartz> okay well let's table this UI issue and move on
15:16:40 <bswartz> vponomaryov are you going to follow up and see what we can do to push this patch in today?
15:17:24 <vponomaryov> bswartz: will try and inform you about investigation results
15:17:36 <bswartz> I'd really like to have it in pike
15:17:37 <bswartz> ok
15:17:47 <bswartz> so regarding IPv6
15:18:05 <bswartz> we have these 2 patches:
15:18:07 <bswartz> #link https://review.openstack.org/#/c/328932/
15:18:34 <bswartz> #link https://review.openstack.org/#/c/357320/
15:18:52 <bswartz> oh wait, that last one is abandoned
15:19:13 <bswartz> just the client patch
15:20:17 <bswartz> is anyone currently looking at the ipv6 client patch?
15:21:07 <bswartz> I'll take that as a no...
15:21:18 <zhongjun> https://review.openstack.org/#/c/328932
15:21:44 <bswartz> markstur, gouthamr, vponomaryov, you've all had previous reviews here
15:21:56 <bswartz> oh tbarron too
15:22:15 <tbarron> i'm looking again now, it has been a bit but mostly looks like rebasing
15:22:15 <gouthamr> bswartz: i can take a look right after this meeting
15:22:20 <gouthamr> tbarron: https://review.openstack.org/#/c/468277/19
15:22:52 <bswartz> thanks
15:22:58 <gouthamr> we've three conflicts to resolve and all three patches can get in
15:23:00 <bswartz> okay that leasts ensure-share
15:23:00 <tbarron> gouthamr: will look
15:23:08 <tbarron> and like-filter
15:23:19 <bswartz> we previously agreed that ensure share was lower priority
15:23:48 <bswartz> I personally would like to revisit it in queens
15:24:03 <bswartz> and the current patch seems to be failing jenkins
15:24:22 <bswartz> any objection to pushing it out now?
15:24:40 <gouthamr> personally haven't looked at it... agree with tbarron and bswartz
15:24:51 * bswartz checks to make sure zhongjun is here
15:25:12 <bswartz> oh I see zhongjun
15:25:24 <bswartz> zhongjun: what do you mean continue to work on it? you mean try to get it in today?
15:25:28 <zhongjun> Not actually failing now
15:25:42 <tbarron> i don't think we've had enough review attention to this patch to do it in pike
15:25:44 <gouthamr> no you don't
15:25:50 * tbarron points at himself when he says that
15:25:54 <zhongjun> For next one week?
15:26:00 <bswartz> zhongjun: http://logs.openstack.org/45/457545/32/check/gate-manila-tempest-minimal-dsvm-lvm-ubuntu-xenial/2ff0819/console.html
15:26:16 <tbarron> it's more than just tests failing
15:26:29 <tbarron> I'm not sure we're doing what we agreed to do yet
15:26:47 <bswartz> okay perhaps the test failure I see is a random one, not related to the patch
15:26:53 <tbarron> zhongjun has done great work on this, but we haven't as a community worked on it
15:27:10 <tbarron> to the extent we should
15:27:16 <bswartz> yes out attention has been stretched in many directions this release
15:27:20 <bswartz> s/out/our/
15:27:33 <tbarron> I don't think it's anyone's fault, it's just the way it is.
15:27:55 <tbarron> like-filter on the other hand has had lots of review attention and is almost ready.
15:28:57 <bswartz> well I'll repeat what I've said before to zhongjun -- I really appreciate you trying to do so much, but it's more valuable to focus on a smaller number of things and do them well
15:29:10 <bswartz> the rest of us haven't been able to focus on ensure share
15:29:41 <bswartz> I think it's clear we need to push it out -- that doesn't mean you can't keep working on it -- it just means that we won't consider merging it until queens opens up
15:31:00 <bswartz> let's make sure ensure share ends up on the agenda for PTG this fall
15:31:21 <bswartz> so that covers all the stuff on LP
15:31:41 <bswartz> let me make sure we capture remaining work
15:31:59 <bswartz> #action gouthamr review https://review.openstack.org/#/c/328932/
15:32:21 <tbarron> bswartz: but we have like-filter in https://etherpad.openstack.org/p/pike-manila-code-review-focus
15:32:24 <bswartz> #action tbarron review https://review.openstack.org/#/c/468277
15:32:36 <bswartz> err
15:32:40 <bswartz> did I miss something
15:33:44 <gouthamr> vponomaryov, will you help with the manila-ui fix?
15:34:13 <vponomaryov> gouthamr: yes
15:34:29 <bswartz> #action vponomaryov fix dj111 bugs in https://review.openstack.org/#/c/468899/
15:34:46 <gouthamr> vponomaryov: thank you.. happy to review..
15:35:05 * gouthamr and leave the hard work to vponomaryov
15:35:20 <bswartz> tbarron: where is the blueprint for the like filter stuff
15:35:39 * bswartz headdesk
15:35:39 * tbarron looks
15:35:41 <bswartz> #link https://blueprints.launchpad.net/manila/+spec/like-filter
15:36:10 <bswartz> okay I jumped the gun here because I didn't see the client patch
15:36:51 <bswartz> alright
15:36:58 <bswartz> anything else I missed?
15:37:59 <bswartz> #topic Bug Squash Day
15:38:09 <bswartz> #link https://etherpad.openstack.org/p/pike-manila-bug-squash
15:38:18 <bswartz> I created an etherpad
15:38:27 <bswartz> I will be setting up a webex for this event
15:38:32 <bswartz> there is an ML post about it too
15:39:02 <bswartz> feel free to start throwing bug onto the list
15:39:24 <bswartz> the first thing we do when we start the event will be to go looking for bugs that need fixing or bugs that need filing
15:39:51 <bswartz> then we'll do some prioritization and assigning of bugs to volunteers
15:40:14 <bswartz> we might address some as teams or hand them off to individuals
15:40:45 <bswartz> I hope to also use this time to try to capture some of our longstanding issues in written bug form that haven't been written down already
15:41:04 <gouthamr> we should perhaps break them into three levels of percieved complexity..
15:41:15 <bswartz> There's a long list of things in my heat that bother me, and only some of them are captured as bugs I'm sure
15:41:31 <bswartz> s/heat/head/
15:41:37 <tbarron> hothead
15:41:44 <ganso> bswartz: thought it was a type for heart
15:41:44 <gouthamr> docs, low-hanging-fruit, others
15:41:48 <ganso> bswartz: *typo
15:41:56 <gouthamr> heated head
15:42:12 <bswartz> yes they bother me in my heart too
15:42:19 <bswartz> but the list is in my head
15:42:53 <bswartz> anyways I set the time for basically all day east coast USA time
15:43:03 <bswartz> if people can only join for part of the day that's fine
15:43:15 <bswartz> I'll be there more or less all day to coordinate things
15:43:51 <bswartz> this community has never done a bug squash day before so it will be interesting to see who shows up and what we accomplish
15:44:02 <bswartz> I know these types of events have been very positive for other projects
15:44:28 <bswartz> and there's one other topic that's been weighing on me...
15:44:35 <bswartz> #topic Python 3 in Queens
15:45:00 <bswartz> the amount of time it's taken to transition from py2 to py3 is a kind of a joke
15:45:27 <bswartz> it's an issue for the whole community, but I'd like to do what we can in Manila to speed up the process of dropping py2
15:45:56 <bswartz> in particular, I'd like to move every test job that's currently py2-only to be py3-only
15:46:08 <bswartz> stuff that's tested on both can continue to be tested on both
15:46:31 <bswartz> but py3 should be our primary platform at this point, and py2 should be moving towards deprecation
15:46:43 <bswartz> I suspect the TC will decide when py2 becomes officially deprecated
15:47:29 <bswartz> I'm looking forward to a time when all of the "six" code in manila disappears
15:47:51 <bswartz> it's incredibly awkward to support both versions
15:48:26 * bswartz gets off soapbox
15:48:41 <bswartz> okay that's all I had!
15:48:44 <bswartz> #topic open discussion
15:48:47 <bswartz> we have a few minutes left
15:49:02 <bswartz> any other urgent topics?
15:49:16 <bswartz> if not, let's get onto wrapping up loose ends for pike-3
15:49:34 <bswartz> I expect to push the milestone tags this afternoon
15:49:44 <gouthamr> https://wiki.ubuntu.com/Python
15:50:37 <vponomaryov> bswartz: afternonn is in 10 minutes, isn't it?
15:50:52 <bswartz> looks like ubuntu 18.04 won't have py2 installed by default
15:50:55 <vponomaryov> bswartz: or you mean soem other timezone?
15:51:01 <bswartz> huzzah for canonical!
15:51:10 <gouthamr> "Overarching" goal though..
15:51:16 <bswartz> vponomaryov: well I'm having lunch in 10 minutes...
15:51:53 <bswartz> when I get back from lunch I'm going to check if the remaining stuff got through the gate and it so, I'll start pushing releases
15:52:03 <dustins> Fedora has had Python 3.X as the default since F23, but you can install 2.X if you want
15:52:14 <bswartz> if not I'll work on shepherding those last few patches until they're merged
15:52:27 * dustins apparently needs to trim some whitespace O.o
15:52:32 <bswartz> dustins: can you say the same for RHEL?
15:52:40 <dustins> bswartz: I cannot
15:52:52 <dustins> Unfortunately
15:52:56 <tbarron> bswartz: dustins there we have customers
15:53:18 <tbarron> banks, hospitals, etc.
15:53:22 <tbarron> but I digress
15:53:27 <dustins> I'm sure some folks somewhere are looking at it, but I don't know timeframes
15:53:37 <bswartz> well it's not the end of the world to have py2+py3 installed on your boxes
15:53:44 <bswartz> the key is that py3 is available and we can rely on it
15:53:45 * tbarron seems to remember bswartz talking about backwards compatability some time ago
15:54:17 <tbarron> yeah, I'm all for moving *us* to python3
15:54:21 <bswartz> because that allows US to kill off py2 support from our code even manila end-users have it for other reasons
15:54:36 <bswartz> even though*
15:55:07 <bswartz> alright I think we're done
15:55:26 <bswartz> thanks to all the reviewers for all the reviews these last 2 weeks
15:55:52 <bswartz> and thanks to the contributors for updating patches so often
15:56:04 <bswartz> #endmeeting