15:01:13 <bswartz> #startmeeting manila
15:01:14 <openstack> Meeting started Thu Aug  3 15:01:13 2017 UTC and is due to finish in 60 minutes.  The chair is bswartz. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:17 <openstack> The meeting name has been set to 'manila'
15:01:21 <bswartz> hello all
15:01:22 <cknight> Hi
15:01:25 <dustins> hey hey
15:01:27 <bswartz> sorry I'm late
15:01:28 <Yogi1> Hello
15:01:30 <vponomaryov> hello
15:01:41 <tbarron> hi
15:01:55 <bswartz> #topic announcements
15:01:55 <zhongjun> hi
15:01:55 <ganso> hello
15:02:25 <bswartz> so we achieved feature freeze last week
15:03:10 <bswartz> there saw a small issue with the client and requirements which led to a late release, but it turned out okay
15:03:29 <bswartz> The RC1 target date is next week, August 10
15:03:38 <bswartz> more about RC1 later
15:03:59 <bswartz> #topic bug squash
15:04:11 <bswartz> we held the bug squash event yesterday
15:04:44 <bswartz> I think it went pretty well -- we scrubbed a lot of bugs and managed to review/merge several and work on new fixes
15:05:20 <bswartz> We had 3 people from NetApp, 4 people from RedHat, and 1 person from Huawei
15:05:26 <bswartz> Thanks to those who attended
15:05:56 <dustins> It was a blast, thanks for organizing!
15:06:06 <vkmc_> o/
15:06:10 <bswartz> I think it would have been better if we had more participation but given who we had we made good progress
15:06:32 <bswartz> #topic RC1
15:06:43 <xyang1> hi
15:06:46 <bswartz> #link https://launchpad.net/manila/+milestone/pike-rc1
15:07:12 <bswartz> this is the bug list for RC1
15:07:49 <bswartz> just a reminder -- when the number of bugs gets to zero, we will cut the RC
15:07:57 <toabctl> hi
15:08:14 <bswartz> if we're getting close to the target date and some bugs remain unfixed, we will punt them out to Queens
15:08:49 <bswartz> err
15:08:57 <bswartz> I just realized I might be missing a bug on this list
15:09:26 <bswartz> if any of you know about bugs that should be on this list but aren't please send me links asap
15:09:32 <bswartz> so I can target them
15:09:45 <bswartz> I'll be more willing to add thing to the list today than I will next week
15:10:23 <bswartz> #topic PTG
15:11:03 <bswartz> We agreed to hold a virtual PTG for Queens, instead of traveling to Denver (or in additional to traveling to Denver)
15:11:16 <bswartz> we have not yet chosen dates though
15:11:37 <bswartz> the obvious options are the weeks before and after the Denver event
15:11:57 <bswartz> does anyone have conflicts those 2 weeks?
15:12:46 * bswartz hears crickets
15:13:15 <bswartz> the Denver PTG is Sep 11-15
15:13:41 <tbarron> the week before has labor day (US) on monday
15:13:42 <bswartz> so we're looking at Sep 5-7 or Sep 19-21
15:13:57 <dustins> I think either one of those weeks would work for me, but probably wise to work around Labor Day?
15:14:14 <bswartz> the event would be Tue/Wed or Wed/Thu
15:14:35 <bswartz> we never do community events on Mondays or Fridays precisely due to holidays
15:15:05 <tbarron> so if we do it the week before I'd advocate Wed/Thu
15:15:28 <dustins> Makes sense to me
15:15:59 <bswartz> personally I lean towards the week after
15:16:15 <bswartz> There's a good change stuff will come up at the Denver event we may need to react to
15:16:20 <zhongjun> I haven't conflicts those 2 weeks
15:16:29 <vponomaryov> bswartz: +1
15:17:32 <bswartz> anyone have a reason to prefer the week before?
15:17:38 <vkmc_> bswartz: +1
15:18:36 <bswartz> vkmc is that a vote for before or after?
15:18:47 <vkmc_> For after
15:18:51 <bswartz> okay
15:19:26 <vponomaryov> bswartz: you asked for a reason, +1 is not suitable for such ask ))
15:19:35 <bswartz> yeah...
15:19:53 <vkmc_> as you mentioned, I think we could use discussions on the Denver PTG for our own virtual PTG
15:19:59 <bswartz> okay well I don't hear anyone speaking up for the week of labor day
15:20:13 <vkmc_> if something comes up eventually
15:20:13 <bswartz> so let's aim for Sep 19-21
15:20:24 <bswartz> any preferenve for Tue/Wed vs Wed/Thu?
15:21:15 <ganso> for me Wed/Thu is better
15:21:23 <tbarron> slight pref for Wed/Thu as I have *lots* of meetings Tue
15:21:52 <dustins> Same here
15:21:54 <bswartz> I think we did Wed/Thu for our last virtual midcycle
15:22:01 <bswartz> and it turned out okay
15:22:54 <bswartz> okay Wed/Thu it is
15:23:14 <bswartz> #agreed Virtual PTG scheduled for Sep 20+21
15:23:40 <bswartz> okay that covers my agenda
15:23:44 <bswartz> #topic open discussion
15:23:49 <bswartz> anyone have specific bugs to discuss?
15:23:55 <bswartz> or other topics?
15:24:05 <vponomaryov> https://wiki.openstack.org/wiki/Manila/Meetings has py3 topic
15:24:24 <vponomaryov> oh, it is old one )
15:24:27 <vponomaryov> sorry )
15:24:40 <bswartz> yeah we talked about Py3 last week vponomaryov
15:24:55 <tbarron> vponomaryov: py2 is dead now :D
15:24:55 <vponomaryov> ok, will read it
15:25:01 <bswartz> in case you missed it, I want to switch all the jobs from py2 to Py3 in queens
15:25:09 <ganso> tbarron: dead but not buried
15:25:20 <bswartz> those that run on both can continue to run on both
15:25:22 <tbarron> ganso: the past is not even past
15:25:29 <bswartz> but py2-only jobs should be replaced by py3-only jobs
15:26:16 <bswartz> I want to help py2 on a speedier path to the grave if I can
15:26:47 <bswartz> not because I dislike py2 -- what I dislike is all the 'six' garbage in the code
15:26:58 <tbarron> ahem
15:27:19 <bswartz> and we can't remove that until py2 is officially unsupported
15:28:06 <xyang> bswartz: is anyone working on moving manila docs?
15:28:10 <bswartz> I thought there were some bugs yesterday that we needed to discuss today
15:28:32 <bswartz> but I can't remember which ones specifically
15:29:35 <tbarron> bswartz: maybe share the etherpad again so if we talk about them later in channel people can join in if they want
15:29:41 <xyang> there docs are no longer in master: https://github.com/openstack/openstack-manuals/tree/stable/ocata/doc/config-reference/source/shared-file-systems
15:29:54 <xyang> I don't see them in manila tree yet
15:30:06 <bswartz> tbarron was going to look at what jungleboyj did for cinder docs
15:30:14 <xyang> ok, cool
15:30:17 <bswartz> #link http://eavesdrop.openstack.org/meetings/manila/2017/manila.2017-07-13-15.00.log.html#l-144
15:30:23 * tbarron hasn't started on that yet though
15:30:38 <bswartz> is jay around?
15:30:43 <bswartz> is the cinder work done?
15:30:48 <jaypipes> bswartz: I am indeed.
15:30:51 <bswartz> I missed the cinder meeting yesterday on account of bug squash
15:30:53 <jungleboyj> I can be.
15:30:55 <xyang> jungleboyj
15:31:00 <jaypipes> I know :)
15:31:04 <xyang> :)
15:31:07 <bswartz> jaypipes: sorry to ping you
15:31:21 <jaypipes> bswartz: lol, no worries, happens all the time :)
15:31:46 <jungleboyj> You are looking for the other day.
15:31:49 <jungleboyj> *Jay.
15:31:54 <jungleboyj> What's up?
15:32:08 <bswartz> jungleboyj: cinder docs migration patches -- are they done?
15:32:11 <tbarron> are your cinder doc patches ready for me to crib?
15:32:15 <bswartz> we want to steal you work
15:32:18 <bswartz> your
15:32:46 <jungleboyj> So ... I have migrated the majority of the content and gotten our repository to look the way that it is supposed to.
15:33:20 <tbarron> jungleboyj: if you'd be so kind as to send me the review numbers I'll start on the corresponding manila work
15:33:21 <jungleboyj> Unfortunately we had MANY docstring problems that caused Sphinx warnings/failures and things that didn't come overover properly.
15:33:35 <jungleboyj> I am still working on getting that done.
15:33:53 <bswartz> jungleboyj: that sounds ominous for us
15:34:00 <tbarron> jungleboyj: isn't there some infra work ongoing to help on this issue too?
15:34:08 <bswartz> I don't want this docs migration to turn into a large effort
15:34:41 * jungleboyj laughs
15:35:04 <jungleboyj> bswartz:  Well, it depends on what your goal is.
15:35:18 <jungleboyj> If you just want the docs moved and don't care what it looks like, then it can be small work.
15:35:28 <jungleboyj> If you want them to look usable, it is going to be a larger effort.
15:35:43 <bswartz> what happened?
15:35:47 <xyang> I think migrating the existing docs from openstack-manual is the most important thing.  Fixing docstrings should be the next step. those are existing issues in the code
15:36:05 <jungleboyj> tbarron:  I have all of the build fixes under a doc-bld-fix topic.
15:36:15 <tbarron> jungleboyj: ack
15:36:21 <jungleboyj> xyang:  True, moving the docs should be your top priority.
15:36:41 <jungleboyj> Getting the other issues fixed can be a lower priority.
15:37:06 <bswartz> yes we can certainly split up the work into phases
15:37:18 <bswartz> the risk is that the later phases never happen
15:37:22 <jungleboyj> bswartz:  True.
15:37:59 <xyang> right now we don't even have any doc links for pike
15:38:16 <bswartz> yeah we need to make sure we have docs deliverables for pike
15:38:24 <jungleboyj> tbarron:  I need to look and find the patches that are the basis for the move.  I can get them to you.  I am in a class today but can be available to answer questions tomorrow and after that.
15:38:26 <bswartz> it seems like something that could in theory happen between RC1 and final release
15:38:53 <bswartz> we can fix doc bugs at any time (except the day of release)
15:39:18 <jungleboyj> bswartz:  When Pike is cut they will create a branch for the docs at that point.  So, you want to have things good at that point.
15:39:30 <jungleboyj> You can backport fixes, obviously , though.
15:39:40 <bswartz> ah, crud
15:39:42 <bswartz> you're right
15:39:55 <bswartz> having the docs in the stable branch means we need to maintain multiple copies
15:40:11 <bswartz> Do they actually publish stable docs though?
15:40:29 <bswartz> I thought the site only showed docs for master, with an exception for the install guide which was versioned
15:40:38 <jungleboyj> bswartz:  I haven't gotten a great answer on that.  Some of this we will learn when it happens.
15:40:47 <xyang> stable/ocata: https://github.com/openstack/openstack-manuals/tree/stable/ocata/doc/config-reference/source/shared-file-systems
15:41:01 <bswartz> hmmm
15:41:27 <bswartz> having to backport doc fixes feels like not a good use of effort to me
15:41:36 <jungleboyj> Now that we are part of our repo though, there will be a stable version and I am thinking that the build tools for the website will create such branches out on the web with doc.o.o/latest/manila being the current branch.
15:41:40 <jungleboyj> Master.
15:41:43 <bswartz> without a good reason to do so, I'd prefer to keep all the up to date docs in master
15:42:00 <bswartz> we never update things like the devref in stable branches
15:42:03 <jungleboyj> bswartz:  Agreed.  Won't do a lot of that for Cinder, but was just sharing that it is possible.
15:42:13 <bswartz> jungleboyj: thanks
15:42:38 <bswartz> yeah I won't be too upset if there's no docs in stable/pike, as long as they get into master
15:43:00 <bswartz> I would want to hear why it's worth keeping 2 copies around, and if there's a good reason, we could backport at that time
15:43:46 <bswartz> okay anything else for today?
15:44:11 <bswartz> if not, I'll give you all a few minutes back
15:44:21 <jungleboyj> tbarron:  I will catch up with you here shorlty.
15:44:30 <tbarron> jungleboyj: thanks
15:44:45 <bswartz> thanks everyone, please focus on fixing bugs and reviewing bugfixes from https://launchpad.net/manila/+milestone/pike-rc1
15:44:53 <bswartz> #endmeeting