15:02:22 <bswartz> #startmeeting manila
15:02:22 <openstack> Meeting started Thu Nov  2 15:02:22 2017 UTC and is due to finish in 60 minutes.  The chair is bswartz. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:26 <openstack> The meeting name has been set to 'manila'
15:02:29 <bswartz> hello all
15:02:32 <ganso> hello
15:02:35 <zhongjun> hi
15:02:36 <markstur> hi
15:02:38 <dustins> \o
15:02:53 * bswartz notes that some people may be traveling to sydney already
15:03:46 <dustins> It is a long swim
15:03:50 <bswartz> #topic announcements
15:03:55 <bswartz> dustins: lol
15:04:28 <bswartz> so sydney is next week
15:04:47 <bswartz> I'm not going, but we will have some manila people there
15:05:04 <bswartz> thanks for representing us gouthamr ganso vkmc
15:05:13 <ganso> o/
15:05:25 <tbarron> the three musketeers
15:06:19 <bswartz> traditionally we cancel the meeting on the week of the summit, but since only a minority of us will be there there, we can discuss what to do for next week
15:06:45 <amito-infinidat> o/
15:07:30 <bswartz> how do you all feel about meeting next week?
15:07:33 <tbarron> i don't see any reason to skip; even if some of us want to follow the happenings they are going to be 12 hours off from the manila meeting
15:08:07 <zhongjun> I am always here
15:08:15 <zhongjun> :)
15:08:18 <tbarron> but I don't feel strongly if people want to take a break
15:08:20 <bswartz> yeah anyone at the summit will see this meeting happen at 3AM
15:08:33 <tbarron> like zhongjun might want to get to sleep for once
15:09:11 <bswartz> well there's not much of an agenda today
15:09:22 <tbarron> I see her answering questions in channel from people in asia all "night" (from my POV) and then coming to this meeting too!
15:09:46 <bswartz> yeah thanks for being in the channel to answer questions zhongjun
15:09:49 <zhongjun> haha,  maybe
15:09:57 <dustins> zhongjun++
15:10:18 <bswartz> okay, well, I'm okay holding the meeting next week or not
15:10:20 <zhongjun> bswartz: np
15:10:27 <amito-infinidat> It'll still be 5pm for me :)
15:10:43 <bswartz> I don't see any harm in holding the meeting
15:10:54 <tbarron> amito-infinidat: you can have a cocktail or a beer during the meeting then
15:11:02 <bswartz> maybe it will be short (like today will most likely be) or if not, we can resync with the people that missed it
15:11:09 <bswartz> #agenda https://wiki.openstack.org/wiki/Manila/Meetings
15:11:32 <amito-infinidat> tbarron: that's a great idea
15:11:34 <bswartz> the only topic we have today is covering bugs
15:11:54 <bswartz> amito-infinidat: like they say, it's always 5pm somewhere
15:12:41 <bswartz> #topic Let's go over new bugs
15:12:54 <bswartz> dustins: I added this topic for you, dunno if you have anything
15:13:06 <dustins> bswartz: Indeed I do!
15:13:15 <bswartz> #link https://etherpad.openstack.org/p/manila-bug-triage-pad
15:13:29 <dustins> https://bugs.launchpad.net/manila/+bug/1708213
15:13:29 <openstack> Launchpad bug 1708213 in Manila "5.0.0.0b3 tests fail with ipaddress===1.0.17" [Undecided,New]
15:13:32 <bswartz> dustins: I also fixed the caps (removed them)
15:13:43 <zhongjun> #link: https://bugs.launchpad.net/manila/+bug/1707946
15:13:44 <openstack> Launchpad bug 1707946 in Manila "LVM driver fails to apply access rules to /0 networks" [Critical,Fix released] - Assigned to Ben Swartzlander (bswartz)
15:14:03 <zhongjun> dustins: bswartz fixed it
15:14:26 <bswartz> wait which bug ar we talking about
15:14:43 <dustins> zhongjun: Go ahead, that looks more important than my bugs
15:14:50 <zhongjun> Both are the same?
15:15:24 <bswartz> dustins: the one zhongjun linked was fixed by me in pike
15:15:44 <zhongjun> I mean  since the second bug has been fixed, the first bug also be fixed too
15:16:15 <dustins> zhongjun: I don't think so, the one I linked has to do with what looks to be an issue with a certain version of Python's ipaddress library
15:16:25 <bswartz> oh
15:16:42 <bswartz> so one of the issues is that there were badly written unit tests in this code path
15:16:51 <bswartz> when I fixed the bug I also cleaned up the unit tests
15:16:58 <bswartz> perhaps I accidentally fixed the other bug too
15:17:23 <bswartz> it's hard to tell from the bug description
15:17:35 <bswartz> bug since we don't have failing tests anymore -- I think it's safe to assume this is resolved
15:17:58 <dustins> bswartz: Sounds good to me
15:18:02 <tbarron> +1, with  a comment to re-open if needed of course
15:18:19 <zhongjun> yeah, since bswartz cleaned up the unit tests, we don't have the fail test now
15:18:38 <bswartz> okay I marked it "fix released" with a note
15:18:42 <bswartz> next?
15:18:52 <dustins> https://bugs.launchpad.net/manila/+bug/1708174
15:18:54 <openstack> Launchpad bug 1708174 in Manila "glusterfs-native driver job fails" [Low,New]
15:19:05 <tbarron> I tried to fix it but it was beyond me.
15:19:16 <dustins> This is more of something of "do we still want to fix this"
15:19:20 <tbarron> glusterfs has changed since the driver was written and no one mainitains it.
15:19:37 <bswartz> I recommend we disable the job
15:19:39 <tbarron> I propose that we mark it unmaintained and remove the job (or move it to experimental)
15:19:47 <bswartz> we've discussed this before IIRC -- is there a patch to do that yet?
15:19:49 <tbarron> ditto for hdfs, same deal
15:20:13 <tbarron> I didn't remember that we agreed that it's OK, if it is I will follow through.
15:20:13 <bswartz> tbarron: +1
15:20:18 <bswartz> let's decide now
15:20:40 <tbarron> w.r.t. "mark it unmaintained" is driverlog sufficient for now?
15:20:56 <bswartz> anyone opposed to marking glusterfs and/or hdfs unmaintained, and disabling the related CI jobs to stop wasting CPU cycles?
15:21:34 <tbarron> if we do this then all first party jobs (even non-voting) should be green.
15:21:39 <bswartz> if we do this, we should announce on the ML as well in case someone pops out of the woodwork to start maintaining them again
15:21:49 <markstur> green is good
15:21:51 <tbarron> well, there are some intermittent failures but we can start fixing these
15:22:09 <tbarron> +1 on mail list
15:22:11 <bswartz> I propose: push the patch to disable them, then post to the ML with a link to the patch
15:22:21 <bswartz> if someone has an issue, they can -1 the patch
15:22:33 <dustins> Sounds good to me
15:22:39 <zhongjun> +1 fair
15:22:42 <bswartz> ideally 2 separate patches so they can be voted on and merged independently
15:22:43 <ganso> we should set a deadline for someone to show up
15:22:46 <ganso> like a week
15:22:47 <tbarron> we can wait till, say  M2
15:22:49 <tbarron> ?
15:23:02 <tbarron> given travel. sydney, etc.
15:23:02 <ganso> tbarron: +1
15:23:10 <bswartz> it's not hard to reverse such a patch though
15:23:37 <tbarron> bswartz: true, we could set two weeks after patch submission as deadline in the email
15:23:41 <bswartz> I agree we should wait a short while so people can read their mail, but no need to wait for weeks
15:24:20 <bswartz> won't the patch be to the infra-controlled project-config repo?
15:24:35 <bswartz> in which case we don't control when it merges?
15:24:37 <tbarron> bswartz: no, we've moved the jobs to be locally defined now
15:24:43 <tbarron> zuulv3
15:24:44 <bswartz> oh even better
15:24:50 <bswartz> so we can merged it when we like
15:24:56 <bswartz> okay that's easy
15:25:12 <tbarron> right, need to co-ordinate with raissa and her repo split but we know where she lives
15:25:20 <tbarron> as it were
15:25:24 <bswartz> is she traveling next week?
15:25:29 <tbarron> not that I know of
15:25:38 <bswartz> cool
15:26:00 <bswartz> okay -- the patch that disables the glusterfs job should mark this bug as fixed :-)
15:26:11 <tbarron> bswartz: you can give me the AI to get the jobs removed
15:26:17 <tbarron> if you want
15:26:30 <bswartz> #action tbarron push patches to disable unmaintained driver CI jobs
15:26:56 <bswartz> next?
15:27:22 <dustins> https://bugs.launchpad.net/manila/+bug/1707377
15:27:23 <openstack> Launchpad bug 1707377 in Manila "Quota usage value error" [Undecided,New]
15:28:14 <bswartz> is this one of the known race-condition-related quota problems?
15:28:34 <bswartz> where the counting gets off due to racing operations?
15:28:35 <zhongjun> yeah, we talked it in PTG
15:28:46 <tbarron> "delete the same share at the same time in each of 4 VMs"
15:28:47 <zhongjun> It is the same as cinder
15:29:05 <bswartz> so the plan is to fix this bug with a rewrite of the quota syste
15:29:07 <bswartz> system
15:29:14 <tbarron> can we somehow mark this bug to indicate that it will wait for quota rewrite?
15:29:33 <bswartz> yeah we can add a note
15:29:34 <dustins> We can mark it as triaged and make note of that
15:30:07 <zhongjun> The plan was to do both,   rewrite of the quota syste and fix bug
15:30:23 <bswartz> zhongjun: are you going that during queens?
15:30:29 <zhongjun> no
15:30:46 <zhongjun> It is too big change
15:30:50 <bswartz> whoever volunteers to do that work should take ownership of the bug
15:30:54 <bswartz> we can target it a rocky for now
15:30:59 <bswartz> and leave it unowned
15:31:52 <bswartz> next?
15:32:02 <dustins> https://bugs.launchpad.net/manila/+bug/1706743
15:32:03 <openstack> Launchpad bug 1706743 in Manila " Add share usage size tracking in doc" [Undecided,New]
15:32:32 <dustins> Next two are pretty easy, they're DocImpact bugs and just circling back to see if any other docs needed to be done on this one or the next one
15:32:38 <bswartz> looks like the DocImpact line caused this to get filed automatically
15:32:48 <bswartz> were any docs added related to this feature?
15:33:08 <dustins> The patch linked there does add docs
15:33:36 <dustins> #link https://review.openstack.org/#/c/487273/
15:33:42 <bswartz> so the bug can be closed then
15:33:52 <zhongjun> I think so
15:34:38 <dustins> https://bugs.launchpad.net/manila/+bug/1706708
15:34:39 <openstack> Launchpad bug 1706708 in Manila " Add share groups and share group snapshots quotas" [Undecided,New]
15:34:44 <dustins> That's the last one for this week
15:34:57 <dustins> Same deal, was opened by the DocImpact tag
15:35:39 <zhongjun> We should be careful about the DocImpact tag when we want to add it
15:35:55 <bswartz> the whole point of the DocImpact tag is to create these bugs
15:36:07 <bswartz> the theory being that someone other than the implementor will be writing the docs
15:36:21 <bswartz> if we write docs in the same patch as the code, then no tag is needed
15:36:30 <ganso> zhongjun: why should we be careful if we are adding something that requires a doc update?
15:36:59 <tbarron> ganso: I think she's saying the same thing as Ben
15:37:06 <zhongjun> ganso : like this https://review.openstack.org/#/c/487273/,  It doesn't need a tage
15:37:14 <zhongjun> s/tage/doc tag
15:37:21 <ganso> tbarron: oh ok, ya if the patch already includes doc then no tag is required
15:37:25 <tbarron> ganso: it doesn't do a lot of harm, but reviewers can note that it's not needed and we can save some process
15:38:06 <ganso> zhongjun: yea that was a mistake
15:38:23 <zhongjun> ganso : :)  just remind myself
15:38:46 <bswartz> so what about the docs for share groups and share group snapshots quotas"
15:38:50 <bswartz> ?
15:39:02 <bswartz> anything more needed on those?
15:39:08 <dustins> Either they exist or they don't
15:39:31 <tbarron> I don't think it was included with the code, but zhong has been working on it I think ??
15:39:40 <zhongjun> bswartz:  https://review.openstack.org/#/q/status:open+project:openstack/manila+branch:master+topic:bug/1724716
15:39:53 <tbarron> I doublt vponomaryov has any time for it now.
15:40:00 <dustins> Heh, likely not :)
15:40:04 <bswartz> doh we keep not reviewing these patches
15:40:13 <zhongjun> Do I need to add this bug in my patches, or just close it
15:40:38 <bswartz> ideally the bug would be mentioned in the commit
15:40:51 <bswartz> but it's really not that important for a docimpact bug
15:40:53 <dustins> zhongjun: I think you can just do Closes-Bug on that ID
15:41:08 <bswartz> docimpact bugs are really a misuse of LP
15:41:22 <bswartz> LP bugs are only supposed to contain infomration relevant to end users
15:41:48 <zhongjun> dustins: We have more than one bug about share group , share snapshot group docs :D
15:41:49 <tbarron> these patches are passing check, I don't see a reason to change the commit msg and make check run again
15:41:52 <ganso> well, it informs that such documentation is missing and someone needs to volunteer to work on it
15:41:56 <ganso> bswartz: ^
15:41:59 <dustins> tbarron: +1
15:42:05 <dustins> ganso: +1
15:42:27 <dustins> Docs are arguably the most important end-user information
15:42:49 <bswartz> dustins: yes but tracking bugs reminding us to write docs are just noise to an end user
15:43:20 <bswartz> openstack lacks any kind of "task tracking" system so we abuse other tools like LP
15:43:25 <tbarron> Just put a remark in 1706708 that the doc was taken care of in 1724716
15:43:40 <tbarron> that it is a dupe of 1724716
15:43:49 <tbarron> close it as such
15:44:32 <bswartz> dustins: that all for bugs?
15:44:41 <dustins> Yup!
15:44:58 <zhongjun> Add some commit in the doc bug link
15:45:16 <bswartz> #topic open discussion
15:45:27 <bswartz> anyone have somthing else not on the agenda?
15:45:53 <zhongjun> By the way, those docs about share group is ready for review
15:45:59 <tbarron> :-)
15:46:11 <bswartz> zhongjun: yes I'm embarrassed that they've gone for so long without getting merged
15:46:15 <bswartz> I'll get on that
15:46:40 <zhongjun> Thanks
15:46:57 <bswartz> okay so at this point the meeting for next week is on
15:47:06 <bswartz> probably it will be a short agenda like this week
15:47:20 <bswartz> if we need to cancel it, I'll announce on the ML
15:47:26 <bswartz> that's all for today
15:47:28 <bswartz> thanks a
15:47:32 <bswartz> thanks all!
15:47:46 <bswartz> #endmeeting