15:01:03 <tbarron> #startmeeting manila
15:01:04 <openstack> Meeting started Thu Mar 15 15:01:03 2018 UTC and is due to finish in 60 minutes.  The chair is tbarron. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:07 <openstack> The meeting name has been set to 'manila'
15:01:11 <gouthamr> o/
15:01:11 <bswartz> .o/
15:01:11 <amito> o/ hey
15:01:14 <zhongjun> hi
15:01:21 <dustins> \o
15:01:42 <xyang> hi
15:01:44 <tbarron> courtesy ping:  gouthamr zhongjun xyang markstur vponomaryov cknight toabctl bswartz ganso
15:02:00 <tbarron> Hello all!
15:02:25 <tbarron> #topic announcements
15:03:08 <vkmc> o/
15:03:08 <tbarron> I have updated
15:03:09 <tbarron> #link https://releases.openstack.org/rocky/schedule.html
15:03:09 <tbarron> for manila project specific deadlines
15:03:09 <tbarron> Spec freeze is 19 Apr 2018 (23:59 UTC), about a month from now.
15:03:09 <tbarron> Let's get spec reviews moving.
15:03:10 <tbarron> #link https://etherpad.openstack.org/p/manila-rocky-specs
15:03:46 <tbarron> Any questions/comments on that?
15:04:17 <tbarron> OpenStack-wide, the next couple weeks are for Forum Topic Brainstorming.
15:04:17 <tbarron> Please add your ideas to
15:04:17 <tbarron> #link https://etherpad.openstack.org/p/YVR-manila-brainstorming
15:04:21 <bswartz> deadlines look reasonable
15:04:37 <tbarron> And they are what we agreed to at the PTG
15:04:51 <diablo_rojo_> o/
15:05:00 * tbarron passes diablo_rojo_ a cup of coffee
15:05:08 <tbarron> diablo_rojo_: we're still on announcements
15:05:28 <diablo_rojo_> tbarron, cool :)
15:05:31 <tbarron> So let's get some ideas for the Forum other than those I posted.
15:05:36 * diablo_rojo_ accepts mug
15:05:46 <tbarron> We want operator-facing type ideas.
15:06:04 <tbarron> ok
15:06:20 <tbarron> I sent a (too long) PTG summary to openstack-dev and reflected it here:
15:06:20 <tbarron> #link https://etherpad.openstack.org/p/manila-rocky-ptg-summary
15:06:20 <tbarron> We will be referring to it w.r.t agreements and direction over the cycle so take
15:06:20 <tbarron> a look and add comments as appropriate with additions, corrections, differences
15:06:20 <tbarron> in interpretation, etc.
15:06:35 <gouthamr> tbarron: perhaps we should forward your email to the operators list, we might have some ideas from there
15:06:55 <tbarron> gouthamr: I have to join that list to post
15:07:09 <tbarron> gouthamr: probably I should join, just have a lot of email
15:07:16 <gouthamr> tbarron: finding the email, i'll forward it
15:07:21 <tbarron> gouthamr: thanks
15:07:34 <tbarron> gouthamr: and I will join too in due time
15:07:40 <gouthamr> +1
15:07:50 <tbarron> Finally, it's time to update our cross-project liaison list:
15:07:50 <tbarron> #link https://wiki.openstack.org/wiki/CrossProjectLiaisons
15:07:50 <tbarron> Take a look and ping me if you are interested in any of these.
15:07:50 <tbarron> My name is on some of them by default but I'm looking to distribute
15:07:50 <tbarron> responsibility so don't let that stop you.
15:08:10 <tbarron> OK, that's it for announcements.
15:08:23 <tbarron> #agenda https://wiki.openstack.org/wiki/Manila/Meetings#Next_meeting
15:08:42 <tbarron> #topic StoryBoard
15:08:51 <tbarron> diablo_rojo_: your're up!
15:08:59 <diablo_rojo_> Wonderful :)
15:09:12 <diablo_rojo_> So following up on our conversation at the PTG
15:09:32 <diablo_rojo_> I went through each of Manila's 4  launchpad repos and ran test migrations of each one
15:09:57 <diablo_rojo_> They all completed successfully without any issue so it looks like Manila is good to go
15:10:16 <dustins> diablo_rojo_: We're migrating from launchpad?! What for?
15:10:40 <diablo_rojo_> Next step is, if you are all comfortable, to pick a date to do the migration and push your project config change (its only a few lines).
15:10:44 <zhongjun> diablo_rojo_: 4 launchpad?
15:10:45 <bswartz> dustins: the community has been planning to ditch LP for years
15:10:54 <diablo_rojo_> dustins, many reasons :)
15:11:00 <dustins> bswartz: They have? To what end?
15:11:03 <bswartz> diablo_rojo_: how do I search for issues created by myself
15:11:07 <diablo_rojo_> How many blogposts do you want to read?
15:11:18 <dustins> diablo_rojo_: A few at least :)
15:11:22 <bswartz> #reasons
15:11:43 <diablo_rojo_> Click on the advanced search icon and search for your name
15:12:05 <bswartz> There is no advanced search icon on the search page :(
15:12:09 <diablo_rojo_> Or, if they are ones you made, they will also appear on your dashboard when you sign in until they are completed
15:12:24 <diablo_rojo_> The magifying glass is the advanced search
15:12:30 <dustins> I'm just surprised that this is the first I've heard of this migration and the ire toward Launchpad
15:12:37 <diablo_rojo_> the little search box is a quick search
15:13:14 <diablo_rojo_> dustins, I've written several emails to the dev list, proposed it as a release goal and the TC just started using it for tracking release goals.
15:13:18 <xyang> diablo_rojo: can you put a link here for storyboard?
15:13:28 <bswartz> diablo_rojo_: the magnifying glass does nothing when I click it
15:13:29 <diablo_rojo_> dustins, we've already migrated about a half a dozen projects.
15:13:32 <gouthamr> https://storyboard.openstack.org/
15:13:36 <xyang> thanks
15:13:39 <bswartz> but the dashboard does show some open issues created by me
15:13:47 * dustins must be way outta the loop
15:13:47 <dustins> :)
15:13:52 <diablo_rojo_> Ironic is about a week and a half out from their own migration :)
15:14:12 <diablo_rojo_> bswartz, it should bring you to a different search page
15:14:22 <gouthamr> manila has some test stories and tasks :) https://storyboard.openstack.org/#!/search?q=manila&title=manila
15:14:29 <bswartz> #link https://storyboard.openstack.org/#!/story/2000726
15:14:59 <bswartz> !!
15:15:00 <openstack> bswartz: Error: "!" is not a valid command.
15:15:04 <gouthamr> real problem
15:16:01 <tbarron> diablo_rojo_: there were some real issues that the cinder folks raised about the rendering of info from launchpad
15:16:21 <tbarron> diablo_rojo_: your import tests don't check for those, right?
15:16:25 <diablo_rojo_> dustins, https://storyboard-blog.io/why-storyboard-for-openstack.html
15:17:00 <diablo_rojo_> tbarron, can you jog my memory?
15:17:05 <bswartz> diablo_rojo_: I still can't find advanced search -- but I'm gratified that many of the issues I raised last year have been addressed
15:17:05 * diablo_rojo_ sips more caffeine
15:17:17 <dustins> diablo_rojo_: Thanks! I'll have a read
15:17:33 <tbarron> diablo_rojo_: plaintext got rendered as markup, so code with *token turned to bold token, etc.
15:18:08 <diablo_rojo_> bswartz, lol well it doesn't explicitly say 'Advanced Search' but the magnifying glass is the advanced search
15:18:09 <tbarron> diablo_rojo_: I don't want to dawdle on this, but probably we need to see the
15:18:33 <bswartz> diablo_rojo_: clicking the magnifying glass does nothing in Chromium and Firefox
15:18:45 <tbarron> actual import results at some point rather than just relying on lack of errror being thrown in the import
15:18:54 <diablo_rojo_> tbarron, got it. I can look into that today and get back to you.
15:18:55 <tbarron> Althought that's an important result!!!
15:19:05 <diablo_rojo_> unless SotK is here and can help me out :)
15:19:11 <vkmc> we would need some time to get familiar with it and start dealing with this usability stuff :)
15:19:16 <diablo_rojo_> bswartz, I'm using firefox and it works for me :)
15:19:31 * SotK reads backscroll
15:19:31 <tbarron> Especially since we have quite a number of launchpads that got merged.
15:20:07 <diablo_rojo_> tbarron, once I get access to the storyboard-dev db I can run test migrations into there and it will be easier to peruse the effect of the migration
15:20:24 <tbarron> diablo_rojo_: SotK so I think it makes sense to:
15:20:30 <SotK> https://storyboard.openstack.org/#!/search is "advanced search", the magnifying glass in question being the one in the sidebar
15:20:42 <tbarron> (1) get the issues that the cinder folks raised resolved, we will have them too
15:20:48 <SotK> though I think searching for your name there will only show stories you are assigned to a task in
15:21:04 <tbarron> (2) after that, get a sandbox where folks like dustin (our bug czar) can play
15:21:32 <tbarron> If we do #2 before #1 then you are just going to hear a lot of the same old stuff over again.
15:22:14 <dustins> tbarron: Yes, please :)
15:22:18 <tbarron> diablo_rojo_: SotK: does that make sense?
15:22:39 <diablo_rojo_> tbarron, works for me
15:22:45 <gouthamr> + request, can a link to the docs be added to the UI somewhere
15:22:54 <gouthamr> suppose it is https://docs.openstack.org/infra/storyboard/
15:22:56 <SotK> those issues being names not numbers in project URLs and imported descriptions being interpreted as markdown when they likely aren't?
15:23:01 <diablo_rojo_> https://docs.openstack.org/infra/storyboard/gui/manual.html
15:23:05 <diablo_rojo_> gouthamr, ^
15:23:11 <gouthamr> oh, that's better!
15:23:15 <diablo_rojo_> :)
15:23:24 <tbarron> SotK: and I think there was an issue about newline rendering as well??
15:23:51 <SotK> yep, that is part of the markdown bit
15:23:58 <tbarron> SotK: basically, if cinder or another team has said "this is a blocker for us" then
15:24:08 <SotK> makes sense
15:24:12 <tbarron> SotK: probably it's efficient to solve those before asking another team to
15:24:31 <tbarron> SotK: consider merging, you'll just have more of the same reasons for why we won't do it yet
15:25:06 <tbarron> OK, diablo_rojo_ SotK we'll schedule another slot when you ping me indicating we're ready to do sandbox
15:25:14 <tbarron> Thanks for the great work so far!!
15:25:28 <gouthamr> +1
15:25:37 <gouthamr> thanks diablo_rojo_ SotK
15:25:45 <SotK> yw :)
15:25:53 * tbarron checks the agenda b/c he thinks it was being revised, sec
15:26:16 <diablo_rojo_> Thanks tbarron :)
15:26:25 <tbarron> #topic How to update the content that's in the tempest scenario tests spec?
15:26:29 <tbarron> diablo_rojo_: yw
15:26:39 <tbarron> vkmc: take it away!
15:26:46 <vkmc> hey all
15:27:01 <vkmc> so, we were talking today with some folks working on scenario tests for manila
15:27:21 <vkmc> I don't see them here, but there are few patch sets of them in gerrit
15:27:54 <vkmc> not many people reviewed those patch sets... so the discussion on the requirement to track that work on some sort of doc came up
15:28:06 <vkmc> basically they were following this spec to complete the missing work
15:28:17 <vkmc> #link https://github.com/openstack/manila-specs/blob/master/specs/ocata/scenario-tests.rst
15:28:33 <vkmc> and also, they want to add a few more scenario tests that correspond to new features in manila
15:29:10 <bswartz> vkmc: very cool
15:29:13 <vkmc> so, one of the ideas that came up was to do as other projects are doing and have a non-dependent branch location for specs
15:29:25 <vkmc> so they actually extend that spec that was proposed in the first place
15:29:29 <vkmc> and add the work they are doing
15:29:52 <vkmc> we are not sure if that is the right approach
15:30:11 <vkmc> another option would be to add some docs on scenario tests in the main documentation
15:30:40 <vkmc> but having some place to store specs that actually are not for a release in particular sounded good... since there are a few features that might benefit from this
15:30:42 <bswartz> vkmc: IMO we don't need specs for every new test case
15:30:45 <vkmc> what do you guys think?
15:30:48 <vkmc> yeah
15:30:58 <bswartz> vponomaryov went a bit overboard here in terms of detail
15:31:11 <bswartz> It's good to have the details somewhere, they didn't need to be in the spec
15:31:44 <tbarron> bswartz: do we need natural language description of the tests?  a test plan? or is that too pedantic?
15:31:59 <bswartz> That's what vponomaryov gave us here
15:32:17 <amito> this could be generated from the test docstrings as well.
15:32:17 <tbarron> dustins: you do test plans ... what do you think?
15:32:21 <zhongjun> Is there any strong reason to add those new tests in a spec?
15:32:26 <bswartz> It's a helpful thing to have, if the person designing the tests and writing the tests are not the same person
15:32:47 <bswartz> If the person designing the tests just writes them, then the test code serves as the spec
15:32:53 <tbarron> maybe amito's idea plust gerrit review is sufficient
15:33:02 <vkmc> not in a new specs... we wanted to extend https://github.com/openstack/manila-specs/blob/master/specs/ocata/scenario-tests.rst and put it in some place that actually reflects that the work on scenario tests is updating all the time
15:33:34 <amito> when it comes as part of the test docstring it's more easy to read for someone who's adding to the code. IMHO, a reference should also be available on the proper docs, though.
15:33:39 <bswartz> In this case I think we asked vponomaryov to go deep on designing new tests, without asking him to actually write all of them (because writing a test takes a order of magnitude more effort)
15:33:57 <bswartz> The goal was to get a sense of how deep a hole we were in on scenario testing
15:34:07 <dustins> tbarron: Hmmm, maybe the doctext of the tests themselves would be a good place for them
15:34:27 <dustins> Could also justify somewhere in the Manila docs, or a "constant" spec
15:34:51 <tbarron> bswartz: since the tests weren't being written yet docstring approach wasn't feasible at the time
15:35:10 <tbarron> not all the tests were being written yet
15:35:13 <bswartz> IMO having test plans written down is great, but it doesn't matter much where they are -- as long as they eventually get turned into code and the person writing that code can find the plans
15:35:51 <tbarron> Maybe having a release-independent specs area makes sense in any case.
15:36:06 <tbarron> We could move specs there after approval that will need updates.
15:36:45 <bswartz> tbarron: +1
15:36:49 <vkmc> tbarron, +1
15:37:28 <vkmc> thanks for the feedback
15:37:32 <dustins> Oooh, good idea
15:37:32 <tbarron> we don't have to insist that every new test case necessarily requires a spec update though
15:37:50 <tbarron> if in review docstrings, etc. make it all clear
15:38:02 <tbarron> that is, we don't want to insist on process for its own sake
15:38:34 <tbarron> nir wanted to make a spec correction in this case so that solves his case
15:38:52 <tbarron> Anything else on this one?
15:39:14 <vkmc> not from me
15:39:26 <bswartz> So we will move this one to a release independent place and then update it there?
15:39:39 <dustins> Sounds good to me
15:39:51 <tbarron> bswartz: yup, what's the directive for #agree or whatever?
15:40:16 <bswartz> it's #agreed
15:40:25 <bswartz> I think
15:40:44 <tbarron> #agreed we will set up a release independent section of the specs repo
15:40:51 <tbarron> we'll try that
15:41:10 <tbarron> #topic New Bugs
15:41:10 <tbarron> #link https://etherpad.openstack.org/p/manila-bug-triage-pad
15:41:10 <tbarron> dschoenb: this one is yours!
15:41:19 <dustins> tbarron: Thanks!
15:41:54 <dustins> #link: https://bugs.launchpad.net/manila/+bug/1631314
15:41:55 <openstack> Launchpad bug 1631314 in Manila "Tempest test "test_promote_out_of_sync_share_replica" is concurrency-prone" [High,Confirmed] - Assigned to Goutham Pacha Ravi (gouthamr)
15:42:10 <gouthamr> grrr, this one :/
15:42:11 <dustins> I'm focusing on Tempest and Concurrency stuff this week
15:42:15 <dustins> gouthamr: hehehe
15:42:51 <gouthamr> dustins: this one has a back-story. We didn't conclude on how to fix it yet, i'll be glad to un-assign myself if someone wants to take a look at this
15:43:19 <gouthamr> the test itself is expecting something the APIs weren't designed for
15:43:29 <tbarron> dustins: gouthamr: take a look at the last comment, there's someone who wants to work on this
15:43:47 <dustins> at least they did a couple of months ago :)
15:44:00 <gouthamr> :( didn't notice that..
15:44:03 <gouthamr> i'll respond
15:44:32 <tbarron> gouthamr: cool, it might not be the most gentle intro to manila so you'd want to be involved in any case
15:44:45 <gouthamr> yep
15:44:45 <tbarron> :)
15:45:31 <tbarron> dustins: next bug?
15:45:42 <dustins> #link: https://bugs.launchpad.net/manila/+bug/1477547
15:45:43 <openstack> Launchpad bug 1477547 in Manila "manila 'cover' tox job shows different results after reruns" [Low,Confirmed]
15:46:23 <tbarron> dustins: I think that should be fixed.  I didn't know about this bug when I made the change.
15:46:29 <tbarron> dustins: I"ll update this one.
15:46:34 <dustins> w00t
15:46:55 <dustins> #link: https://bugs.launchpad.net/manila/+bug/1479174
15:46:56 <openstack> Launchpad bug 1479174 in Manila "Lock required in delete share/snapshot" [Medium,In progress] - Assigned to Madhu Mohan Nelemane (mmohan-9)
15:48:18 <bswartz> wow super old bug
15:48:31 <dustins> bswartz: Indeed
15:48:39 <gouthamr> this is an RFE, and it was part of a bug squash in Germany
15:48:45 <gouthamr> iirc
15:48:57 <gouthamr> and the reasoning was that locks exist in cinder :P
15:49:03 <bswartz> from 2015...
15:49:21 <bswartz> I don't see actual incorrect behavior being demonstrated here
15:49:28 <bswartz> However it's possible that there's still a bug
15:49:34 <tbarron> Do we still have the races?
15:49:53 <gouthamr> tbarron: yes we do..
15:49:58 <zhongjun> I think so
15:50:54 <gouthamr> the case here is probably when the API requests come in concurrently
15:51:15 <gouthamr> because the "deleting" status in the snapshot should block subsequent requests
15:51:35 <tbarron> It's too bad the patch was abandoned as it seemed close to merge and was getting review attention.
15:52:58 <tbarron> dustins: would you start a concurrency-but etherpad and put this one on it?
15:53:12 <tbarron> dustins: nm, I"ll do it
15:53:16 <dustins> tbarron: okay!
15:53:33 <tbarron> We'll keep a list of open issues at least.
15:53:50 <tbarron> Don't think we can dispose of this one immediately.
15:54:55 <tbarron> dustins: any more for today?
15:55:00 <dustins> One more for today
15:55:04 <dustins> #link: https://bugs.launchpad.net/manila/+bug/1490909
15:55:05 <openstack> Launchpad bug 1490909 in Manila "Tempest Scenario tests do not respect config opts" [Medium,New]
15:55:45 <bswartz> We've changed how we handle these kinds of opts over time
15:56:00 <bswartz> It's possible this bug is no longer accurate
15:56:32 <bswartz> I think the important thing is that tempest has options to support the cases we actually care about, and we should remove anything that's not relevant
15:56:41 <tbarron> yeah, like we don't run ip access tests against cert backends, etc.
15:57:01 <bswartz> In particular, we specifically don't support user rules for NFS and IP rules for CIFS (although we tried to in the past)
15:57:06 <tbarron> can we mark this one no longer valid and close it?
15:57:22 <tbarron> There might be residual issues but if so they should have new bugs.
15:57:24 <bswartz> IMO we should actually remove the now-useless tempest options
15:57:50 <dustins> +1000000
15:57:57 <tbarron> bswartz: +1 but we don't need this bug to do that
15:58:03 <bswartz> And if a use case comes up that requires something similar, then add the options specifically for that case
15:58:35 <tbarron> k, we have two minutes, dustins anything else?
15:58:59 <tbarron> #topic Open Discussion
15:59:00 <dustins> Nope! I'm good!
15:59:02 <tbarron> :)
15:59:06 <tbarron> 1.5 minutes
15:59:31 <tbarron> OK, if we have anything let's take it to #openstack-manila
15:59:35 <tbarron> Thanks all!!!
15:59:39 <bswartz> since this is the first meeting since PTG
15:59:46 <bswartz> I'd like to say the PTG went really great
15:59:51 <amito> +1
16:00:02 <tbarron> bswartz: agree
16:00:02 <dustins> Hoping I can make the next one :)
16:00:06 <xyang> +1
16:00:08 <bswartz> Thanks to those that attended and to the staff who rescued the event when #snowpenstack nearly ruined it
16:00:18 <zhongjun> +1
16:00:19 <xyang> the remote session is great
16:00:34 <tbarron> xyang: you made it worthwhile!
16:00:39 <gouthamr> with dustins on that one. Hope I can make it to the next one
16:00:48 <tbarron> #endmeeting