15:01:01 <tbarron> #startmeeting manila
15:01:02 <openstack> Meeting started Thu May 17 15:01:01 2018 UTC and is due to finish in 60 minutes.  The chair is tbarron. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:05 <openstack> The meeting name has been set to 'manila'
15:01:22 <tbarron> manila courtesy ping:  gouthamr zhongjun xyang markstur vponomaryov cknight toabctl bswartz ganso
15:01:24 <gouthamr> o/
15:01:25 <dustins> \o
15:01:32 <zhongjun_> Hi
15:01:39 <ganso> hello
15:01:53 * tbarron waits a minute
15:02:02 <erlon> hey
15:02:12 <xyang> hi
15:02:26 <tbarron> Hi all!
15:02:36 <vgreen> hello
15:02:49 <tbarron> I want to thank bswartz for chairing the meeting last week.
15:03:10 <vgreen> or "howdy y'all" in southern vernacular
15:03:10 <tbarron> I believe he's traveling this week but may be able to join at some point.
15:03:27 <tbarron> vgreen hails from South Carolina
15:03:59 <vgreen> go Clemson Tigers!
15:04:07 <tbarron> Last week's meeting seemed productive (I read the transcript).
15:04:15 <tbarron> #topic announcements
15:04:16 <gouthamr> vgreen: +1
15:04:39 <tbarron> Next week is summit.
15:04:51 <tbarron> I won't be available at this time slot.
15:05:04 <tbarron> Does anyone feel a need to hold the meeting next week?
15:05:16 * tbarron waits a polite interval
15:05:30 <gouthamr> i presume a bunch of people will be at the summit, so i think we should skip it
15:05:38 <dustins> Same here
15:05:47 <tbarron> If not, I'll send an email notice to that effect ^^
15:05:57 <tbarron> you've seen others like it go by I expect
15:06:06 <zhongjun_> gouthamr: +1
15:06:35 <tbarron> #agreed no meeting next week
15:06:52 <tbarron> Milestone 2 for Rocky is the week of 4 June.
15:07:01 <tbarron> #link https://releases.openstack.org/rocky/schedule.html
15:07:13 <tbarron> That's also the manila new driver submission deadline.
15:07:27 <tbarron> New drivers were covered well last week.
15:07:39 <tbarron> My impression is that nothing has changed, that is
15:07:49 <tbarron> Inspur is making good progress and
15:08:02 <gouthamr> yes, still see only the inspur CI listening to changes, and passing
15:08:03 <tbarron> that Pure driver is in peril because of lack of CI.
15:08:27 <tbarron> I've given fair warning on #openstack-manila
15:08:40 <tbarron> Anyone have other updates/corrections on this subject?
15:09:21 <tbarron> OK, todays' agenda is
15:09:29 <tbarron> #link https://wiki.openstack.org/w/index.php?title=Manila/Meetings&section=2
15:09:35 <tbarron> #topic python3 status
15:09:51 <tbarron> vkmc is travelling I believe but gouthamr your name is on this one too
15:10:24 <gouthamr> yep, i can cover this slightly, but i didn't sync up with vkmc so I may be missing the entire context
15:10:49 <tbarron> gouthamr: we can carry this item forward as well but why don't you broach the subject
15:10:58 <gouthamr> yep
15:11:38 * tbarron passes gouthamr some coffee
15:11:40 <gouthamr> as you're aware, we're on track to get python3 compatibility through all of the manila projects: server, client, UI
15:11:43 <tbarron> Seattle's best
15:11:51 <gouthamr> haha :)
15:12:19 <gouthamr> much thanks to vkmc to get the issues sorted out within manila UI
15:12:41 <gouthamr> the next steps here are to enable Python3 on the DSVM jobs
15:12:55 <gouthamr> and request that third party CIs do the same..
15:13:21 <gouthamr> there's one blocker though, and vkmc asked if it was a blocker to us reaching the python3 community goal
15:13:37 <gouthamr> #link http://lists.openstack.org/pipermail/openstack-dev/2018-May/130463.html
15:14:33 <gouthamr> you're aware that we still have our out-of-the-box wsgi app that uses the eventlet library that can be used as the manila API server
15:15:02 <tbarron> Does anyone *here* use this?
15:15:21 <gouthamr> as well as (thanks vponomaryov), we support running as a virtual host behind a web server..
15:15:33 <gouthamr> tbarron: +1 important question
15:16:06 <tbarron> We can check with operator community as well, but worth asking the devs here too.
15:16:19 <tbarron> If any of you say "yes" that's worth knowing.
15:17:03 <tbarron> I am concerned that if we have to wait for eventlet to sort out py3 support issues we could wait a long time.
15:17:22 <gouthamr> unless you toggle MANILA_USE_MOD_WSGI to False, you're currently using manila-api behind your webserver
15:17:27 <gouthamr> ^^ in DevStack
15:18:28 <tbarron> Well I can probably raise this question in the manila operator's forum session next week and
15:18:49 <tbarron> vkmc and I can attend the general python3 readiness session
15:18:55 * tbarron thinks there is one
15:19:03 <gouthamr> good stuff tbarron
15:19:14 <tbarron> and we can pursue the issue on the operator's week after summit
15:19:29 <tbarron> If we can remove the builtin server, great.
15:19:45 <gouthamr> #link https://bugs.launchpad.net/manila/+bug/1482633
15:19:46 <openstack> Launchpad bug 1482633 in oslo.service "requests to SSL wrapped sockets hang while reading using py3" [High,Triaged]
15:19:50 <tbarron> If not, we may need to make use of it conditional, not supported with python3 ....
15:20:43 <tbarron> Anything more on this today?
15:20:49 <gouthamr> the unit test that exposes the bug was removed as part of the effort to add mod-wsgi support - https://review.openstack.org/#/c/448190/12/manila/tests/test_wsgi.py
15:21:56 <gouthamr> nope, i think we can seek feedback on the forums you mentioned tbarron
15:22:01 <tbarron> so we could also deprecate in Rocky and see who yeslls at us
15:22:08 <tbarron> *yells
15:22:14 <gouthamr> YELLS
15:22:19 <tbarron> haha
15:22:22 <tbarron> hahaHA
15:22:36 <tbarron> #topic bugs
15:22:45 <tbarron> dustins: what do you have for us?
15:22:47 <ganso> tbarron: my topic is going to be later?
15:22:59 <tbarron> ganso: did you just update the agenda?
15:23:13 * tbarron must have an old cached copy?
15:23:14 <ganso> tbarron: a few minutes after the meeting started, before posting the agenda
15:23:48 <tbarron> #topic missing share servers in ensure_shares driver method
15:23:53 <ganso> tbarron: thanks
15:23:56 <tbarron> ganso you are up!
15:23:56 <ganso> should be a quick one
15:24:13 <ganso> so past 2 releases the ensure share functionality got updated
15:24:27 <ganso> and no other driver was using it other than LVM just as an example
15:24:35 <ganso> LVM is a DHSS=False driver
15:24:39 <zhongjun_> That is true
15:24:45 <ganso> I was trying to use it in NetApp driver
15:24:54 <ganso> but because of this https://github.com/openstack/manila/blob/master/manila/share/manager.py#L390
15:25:02 <ganso> no share servers are being passed
15:25:15 <zhongjun_> I miss the share server in ensure shares
15:25:18 <ganso> and I cannot talk to my share server to perform ensure share
15:25:43 <tbarron> ganso: so that seems like a bug
15:25:45 <ganso> the attribute cannot be accessed directly because of
15:25:46 <ganso> May 17 10:31:41.328469 openstack2 manila-share[4326]: 2018-05-17 10:31:41.323 ERROR manila.share.manager [req-b4cdc68f-2e1f-43f6-a725-f22b6eaf9967 None None] Caught exception trying ensure share instances.: DetachedInstanceError: Parent instance <ShareInstance at 0x7fcb00f5f310> is not bound to a Session; lazy load operation of attribute 'share_server' cannot proceed (Background on this error at:
15:25:47 <ganso> http://sqlalche.me/e/bhk3)
15:26:13 <ganso> ^ that is why we pass the share server for every method we invoke in the driver
15:26:26 <ganso> the manager needs to obtain the share server and pass to the driver
15:26:42 <ganso> this does look like a bug
15:26:50 <gouthamr> ganso: but a driver may be managing multiple share servers
15:27:06 <ganso> gouthamr: exactly, so we also cannot pass a single share server
15:27:09 <gouthamr> ganso: so probably update the share to a dict and explicitly pass the share server
15:27:16 <ganso> gouthamr: yes
15:27:23 <tbarron> zhongjun_: do you agree?
15:27:25 <ganso> I just wanted to get agreement that this is a bug
15:27:37 <zhongjun_> It’s a bug
15:27:43 <ganso> ok
15:27:44 <gouthamr> ganso: +1
15:27:46 <tbarron> zhongjun_: on 1) it's a bug, 2) likely fix
15:28:15 <zhongjun_> Both
15:28:21 <tbarron> awesome
15:28:22 <ganso> alright =)
15:28:35 <ganso> looks like we are done here, I'll create the launchpad bug entry
15:28:44 <tbarron> ganso: thanks for finding the issue and for fixing it (TIA) :)
15:28:55 <ganso> tbarron: =D
15:29:14 <tbarron> #topic bugs (in general)
15:29:33 <tbarron> #link  https://etherpad.openstack.org/p/manila-bug-triage-pad
15:29:38 <tbarron> dustin you are up!
15:29:44 <dustins> Thanks, tbarron
15:29:56 <dustins> Not much today as we're pretty well up to date with new bugs
15:30:07 <dustins> So let's check in on our ongoing efforts
15:30:29 <dustins> #link https://bugs.launchpad.net/manila/+bug/1762900
15:30:30 <openstack> Launchpad bug 1762900 in Manila "tearDownClass manila_tempest_tests.tests.api.test_share_networks_negative.ShareNetworksNegativeTest Failed" [High,Triaged] - Assigned to Tom Barron (tpb)
15:30:51 <tbarron> dustins: I haven't done anythign with this one
15:30:58 <dustins> As part of our ongoing "make Tempest suck less" effort :)
15:31:19 <tbarron> dustins: I have this because we have the same issue assigned to me as default stuckee downstream
15:31:34 <dustins> tbarron: Ahh, gotcha
15:31:35 <tbarron> dustins: my plan was to ask our in-house tempest folks to replicate it since
15:31:45 <tbarron> they are sitting around twiddling their thumbs and
15:31:49 <tbarron> not doing much
15:31:53 <dustins> hehehe
15:31:58 * gouthamr shots fired
15:31:59 * tbarron is joking of course
15:32:11 <dustins> Makes sense to me, let's move on
15:32:18 <tbarron> dustins: so let's keep this one on the backlog for the moment
15:32:25 <dustins> #link https://bugs.launchpad.net/manila/+bug/1760644
15:32:26 <openstack> Launchpad bug 1760644 in Manila "API refference contains mistakes" [High,Triaged] - Assigned to Victoria Martinez de la Cruz (vkmc)
15:32:54 <tbarron> vkmc is traveling and at summit next week so probably the same status
15:33:06 <dustins> Still need that API ref audit, but that's going to be a larger effort than what can be accomplished in a week
15:33:18 <dustins> And yeah, vkmc is currently racking up frequent flyer miles :)
15:34:06 <dustins> This is the last one that I have for today, nothing new this time
15:34:17 <dustins> I'm sure summit will change that though
15:34:22 <dustins> #link https://bugs.launchpad.net/manila/+bug/1755795
15:34:23 <openstack> Launchpad bug 1755795 in Manila "manila_tempest_tests.tests.scenario.test_share_basic_ops create share failed because share type not found" [Undecided,New]
15:34:51 <dustins> Again, a part of the larger effort to improve our Tempest tests
15:35:18 <gouthamr> yep, and vkmc was working on the API tests at least.. let's keep this one around so we can target the scenario tests right after
15:35:29 <dustins> gouthamr: Absolutely
15:35:33 <tbarron> dustins: I just added one under 17 May
15:36:04 <dustins> #link https://bugs.launchpad.net/manila/+bug/1767430
15:36:05 <openstack> Launchpad bug 1767430 in Manila "host prefixes for access allow should conflict with /32 and /128 prefixes" [High,In progress] - Assigned to Goutham Pacha Ravi (gouthamr)
15:36:38 <gouthamr> so gate's broken because of a couple of issues
15:36:56 <tbarron> There's a review posted for this one but it needs core reviewer attention.
15:37:10 <gouthamr> #link https://bugs.launchpad.net/manila/+bug/1770183
15:37:11 <openstack> Launchpad bug 1770183 in Manila "manila-tempest-dsvm-scenario job does not fail if individual tests fail" [High,In progress] - Assigned to Goutham Pacha Ravi (gouthamr)
15:37:30 <gouthamr> the bug was opened for the scenario test job, but extends to other tests as well
15:37:53 <gouthamr> the fix is up for review, and it seems to work
15:38:05 <gouthamr> #link https://review.openstack.org/#/c/568650/
15:38:23 <tbarron> gouthamr: and yes, gate is broken so we need to sort those issues independently, can
15:38:28 <gouthamr> see https://review.openstack.org/#/c/568393/ where tests really fail
15:38:33 <tbarron> come back to that in OpenDiscussion
15:38:42 <gouthamr> yep
15:39:21 <dustins> tbarron: that's all I have for this week
15:39:24 <gouthamr> dustins: short answer: there are patches in place for LP 1767430 and the tests that bswartz asked for
15:39:25 <openstack> Launchpad bug 1767430 in Manila "host prefixes for access allow should conflict with /32 and /128 prefixes" [High,In progress] https://launchpad.net/bugs/1767430 - Assigned to Goutham Pacha Ravi (gouthamr)
15:39:32 <tbarron> gouthamr: thanks for that fix, others please review
15:39:52 <dustins> gouthamr: Sounds good!
15:40:36 <tbarron> #topic Open Discussion
15:40:57 <tbarron> First the centos jobs were failing
15:41:05 <tbarron> problems getting to yum repos
15:41:29 <tbarron> I asked on #openstack-infra, got no response, and got diverted with other things.
15:41:49 <tbarron> Too many people cheering for Clemson in my workplace, got distracted.
15:42:00 <vgreen> haha
15:42:02 <tbarron> Then it looks like other jobs are failing too.
15:42:25 <tbarron> https://review.openstack.org/#/c/556197/
15:42:36 <gouthamr> easy to get distracted that way
15:42:50 <tbarron> So there is some work to be done cleaning up gate and getting it going again.
15:43:03 <tbarron> Any efforts or insights will be appreciated :)
15:43:15 <tbarron> I'll try to get back to this stuff myself as well.
15:43:16 <gouthamr> tbarron: the last tests ran on Apr 15th
15:43:44 <tbarron> gouthamr: ok, I'll start with a recheck :)
15:43:53 <gouthamr> tbarron: just rebased that patch :)
15:44:01 <tbarron> maybe we'll get lucky
15:44:06 <tbarron> gouthamr: ty
15:44:37 <tbarron> Other stuff to talk about today?
15:44:51 <gouthamr> tbarron: do you mean to follow up about the centos failure?
15:45:06 <tbarron> gouthamr: yeah, assuming it's still there
15:45:08 <gouthamr> i'd be glad to take that off your already-full plate..
15:45:25 <tbarron> gouthamr: you are very welcome to do that, thanks for volunteering :)
15:45:49 <tbarron> go Clemson!
15:45:53 <gouthamr> tbarron: np...
15:45:58 <tbarron> Anything else?
15:46:14 <tbarron> if not, you get 14 minutes of your life back today.
15:46:23 <tbarron> Thanks all!!!
15:46:27 * gouthamr what do i do with all this extra time
15:46:30 <tbarron> #endmeeting