15:00:55 <tbarron> #startmeeting manila
15:00:56 <openstack> Meeting started Thu Jun 21 15:00:55 2018 UTC and is due to finish in 60 minutes.  The chair is tbarron. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:57 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:00 <openstack> The meeting name has been set to 'manila'
15:01:02 <bswartz> .o/
15:01:08 <ganso> hello
15:01:13 <vkmc> o/
15:01:18 <tbarron> manila courtesy ping: gouthamr zhongjun xyang markstur toabctl bswartz ganso tpsilva vkmc vgreen erlon
15:01:26 <zhongjun__> hi
15:01:34 <gouthamr> o/
15:02:00 <vgreen> o/
15:02:02 <tbarron> Hi all!
15:02:10 <erlon_> hey
15:02:18 <tbarron> #topic announcements
15:02:43 <tbarron> Yesterday gouthamr fixed the project "badges" so that manila's
15:02:57 <tbarron> achievements and status are properly reflected.
15:03:09 <tbarron> #link https://review.openstack.org/#/c/577020/
15:03:15 <tbarron> Thanks gouthamr !!!
15:03:38 <gouthamr> :)
15:03:48 <tbarron> Just a reminder that we are working with an eye towards
15:03:54 <bswartz> Was that the change you intended to link?
15:03:54 <tbarron> M3 on July 26.
15:03:58 <bswartz> Doesn't look manila specific
15:04:09 <tbarron> bswartz: it fixed stuff for us though
15:04:23 <gouthamr> bswartz: yeah, everyone had lesser badges than they really did
15:04:23 <tbarron> our badges were getting squashed out
15:04:30 <bswartz> interesting
15:04:38 <bswartz> Thx gouthamr
15:05:05 <tbarron> w.r.t. M3 on July 26 we need to review and merge
15:05:10 <tbarron> Inspur driver
15:05:22 <tbarron> #link https://review.openstack.org/#/c/550454/
15:05:34 <tbarron> metadta for access rules
15:05:46 <tbarron> #link https://review.openstack.org/#/c/570708/
15:05:47 <tbarron> #link https://review.openstack.org/#/c/571366/
15:05:56 <tbarron> priority for access rules
15:06:05 <tbarron> #link https://review.openstack.org/#/c/572283/
15:06:12 <tbarron> json query validation
15:06:41 <tbarron> #link https://review.openstack.org/#/c/563429/
15:06:56 <tbarron> Just reminding ....
15:07:07 <bswartz> Will there be a review etherpad this cycle?
15:07:07 <tbarron> Any other announcements?
15:07:46 <tbarron> bswartz: I will put one together since we don't have a storyboard for same yet :)
15:08:21 <bswartz> To help coordinate reviews (mostly to avoid too many people reviewing the same thing while nobody reviews other things)
15:08:34 <bswartz> Will storyboard eventually support that feature?
15:08:36 <tbarron> #action tbarron will create a review etherpad for m3
15:09:00 <tbarron> storyboard is low level tooling on which such a feature could be built
15:09:10 <tbarron> it allows one to do trello-like stuff
15:09:25 * bswartz knows nothing of trello...
15:09:29 <tbarron> and this would I think be a natural application.
15:09:52 <tbarron> bswartz: post-its in columns with annotations
15:09:59 <gouthamr> bswartz: trello's like rally's kanban board, a little more flexible
15:10:20 <ganso> gouthamr: much more simple as well
15:10:27 <tbarron> doesn't necessarily imply kanban methodology though
15:10:31 <ganso> s/more simple/simpler
15:10:35 <gouthamr> true..
15:10:55 <tbarron> like we can still all work on 15 things at once :D
15:11:08 <tbarron> for better or worse
15:11:23 <tbarron> Any other announcements??
15:11:35 * bswartz can work on 16 things at once, as long as 15 of them are not important
15:11:44 <gouthamr> :) atleast we get to see all the 15 things in a place (channeling ameade)
15:11:46 <tbarron> :D
15:12:13 <tbarron> #topic Beijing bug smash
15:12:21 <tbarron> It was this week.
15:12:34 <tbarron> Thanks to those participating or helping do reviews.
15:12:51 <tbarron> And special thanks to zhongjun__ for coordinating manila aspects.
15:12:52 <zhongjun__> Thanks all
15:13:03 <gouthamr> ++ thanks zhongjun__
15:13:06 <tbarron> #link  https://etherpad.openstack.org/p/OpenSource-Hackathon-Rocky-Beijing-Bugs-List
15:13:23 <zhongjun__> #link https://etherpad.openstack.org/p/OpenSource-Hackathon-8-beijing
15:13:39 <tbarron> Some bugs are fixed, some are in review, some are still in backlog.
15:13:50 <tbarron> But good progress, thanks again!
15:14:02 <zhongjun__> In line  162,  We don't have separate statistics on manila projects, we only count bug number of storage.
15:14:50 <tbarron> zhongjun__: understood
15:15:18 <tbarron> I was late gettiing bugs into the list for this bug smash but overall I think good progress was made.
15:15:31 <tbarron> Anything else on this topic?
15:16:10 <tbarron> #topic manila meeting time (bswartz)
15:16:17 <bswartz> o_O
15:16:21 <bswartz> Oh yes, I remember this
15:16:25 <tbarron> Ben brought this one up after the meeting last week.
15:16:50 <tbarron> Ben?
15:16:57 <bswartz> Want me to cover it?
15:17:18 <tbarron> You were pretty articulate at the time, let's assume you will be again :D
15:17:31 <tbarron> so yes please
15:18:06 <bswartz> I realized during the meeting last week that we chose the time for this weekly meeting many years ago, when we had a number of core team members in Europe and the east coast of the US, and none in the west coast or pacific region
15:18:34 <bswartz> I think that over time the center of gravity of the team has moved, and it's worth considering a different meeting time
15:19:11 <bswartz> In particular, something more friendly to the pacific region -- so probably 4-5 hours later than currently scheduled
15:19:44 <bswartz> This would cause pain for anyone joining from the EMEA region
15:20:21 <bswartz> But other than toabctl, I don't know who that includes
15:21:00 <bswartz> Thoughts?
15:21:24 <bswartz> zhongjun__: would you prefer this meeting to be 4-5 hours later?
15:21:44 <bswartz> I'm sure that gouthamr/markstur would
15:21:53 <tbarron> toabctl: is on paternity leave which implies that he will soon be awake at odd hours anyways :D
15:21:58 <zhongjun__> 4-5 hours later, It will be at 4:00
15:22:16 <zhongjun__> 4:00 morning
15:22:24 <bswartz> erm
15:22:26 <bswartz> Really?
15:22:32 <bswartz> That's not good
15:22:46 <markstur> this time is fine for me
15:22:47 <zhongjun__> Now It's 23:22 in my zone
15:22:51 <bswartz> How much later would it need to be for it to be morning time for you zhongjun__?
15:23:11 <bswartz> So it would need to be 9 hours later?
15:23:32 <bswartz> That would create problems for those of us on the east coast
15:23:33 <vgreen> beijing is 12hr ahead of EST
15:23:47 <zhongjun__> It's fine,  10 hours later would be more better
15:24:20 <bswartz> Okay I hadn't done the math last week
15:24:27 <zhongjun__> haha
15:24:50 <bswartz> That would mean that in order to make the situation better in China, those of us on the east coast would have to join in the evening after dinner
15:24:56 <bswartz> tbarron: what do you think?
15:25:27 <tbarron> I'm willing to do it but fear that we'll lose attendance from the current group.
15:25:35 <zhongjun__> \
15:26:02 <amito> I'm joining from EMEA. 4-5 hours later will be around midnight.
15:26:06 <markstur> to be fair you could at least try alternating times or something.  Unfortunately inconsistent meeting times can also hurt attendance
15:26:06 <ganso> how about 2 meetings or async meetings? I've heard there are other projects doing that
15:26:32 <bswartz> ganso: we've avoided that in the past -- it means you never have a quorum for important discussions
15:26:46 <bswartz> And it's twice as much work for the meeting chair
15:26:49 <amito> (I don't have reception here so I'll probably disappear in a minute or two...)
15:27:04 <tbarron> amito: noted
15:27:53 <tbarron> some meetings (like TC) have gone away altogether in favor of async IRC and "office hours"
15:28:06 <bswartz> So based on the realities of the timezones, I don't know if we can do better than the current time
15:28:16 <tbarron> but I don't know that that would really work for us either.
15:28:29 <bswartz> I don't have a specific proposal, but I wanted to shine light on the fact that the team's center of gravity has moved
15:28:52 <tbarron> I'm not hearing a consensus for a change but bswartz has certainly raised an important issue.
15:29:13 <tbarron> We also don't know who *would* be attending if we had the meeting at another time.
15:29:45 <tbarron> Let's everyone think about this and don't be afraid to make suggestions.
15:29:48 <ganso> it seems we can't agree to a better meeting time
15:30:00 <tbarron> ganso: at least not today
15:30:10 <bswartz> I has been hoping that moving the meeting a few hours would help china, but I didn't realize how far we would have to move it to make it work
15:30:17 <zhongjun__> I think so, We almost have a half-day time difference
15:30:52 <bswartz> If we moved it 9 or 10 hours, then it would cause problems for east coast people, including brazil
15:31:10 <ganso> bswartz: yup
15:32:14 <bswartz> Personally I'm not sure how often I could attend a 9pm or 10pm meeting
15:32:16 <tbarron> well let's table this topic for now; if you get an idea pertaining to $subject then let's talk about it again
15:32:41 <tbarron> #topic Open Discussion
15:32:53 <tbarron> Do we have other things to talk about today?
15:33:41 <bswartz> We could discuss the world cup...
15:33:51 <tbarron> :)
15:33:52 <ganso> lol
15:34:19 <tbarron> OK, let's go do work or watch TV or whatever, see you all next week!
15:34:24 <tbarron> Thanks for working on manila!
15:34:29 <tbarron> #endmeeting