15:00:14 <tbarron> #startmeeting manila
15:00:15 <openstack> Meeting started Thu Aug 16 15:00:14 2018 UTC and is due to finish in 60 minutes.  The chair is tbarron. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:19 <openstack> The meeting name has been set to 'manila'
15:01:02 <dustins> \o
15:01:03 <ganso> hello
15:01:06 <xyang> hi
15:01:27 <tbarron> ping gouthamr
15:01:28 <gouthamr> o/
15:01:31 <tbarron> ping bswartz
15:01:31 <jun2222> hello
15:01:46 <tbarron> jun2222 just esacaped a unicast ping
15:01:51 <tbarron> Hi folks!
15:02:03 <vgreen> o/
15:02:03 <tbarron> I don't have a big agenda today
15:02:18 <tbarron> https://wiki.openstack.org/wiki/Manila/Meetings#Next_meeting
15:02:25 <tbarron> #topic announcments
15:02:53 <tbarron> Final rc will be cut next week.
15:03:17 <tbarron> Also we'll need to release manila-tempest-plugin by then.
15:03:38 <tbarron> Reminder that PTG planning etherpad is here:
15:03:53 <tbarron> #link https://etherpad.openstack.org/p/manila-ptg-planning-denver-2018
15:04:10 <gouthamr> tbarron: can ^ be channel topic please :)
15:04:20 <tbarron> We need to be exercising our rc code and planning for the PTG
15:04:24 <tbarron> gouthamr: sure thing
15:04:51 <tbarron> Any other announcments?
15:05:13 <tbarron> #chair gouthamr
15:05:14 <openstack> Current chairs: gouthamr tbarron
15:05:27 <vkmc> o/
15:05:28 <tbarron> gouthamr: ^^ my internet connection is flaky, so just for  backup
15:05:41 <gouthamr> np, thank you..
15:05:43 * tbarron doesn't notice vkmc sneaking in
15:05:54 * vkmc hides
15:06:17 <tbarron> #topic upcoming releases
15:06:26 <tbarron> Do we have any rc blockers?
15:07:03 <tbarron> I don't know of any bugs that would block myself.
15:07:14 <tbarron> crickets
15:07:36 <tbarron> Do we have any manila-test-plugin fixes that have to get in before release?
15:07:49 <tbarron> If not, I'll release it today since tempest just released.
15:07:57 <gouthamr> nope, i'm still proposing backports, but we don't need to redo the rc that people may be testing..
15:08:14 <gouthamr> manila-tempest-plugin's not got any patches that need to go in either
15:08:26 <tbarron> Other things being equal it's helpful to have the tags for tempest and for the plugins line up.
15:08:59 <tbarron> OK, let me know in the next couple hours if anything comes up but
15:09:12 <tbarron> otherwise I will release the plugin in a bit.
15:09:16 <gouthamr> +1
15:09:19 <tbarron> Please keep testing our rc.
15:09:23 <tbarron> for manila itself.
15:09:35 <tbarron> Anything else on this topic?
15:09:52 <tbarron> #topic Bugs
15:10:00 <tbarron> dustins: got any for us today?
15:10:03 <dustins> Going buggy early :)
15:10:19 <dustins> Yeah, I've got a few for our Horizon plugin
15:10:27 <dustins> So brace yourselves
15:10:39 <dustins> #link https://etherpad.openstack.org/p/manila-bug-triage-pad
15:11:00 <dustins> #link https://bugs.launchpad.net/manila-ui/+bug/1787016
15:11:00 <openstack> Launchpad bug 1787016 in manila-ui "Unable to retrieve replica details as non-admin user" [Undecided,New]
15:11:57 <tbarron> yeah, that's a bug
15:12:14 <gouthamr> ah, this is me. I *think* the problem is because we're invoking an admin API
15:12:31 <tbarron> and when we fix it it will void my dumb suggested fix for displaying the host field
15:13:21 <gouthamr> tbarron: nope, the admin API was to extract per-instance export locations
15:13:45 <gouthamr> s/was/is
15:14:18 <gouthamr> i may be mistaken, but i suppose the share replica APIs currently don't return export locations, and that's bad
15:14:49 <gouthamr> so this may become a manila bug too
15:14:49 <tbarron> gouthamr: so do we have the issue quite apart from the ui ?
15:15:07 <gouthamr> tbarron: yes, checking..
15:15:15 <tbarron> gouthamr: ok
15:15:36 <dustins> gouthamr: Would you mind updating the bug with what you find?
15:15:48 <tbarron> #action gouthamr will check whether the bug is more general than the ui and update the bug
15:15:53 <gouthamr> grrr, https://developer.openstack.org/api-ref/shared-file-system/#show-share-replica
15:16:11 <gouthamr> yep, we don't have the export locations on that API ^
15:16:26 <gouthamr> dustins: sure thing, i'll assign it to myself too
15:16:32 <dustins> gouthamr++
15:16:48 * dustins sets to triaged
15:16:51 <dustins> Moving on then
15:17:11 <dustins> #link https://bugs.launchpad.net/manila-ui/+bug/1749316
15:17:12 <openstack> Launchpad bug 1749316 in manila-ui "multiple requests to manila while on network pages" [Undecided,New]
15:17:30 <dustins> I honestly can't remember if we touched on this last week or not (I may have skipped it)
15:18:16 <tbarron> I don't remember discussing it.
15:18:47 <tbarron> I wonder if this is another case of our plugin monkey patching into horizon.
15:19:27 <gouthamr> possibly, but it seems really odd
15:19:49 <gouthamr> we're missing the release info
15:19:57 <tbarron> gouthamr: right
15:20:23 <tbarron> dustins: would you ask for that?  release, distribution (if htere is one), etc.
15:20:47 <dustins> tbarron: Sure can, lemme jot that down to follow up on that after the meeting
15:20:52 <gouthamr> we committed a major refactor a while ago
15:21:02 <gouthamr> #LINK: https://review.openstack.org/#/c/465127/
15:21:08 <gouthamr> #LINK: https://review.openstack.org/#/c/464716/
15:21:24 <gouthamr> and manila-ui became a whole lot less needy/chatty
15:21:39 <gouthamr> i wonder if OP was using an earlier release
15:23:04 <tbarron> #action dustins will follow up with release query
15:23:55 * dustins updates bug
15:23:59 <dustins> #link https://bugs.launchpad.net/manila-ui/+bug/1702396
15:24:00 <openstack> Launchpad bug 1702396 in manila-ui "Non-admin user can't get the share network details" [Undecided,New]
15:24:14 <gouthamr> :(
15:24:15 <dustins> This is an old one
15:24:25 <vgreen> lots of manila-ui, ugh
15:24:45 <dustins> vgreen: Spoiler - All the bugs today are manila-ui
15:24:53 * vgreen hides
15:24:56 <dustins> And some of them are more than a year old
15:25:02 <dustins> ...like this one
15:25:11 * gouthamr suspects dustins's not had coffee yet
15:25:31 <tbarron> #action tbarron will see if he can repro this with current code
15:25:33 <dustins> gouthamr: You'd be correct, and it was an early morning :)
15:25:39 <dustins> tbarron: Sounds good to me
15:25:51 <tbarron> and follow up asking for release details if not
15:26:06 <dustins> tbarron++
15:26:50 <gouthamr> dustins tbarron: just confirmed, bug still exists
15:26:58 <tbarron> gouthamr: thanks
15:27:02 <dustins> gouthamr: awesome, thanks
15:27:30 * dustins marks as triaged with medium priority
15:28:05 <dustins> #link https://bugs.launchpad.net/manila-ui/+bug/1685655
15:28:05 <openstack> Launchpad bug 1685655 in manila-ui "Share type is created with snapshot_support=True by default" [Undecided,New]
15:28:12 * vkmc takes it
15:28:21 <dustins> vkmc++
15:28:43 <dustins> ganso: You reported this a LONG time ago
15:28:59 <ganso> dustins: so long I don't even remember xD
15:29:07 <dustins> hehehe
15:29:17 <jun2222> :D
15:29:49 <dustins> We can check to see if this still happens in the current code or was fixed with the Great Refactoring
15:30:28 <dustins> My guess is that this is still an issue as manila-ui isn't frequently updated with microversion changes
15:30:50 <gouthamr> dustins: it does
15:31:10 <dustins> gouthamr: Then it was a good guess :)
15:31:23 <gouthamr> it's an annoyance, but i suppose it does provide backwards compatibility?
15:31:37 <ganso> "The Great Refactoring", as it is engraved in manila's history book
15:32:07 <gouthamr> we've always had "snapshot_support", even when it became optional
15:32:08 <dustins> gouthamr: Is that what we want with that? And what microversion does Horizon default to
15:32:16 <dustins> (and can we change that should we want to)
15:32:23 <dustins> ganso: Hah!
15:33:10 <ganso> I think the proper behavior should be the same as the manila cli
15:33:24 <ganso> so, to not create new share types with snapshot_support defaulting to True
15:33:28 <tbarron> ganso++
15:33:29 <dustins> ganso: That sounds reasonable to me
15:33:50 <gouthamr> dustins: 2.32
15:34:09 <gouthamr> i.e, that's the hard-coded maximum for the last couple of releases
15:34:24 <tbarron> current manila-ui not matching current cli is more puzzlliing to the user than having it change some behaviors over time
15:35:01 <dustins> So should we update manila-ui to use the 2.40 to match the CLI?
15:35:02 <tbarron> the ui needs love and attention
15:35:08 <dustins> That it does
15:35:53 <tbarron> is there any reason that we'd want to have the UI run at an older microversion?
15:36:04 * tbarron hasn't  thought about the matter deeply at all
15:36:37 <dustins> I can't think of a good one since we don't have a concept of a "master" microversion and a "stable" microversion
15:36:37 <tbarron> if we don't expose some new api features in the ui?
15:36:42 <tbarron> yet
15:36:52 <dustins> tbarron: Oooh, that's a good point
15:37:15 <dustins> I wonder what features are missing from manila-ui
15:37:29 <gouthamr> dustins: everything between 2.32 and 2.46 :)
15:37:34 <tbarron> well, access rule metadata
15:37:39 * tbarron works backwards
15:37:48 <dustins> gouthamr: eek
15:39:45 <gouthamr> dustins: we can mark this bug "medium" and list the workaround on the bug, and get to it soon-ish
15:40:05 <gouthamr> the workaround is, edit the extra-specs if you don't want 'snapshot_support'
15:40:38 <dustins> Done
15:40:56 <dustins> Just need to add the workaround while we work on the permanent solution
15:41:26 <jun2222> open bug for each new APIs which not support in manila-ui?
15:41:45 <tbarron> jun2222: agree
15:42:25 <gouthamr> +1
15:42:26 <dustins> The manila-ui bug page is about to get a bit more full :)
15:42:46 <dustins> It's a very good thing, IMHO
15:42:47 <vkmc> yeah... and maybe add a new flag for features so the bug is created automagically in the future
15:42:59 <vkmc> DocImpact ~= UIImpact
15:43:00 <gouthamr> vkmc: +1
15:43:03 <vkmc> if it's not there yet
15:43:09 <tbarron> vkmc: agree
15:43:15 <gouthamr> vkmc: not there, but we can do it on storyboard perhaps!
15:43:20 <jun2222> vkmc: +1
15:44:14 <vkmc> sounds good!
15:44:34 <dustins> fantastic idea, let's do it!
15:44:37 <dustins> #link https://bugs.launchpad.net/manila-ui/+bug/1650357
15:44:37 <openstack> Launchpad bug 1650357 in manila-ui "Link supported protocols and share types when creating a share" [Undecided,New]
15:45:00 <dustins> This one seems more like a feature request
15:45:14 <dustins> But it seems like a good idea, if feasible
15:45:41 <gouthamr> dustins: let's add manila to that bug.. this may be helpful outside of manila as well
15:46:23 <dustins> Done!
15:46:34 <tbarron> proabably set it to wishlist
15:46:42 <dustins> Oh sheesh, this bug's been open for nearly two years
15:46:52 <tbarron> I don't like that name - sounds too dismissive
15:47:05 <tbarron> but  it's an enhancement I think.
15:47:27 <gouthamr> yep, it wasn't high priority, vkmc and i discussed it at boston
15:48:11 <gouthamr> so long ago..
15:48:16 <tbarron> :D
15:49:16 <dustins> One last one from me, an update from last week
15:49:21 <dustins> #link https://bugs.launchpad.net/manila/+bug/1786059
15:49:21 <openstack> Launchpad bug 1786059 in Manila "Cannot Connect to Share Server when Creating Share with Generic Driver (DHSS=True)" [Undecided,New]
15:50:40 <vkmc> gouthamr, yeah, more than a year :o
15:50:55 <ganso> I posted a comment in the bug entry, and the reporter responded
15:51:28 <ganso> since he/she redeployed with openvswitch and the problem persists, I have no idea how to approach this, as this works perfectly fine in our CI and in our devstacks
15:51:42 <ganso> openvswitch and *single node
15:53:09 <ganso> anyone else have any ideas?
15:53:21 <tbarron> ganso: maybe note that, point to a review with a working job (and to the job), and indicate that there may be some packaging/distro difference?
15:53:57 <tbarron> ganso: we can submit a DNM change to stable/queens first
15:55:53 <ganso> yea we can do that
15:56:09 <tbarron> ganso: i'll submit the jobs and consult with you after it runs
15:56:12 <ganso> but we will probably not be addressing the bug, because it seems it is not a bug
15:56:34 <tbarron> well we'd have something to point to when we say we can't reproduce the issue
15:56:54 <tbarron> maybe he has a different version of paramiko or something
15:57:32 <ganso> sounds good
15:57:49 <tbarron> ok, we're about out of time
15:57:57 <tbarron> #topic open discussion
15:58:01 <tbarron> anything else for today?
15:58:29 <ganso> pee-tee-gee dinner planning?
15:58:32 <gouthamr> yes, i have a gate blocker: https://review.openstack.org/#/c/592219/
15:58:49 <gouthamr> and this may interest all of us: https://review.openstack.org/#/c/588855/
15:58:51 <tbarron> yeah, we need a non RH reviewer
15:59:13 <gouthamr> ganso ^ figured out what the darn problem was :) check https://review.openstack.org/#/c/588855/
15:59:16 <tbarron> yeah, please review
15:59:37 <tbarron> on PTG dinner, what do you folks think about a combined event with cinder?
15:59:44 <tbarron> they proposed it
15:59:48 <ganso> gouthamr: omg we will have filtered and coloured log again!
15:59:55 <ganso> gouthamr: thanks a lot! =D
16:00:09 <gouthamr> ganso: :)
16:00:14 <gouthamr> tbarron: +1
16:00:15 <ganso> tbarron: I think combined dinner is fine
16:00:20 <tbarron> OK, thanks everyone.  I'm going to adjourn.
16:00:41 <tbarron> Anyone against combined dinner say so on #openstack-manila
16:00:45 <tbarron> #endmeeting