15:00:29 <tbarron> #startmeeting manila
15:00:30 <openstack> Meeting started Thu Sep 20 15:00:29 2018 UTC and is due to finish in 60 minutes.  The chair is tbarron. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:34 <openstack> The meeting name has been set to 'manila'
15:00:42 <tbarron> Hi all!
15:01:00 <tbarron> ping bswartz
15:01:02 <dustins> \o
15:01:05 <tbarron> ping erlon
15:01:06 <ganso> hello
15:01:12 <tbarron> ping gouthamr
15:01:16 <tbarron> ping vkmc
15:01:27 <tbarron> ping xyang
15:01:31 <vkmc> o/
15:01:43 <tbarron> ping toabctl
15:01:49 <tbarron> ping tpsilva
15:01:50 <xyang> hi
15:02:14 <gouthamr> o/
15:02:22 <tbarron> Agenda: https://wiki.openstack.org/w/index.php?title=Manila/Meetings&section=2
15:02:43 <tbarron> #topic Announcements
15:02:54 <bswartz> .o/
15:03:20 <tbarron> We agreed on a schedule for Stein dev cycle
15:03:33 <tbarron> #link https://releases.openstack.org/stein/schedule.html
15:03:56 <tbarron> We're at R-29
15:04:07 <tbarron> Stein is four weeks longer than Rocky.
15:04:17 <tbarron> TC elections are underway
15:04:29 <bswartz> Longer but with more holidays
15:04:40 <tbarron> Milestone 1 is Oct 22-26
15:04:43 <tbarron> bswartz: +1`
15:05:01 <tbarron> Spec freeze is two weeks later by agreement
15:05:17 <tbarron> Nov 5-9
15:05:46 <tbarron> Nov 8 to be more precise
15:06:26 <tbarron> Next Wednesday is forum topic submission deadline
15:06:40 <tbarron> #link http://lists.openstack.org/pipermail/openstack-dev/2018-September/134740.html
15:07:16 <tbarron> but last cycle I was late and had to get special exemption so
15:07:28 <tbarron> I plan to submit our topics soon
15:07:38 <tbarron> Our brainstorming is here:
15:07:51 <tbarron> #link https://etherpad.openstack.org/p/manila-berlin-forum-brainstorm
15:08:16 <tbarron> If you have further input on forum topics please act quickly.
15:08:27 <tbarron> I think we have enough to work from though.
15:08:37 <tbarron> Any other announcements?
15:08:54 <erlon> hey
15:09:20 <tbarron> Oh, Mark Sturdevant is standing down from core.  If you want to be a manila core, get a review track record!
15:09:32 * tbarron didn't see erlon sneak in
15:09:33 <gouthamr> :(
15:09:51 <tbarron> #topic PTG summary and look ahead
15:10:00 <ganso> tbarron: he was just ignoring your ping
15:10:04 * erlon sneaked very very quietly :P
15:10:13 <tbarron> #link https://etherpad.openstack.org/p/manila-ptg-stein-summation
15:10:44 <tbarron> I will send the conventional PTG summary email later this week but
15:10:54 <tbarron> mostly it will point to the link above.
15:11:13 <tbarron> I've had some help distilling stuff from the raw record here:
15:11:42 <tbarron> #link https://etherpad.openstack.org/p/manila-ptg-planning-denver-2018
15:12:07 <tbarron> So now is your chance to look these over, fix and add as you deem appropriate
15:12:51 <ganso> our chance to discuss it right now?
15:13:20 <tbarron> ganso: yes, that fits with my plans too :)
15:13:57 <tbarron> The summary covers
15:13:59 <ganso> tbarron: ok I have a topic from the PTG I would like to discuss. Can be later after all the meetings topics
15:14:40 <tbarron> 1) Retrospective, Survey Reesults, Work planned for Stein, Agreements, and Action Items
15:14:58 <tbarron> also an item at the end that we'll get to in a moment
15:15:24 <tbarron> Looking at it, I'm struck by the significant amount of work planned and AIs.
15:15:53 <tbarron> We decided to revamp the manila wiki to track work and AIs and stuff like bug focus
15:16:07 <tbarron> instead of using lots of easily-misplaced etherpads.
15:16:30 <tbarron> I aim to get at least a first cut on the main wiki page by next meeting.
15:16:42 <tbarron> so ....
15:17:00 <tbarron> ganso, why don't we do your topic, then circle back.
15:17:10 <ganso> tbarron: ok
15:17:38 <ganso> I would just like to clarify on the ocata branch, and if there is going to be or not driverfixes branches
15:18:12 <ganso> I remember at some point I asked if we were going to immediately create the driverfixes/ocata branch. The answer was no
15:18:27 <gouthamr> there isn't going to be a driverfixes branch
15:18:37 <tbarron> Because we were thinking we'd maintian ocata itself.
15:18:39 <ganso> and that we would continue to support it until the CI breaks, in the extended support period. Once the CI breaks it will be marked as unmaintained
15:19:01 <ganso> that ^ is ok. But what if now my customer that is using ocata wants a fix?
15:19:22 <tbarron> ganso: can we fix and backport to stable/ocata?
15:19:38 <erlon> ganso it should be an unsupported fix them
15:19:49 <ganso> erlon, tbarron: the main purpose of the driverfixes branch was that it was unsupported and unmaintained
15:19:49 <erlon> at least not supported by the community
15:19:55 <gouthamr> ganso: if we can't gate it, we will not leave it unmaintained, it will be tagged, and the branch deleted
15:20:26 <tbarron> I'm confused.  Is stable/ocata already unmaintainable?
15:20:30 <gouthamr> nope
15:20:35 <gouthamr> it currently is
15:20:50 <erlon> gouthamr, I was expecting the branches to be there, like the driver fixes, but not be listed as supported
15:20:52 <tbarron> is what?
15:21:07 <ganso> basically we are getting rid of driverfixes branch approach that we've implemented since mitaka IIRC, to not allowing backports at all, no place where vendors could pick commits at their own risk?
15:21:13 <erlon> gouthamr, vendors might just need a place to land some old code
15:21:53 <ganso> tbarron: stable/ocata is currently maintained under the extended maintenance period, and we will stop maintaining it once the CI breaks for whatever reason. We agreed to this at the PTG
15:22:17 <tbarron> we said when the CI breaks and can't be feasibly fixed
15:22:26 <gouthamr> +1
15:22:31 <tbarron> CI breaks all the time; we fix it
15:22:48 <ganso> tbarron: yes, when that happens. Is there going to be a place to push fixes that are unsupported?
15:23:13 <tbarron> ganso: just so I'm clear, you are asking a hypothetical then
15:23:16 <vkmc> I don't really get the idea of having an unsupported branch that is not master
15:23:30 <ganso> tbarron: not hypothetical, it will eventually happen
15:23:31 <vkmc> but I'll ask you after the meeting
15:23:54 <gouthamr> ganso erlon: so this is a question for when CI breaks
15:24:03 <tbarron> ganso: maybe then a driverfixes branch would make sense
15:24:04 <ganso> gouthamr: yes
15:24:07 <gouthamr> for now, i think our PTG agreement is in-line with https://review.openstack.org/#/c/598164/
15:24:22 <ganso> gouthamr: for now yes
15:25:01 <tbarron> but to be clear, we're not in that position yet
15:25:05 <gouthamr> yeo
15:25:08 <gouthamr> yep*
15:25:11 <tbarron> Anything else on this topic?
15:25:42 <erlon> so, that was what was clear to me, we would keep the branches, not necessarily they would be maintained/supported
15:25:52 <ganso> nope, I just wanted to confirm we are not discarding the idea of having a place to push unmaintained fixes
15:26:09 <erlon> wich makes sense to have the series_status to report what is or not supported
15:26:20 <tbarron> erlon: currently we are maintining extended branches from stable/ocata forwards
15:26:51 <erlon> by we you mean, OpenStack community or Manila?
15:26:53 <tbarron> that was an agreement from the last cycle, not at PTG
15:26:58 <tbarron> erlon: manila
15:27:00 <erlon> ok
15:27:22 <gouthamr> also, we are still letting driver authors push fixes to driverfixes/newton
15:27:43 <tbarron> erlon: OpenStack community said each project can decide how long to keep stable/* maintained after normal EOL
15:28:00 <erlon> tbarron, ok, nice
15:28:14 <erlon> and it was they that decided to remove the driverfixes?
15:28:23 <tbarron> If stable/ocata gets too burdensome then we talk about it and then do driverfixes.
15:28:40 <ganso> tbarron: ok, thank you. We can further discuss this when stable/ocata becomes unmaintained then
15:28:48 <tbarron> *We* decided to have driverfixes exactly where we don't have stable/*  maintainerd.
15:28:59 <tbarron> So that is newton for now.
15:29:13 <ganso> tbarron: that is correct
15:29:48 <tbarron> ok, anything else on this topic?
15:29:56 <tbarron> sub-topic?
15:30:00 <ganso> not from me. Thank you
15:30:05 <erlon> im good
15:30:16 <tbarron> Returning then to the PTG summary ...
15:30:22 <gouthamr> argh
15:30:26 <gouthamr> can't type this AM
15:30:27 <gouthamr> i do
15:30:40 <gouthamr> cinder deleted their driverfixes/ocata branch
15:30:42 <tbarron> gouthamr: shoot ...
15:30:48 <gouthamr> do we want to?
15:31:48 <ganso> gouthamr: I'm not sure what cinder plans are, but their driverfixes/ocata (and ours too) started not making sense when the policy changed and stable/ocata was revived during the last cycle
15:31:48 <tbarron> I don't myself particularly care as long as we don't merge to it until if/when we quit maintaining stable/ocata.
15:32:11 <tbarron> Unless people are confused by its existence.
15:32:19 <gouthamr> +1 , i think we won't merge anything there - but from a consumption pov
15:32:22 <ganso> gouthamr: we could delete it, and create it back from the latest stable/ocata when the time comes
15:32:29 <tbarron> I certainly am fine with initiative to clean it up.
15:32:30 <gouthamr> it may be confusing to see two ocata branches
15:32:44 <tbarron> do we have a cleanup volunteer?
15:32:45 <ganso> gouthamr: yes, at this moment specially
15:32:55 <ganso> tbarron: who can delete branches?
15:33:00 <gouthamr> clarkb :)
15:33:14 <ganso> gouthamr: there's our volunteer?
15:33:17 <tbarron> yes, a volunteer to work with infra to get it done
15:33:22 <ganso> tbarron: oh
15:33:26 <tbarron> someone from manila side to get it done
15:33:37 <ganso> I can talk to him
15:33:39 <clarkb> see the email thread on the dev list about the cinder branch
15:33:44 <clarkb> has details on the prep steps you will want to take
15:33:55 <ganso> hmmmm ok I need to find that email first
15:33:56 <gouthamr> ty clarkb!
15:34:03 <tbarron> #agreed ganso will work with clarkb to cleanup driverixes on ocata
15:34:07 <tbarron> ty clarkb
15:34:36 <tbarron> ganso: I know that email thread so if you have trouble finding it ping me
15:34:54 <ganso> tbarron: if you the title you will make my life easier
15:35:00 <tbarron> ok, trying again :)  Anything else on this sub-topic?
15:35:06 <tbarron> ganso: kk, right after this meeting
15:35:11 <ganso> tbarron: thanks!
15:35:33 <tbarron> OK, let's circle back to the PTG summary etherpad
15:35:48 <tbarron> #link https://etherpad.openstack.org/p/manila-ptg-stein-summation
15:36:10 <tbarron> please scan the Retrospective section, line 6ff.
15:36:26 <tbarron> Dustin has agreed to continue as bug czar.
15:36:36 <dustins> \o/
15:36:44 <gouthamr> \m/
15:36:52 <dustins> Thanks, everyone, for thinking that I do this well enough to keep doing it
15:36:56 <dustins> I will not let you down
15:37:24 <tbarron> tangentially related, we've agreed to have standing weekly agenda item (starting next week) on test reviews, since these aren't getting sufficient attentioh
15:37:29 <tbarron> attention
15:38:10 <tbarron> At line 14ff. we have user survey results.
15:38:26 <tbarron> I'm not personally particularly happy with our survey question.
15:38:44 <tbarron> So I'm going to ask how we get it updated, and by when.
15:38:59 <tbarron> Then we can as a community decide what the next one will be.
15:39:26 <tbarron> IMO the survey question is a bit "battle of the bands" style and not particulary accurate.
15:39:59 <tbarron> Line 17 captures work we said we'd continue or start in stein.
15:40:14 <tbarron> IMO it's a lot of work to actually commplete.
15:40:32 <tbarron> So we'll do the usual specs qualification process.
15:40:47 <tbarron> And try to winnow down our Stein commitments.
15:41:39 <tbarron> Any thoughts/comments thus far?
15:42:22 <erlon> tbarron, do we have the current questions? It could be a starting point
15:42:26 <tbarron> Line 65ff shows agreements.  Anyone see anything inaccurate?
15:42:52 <tbarron> erlon: current question is in that link: It was: what backend(s) do you use for manila?
15:43:02 <bswartz> Yeah I came up with that question
15:43:18 <bswartz> It was analagous to the question asked for cinder
15:43:23 <bswartz> It's find to change it
15:43:29 <vkmc> <dustins> Thanks, everyone, for thinking that I do this well enough to keep doing it <- you nail it... it's not only "well enough"
15:43:34 <bswartz> But they would never let me ask more than 1 question
15:43:39 <tbarron> bswartz: it's an interesting question but I think gets more accurate answers when vendors actively get their customers to respond.
15:44:07 <tbarron> e.g. I doubt that there are fewer netapp back ends deployed today than in ocata :)
15:44:27 <bswartz> Well NetApp has other ways of knowing who our customers are
15:44:32 <tbarron> that doesn't fit with what I can extrapolate from our customer case db
15:44:45 <bswartz> But there was a time when there was no hard data available the survey had some use
15:44:53 <tbarron> bswartz: right, I bet the survey results don't match asup reports
15:45:20 <tbarron> bswartz: oh I'm not criticizing the question in its original context, am just
15:45:33 <tbarron> suggesting that we may want to revamp it for next time.
15:45:59 <tbarron> Cinder asked for customer suggestions for improvements, new features, etc.
15:46:09 <tbarron> Maybe it was more open ended - how are we doing?
15:46:20 <erlon> yes, the Cinder question asking for suggestions and requested features was very useful
15:46:21 <tbarron> And got some perhaps useful responses.
15:46:38 <bswartz> Yeah if you can think of a better question
15:46:42 <erlon> bswartz, you said that they only allow you to submmit/suggest 1 question?
15:46:47 <bswartz> I wanted to ask 3 or 4 and they said no
15:46:55 <erlon> hmmm
15:48:07 <tbarron> anyways, I tabulated the raw results and made a bar chart on sheet#3 in that workbook so if you see any errors in the spreadsheet pls. let me know
15:48:42 <tbarron> Anything else from the PTG summary?
15:49:32 <tbarron> We have lots of AIs, when I get the wiki ready it will likely point to an AI etherpad or some such since they are fairly volatile but
15:49:49 <gouthamr> i like the cinder question, i think we ought to know if users want us to continue developing the UI or focus on graduating experimental features
15:50:07 <tbarron> I want some way that people can check these and check them off themselves so that we don't have a lot of PTL chasing people going on.
15:51:04 <tbarron> gouthamr: we may have to send mail to the operator's list (soon to merge with dev list) for some of the more detailed questions.
15:51:20 <erlon> tbarron, +1
15:51:23 <tbarron> Let's think about how to do outreach/get feedback most effectively.
15:51:39 <tbarron> We want it more often than just in these user surveys anyways.
15:51:55 <gouthamr> "what question do you want us to ask you guys?" :P
15:52:06 <tbarron> gouthamr  is so meta
15:52:23 <ganso> gouthamr: lol
15:52:39 <tbarron> I don't know that I captured it well in the summary but
15:52:52 <bswartz> I think they prefer multiple choice questions
15:52:54 <tbarron> one theme that came up repeatedly in PTG was outreach.
15:53:30 <tbarron> bswartz: is manila (a) awesome, (b) better than that, (c) don't  know what it is.
15:54:09 <tbarron> OK, we had another agenda topic today
15:54:24 <tbarron> #topic mid-cycle and regional bug scrubs?
15:54:47 <tbarron> Do we want to have a (likely virtual) mid-cycle?
15:55:09 <tbarron> Should we combine it with regional (like Americas) bug scrubs where possible?
15:55:41 <dustins> I think that's a good idea. Good excuse to bring in new contributors too
15:56:20 <bswartz> IMO bug squashes and PTGs are for different purposes
15:56:27 <bswartz> Errr
15:56:35 <bswartz> s/PTG/midcycle meetup/
15:57:05 <tbarron> bswartz: agree, the only point would perhaps that making them adjacent would help with scheduling
15:57:12 <erlon> I think the idea there was just to gather the 2 in a few days
15:57:12 <tbarron> or perhaps harm b/c
15:57:19 <bswartz> Could cause burnout
15:57:36 <bswartz> I can't take more than 2 days on the phone
15:57:36 <tbarron> it might be easier to get time out for two dedicated days at different times
15:58:01 <tbarron> bswartz: true that
15:58:09 <erlon> because would be easier to get people to focus in 1 bigger event than 2 smaller
15:58:18 <bswartz> When travel is involved, it makes more sense to try to cram a lot in
15:58:33 <bswartz> But when it's virtual it should be spread out
15:58:33 <tbarron> let's come back to this next week, please review the schedule in the mean time
15:58:50 <tbarron> and see when we should set these up
15:58:55 <tbarron> reminder
15:59:12 <tbarron> #link https://releases.openstack.org/stein/schedule.html
15:59:19 <tbarron> I think we're out of time.
15:59:45 <tbarron> Tnanks everyon!  See you in #openstack-manila ...
15:59:55 <tbarron> #endmeeting