15:00:28 <tbarron> #startmeeting manila
15:00:28 <openstack> Meeting started Thu Sep 27 15:00:28 2018 UTC and is due to finish in 60 minutes.  The chair is tbarron. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:31 <openstack> The meeting name has been set to 'manila'
15:00:33 <bswartz> .o/
15:00:41 <tbarron> ping ganso
15:00:41 <dustins> \o
15:00:43 <xyang> hi
15:00:46 <tbarron> ping erlon
15:00:46 <ganso> hello
15:01:01 <tbarron> ping gouthamr
15:01:10 <tbarron> ping tpsilva
15:01:17 <tbarron> ping zhongjun2_
15:01:24 <tbarron> vkmc is on PTO
15:01:32 <zhongjun2_> Hi
15:01:37 <tbarron> amito is just returning from PTO and is driving atm
15:01:54 <tbarron> That's all on my ping list.
15:01:58 <tbarron> Hi all!
15:02:16 <tbarron> Agenda: https://wiki.openstack.org/wiki/Manila/Meetings#Next_meeting
15:02:31 <tbarron> #topic Announcements
15:02:49 <tbarron> Forum Submission deadline was yesterday.
15:03:26 <tbarron> I used our brainstorm etherpad as the basis of a submisision more or less along
15:03:43 <tbarron> the lines of last time: get operator feedback on what we're doing and
15:03:48 <tbarron> on what is needed.
15:04:10 <tbarron> Last time they gave us good feedback and we learned of use of manila in new places, e.g.
15:04:31 <tbarron> Square Kilometre Array and Minnesota supercomputing Center
15:05:00 <tbarron> You can see all the submissions here:
15:05:19 <tbarron> #link https://www.openstack.org/summit/berlin-2018/vote-for-speakers
15:05:55 <tbarron> Despite the name in the link, there is no vote; they're just reusing the web interface to collect the submissions
15:06:05 <tbarron> Selection is by 9 October.
15:06:39 <tbarron> Next: there has been a recent discussion of T-series goals, with a lot of support for
15:06:52 <tbarron> requiring projects to have OpenStack client support
15:07:03 <tbarron> manila was called out specifically
15:07:24 <tbarron> #link http://lists.openstack.org/pipermail/openstack-dev/2018-September/135107.html
15:07:46 <tbarron> I was happy to be able to respond that this is something operators asked for in the last forum and
15:07:58 <tbarron> that we have it as a Stein cycle goal.
15:08:06 <tbarron> Any other announcements?
15:08:41 <tbarron> ok
15:08:59 <tbarron> #topic MidCycle and Bug Swat days.
15:09:23 <tbarron> Last meeting we agreed to think about having a virtual 1-day midcycle.
15:09:40 <tbarron> Does that still seem like a good idea?
15:09:48 <bswartz> Back to the old ways
15:10:09 <bswartz> When would we aim to do it?
15:10:22 <tbarron> Yeah, that's the next question.
15:10:27 <bswartz> It think having a higher-bandwidth get together is a good idea
15:10:36 <tbarron> Here's the Stein cycle calendar:
15:10:40 <bswartz> Whether it should be 1 or 2 days depends on how much we have to discuss
15:10:57 <tbarron> #link https://releases.openstack.org/stein/schedule.html
15:10:58 <bswartz> No longer than 2 days though
15:11:14 <tbarron> We could allocate two days and try to do it all in one.
15:11:52 <ganso> 1.5 days is not bad either
15:12:16 <tbarron> mid January right after Stein2 milestone?
15:12:27 <ganso> tbarron: +1
15:12:49 <tbarron> That's after the end-of-year holidays and before Chinese New Year.
15:13:38 <zhongjun2_> +1
15:13:58 <tbarron> Wednesday and Thursday 16-17 January?
15:13:58 <bswartz> That's not bad
15:15:23 <tbarron> Sounds like we have some level of agreement.  I will send email to the dev list indicating that decision with a note that if there are objections or counter-proposals to please respond.
15:16:03 <tbarron> Given that not everyone who may be interested is able to attend this meeting on IRC let's also email for such decisions.
15:16:36 <tbarron> zhongjun2_: do you know if there is a bug swat in China this year, and when?
15:17:01 <zhongjun2_> Not sure now
15:17:10 <bswartz> Are we calling them bug swats now?
15:17:22 <bswartz> What happened to bug smashes and bug squashes?
15:17:25 <zhongjun2_> Bug smash
15:17:59 <tbarron> #action tbarron will write 'bug smash' on the blackboard 100 times
15:18:17 <zhongjun2_> ;)
15:18:17 <ganso> lol
15:18:32 <tbarron> We are thinking of also having a (virtual) Americas-time-zone bug smash
15:19:18 <tbarron> Would we want to do this around RC1?
15:19:42 <tbarron> That's 21 march I think.
15:19:47 <bswartz> Yeah as long as it's after feature freeze
15:19:59 <bswartz> The week or 2 after feature freeze are the best times
15:20:02 <tbarron> Feature Freeze i s7 March.
15:20:24 <tbarron> When are Easter and Passover?
15:20:56 <tbarron> not till mid-april
15:21:00 <dustins> tbarron: Easter is April 21
15:22:05 <dustins> and Passover is April 19-27
15:22:11 <tbarron> if it's ok then I'll include in that email a proposal for a couple of days of bug smash -- say march 13-14
15:22:32 <tbarron> dustins: you're our bug czar, do those dates work for you?
15:22:41 <dustins> Yup! Fine by me
15:23:14 <tbarron> OK, moving along unless anyone else has more on this topic ...
15:23:36 <tbarron> #topic Planning Our Work
15:24:00 <tbarron> We came up with enough work at PTG to keep us going for a while :)
15:24:12 <tbarron> Not all will get done this cycle I bet but
15:24:37 <tbarron> we agreed to begin it, to have leaders for work items, and to track the work better than
15:24:40 <tbarron> I at least
15:24:45 <tbarron> was doing previously.
15:25:09 <tbarron> So to that end, I've started to track the work on our wiki
15:25:22 <tbarron> #link https://wiki.openstack.org/wiki/Manila/SteinCycle
15:25:35 <tbarron> It's top down and there's lots to be filled in.
15:26:08 <tbarron> At the bottom, under References, is a link to the etherpad from last week where we distilled from the PTG.
15:26:25 <tbarron> That etherpad in turn points back to the raw PTG etherpad.
15:26:54 <tbarron> Please look over the wiki and make sure your pet projects are there :)
15:27:14 <tbarron> Look for your nick as a Leader or Owner :)
15:27:44 <tbarron> I'll be working with Leaders/Owners to fill out the tasks, reviews, etc.
15:28:05 <tbarron> The idea is that leaders/owners will keep their own sections up to date.
15:28:18 <tbarron> Clearly there's still a lot to fill in.
15:28:27 <tbarron> questions?  comments?
15:28:51 <bswartz> Is this wiki format new?
15:29:14 <tbarron> yes, and I'm open to suggestions as to better ways to do it
15:29:25 <bswartz> I actually like it
15:29:41 <bswartz> Is the goal to not rely on blueprints, or does this augment the blueprint system?
15:29:56 <tbarron> It would augment the blueprints.
15:30:13 <bswartz> Also presumably we have this because storyboard doesn't meet our needs
15:30:14 <tbarron> blueprints per se will go away when we migrate to storyboard
15:30:28 <bswartz> s/when/if/
15:30:35 <bswartz> >_<
15:30:40 <tbarron> storyboard may well meet our needs but we haven't built what we need on it yet
15:31:01 <tbarron> jungleboyj and I agreed to try to do that together in this cycle
15:31:06 <tbarron> before we cut over
15:31:32 <tbarron> maybe this wiki will go away but I think we'll want to track info of this sort in storyboard then
15:31:49 <bswartz> Yeah it's good to have a centralized place
15:31:53 <bswartz> +1
15:32:11 <tbarron> We need clear leaders/owners for "stories" and to have them drive the definition and tracking of their own work
15:32:46 <tbarron> You all need to hold me accountable for ensuring that we do that.
15:33:08 <tbarron> Anything else on this topic today?
15:33:38 <tbarron> OK,
15:33:46 <tbarron> #topic Let's talk about bugs.
15:34:09 <tbarron> dustins: I put a triage page in the Work Plan wiki
15:34:21 <tbarron> dustins: right now it points to the etherpad
15:34:31 <tbarron> dustins: up to you how to track
15:34:51 <tbarron> #link https://wiki.openstack.org/wiki/Manila/SteinCycle#Bug_Triage
15:35:10 <dustins> tbarron: Okay, awesome, I'll have a look at it
15:35:33 <dustins> And add to it
15:36:38 <dustins> Anyway, onto the bugs
15:36:45 <dustins> #link: https://bugs.launchpad.net/manila/+bug/1791103
15:36:45 <openstack> Launchpad bug 1791103 in Manila "NeutronBindNetworkPlugin disappeared after docs migration" [Undecided,New]
15:38:34 <dustins> ganso: You reported this, what exactly was going on with this one?
15:38:49 <bswartz> So only the docs are gone, not the code?
15:39:16 <ganso> dustins: so there was a doc migration effort in Pike release
15:39:38 <ganso> dustins: and after docs were migrated, the section for NeutronBindNetworkPlugin disappeared
15:40:13 <tbarron> ganso asked me why I dropped those dods and I said "my bad, not intended"
15:40:17 <ganso> I checked the commits, and the commit that added the pike pages did not contain any reference to NeutronBindNetworkPlugin
15:40:24 <dustins> ganso: Ahh, so we just have to add them back
15:40:39 <bswartz> Fixed the title
15:40:54 <tbarron> bswartz: ty
15:41:12 <ganso> dustins: yea, but I'd say it raises a flag that more things could have gone missing after the migration
15:41:36 <ganso> bswartz: ty
15:41:41 <dustins> ganso: Yeah, we'll have to have a look at the old docs and the new ones and make sure everything's where we expect it to be
15:41:42 <tbarron> I marked the bug confirmed, do we have an ownwer?
15:42:24 <tbarron> for the specific task in *this* bug
15:43:21 <tbarron> cmon folks, this is just restoring a file and updating the corresponing index.html
15:43:32 <dustins> tbarron: I can have a look, but I don't think it'll be immediately
15:43:57 <tbarron> I didn't see anyone say it has to be fixed immediately.
15:44:08 <tbarron> I marked it low priority.
15:44:19 <dustins> tbarron: Just assigned myself, I'll have a look soon
15:44:31 <tbarron> If someone disagrees, bump the priority, take ownership, and take 15 minutes to do it.
15:44:38 <dustins> Agreed
15:45:09 <dustins> #link https://bugs.launchpad.net/manila/+bug/1742430
15:45:09 <openstack> Launchpad bug 1742430 in Manila "manila_tempest_test create_share fails because a share type not create or define in advance" [Undecided,New]
15:46:16 <tbarron> dustins: it says the problem is solved
15:46:29 <bswartz> The fix here is to make the test create its own share type
15:46:38 <bswartz> Rather than relying on something to preexist
15:47:08 <tbarron> and that's what vkmc's fixes did
15:47:28 <ganso> tbarron: hmmm so that bug should already be fixed?
15:47:46 <tbarron> yes and that's what the last comment in the bug says
15:47:49 <bswartz> It's pretty old
15:47:53 <bswartz> Probably safe to close
15:48:08 <tbarron> _+1
15:48:11 <dustins> works for me
15:49:33 <dustins> #link: https://bugs.launchpad.net/manila/+bug/1790470
15:49:33 <openstack> Launchpad bug 1790470 in Manila "run_tests.sh fails with invalid command testr" [Undecided,New]
15:49:57 <dustins> So, I thought that run_tests.sh had been deprecated
15:50:08 <bswartz> Me too
15:50:17 <tbarron> but we never removed it
15:50:25 <bswartz> It should be either removed or fixed though
15:50:34 <tbarron> cause some people wanted to run it anyways b/c it
15:50:42 <bswartz> It might be easy to just fix it
15:50:46 <bswartz> What is the replacement?
15:50:53 <tbarron> is faster b/c it doesn't do all the checks that tox does
15:51:00 <tbarron> replacement is tox
15:51:25 <bswartz> Well if run_tests.sh can easily be changed to invoke tox, then maybe that's the fix
15:51:33 <bswartz> If that's a bad idea, then just remove it
15:51:38 <tbarron> then it will run as slowly as tox :)
15:52:03 <tbarron> is there anyone here who still uses run_tests.sh?
15:52:15 * bswartz bids a fond farewell to run_tests.sh
15:52:20 <dustins> I use "tempest run"
15:52:47 <tbarron> dustins: we're talking about unit tests, pep8, coverage, docs generation, etc.
15:53:04 <tbarron> and some of that is out of scope for run_tests but in scope for tox
15:53:13 <dustins> Whoops, then in that regard I use tox
15:53:48 <tbarron> if no one objects, I will suggest to the reporter that we are goiing to remove run_tests.sh b/c it is  no longer supported.
15:54:02 <bswartz> I commented in the bug
15:54:11 <tbarron> And that if he wants to fix it and maintian it he's welcome to do so.
15:54:14 <tbarron> bswartz: ty!
15:54:18 <dustins> Sounds good to me!
15:54:57 <dustins> #link: https://bugs.launchpad.net/manila/+bug/1786059
15:54:57 <openstack> Launchpad bug 1786059 in Manila "Cannot Connect to Share Server when Creating Share with Generic Driver (DHSS=True)" [Undecided,New]
15:55:57 <tbarron> so ganso responded to the reporter over a month ago
15:56:09 <tbarron> indicating that we can't repro and that
15:56:20 <tbarron> the issue doesn't occur in our CI
15:56:32 <tbarron> Suggested he compare his env with our CI.
15:57:05 <tbarron> Anyone not OK with a Closed/Invalid?  Seems like an environmental issue rather than a manila issue.
15:57:22 <dustins> Fine by me
15:58:30 <tbarron> k, I'm doing it
15:59:15 <tbarron> we're out of time
15:59:20 <tbarron> Thanks Dustin.
15:59:24 <dustins> Anytime!
15:59:37 <tbarron> And  thanks everyone!  Please look at the work plan ...
15:59:49 <tbarron> See you in #openstack-manila!
15:59:54 <tbarron> #endmeeting