15:00:39 <bswartz> #startmeeting manila
15:00:39 <openstack> Meeting started Thu Apr 4 15:00:39 2019 UTC and is due to finish in 60 minutes. The chair is bswartz. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:40 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:43 <openstack> The meeting name has been set to 'manila'
15:00:52 <gouthamr> o/ hey!
15:00:58 <carloss> hi :)
15:00:59 <ganso> hello
15:00:59 <erlon_> Hola
15:01:00 <bswartz> courtesy ping: gouthamr xyang toabctl bswartz ganso erlon tpsilva vkmc amito jgrosso
15:01:31 <bswartz> tbarron can't join us for the first ~30 minutes, so he asked me to chair the meeting today
15:01:36 <vhariria> hey :)
15:01:45 <jgrosso> Hi
15:01:52 <erlon_> bswartz, welcome back to the chair :)
15:02:06 <lseki> hi
15:02:24 <carthaca> Hello
15:02:29 <amito> hey. Here but my irc client is dying for some reason...
15:02:54 <vkmc> hey
15:03:14 <bswartz> #topic announcements
15:03:36 <bswartz> So the main thing is that the release is scheduled for April 10
15:03:54 <bswartz> There are no more RCs planned, so I hope there are no lurking bugs
15:04:39 <bswartz> Any questions/issues about the Stein release?
15:04:44 <bswartz> Any other announcements?
15:05:04 <bswartz> #agenda https://wiki.openstack.org/wiki/Manila/Meetings
15:05:27 <bswartz> #topic DevStack plugin changes
15:05:41 <bswartz> Attn: Third party CIs and devs: DevStack plugin changes - we will no longer support installing manila-tempest-plugin
15:05:50 <xyang> hi
15:05:53 <bswartz> #link https://review.openstack.org/#/c/646037/
15:06:08 <bswartz> #link https://review.openstack.org/#/c/648716/
15:06:14 <bswartz> gouthamr: is this your topic?
15:06:29 <gouthamr> thanks bswartz
15:06:41 * bswartz hands gouthamr a stein full of coffee
15:06:51 * gouthamr hit and piping
15:06:54 <gouthamr> :P
15:07:04 <gouthamr> okay, wanted to call out attention to those patches ^
15:07:33 <gouthamr> for a couple of releases, we have been installing manila-tempest-plugin within manila's devstack plugin
15:08:25 <gouthamr> we're fixing that approach by adding devstack-plugin mechanism to manila-tempest-plugin
15:08:55 <gouthamr> which means we'll stop installing manila-tempest-plugin and third party CIs must add another line to their manifests so they don't fail
15:09:09 <bswartz> Oh interesting
15:09:17 <gouthamr> "enable_plugin manila-tempest-plugin https://git.openstack.org/openstack/manila-tempest-plugin"
15:09:19 * bswartz clicks links
15:10:15 <bswartz> #link https://review.openstack.org/#/c/648716/7/devstack/README.rst
15:10:33 <bswartz> ^ This readme has the instructions for what developers need to do
15:10:53 <gouthamr> yeah, two motivations for this: 1) devstack's plugin mechanism understands all other devstack context (python version, what ref/branch to install, etc) - by not utilizing this we were going to have to do all of those things within manila's devstack plugin
15:10:59 <bswartz> gouthamr: neither of these patches are merged yet...
15:11:12 <bswartz> When do we want to merge them?
15:12:08 <gouthamr> 2) It's a lot cleaner for users to just set this line in their local.conf and have it install manila-tempest-plugin... :)
15:12:40 <gouthamr> these docs have asked to do it that way for a while now: https://docs.openstack.org/manila/latest/contributor/development-environment-devstack.html
15:13:15 <gouthamr> bswartz: i was holding off my +2 on it so we can have 3rd party CI maintainers ack this change..
15:13:35 <gouthamr> not many of them may be looking at those patches to see why it failed..
15:14:35 <bswartz> So should we ask for +1s from 3rd party CI maintainers?
15:14:49 <bswartz> How many do we want?
15:15:09 <gouthamr> or we can possibly merge and then send an email to openstack-discuss
15:15:16 <bswartz> I see 7 3rd party CIs voted on this patch (if you count all the Dell ones as 1)
15:15:22 <erlon> gouthamr, so, after that merge there will be a window where both methods will work right?
15:15:55 <gouthamr> erlon: not really, not having the "enable_plugin manila-tempest-plugin ..." will mean their CIs will break
15:16:38 <bswartz> Do we have the contact info for all the CI maintainers?
15:16:42 <erlon> gouthamr, so, we will need to change it as soon as the patch merges?
15:16:43 <gouthamr> #LINK https://review.openstack.org/#/c/646037/12/playbooks/legacy/manila-tempest-dsvm-generic-no-share-servers/run.yaml@33
15:16:43 <bswartz> Maybe we should just blast them in addition to the ML
15:17:15 <bswartz> A brief period of breakage doesn't sound terrible, maybe it will tell us who's paying attention and who isn't
15:17:16 <gouthamr> bswartz: yes, i think we do, else i'll reach out to you and get it.. dustins had it at some point. I'll check
15:17:49 <bswartz> Probably the best thing to do is to pick a date in the future and advertise that date
15:18:00 <bswartz> Then make the change on that date
15:18:15 <gouthamr> that makes sense
15:18:31 <gouthamr> i'll take an AI to do this
15:18:38 <bswartz> Thanks
15:18:43 <bswartz> Anything else on this topic?
15:19:17 <gouthamr> #ACTION: gouthamr gather list of 3rd party CI maintainers and plan date for breaking-devstack plugin changes
15:19:22 <bswartz> #topic Bugs
15:19:42 <bswartz> #link https://etherpad.openstack.org/p/manila-bug-triage-pad
15:19:54 <bswartz> grosso: you're up
15:20:10 <gouthamr> bswartz: nope, that's it... anyone else, please ping tbarron/me if you need help. I think i know a thing or two about zuul and jenkins to help
15:20:32 <gouthamr> bswartz: this one can be me as well, jgrosso is in an all-week-training session
15:20:38 <jgrosso> hey all dont have anything new today, still pushing to cleanup of older defects
15:20:45 <gouthamr> or not
15:20:52 <jgrosso> in training but cheating
15:20:53 <gouthamr> :) hey jgrosso
15:20:58 <jgrosso> hey :)
15:21:12 <gouthamr> jgrosso: we have that on record now
15:21:21 <bswartz> Oh your name is misspelled in the agenda jgrosso
15:21:30 <jgrosso> I dont have anything really new everyone has been doing great
15:21:36 <jgrosso> keep it mispelled ;)
15:21:46 <jgrosso> no traceability
15:22:00 <jgrosso> kidding
15:22:11 <bswartz> Oh we have way of finding you
15:22:21 <gouthamr> hahaha
15:22:21 <bswartz> Everything leaves a trace on the internet
15:22:30 <gouthamr> i have one bug/fix that needs reviews
15:22:34 <jgrosso> haha
15:22:38 <jgrosso> yikes
15:22:39 <gouthamr> API Ref fixups: https://review.openstack.org/#/q/project:+openstack/manila+message:%255Eapi-ref+status:open
15:23:09 <gouthamr> mostly deletions and cleanup ^
15:23:45 <gouthamr> and we had some users report some usability bugs with manila-ui that we fixed here: https://review.openstack.org/#/q/project:+openstack/manila-ui+status:open
15:24:05 <bswartz> Okay I'll put those on my list'
15:24:09 <bswartz> #topic Open Discussion
15:24:30 <gouthamr> thanks bswartz
15:24:38 <bswartz> Anything else for today?
15:25:01 <bswartz> If we end the meeting before 11:30, tbarron might come and find an empty room
15:25:16 <gouthamr> nope, please add any PTG topics here: https://etherpad.openstack.org/p/manila-denver-train-ptg-planning
15:25:32 <gouthamr> your regularly scheduled friendly PTG reminder ^ :)
15:26:25 <bswartz> Okay sounds like we're done
15:26:29 * bswartz is already off an reviewing
15:26:34 <bswartz> s/an/and/
15:26:34 <gouthamr> +1
15:26:47 <bswartz> Thanks all
15:26:58 <bswartz> #endmeeting