15:02:10 <tbarron> #startmeeting manila
15:02:11 <openstack> Meeting started Thu Sep  5 15:02:10 2019 UTC and is due to finish in 60 minutes.  The chair is tbarron. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:14 <openstack> The meeting name has been set to 'manila'
15:02:18 <carloss> hey :)
15:02:20 <lseki> hi
15:02:40 <ganso> hello
15:02:42 <bswartz> .o/
15:03:07 <tbarron> courtesy ping: gouthamr xyang toabctl bswartz ganso erlon tpsilva vkmc amito jgrosso dviroel lseki carloss
15:03:10 <gouthamr> o/
15:03:12 <dviroel> o/
15:03:23 <vhari> o/
15:03:34 <tbarron> #topic Announcements
15:03:43 <tbarron> Agenda:
15:03:50 <tbarron> #link  https://wiki.openstack.org/wiki/Manila/Meetings
15:04:02 <tbarron> Hello all!
15:04:03 <amito> I'm confused
15:04:12 <amito> The title in #openstack-manila says there's no meeting today
15:04:25 <tbarron> amito: i need to update it from last week, sorry
15:04:31 <toabctl> hi
15:04:31 <amito> tbarron: all good :)
15:05:27 <tbarron> done
15:06:03 <tbarron> First, please join me in congratulating gouthamr for his election to PTL starting Ussuri cycle!
15:06:32 <bswartz> Was it a coup or a democratic election?
15:06:35 <lseki> πŸ‘ πŸŽ‰
15:06:37 <amito> congrats gouthamr ! :)
15:06:37 <bswartz> :-p
15:06:40 <dviroel> gouthamr: Congrats!
15:06:46 <carloss> Congrats, gouthamr  :) \o
15:06:56 <amito> And thank you tbarron !
15:06:58 <bswartz> Thanks gouthamr for stepping up
15:07:04 <sfernand> congrats gouthamr
15:07:18 <carloss> Also, thanks tbarron  :)
15:07:26 <tbarron> bswartz: It was a Platonic decision in an ideal republic.
15:08:00 <tbarron> Seriously, we're in very good hands now, and change of leadership is a good thing.
15:08:19 <bswartz> tbarron: thanks for your service as PTL
15:08:24 <tbarron> I think in Sparta ?? they cast lots and everyone basically took a turn.
15:08:26 <gouthamr> :) Thanks everyone... Hope to do a good job at it; bswartz and tbarron are a hard act to follow - but you all will make things smooth
15:08:40 <bswartz> Who thought Ussuri was a good name for a release?
15:08:46 * gouthamr this-is-manilaaaaa
15:09:09 <tbarron> It has been a rewarding experience for me but now it's time to contribute in other ways ...
15:09:15 <ganso> congrats gouthamr !
15:09:20 <tbarron> bswartz: the voters did :)
15:09:53 <gouthamr> thank you ganso!
15:10:01 <tbarron> gouthamr has already done a lot of PTL-type jobs and we all need to be prepared to accept delegations from him.
15:10:11 <vkmc> o/
15:10:11 <bswartz> Is there a guide for how to pronounce ussuri and what it means?
15:10:18 <vkmc> congrats gouthamr :)
15:10:41 <vkmc> I know you will be a great bdfl
15:10:49 <vkmc> :P
15:10:53 <gouthamr> vkmc: bdfu :D
15:10:59 <vkmc> haha yes
15:11:18 * tbarron suggests that gouthamr delegate a study commission headed by bswartz to report on the pronunciation and meaning(s) of Ussuri
15:11:40 <bswartz> >_<
15:11:45 <tbarron> though we won't have a formal changing of the guard till U-release starts
15:12:04 <gouthamr> bswartz: probably pronounced δΉŒθ‹ι‡Œζ±Ÿ - rated 4.6 on google, meh
15:12:35 <tbarron> gouthamr: delegate, don't answer everything yourself :)
15:12:45 <tbarron> heh
15:12:45 <gouthamr> lol tbarron :D
15:13:01 <tbarron> Next announcement
15:13:20 <tbarron> Train milestone 3 and feature freeze are next week
15:13:36 <tbarron> #link https://releases.openstack.org/train/schedule.html
15:13:46 <tbarron> We'll talk about actual reviews in a bit.
15:15:00 <tbarron> Also, we have a couple weeks to brainstorm on Forum topics.
15:15:13 <tbarron> And we have an etherpad for that.
15:15:25 <tbarron> #link https://etherpad.openstack.org/p/manila-shanghai-forum-brainstorming
15:15:45 <tbarron> I've seeded it with a couple topics but please add ideas.
15:16:02 <tbarron> Any other announcements?
15:16:18 <tbarron> #topic Python3 tempest 3rd party CI
15:16:20 <ganso> I have one
15:16:22 <ganso> sorry
15:16:31 <bswartz> #undo
15:16:32 <tbarron> #topic announcements
15:16:45 <ganso> my announcement is that I have now a conflict meeting at the same time as the manila meeting, every Thursday
15:17:02 <ganso> so it makes very difficult to me to interact here due to this conflict
15:17:08 <bswartz> ganso: I do too, but I come to manila anyways
15:17:10 <ganso> difficult *for me
15:17:31 <tbarron> but bswartz doesn't *want* to be at the other meeting :)
15:17:42 <bswartz> hush
15:17:59 <tbarron> ganso: maybe make a doodle poll and work with the new PTL to see if another time is better?
15:18:16 <tbarron> he might have an interest in a more Seattle-friendly meeting time.
15:18:18 <bswartz> We've looked at changing times before, but it always causes problems for at least 1 person
15:18:27 <ganso> so, that was the announcement. I will catch up with the meeting notes as soon as my other meeting is done
15:18:29 <ganso> tbarron: yea perhaps
15:18:40 <gouthamr> ack - we can definitely start a poll
15:18:41 <tbarron> I don't think we'd come to a consensus on a new time in *this* meeting
15:18:48 <bswartz> I'm open to a new time, but I doubt we'll find one that's not bad for at least 1 person
15:19:04 <gouthamr> ganso: would this be a problem even with the DST switchover for you next month?
15:19:18 <ganso> gouthamr: yes
15:19:32 <ganso> gouthamr: the meeting schedule is in UTC, same as manila's
15:19:42 <gouthamr> ah... makes sense; we can run a poll
15:19:53 <ganso> gouthamr: thanks!
15:20:16 <lseki> gouthamr: btw we *might* not have DST here in Brazil anymore
15:20:22 <gouthamr> #action: gouthamr will run a doodle poll for a new time for the manila meeting - link will be shared on openstack-discuss
15:20:30 <gouthamr> lseki: smart decision :D
15:20:36 <bswartz> +1 for ending DST
15:20:38 <tbarron> #topic Python3 tempest 3rd party testing
15:20:55 <tbarron> there are a lot of things you might not have in Brazil anymore
15:21:03 * tbarron ducks
15:21:13 <tbarron> here too of course
15:21:59 <tbarron> On the 3rd party testing the new development is that NetAop can reproduce the EMC eventlet/urllib issue with python 3.7 and
15:22:19 <tbarron> it is likely present in NetApp cinder driver as well
15:22:24 <tbarron> Is that correct?
15:22:28 <carloss> Yes
15:22:56 <gouthamr> #link https://bugs.launchpad.net/manila/+bug/1833160
15:22:56 <openstack> Launchpad bug 1833160 in Manila "VNX: driver cannot start under py37 due to wrap_socket() got an unexpected keyword argument '_context'" [Undecided,New]
15:22:57 <tbarron> So this is less of an isolated issue.
15:23:17 <carloss> I'm performing some tests in the drivers, In the next days I'll add some bug comments with my results
15:23:54 <tbarron> carloss: thanks, and at that point I suggest taking the issue to the larger community, via openstack-discuss list
15:24:06 <tbarron> please get the cinder people involved too
15:24:25 <carloss> Sounds good!
15:24:27 <tbarron> They were pushing for 3.7 rather than just 3.6 coverage iirc
15:24:38 <tbarron> We were deliberately vague, 3.6+
15:24:52 <carloss> I'll start a discussion soon
15:24:59 <tbarron> in part b/c we didn't know of any downstream distros using 3.7 on long term releases
15:25:02 <bswartz> Does any distro still ship 3.6?
15:25:05 <tbarron> carloss: thanks much
15:25:11 <bswartz> Oh it's the reverse
15:25:19 <bswartz> 3.6 is more common than 3.7?
15:25:40 <tbarron> bswartz: my impression but maybe i'm wrong
15:26:03 <gouthamr> RHEL8 is 3.6
15:26:25 <bswartz> Ubuntu is giving me 3.6.8
15:26:33 <tbarron> gouthamr is pointing out my bias :)
15:27:01 <tbarron> but manila and cinder aren't the only users of urllib and eventlet I bet
15:27:42 <tbarron> #topic Cross Project Goals
15:28:08 <tbarron> First, a big shout out to toabctl for getting the PDF doc generation done.
15:28:19 <toabctl> :)
15:28:25 <bswartz> huzzah!
15:28:35 <gouthamr> ++
15:29:24 <tbarron> There may be some followup stuff centrally (bindep dependencies, tox target adjstments?) but manila is at
15:29:45 <tbarron> the front of the pack with other projects who are getting the job done.
15:30:07 <tbarron> We'll need to look at client and library components I guess but
15:30:24 <tbarron> we're not behind any other projects in this respect so far as I can tell.
15:30:50 <tbarron> The second goal is IPv6 readiness and I think we"re in good shape there.
15:31:12 <tbarron> ghanshyam will be sending some tests in our direction in the next couple weeks at
15:31:27 <tbarron> which point we can make some adjustments if needed.
15:31:40 <tbarron> OK ...
15:31:49 <tbarron> #topic Our Work - Reviews
15:32:05 <tbarron> #link https://etherpad.openstack.org/p/manila-train-review-focus
15:32:36 <tbarron> I've had limited bandwith due to unexpected family medical emergency in the last week or so.
15:32:58 <tbarron> All OK now but I'm still catching up on lots of fronts.
15:33:27 <tbarron> The main thing here is the good work captured by this
15:33:30 <tbarron> diagram
15:33:45 <tbarron> https://docs.google.com/drawings/d/1oTdJn6s47tSKstH14NEaekm0V1zVnuOxs95Ljt7DI7Y/edit
15:35:02 <tbarron> We're in a situation where very few core reviewers are actually doing reviews :(
15:35:11 <dviroel> :(
15:35:40 <bswartz> Who else from netapp is a core reviewer?
15:35:47 <tbarron> And candidly, it's not the PTL's job to fix that.
15:35:57 <carloss> only you, bswartz
15:36:04 <bswartz> We need to fix that
15:36:10 <gouthamr> bswartz: +1
15:36:15 <tbarron> we are a community and if have stuff that needs to be reviewed or
15:36:37 <tbarron> then it is on  you as well to chase down reviewers
15:36:45 <tbarron> bswartz: I support that but
15:37:19 <tbarron> since this is a netapp submission it isn't directly relevant to this I think
15:37:44 <tbarron> We need reviewers other than goutham and myself.
15:38:49 <tbarron> Especially as Goutham takes PTO responsibility we can't have this bottleneck.
15:38:51 <gouthamr> will help alleviate the issue a bit, we'd get some more eyes/scrutiny around this - thanks dviroel lseki for reviewing the code so far - please continue to take a look as it evolves
15:39:08 <gouthamr> but, again, you two are co-authors on most of those patches?
15:39:23 <gouthamr> :)
15:39:33 <dviroel> gouthamr: yes
15:39:54 <tbarron> right, they've done a good job of having their own internal review conversations in the open
15:39:59 <gouthamr> +1
15:40:18 <tbarron> but who else has back ends that will make use of these features?
15:40:30 <tbarron> They should be reviewing and if they aren't then
15:41:09 <tbarron> the people who want to get this stuff merged need to reach out to them and explain why it's in their interest that
15:41:20 <tbarron> it be merged and be right for the other back ends too.
15:41:49 <tbarron> This is a community, not a top-down command and control organization.
15:42:12 <tbarron> OK, I'll quit preaching, go forth and review, please.
15:43:12 <gouthamr> aye aye, carloss thanks for updating the patch, and responding to the comments
15:43:25 <carloss> yw, thanks for reviewing it :)
15:43:40 <tbarron> Anyone else have anything on this topic?
15:44:09 * tbarron can tick people off with impunity, he's not running for office :)
15:44:18 <jgrosso> :)
15:44:29 <tbarron> jgrosso: Hi!
15:44:30 <gouthamr> carloss: i'll try to be more expedient with the next set of comments, but ofcourse it's a 3k line patch that touches a ton of things in the API - although i'm familiar with the design, i did write it without a PoC back then - so you'll see some back-and-forth
15:44:34 <tbarron> #topic Bugs
15:44:36 <jgrosso> tbarron Hello!
15:44:51 <tbarron> jgrosso: got anything for us today?
15:44:57 <jgrosso> yes rollover from last meeting
15:45:00 <jgrosso> https://bugs.launchpad.net/manila/+bug/1781127
15:45:01 <openstack> Launchpad bug 1781127 in Manila "Share groups created from snapshot can be created with different share group type" [Low,In progress]
15:45:15 <jgrosso> this went from high - medium and now low :)
15:45:27 <carloss> gouthamr:  ok :)
15:45:58 <tbarron> jgrosso: also low-hanging fruit though
15:46:04 <gouthamr> +1
15:46:08 <jgrosso> jgrosso yes
15:46:33 <jgrosso> just trying to understand was it just mark wrong
15:46:40 <jgrosso> twice :)
15:46:50 <tbarron> jgrosso: you set it to low yourself
15:47:04 <tbarron> so i would ask jgrosso why :)
15:47:18 <jgrosso> tbarron started Hi , then Med , and then I marked it low :)
15:47:32 <jgrosso> so I will take it as lhf and leave it :)
15:47:40 <tbarron> last time I argued that it wasn't hi
15:47:48 <gouthamr> nah, at the time of filing that bug, we expected to continue doing more work on share groups - so it was probably set high because we thought we'd get it done asap - for now, i think we have a preliminary useful feature that we must graduate
15:48:15 <jgrosso> yeah and then we argues is it even med :)
15:48:19 <tbarron> I also don't have a problem with it being low
15:48:25 <jgrosso> ack
15:48:27 <gouthamr> and we concluded that it's unlikely that users would make that mistake; even if they did - the new share group may not be created
15:48:36 <tbarron> gouthamr: +1
15:48:43 <jgrosso> gouthamr:+1
15:48:59 <jgrosso> last one
15:49:05 <jgrosso> https://bugs.launchpad.net/manila/+bug/1810988
15:49:07 <openstack> Launchpad bug 1810988 in Manila "[tempest] migration tests often fail with ssh timeouts " [High,In progress]
15:49:24 <jgrosso> its high and marked as stein rc1
15:49:48 <tbarron> well it should stay high IMO but I'll remove the target
15:50:01 <jgrosso> ok thanks tbarron
15:50:08 <gouthamr> hudson-openstack marked it in-progress, did we have a patch tbarron ?
15:50:29 <tbarron> gouthamr: I might have had  a tempest patch, will dig
15:50:56 <jgrosso> that is all I had for today
15:51:15 <tbarron> gouthamr: jgrosso I might even assing this back to myself after gouthamr's ascension
15:51:32 <tbarron> jgrosso: you did ask me to check on, let's see
15:51:57 <gouthamr> this manila UI bug came in:
15:51:59 <gouthamr> #link https://bugs.launchpad.net/manila-ui/+bug/1842119
15:52:00 <openstack> Launchpad bug 1842119 in manila-ui "missing some saved quotas values in manila share tab" [Undecided,In progress] - Assigned to Gloria Gu (gloria-gu)
15:52:27 <gouthamr> it has a fix from some new contributor/s: https://review.opendev.org/679897
15:52:41 <gouthamr> would be nice to get it reviewed quickly
15:53:21 <tbarron> yeah, has anyone reproduced the issue?
15:53:35 <jgrosso> tbarron I asked about this one  https://bugs.launchpad.net/manila/+bug/1746725
15:53:37 <openstack> Launchpad bug 1746725 in Manila "LVM driver is unable to remove addresses in different IP versions belonging to the same interface properly" [Medium,Invalid] - Assigned to Tom Barron (tpb)
15:54:01 <jgrosso> with the request " please help me remember and we can test whether the library bug ganso found is present in bionic"
15:54:18 <tbarron> jgrosso: yeah that was it, the OS bug doesn't happen in ubuntu bionic so I said it's not a manila bug
15:54:19 <jgrosso> tbarron is that the bug you meant?
15:54:35 <tbarron> we don't need to work around the OS bug for our gate and
15:54:36 <jgrosso> tbarron ack
15:54:51 <tbarron> we're not in the business of supporting earlier ubuntu per se
15:56:10 <tbarron> I'll load up that manila-ui patch and see if it does the right thing so far as I can tell but
15:56:31 <tbarron> I'm no django coder so if someone more competent wants to review that would be great.
15:56:55 <tbarron> Any other bugs?
15:57:00 <gouthamr> tbarron: ack, we release manila-ui next week?
15:57:00 <jgrosso> nope
15:57:09 <tbarron> gouthamr: yes
15:57:35 <tbarron> any python-manilaclient stuff pending that I'm missing?
15:57:38 <gouthamr> tbarron: ack, i'll try to take a look as well - or engage vkmc, our in-house manila-ui wiz
15:57:56 <tbarron> It's next week too and the netapp  patches are of course relevant
15:58:23 <tbarron> But any other manilclient stuff that we need to get in?
15:58:41 <gouthamr> #link https://review.opendev.org/#/c/670750/
15:58:46 <gouthamr> would be the other one ^
15:59:04 <vkmc> gouthamr, looking into it actually :)
15:59:08 <tbarron> oh yeah, it's on the review pad and shoudlmake it I think.
15:59:13 <gouthamr> awesome ty vkmc
15:59:31 <gouthamr> tbarron: i'll add https://review.opendev.org/#/c/647538/ to the list on the review pad
16:00:27 <tbarron> ok, we're out of  time
16:00:38 <tbarron> see you in #openstack-manila
16:00:43 <tbarron> Thanks everyone!
16:00:47 <tbarron> #endmeeting