15:00:53 <gouthamr> #startmeeting manila
15:00:54 <openstack> Meeting started Thu Oct 17 15:00:53 2019 UTC and is due to finish in 60 minutes.  The chair is gouthamr. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:55 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:57 <openstack> The meeting name has been set to 'manila'
15:01:05 <carloss> hi :)
15:01:06 <jgrosso> hello
15:01:09 <lseki> \o
15:01:16 <vhari> hi :)
15:01:40 <gouthamr> hello everyone, let's wait a minute to allow stragglers :)
15:01:55 <dviroel> o/
15:02:04 <gouthamr> courtesy ping: xyang toabctl bswartz ganso erlon tpsilva vkmc amito
15:02:54 <gouthamr> ^ tbarron is out today, probably on a boat somewhere
15:03:28 <gouthamr> okay, we have a small group and a short agenda too - so let's get rolling
15:04:16 <gouthamr> typically, we'd like to have atleast 40% of the core reviewer team in attendance; but, i'd like to cover a few things despite not having quorum
15:04:38 <gouthamr> which means, we will not make any decisions today
15:05:01 <gouthamr> The meeting agenda is here:
15:05:03 <gouthamr> #link: https://wiki.openstack.org/wiki/Manila/Meetings
15:05:20 <gouthamr> #topic Announcements
15:05:26 <bswartz> .o/
15:05:37 <gouthamr> hey bswartz...
15:05:47 <gouthamr> so, Train release has shipped!
15:05:57 <dviroel> \o/
15:05:57 <gouthamr> #link: http://lists.openstack.org/pipermail/openstack-discuss/2019-October/010156.html
15:06:10 <bswartz> So, is it fair to say that the train has left the station?
15:06:16 <bswartz> #badpun
15:06:24 <jgrosso> :)
15:06:28 <gouthamr> #thanks everyone who spent valuable time and effort in any way on the Train release of OpenStack Manila!
15:06:35 <jgrosso> choo choo
15:06:38 <lseki> \o/
15:06:48 <gouthamr> grr, where's openstackstatus when you need it :)
15:07:08 <gouthamr> well, you have my thanks
15:07:49 <gouthamr> please encourage folks to upgrade, it's the best release ever!
15:08:29 <gouthamr> next up: as we keep rolling, stable/queens is going to be in EM soon
15:08:49 <gouthamr> EM stands for "extended maintenance"
15:08:50 <gouthamr> #link: http://lists.openstack.org/pipermail/openstack-discuss/2019-October/010161.html
15:09:32 <gouthamr> what this means is that in the next couple of weeks, we'll merge any remaining bugfixes to this branch
15:09:38 <gouthamr> and make one final Queens release
15:09:43 <gouthamr> #link: https://docs.openstack.org/project-team-guide/stable-branches.html
15:10:35 <gouthamr> after this release, you can continue to backport fixes to stable/queens, but cannot rely on us producing any more tagged releases
15:11:22 <gouthamr> i think there are a bunch of fixes in flight, so if you're reviewing please pay attention to the timeframe so we can get them into this final release
15:11:53 <gouthamr> still speaking of releases, we cut some new ones that i'd like to call your attention to
15:12:01 <gouthamr> #link: https://review.opendev.org/#/c/689047/ Bug-fix releases for manila-ui
15:12:44 <gouthamr> thanks to Gloria Gu, KeithMnemonic and other contributors from Suse, we were able to land a critical bugfix in manila-ui that affected Rocky-->Train
15:13:04 <gouthamr> #link: https://review.opendev.org/#/c/687967/ Release manila-tempest-plugin 0.4.1
15:13:54 <gouthamr> ^ this bugfix release should be preferred over the train release of manila-tempest-plugin
15:14:25 <gouthamr> the initial train release (0.4.0) will break when used against versions of manila prior to Train
15:14:50 <gouthamr> that's all i had wrt announcements :)
15:14:57 <gouthamr> does anyone else have anything to add?
15:15:32 <gouthamr> #topic Retire older branches?
15:16:17 <gouthamr> we've chugged past the 9th release of manila
15:16:44 <gouthamr> but, we continue to invest valuable time, effort and CI resources on maintaining some old versions
15:17:18 <gouthamr> i'd like to get your opinion on retiring these branches
15:17:35 <gouthamr> Specifically:
15:17:39 <gouthamr> Driverfixes branches
15:17:39 <gouthamr> #link: https://opendev.org/openstack/manila/src/branch/driverfixes/mitaka
15:17:39 <gouthamr> #link: https://opendev.org/openstack/manila/src/branch/driverfixes/newton
15:17:39 <gouthamr> #link: https://opendev.org/openstack/manila/src/branch/driverfixes/ocata
15:17:39 <gouthamr> Stable branches
15:17:40 <gouthamr> #link: https://opendev.org/openstack/manila/src/branch/stable/ocata
15:17:41 <gouthamr> #link: https://opendev.org/openstack/manila/src/branch/stable/pike
15:18:05 <bswartz> What effort does it take to keep an old branch arond?
15:18:28 <bswartz> I thought driverfixes branches were created with zero effort upstream and that was the point
15:18:54 <gouthamr> mostly CI - third party CI doesn't run on them, but, most of our unittests and tempest jobs do
15:19:04 <gouthamr> s/our/first party
15:19:29 <gouthamr> and we've had these break once or twice during the past release
15:19:34 <bswartz> We should ask the distro vendors -- they are the theoretical beneficiaries of these branches
15:19:39 <gouthamr> ++
15:19:50 <bswartz> It would be RedHat, Canonical, Huawei, and who else?
15:19:57 <gouthamr> Mirantis
15:20:06 <bswartz> Mirantis still does Openstack?
15:20:11 * bswartz is surprised
15:20:33 <gouthamr> as far as i understand, they had installation tooling and docs for manila as recent as Rocky
15:21:16 <gouthamr> or Queens
15:21:23 <gouthamr> https://www.mirantis.com/software/openstack/releases/
15:21:32 <bswartz> Well unless any of the distros consume stuff from those branches, they're probably not worth keeping around
15:21:58 <gouthamr> yes - if it's not being useful, we shouldn't spend our time on it
15:22:22 <gouthamr> if it's being useful, i'd like to know the impact and some support from the consumers to maintain these branches when things break
15:22:50 <gouthamr> for one, some of our current jobs on these branches run and always fail
15:23:24 <gouthamr> we haven't taken a look at them, if these branches are useful, i'd like for someone to start by running a meaningful set of test jobs
15:24:05 <gouthamr> to provide some historic context, we don't do "driverfixes" branches anymore
15:24:37 <gouthamr> because we decided to impose extended retirement on these branches - i.e., keep them around best effort
15:25:31 <gouthamr> so i think it wouldn't be harmful if we removed the driverfixes branches, but, that would mean we no longer have a mitaka or a newton branch for any fixes
15:25:34 <bswartz> Both solutions seem reasonable to me
15:25:46 <bswartz> Keep the branch alive, but studiously avoid spending time on fixing anything about it
15:25:56 <gouthamr> ack
15:26:20 <gouthamr> i'll take a action item to bring this up in openstack-discuss and openstack-operators mailing lists
15:27:01 <gouthamr> #action gouthamr: mail openstack-discuss and openstack-operators about old branches and their maintenance status
15:27:18 <gouthamr> that's all i had about $topic
15:27:34 <gouthamr> any questions/concerns/additions?
15:27:56 <gouthamr> #topic Ussuri PTG
15:28:12 <gouthamr> this has been a sticky topic over the past few weeks
15:28:17 <gouthamr> #link: https://etherpad.openstack.org/p/manila-shanghai-ptg-planning PTG Planning Etherpad
15:28:33 <gouthamr> thanks to those that have proposed the topics currently on the pad
15:28:56 <gouthamr> if you're thinking about any discussion topics, please put them on the etherpad asap
15:29:18 <gouthamr> we're less than 3 weeks away from the Shanghai PTG date
15:29:33 <gouthamr> 6th Nov 2019, Wednesday
15:30:13 <gouthamr> i'd like to check with you guys (and on the mailing lists) if we can have the remote-only PTG
15:30:37 <gouthamr> either during the first or second week of Dec
15:30:58 <gouthamr> i know it's a little late, but, i didn't want to distract folks that are preparing for Shanghai
15:31:04 <gouthamr> by having it earlier
15:31:44 <gouthamr> i'm currently ruling out the rest of November because of folks taking time to travel before/after the summit
15:31:52 <gouthamr> and KubeCon in the third week of Nov
15:31:55 <dviroel> yes from our side
15:32:19 <gouthamr> and the final week is surely for eating a lot and regretting
15:32:27 <lseki> ++
15:32:35 <gouthamr> :) Thanksgiving in the US ^
15:33:01 <gouthamr> at the in-person PTG, tbarron will drive the agenda
15:33:29 <gouthamr> and it's possible some of these topics will be dealt with, depending on the audience and the interest in the topics themselves
15:33:50 <gouthamr> however, all of these topics will be discussed again during the remote-only PTG
15:35:12 <gouthamr> to those not attending the Shanghai summit in person, we're increasingly giving up hope on enabling remote participation
15:36:01 <gouthamr> nevertheless, the focus there will be to engage with our APAC users and contributors and discuss their concerns
15:36:24 <bswartz> +1 for no remote attendance
15:36:36 <bswartz> I don't see how it could work
15:36:36 <gouthamr> ack
15:36:58 <gouthamr> #GFW
15:37:20 <gouthamr> sigh - it'll be different
15:37:30 <gouthamr> but, exciting and new :)
15:37:41 <gouthamr> i'd move on to the next topic: Bugs (jgrosso)
15:37:56 <gouthamr> but, jgrosso tells me we haven't had any that we need to look at this week
15:38:23 <gouthamr> i see a number of bug fixes proposed, and folks are actively backporting fixes to other affected releases - thank you for doing that!
15:38:48 <gouthamr> let's slide into...
15:38:54 <gouthamr> #topic: Open Discussion
15:39:31 <gouthamr> *crickets*
15:40:12 <bswartz> I'm still looking at this mirantis page and wondering what's going on
15:40:23 <gouthamr> haha
15:40:29 <bswartz> They shipped a Queens-based openstack in late 2018 and nothing since then
15:40:47 <gouthamr> yep - multiple distros are stabilizing on older releases
15:40:49 <bswartz> Maybe Queens was perfection and they don't want the newer releases?
15:41:15 <bswartz> Or maybe they're skipping some intermediate releases and they will jump from Q to U?
15:41:27 <gouthamr> while Red Hat has shipped Stein (RHOSP 15) - Queens is still a preferred release for most, given it's a Long-Life-Release
15:41:34 <bswartz> I see
15:41:44 <bswartz> What is the next LLR after Queens?
15:41:59 <gouthamr> for RH, it will be the Train release
15:42:20 <bswartz> So now that Train has shipped, maybe we'll see Mirantis take it up?
15:42:35 <gouthamr> it's encouraging to see users upgrading from Newton--->Queens
15:42:54 <gouthamr> probably, Suse did announce that they intend to stop at Rocky
15:43:16 <bswartz> IAC, the whole point of these old driverfixes branches was to create a way for storage vendors (like netapp) to deliver driver bug fixes to distro vendors (like redhat)
15:43:28 <gouthamr> true bswartz
15:43:34 <bswartz> So if those branches aren't serving that purpose, then they're pointless
15:43:46 <gouthamr> back when we created them, i worked with tbarron and toabctl
15:44:22 <gouthamr> but i think both these distros (Red Hat, Suse) don't need them any longer - we'll check
15:45:09 <gouthamr> alright folks, if there's nothing else - let's chat on #openstack-manila
15:45:13 <gouthamr> thank you for joining
15:45:19 <jgrosso> thanks
15:45:21 <gouthamr> #endmeeting