15:01:06 <gouthamr> #startmeeting manila
15:01:06 <openstack> Meeting started Thu Mar 12 15:01:06 2020 UTC and is due to finish in 60 minutes.  The chair is gouthamr. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:09 <dviroel> o/
15:01:11 <openstack> The meeting name has been set to 'manila'
15:01:12 <lseki> o/
15:01:23 <vhari> hi
15:01:27 <vkmc> o/
15:01:28 <maaritamm> o/
15:01:30 <vkmc> henlo
15:01:38 <gouthamr> courtesy ping: xyang toabctl ganso amito carloss tbarron
15:01:46 <ganso> hi
15:01:51 <andrebeltrami> o/
15:01:51 <carloss> hey :)
15:02:00 <amito> Hey
15:02:06 * gouthamr notes that tbarron is on PTO
15:02:29 <gouthamr> welcome, here's the agenda:
15:02:30 <gouthamr> #link https://wiki.openstack.org/wiki/Manila/Meetings#Next_Meeting
15:02:58 <gouthamr> let's begin with Announcements
15:03:04 <gouthamr> #topic Announcements
15:03:22 <gouthamr> Today is feature proposal freeze
15:03:29 <gouthamr> #link https://releases.openstack.org/ussuri/schedule.html#u-manila-fpfreeze
15:04:29 <gouthamr> so, if you're proposing any features for the Ussuri release, we'd like it to be uploaded to gerrit, and passing CI now
15:04:39 <gouthamr> so reviewers can focus their attention
15:05:24 <gouthamr> i believe we're mostly there, based on individual conversations with folks
15:06:08 <gouthamr> i'll take a look today and share a review etherpad for the cycle
15:06:40 <dviroel> great
15:06:56 <gouthamr> the next important deadline is two weeks away, although it has nothing to do with code
15:07:00 <gouthamr> #link https://releases.openstack.org/ussuri/schedule.html#v-ptl-nominations
15:07:38 * gouthamr notes there's a typo in the schedule and it should read "V" PTL nominations...
15:08:26 <gouthamr> i'd like to encourage folks that want to step up and be PTL to self-nominate
15:09:10 <gouthamr> you can speak with me/tbarron if you'd like if you need any help preparing your platform/plans... :)
15:10:58 <gouthamr> The next announcement I had was to do with the final release candidate for the Rocky release
15:11:09 <gouthamr> #link https://review.opendev.org/#/c/709896/ (Final Rocky Release candidate)
15:11:47 <gouthamr> we released manila 7.4.1 today:
15:11:49 <gouthamr> #link https://releases.openstack.org/rocky/index.html#rocky-manila
15:12:44 <gouthamr> this release is being tagged as the final release candidate, and 7.x will move into extended maintenance, meaning we'll continue to create backports to that branch
15:12:52 <gouthamr> but make no further official releases
15:13:26 <gouthamr> distributions may be paying heed to official releases, so that's an important milestone for them
15:14:26 <gouthamr> That's all I had in terms of announcements today, we'll cover a bit more if we have time for Open Discussion
15:14:35 <gouthamr> anyone got anything else?
15:15:13 <gouthamr> moving on...
15:15:14 <gouthamr> #topic OSSA-2020-002
15:15:56 <gouthamr> if you missed the notification on the mailing list, we sent out an OpenStack Security Advisory yesterday
15:15:58 <gouthamr> #link https://security.openstack.org/ossa/OSSA-2020-002.html
15:16:37 <gouthamr> it pertains to a bug in the manila share networks API
15:16:38 <gouthamr> #link https://launchpad.net/bugs/1861485 (Unprivileged users can retrieve, use and manipulate share networks (CVE-2020-9543))
15:16:39 <openstack> Launchpad bug 1861485 in Manila "[OSSA-2020-002] Unprivileged users can retrieve, use and manipulate share networks (CVE-2020-9543)" [High,Fix released] - Assigned to Mohammed Naser (mnaser)
15:17:34 <gouthamr> i'd like to credit a few individuals: tobberydberg for finding it, and participating in its fix
15:17:57 <vkmc> tobberydberg++
15:18:12 <gouthamr> mnaser for fixing it, with tests
15:18:36 <dviroel> tobberydberg++
15:18:40 <dviroel> mnaser++
15:18:55 <gouthamr> fungi for teaching me and working with me to follow the VMT process
15:19:07 <mnaser> \o/ y'all are welcome :)
15:19:11 * mnaser goes back to hiding
15:19:17 <vkmc> mnaser++
15:19:18 <vhari> mnaser++
15:19:26 <carloss> tobberydberg ++
15:19:30 <carloss> mnaser ++
15:19:33 <gouthamr> dviroel/tbarron for the expedited reviews
15:20:32 <gouthamr> and finally, all the distro security folks that responded to the embargo notice and even suggestions.. one of which is now on Launchpad for our consideration
15:20:51 <gouthamr> #link http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-9543 (US NVD)
15:21:05 <gouthamr> ^ the CVE isn't published yet, but will be...
15:21:44 <dviroel> thanks gouthamr for all the hard work around this bug/fix
15:22:18 <gouthamr> it was a great learning experience, two outcomes, beyond fixing the bug..
15:23:31 <gouthamr> 1) We'll be applying for the vulnerability-managed tag, i'm working on it - you should hear about this in upcoming meetings
15:24:56 <gouthamr> and 2) I now have access to a bunch of issues that were probably going into a black-hole due to misconfiguration on launchpad - and some of them are seeking finer grained RBAC on resources
15:26:15 <gouthamr> i'm hoping to note them down and bring them up during the PTG, so we can discuss
15:26:31 <fungi> yw gouthamr! we were just discussing ossa-2020-002 in the security meeting next door
15:26:55 <gouthamr> ah! ty fungi - will check
15:28:32 <gouthamr> great, next up
15:28:39 <gouthamr> #topic Tracking our work
15:29:11 <gouthamr> any one have any reviews to call out?
15:29:52 <gouthamr> i know we were busy chasing this fpf deadline... i have a few pings, one of which was for
15:30:02 <gouthamr> #link https://review.opendev.org/#/c/706438/ (Support query user message by timestamp)
15:30:24 <gouthamr> #link https://review.opendev.org/#/c/708807/ (python-manilaclient)
15:31:40 <gouthamr> i'll add this to the review etherpad, but please do review, haixin's been doing some great work
15:33:05 <gouthamr> #link https://etherpad.openstack.org/p/manila-ussuri-review-focus
15:33:24 <gouthamr> ^ just started filling that up, please join me and add any reviews
15:34:30 <gouthamr> next up,
15:34:33 <gouthamr> #topic Bugs (vhari)
15:34:48 <gouthamr> #link: https://etherpad.openstack.org/p/manila-bug-triage-pad-new (Bug Triage etherpad)
15:35:08 <gouthamr> vhari, what have you got :)
15:35:19 <vhari> thanks gouthamr
15:35:47 <vhari> lets start with one of your bugs today :)
15:35:48 <vhari> https://bugs.launchpad.net/manila/+bug/1867030
15:35:50 <openstack> Launchpad bug 1867030 in Manila "Force delete does not work if share service is down" [Undecided,New]
15:36:34 <gouthamr> This bug was reported by a downstream consumer of manila through RHOSP
15:36:43 <vhari> ack
15:37:27 * gouthamr forgot to add links in the description
15:38:08 <vhari> gouthamr, got the link and can add it
15:38:11 <tobberydberg> Thanks folks for the credit, and thank you all for the real work :-)
15:38:19 <gouthamr> tobberydberg++
15:38:52 <gouthamr> vhari: guess i meant to link to the api ref
15:38:54 <gouthamr> https://docs.openstack.org/api-ref/shared-file-system/?expanded=force-delete-share-detail#force-delete-share
15:39:05 <gouthamr> and the corresponding manilaclient implementation
15:39:29 <gouthamr> #action gouthamr will alter the description after this meeting
15:39:54 <gouthamr> ^ that probably worked
15:40:10 <gouthamr> cool, do we have anything to discuss about this bug?
15:40:30 <vhari> https://bugs.launchpad.net/manila/+bug/1866951
15:40:31 <openstack> Launchpad bug 1866951 in Manila "[db] default value for project_only allows non-secure access" [Medium,New]
15:40:49 <gouthamr> vhari doesn't want to :)
15:40:58 <lseki> haha
15:40:58 <carloss> haha
15:40:59 <vhari> needs some triage
15:41:05 <vhari> hehe
15:41:10 <vhari> you're on again gouthamr
15:41:14 <gouthamr> :P kidding, vhari: about https://bugs.launchpad.net/manila/+bug/1867030 - i think it's medium priority
15:41:15 <openstack> Launchpad bug 1867030 in Manila "Force delete does not work if share service is down" [Undecided,New]
15:41:26 <vhari> k
15:42:16 <vkmc> I can trige
15:42:18 <vkmc> triage*
15:42:22 <gouthamr> i can own it, but won't get to it right away - if anyone else is interested in giving it a shot, please pop me off the assignee and take it
15:42:32 <gouthamr> vkmc: ah, ty
15:42:40 <vhari> vkmc++
15:43:21 <vkmc> this is more like a feature request
15:43:22 <vhari> got another bug but this may take longer discussion so let's cover it next session
15:43:33 <vkmc> and seems it would be good to discuss about it on next ptg
15:43:37 <vkmc> will add that comment in the report
15:43:49 <gouthamr> vkmc: sure we can discuss it on the bug report...
15:44:06 <gouthamr> vhari: we have time for the next few on your list
15:44:07 <vkmc> or that
15:44:21 <vhari> cool
15:44:22 <gouthamr> #link https://bugs.launchpad.net/manila/+bug/1866951
15:44:23 <openstack> Launchpad bug 1866951 in Manila "[db] default value for project_only allows non-secure access" [Medium,New]
15:44:24 <vhari> https://bugs.launchpad.net/manila/+bug/1671652
15:44:25 <openstack> Launchpad bug 1671652 in Manila "Add IPv6 enablement logic in CI" [Undecided,Triaged]
15:44:39 * gouthamr likes to thread switch with vhari
15:45:06 <gouthamr> vhari: sorry about that, let's finish 1866951
15:45:25 <vhari> np
15:46:28 <gouthamr> ^ this one came as a suggestion for the pre-ossa notice we sent out..
15:47:04 <gouthamr> (to distributions and their security contacts)
15:47:41 <gouthamr> i told them that we'd consider this suggestion for master and beyond, but fixing this, imo wouldn't be appropriate for a backport
15:48:15 <gouthamr> because we run the risk of introducing a regression in other APIs
15:48:39 <gouthamr> if you have any thoughts about this one, please leave them on the LP
15:49:08 <gouthamr> i'd like to gather them and work on either a fix or a proposal and bring it to the PTG
15:49:55 <gouthamr> vhari: i'll mark this medium, and assign it to myself, and target it to a milestone in victoria
15:50:14 <vhari> gouthamr, ack ty
15:50:39 <gouthamr> cool, now onto
15:50:45 <gouthamr> #link https://bugs.launchpad.net/manila/+bug/1671652
15:50:46 <openstack> Launchpad bug 1671652 in Manila "Add IPv6 enablement logic in CI" [Undecided,Triaged]
15:51:09 <vhari> cool , needed to get some traction on this one
15:51:29 <gouthamr> yes..
15:51:45 <gouthamr> per vkmc's last note, it looks like we have this capability now
15:52:19 <vkmc> pff this one is old
15:52:20 * vkmc checks
15:53:01 <vkmc> Ben was working on this
15:53:36 <gouthamr> #link https://review.opendev.org/#/c/529142/ (Update manila plugin to support IPv6)
15:53:59 <vkmc> at the moment I reported that because we didn't have any gate to exercise ipv6
15:54:05 <vkmc> seems that Ben implemented this for lvm
15:54:18 <gouthamr> ah, yes - and since then we've had cephfs-nfs as well
15:54:24 <vkmc> the rest of the gates use ivp4
15:55:16 <vkmc> Ben change (529142) only enables multi-ip support
15:55:23 <ganso> what is really missing about enabling IPv6 in the CI? I thought it was already enabled as per my devstack script back in 2018
15:55:32 <gouthamr> okay, so we have a framework for drivers aided by the devstack plugin
15:55:43 <vkmc> I don't know if the ci scripts are updated to use it
15:56:36 <gouthamr> vkmc: they are..
15:57:16 <gouthamr> currently, lvm, cephfs-nfs are the two jobs we run upstream with ipv4+ipv6
15:57:49 <gouthamr> the netapp CI is also still running this, dviroel?
15:57:50 <ganso> gouthamr: netapp driver used to run it, but AFAIK there is nothing code-wise stopping them from being able to run again
15:58:00 <gouthamr> ganso: true..
15:58:42 <gouthamr> vkmc: guess we can close this bug report noting these reviews?
15:58:43 <dviroel> gouthamr: we're having some issues with a scenario test right now
15:58:54 <vkmc> gouthamr, I'll think about it
15:59:03 <gouthamr> vkmc: ack
15:59:21 <dviroel> gouthamr: planning to get it up and running again soon
15:59:22 <gouthamr> dviroel: ack, when you find an issue, we should open another LP
15:59:31 <gouthamr> if necessary
15:59:48 <gouthamr> we're 1 min away from the close
15:59:55 <dviroel> gouthamr: ack, need to make sure that isn't a infra issue
16:00:01 <gouthamr> dviroel: ack
16:00:06 <vkmc> Fix Released is the correct status, is that right?
16:00:16 <gouthamr> alright time's up folks, we'll discuss on #openstack-manila
16:00:19 <vkmc> not sure about the milestone
16:00:25 <vkmc> thanks o/
16:00:40 <gouthamr> do stay safe, all of you..
16:00:49 <gouthamr> see you on #openstack-manila
16:00:54 <gouthamr> thanks for attending
16:01:04 <gouthamr> #endmeeting