15:00:33 <gouthamr> #startmeeting manila
15:00:34 <openstack> Meeting started Thu Jul 30 15:00:33 2020 UTC and is due to finish in 60 minutes. The chair is gouthamr. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:38 <openstack> The meeting name has been set to 'manila'
15:00:43 <dviroel> o/
15:00:45 <lseki> o/
15:00:50 <gouthamr> courtesy ping: ganso vkmc carloss tbarron andrebeltrami danielarthurt
15:00:58 <tbarron> hi
15:00:58 <vhari> hi
15:01:00 <danielarthurt> o/
15:01:15 <andrebeltrami> hello
15:01:33 <carthaca> Hi
15:01:36 <gouthamr> Hello o/ thank you for joining..
15:01:49 <gouthamr> here's our agenda for today:
15:01:50 <gouthamr> https://wiki.openstack.org/wiki/Manila/Meetings#Next_meeting
15:01:59 <gouthamr> lets begin as usual, with
15:02:02 <gouthamr> #topic Announcements
15:02:24 <gouthamr> we had a stable branch release this week
15:02:49 <gouthamr> #link http://lists.openstack.org/pipermail/release-announce/2020-July/009628.html (stable/ussuri manila 10.0.1)
15:03:06 <gouthamr> ^ this was our first release from the branch since the ussuri release
15:03:48 <gouthamr> we also have a couple of End-of-life announcements
15:04:12 <gouthamr> as discussed in the past meetings, ocata and pike branches are now EOL
15:04:13 <gouthamr> https://opendev.org/openstack/manila/src/tag/ocata-eol
15:04:13 <gouthamr> https://opendev.org/openstack/manila/src/tag/pike-eol
15:04:55 <gouthamr> i've requested that the infra team help us delete these two branches
15:05:24 <gouthamr> we're also going to be cleaning up the old driverfixes branches: mitaka, newton and ocata
15:06:15 <gouthamr> please be aware in case you're still consuming code from these :)
15:06:55 <gouthamr> good news is that it leaves us with two "extended maintenance" branches, queens and rocky - which are still able to receive backports
15:07:19 <vkmc> o/
15:07:22 * vkmc sneaks in
15:07:28 <gouthamr> in terms of release schedule, we're at milestone-2!
15:07:36 * gouthamr marks vkmc tardy
15:07:44 <gouthamr> #link https://releases.openstack.org/victoria/schedule.html (victoria release schedule)
15:08:16 <vkmc> D:
15:08:17 <gouthamr> which means today's our new driver deadline, and we've had no new drivers proposed - i'll retarget any blueprints to the next release
15:08:41 <gouthamr> an upcoming deadline is the Feature Proposal Freeze in 3 weeks
15:09:19 <gouthamr> which is when all new features must be proposed and substantially completed, with unit, functional and integration tests
15:10:56 <gouthamr> a community announcement: the call for proposals for the next open infrastructure summit is closing soon
15:10:58 <gouthamr> #link http://lists.openstack.org/pipermail/openstack-discuss/2020-July/015730.html
15:11:26 <gouthamr> the deadline is August 4, 2020, so please submit your manila presentation proposals soon :)
15:11:45 <gouthamr> that's all i had in terms of announcements, anyone else got any?
15:12:29 <gouthamr> #link DocSquash day/s (vhari)
15:12:34 <gouthamr> gah
15:12:39 <gouthamr> #topic DocSquash day/s (vhari)
15:12:45 <gouthamr> vhari: you're up!
15:12:51 <vhari> gouthamr, ty
15:13:18 <vhari> we are proposing to dedicate bug review session
15:13:32 <vhari> starting with doc related bugs
15:13:59 <vhari> one option is to start next week's meeting
15:14:19 <vhari> I have compiled a list of 27+ bugs to review :)
15:14:33 <vhari> any thoughts or ideas are welcome
15:14:56 <vhari> ofc will provide the list in advance .. but most of the bugs are already under the 'doc' tag
15:14:59 <vhari> and available for preview
15:15:27 <gouthamr> great! so this is an effort to drive down the documentation bugs that have been languishing
15:15:41 <vhari> gouthamr, ack ofc
15:16:08 <vhari> 1st in series of bug review sessions to drive down the bug backlog
15:16:30 <vhari> any thoughts or ideas on this?
15:16:30 <gouthamr> between ourselves, looks like we can each take on 2-3 bugs and drive that number down to 0 :)
15:16:42 <vhari> :D
15:17:27 <gouthamr> it's a great idea - thank you so much for proposing it, vhari
15:17:51 <vhari> gouthamr, yw
15:18:14 <dviroel> vhari++
15:18:15 <vhari> we can discuss the logistics such as date etc later if no thoughts
15:18:44 <vhari> or maybe the list will be 0 by the time we schedule a sessions :)
15:18:48 <gouthamr> we can dedicate a day like you said, where we're available on irc or a video bridge, for triage discussions, and each of us take time to only work on the docs
15:18:59 * gouthamr vhari is full of hope
15:19:07 <vhari> gouthamr, one can hope !:)
15:19:45 <vhari> gouthamr, sounds good
15:19:48 <vkmc> \o/
15:19:51 <vkmc> count me in
15:20:03 <vhari> I will paste a link to doc in bug etherpad
15:20:18 <gouthamr> vhari: your plan was to do it next thursday?
15:20:25 <vhari> gouthamr, ack
15:20:38 <vhari> part or all of the time slot as needed
15:21:22 <vkmc> maybe we can send info about this event, a time slot and a google meet/zoom bridge to the mailing list
15:21:34 <gouthamr> vkmc: +1
15:21:35 <vkmc> and invite people to join
15:21:41 <vhari> vkmc +1
15:22:34 <vkmc> I can take the action item
15:22:41 <gouthamr> thank you, vkmc
15:22:48 <vhari> ty vkmc
15:23:11 <vhari> the link is on etherpad now
15:23:18 <gouthamr> regarding the date - do you want to conduct a poll, or does everyone here think next thursday is good?
15:23:51 <vhari> Thur was a suggestion but open to ideas
15:24:52 <vhari> does anyone want to suggest alternate date/time?
15:25:13 <vkmc> IMHO we should go ahead and propose a date
15:25:23 <vkmc> and hope for the best
15:25:46 <vkmc> a "best effort" approach I'd say
15:26:11 <gouthamr> why don't we vote on whether we can make it for this next thursday?
15:26:26 * gouthamr hasn't used the bot to conduct a poll in forever
15:26:36 <vhari> +1 to next Thur 8/6
15:26:53 <tbarron> +1
15:27:03 <gouthamr> #startvote Is Aug, 6th 2020 a good day for the Zorilla Doc-a-thon? Yes, No, Maybe
15:27:04 <openstack> Begin voting on: Is Aug, 6th 2020 a good day for the Zorilla Doc-a-thon? Valid vote options are Yes, No, Maybe.
15:27:05 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
15:27:16 <vhari> Yes
15:27:16 <tbarron> #vote yes
15:27:20 <dviroel> #vote yes
15:27:22 <gouthamr> #vote yes
15:27:25 <vhari> #vote yes
15:27:38 <andrebeltrami> #vote yes
15:27:43 <lseki> #vote yes
15:28:19 <danielarthurt> #vote yes
15:28:25 <vkmc> #vote yes
15:28:44 <carthaca> #vote maybe
15:28:52 <gouthamr> #endvote
15:28:53 <openstack> Voted on "Is Aug, 6th 2020 a good day for the Zorilla Doc-a-thon?" Results are
15:28:54 <openstack> Maybe (1): carthaca
15:28:55 <openstack> Yes (8): vhari, vkmc, gouthamr, dviroel, lseki, tbarron, andrebeltrami, danielarthurt
15:29:07 <dviroel> \o/
15:29:14 <vkmc> *\o/*
15:29:25 <vhari> nice!
15:29:47 <gouthamr> ty all, we'll have this next week - its overwhelmingly positive, and exciting that we're having our first-ever doc-a-thon!
15:30:16 <gouthamr> carthaca: i hope you can make it, but if you can't, we'll still farm out the hard ones for you :)
15:30:24 <vhari> \o/
15:30:53 <tbarron> dhss true fancy stuff with neutron
15:31:15 <tbarron> needs someone to doc who has real experience there
15:31:17 <tbarron> :)
15:31:25 <tbarron> just messing with you
15:31:30 <carthaca> xD
15:31:34 <gouthamr> #agreed Aug, 6th 2020 is the manila doc-a-thon, vkmc will socialize this to the mailing list... please contact vhari/vkmc for more details
15:31:58 <gouthamr> anything else regarding $topic?
15:32:54 <vkmc> yaay
15:33:23 <gouthamr> if you have ideas, please feel free to share them with vhari and vkmc
15:33:34 <gouthamr> lets move on to
15:33:37 <gouthamr> #topic Reviews needing attention
15:34:59 <gouthamr> i'd like to thank each of you that has reviewed tens of patches to get our victoria cycle goal completed
15:35:07 <gouthamr> at least one of them
15:35:40 <gouthamr> there are no more "legacy" style jobs on the main branches on each repository we own
15:35:45 <gouthamr> long live, devstack-gate
15:36:12 <tbarron> gouthamr: you were a true Tiger on these!
15:36:18 <dviroel> wasn't hard as proposing them, good job gouthamr!
15:37:40 <gouthamr> :) was happy to - as tbarron said, this is one we're glad to do, because it greatly reduces the new contributor onboarding curve and the maintenance burden
15:39:02 <gouthamr> so the thing to look forward to here, is the transition from legacy jobs on maintained release branches - this will happen slowly
15:39:32 <gouthamr> and from the most recent maintained release: ussuri
15:40:09 <vkmc> good job gouthamr :D
15:40:17 <gouthamr> and this may spill into the wallaby cycle, because its no longer a priority - however, if there's someone that would like to take a shot at them, please do!
15:41:04 <gouthamr> next up though is getting our main branch tested on focal fossa - you may have seen patches by gmann already
15:41:16 <gouthamr> and there are quite some failures that need triaging
15:42:10 <gmann> it will be helpful to get that soon. there might be issues with lower-constraint jobs, i need to check what all dep it is failing.
15:42:11 <gouthamr> i'd like help with this - please talk to me if you have cycles - we can pick up the failed jobs individually, triage them, and get them working
15:42:26 <gmann> +1
15:42:37 <gouthamr> +1 ty for getting us started, gmann!
15:43:00 <tbarron> gmann++
15:44:39 <gouthamr> are there any other reviews that need attention?
15:45:02 <gouthamr> if not, lets move on...
15:45:05 <gouthamr> #topic Bugs (vhari)
15:45:19 <gouthamr> vhari: you're up, again
15:45:22 <vhari> gouthamr, have time for a bug or two on the list
15:45:24 <vhari> #link https://bugs.launchpad.net/manila/+bug/1889549
15:45:26 <openstack> Launchpad bug 1889549 in OpenStack Shared File Systems Service (Manila) "500 ShareMigrationError migration-get-progress" [Undecided,New]
15:46:00 <vhari> looking for basic triage on this new bug
15:46:33 <carthaca> \o/
15:46:41 <gouthamr> ugly, i agree
15:47:09 <tbarron> I don't think it should be an error
15:47:53 <gouthamr> +1
15:49:07 <gouthamr> we can detect phase1 is done, so we can refrain from invoking the manager and just return 100%
15:49:36 <tbarron> I think that's intuitive.
15:50:06 <gouthamr> i know the API ref for this is bad/non-existent
15:50:24 <gouthamr> but, there was a review proposing improvements: https://review.opendev.org/#/c/715290/
15:52:00 <gouthamr> i'd vote on this being a "medium"
15:52:17 <gouthamr> any volunteers to fix this?
15:53:41 <gouthamr> carthaca: maybe you can give this a shot yourself? i'd be happy to help review
15:54:21 <carthaca> yes, sound like a plan
15:54:30 <gouthamr> i'm hoping to dust off the api docs during the doc-a-thon; and we can note this discrepancy there
15:55:14 <vhari> carthaca++
15:55:18 <gouthamr> cool, ty carthaca - lets target it to m-3 for now
15:55:31 <vhari> gouthamr, that's all for today
15:55:44 <gouthamr> thank you vhari
15:55:52 <gouthamr> #topic Open Discussion
15:55:53 <vhari> gouthamr, yw
15:57:12 <gouthamr> for some feel good news: https://mashable.com/article/bear-cam-champion-returns/
15:58:32 <lseki> 🧸
15:59:18 <gouthamr> we discussed Holly in a meeting here about a year ago i think <3 much has changed since then, but, holly's return tells you there is always hope
15:59:44 <dviroel> holly++
15:59:46 <gouthamr> that's a wrap for this week.. stay safe everyone, and see you on #openstack-manila
15:59:55 <tbarron> thanks!
16:00:01 <gouthamr> #endmeeting