15:01:08 <gouthamr> #startmeeting manila
15:01:08 <openstack> Meeting started Thu Sep 17 15:01:08 2020 UTC and is due to finish in 60 minutes.  The chair is gouthamr. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:12 <openstack> The meeting name has been set to 'manila'
15:01:27 <dviroel> o/
15:01:27 <carloss> hi o/
15:01:33 <gouthamr> courtesy ping: ganso vkmc lseki tbarron andrebeltrami felipe_rodrigues
15:01:36 <maaritamm> o/
15:01:37 <felipe_rodrigues> Hi alll
15:01:41 <andrebeltrami> o/
15:02:04 <gouthamr> hello o/
15:02:04 <tbarron> \o/
15:02:19 <gouthamr> thank you for joining; here's our agenda for today: https://wiki.openstack.org/wiki/Manila/Meetings#Next_meeting
15:02:22 <carthaca> hi
15:02:25 <vhar> hi
15:02:33 <gouthamr> lets begin as usual with
15:02:36 <gouthamr> #topic Announcements
15:03:03 <gouthamr> we're a week away from pushing out RC1 for manila and manila-ui
15:03:07 <gouthamr> #link https://releases.openstack.org/victoria/schedule.html (victoria release schedule)
15:03:10 <vkmc> o/
15:03:22 <gouthamr> #link http://lists.openstack.org/pipermail/openstack-discuss/2020-September/017210.html ([release] Release countdown for week R-4 Sept 14 - 18)
15:03:48 <lseki> o/
15:04:01 <gouthamr> so we should be in finding, filing and fixing bugs mode :)
15:04:18 <gouthamr> we'll discuss that a bit more shortly
15:04:34 <gouthamr> a few pointers regarding the upcoming Virtual PTG
15:04:43 <gouthamr> #link https://www.eventbrite.com/e/project-teams-gathering-october-2020-tickets-116136313841 (Register here)
15:04:43 <gouthamr> #link https://ethercalc.openstack.org/7xp2pcbh1ncb (Draft Schedule)
15:04:43 <gouthamr> #link https://etherpad.opendev.org/p/wallaby-ptg-manila-planning (Planning Etherpad)
15:05:33 <gouthamr> thanks for adding topics so far, please continue to do so, and as we get closer to the event, we'll schedule the topics into the time slots available
15:06:31 <gouthamr> last week, we submitted two forum proposals concerning manila; the forum schedule hasn't been published yet to my knowledge
15:06:32 <tbarron> gouthamr: thanks for the schedule planning and topic setup, lots of work right after feature freeze reviews
15:06:42 <tbarron> and that too
15:07:02 <gouthamr> true that
15:07:42 <gouthamr> tbarron suggested we bundle the longer more subjective questions we intended to ask for the user survey into a forum session
15:08:20 <gouthamr> we've had good participation from folks that use manila or operate it in the past, so we'll see if that session gets accepted
15:09:17 <gouthamr> the other forum session is on container storage with openstack, a bit more generic and it'll have folks working on the CSI drivers for cinder, -lib and manila in one room, so i think it'll bring some interesting discussion too
15:09:37 <gouthamr> that's all i had in terms of announcements - anyone else got any?
15:10:05 <gouthamr> #topic Victoria Bug Squash (vkmc)
15:10:15 <gouthamr> o/ vkmc
15:10:22 <vkmc> \o
15:10:32 <vkmc> hey folks
15:10:41 <vkmc> we are working on planning a bug squash
15:10:42 * gouthamr guesses vkmc is in a virtual f2f and typing here at the same time
15:11:07 <vkmc> something like the doc-a-thon last time (which I know I'm missing some feedback... I'm preparing a summary on how that went)
15:11:35 <gouthamr> vkmc++
15:11:44 <vkmc> the idea is to do it following the same format... on a bluejeans/zoom/jitsi call, go over a list of bugs we consider good candidates for rc
15:11:45 <carloss> vkmc++
15:13:01 <gouthamr> great, do we have a date for the call vkmc?
15:13:24 <vkmc> so we can rely on the list of bugs that vhari prepared for us, and also feel free to submit your own if you see are good candidates
15:13:41 <vkmc> so... yes, date
15:13:43 * gouthamr she's vhar today
15:13:48 <vkmc> unfortunately we don't have much time
15:13:49 <vhar> :D
15:13:51 <vkmc> we cut rc next friday
15:14:06 <vkmc> so the idea is to do it next monday
15:14:22 <vkmc> starting at the same time we hold our weekly meeting (this one)
15:14:33 <gouthamr> +1 great, i think that gives us good time to iterate on reviews
15:14:35 <vkmc> and then work on the bugs during the week
15:14:37 <vkmc> how does that sound?
15:14:40 <vkmc> yes :)
15:14:58 <carloss> sounds good!
15:15:02 <vkmc> it's very short time, but we can manage to get some fixes for small bugs
15:15:10 <vkmc> that's the hope at least
15:15:19 <vkmc> I'll send a summary on this plan on the mailing list later today
15:15:39 <gouthamr> any objections to this proposal?
15:16:05 <gouthamr> hearing none...
15:16:58 <gouthamr> #agreed Manila team will meet for the victoria cycle bugsquash on 21st Sep at 1500 UTC - details will be posted by vkmc on the openstack-discuss ML soon
15:17:35 <gouthamr> thank you for putting this together vkmc and vhar!
15:17:50 <vkmc> southern hemisphere, we can celebrate spring... bug smash and spring break
15:18:01 <vhar> gouthamr, yw
15:18:32 <gouthamr> Nice :) spring festivals are always fun when we don't let bugs into the produce
15:19:07 <gouthamr> anything else regarding $topic
15:19:14 <vhar> gouthamr, vkmc, I will create an ethercalc and add a few items to boot
15:19:32 <gouthamr> vhar: great, thank you!
15:19:53 <gouthamr> #topic Reviews needing attention
15:20:00 <gouthamr> #link https://etherpad.openstack.org/p/manila-victoria-review-focus (review focus ether pad)
15:21:09 <gouthamr> thanks for keeping that etherpad up to date!
15:21:25 <vkmc> vhar++
15:21:27 <vkmc> thanks!
15:21:30 <vhar> no translation:)
15:21:32 <gouthamr> we'll rearrange things a bit; but i see status updates on the items
15:21:37 <gouthamr> haha vhar +1
15:22:37 <gouthamr> lets discuss the changes
15:22:38 <gouthamr> Manila UI: User Messages Panel
15:22:44 <gouthamr> #link https://review.opendev.org/#/c/742550/
15:23:29 <gouthamr> carloss has reviewed this, and i see tbarron's comment on the pad
15:23:50 <tbarron> I've looked over this one and it's fine by me but it isn't one of my many vast areas of expertise :D
15:24:33 <gouthamr> ack; ty - vkmc this has been getting some horizon reviewers' attention
15:25:20 <gouthamr> since you worked with them to ensure the UX is similar between cinder and manila, can we ask them to re-review this change?
15:25:54 <tbarron> I think we can merge it just as soon as one of them says it's OK
15:26:17 <gouthamr> +1, sounds like a plan
15:26:22 <tbarron> and vkmc thanks for the great work on it!
15:26:27 <vkmc> gouthamr, yes, I think it's a good idea
15:26:30 <carloss> +1 tbarron
15:26:35 <tbarron> and carloss++
15:26:38 <carloss> great job vkmc
15:26:47 <vkmc> thanks for your reviews :)
15:26:57 <carloss> yw :)
15:26:59 <gouthamr> thanks all, next scroll down to "bug fixes"
15:27:09 <gouthamr> Extend share will go through scheduler
15:27:16 <gouthamr> #link https://review.opendev.org/#/c/700393/
15:27:31 <gouthamr> oh boy, pretty old change, but i don't recall why we stalled on this
15:28:04 <gouthamr> dviroel had this comment: https://review.opendev.org/#/c/700393/13/manila/share/api.py
15:28:58 <dviroel> remember to ask a flag to switch between the current flow and the new, that goes through the scheduler
15:29:05 <gouthamr> i dunno if we can get this resolved by rc1, dviroel - mind poking once again?
15:29:28 <dviroel> gouthamr: no, i can do that
15:29:34 <gouthamr> dviroel: ty
15:29:35 <gouthamr> Totalcount returned by pagination query is wrong
15:29:44 <gouthamr> (carloss) Issues were resolved. Some more things were pointed out. I think we are getting in a good shape to merge this patch.
15:30:18 <gouthamr> great! thanks for updating that change and addressing the issues carloss
15:30:25 <carthaca> carloss ++
15:30:29 <carloss> my pleasure :)
15:31:07 <gouthamr> so you have a fresh -1, so i guess we'll need to wait for a new patch
15:31:28 <gouthamr> Fix manila OverQuota issue while managing shares
15:31:35 <gouthamr> #link  https://review.opendev.org/#/c/722418/
15:32:06 <gouthamr> vkmc wanted to test this change - and re-review it
15:32:15 <gouthamr> but looks like its in good shape
15:32:16 * vkmc checks
15:32:25 <vkmc> yes
15:32:26 <gouthamr> wait, no CI since Apr :)
15:32:29 <gouthamr> lets recheck
15:32:32 <dviroel> +1
15:33:00 <vkmc> we might need a rebase for it
15:33:01 <gouthamr> vkmc dviroel: i'll look to you to get this in..
15:33:06 <gouthamr> vkmc: ack
15:33:21 <dviroel> gouthamr: tks
15:33:22 <gouthamr> next: Add generic fuzzy matching logic to the database layer
15:33:33 <gouthamr> #link https://review.opendev.org/#/c/734041/
15:34:25 <gouthamr> cool, in the lines of the pagination bugfix
15:34:48 <gouthamr> carloss can i throw this one at you as well? :)
15:34:54 <carloss> sure :)
15:35:26 <gouthamr> haha, thanks! you're becoming our (more responsible) API guy
15:35:38 <dviroel> carloss++
15:35:41 <carloss> haha
15:35:45 <gouthamr> [NetApp] Fix CIFS promote back issue
15:35:55 <gouthamr> #link https://review.opendev.org/#/c/732757/
15:36:18 <carloss> working on this atm :)
15:36:24 <gouthamr> great, thanks
15:36:24 <carloss> will provide updates soon
15:36:47 <gouthamr> adding this one to the etherpad now:
15:36:47 <gouthamr> Modify share groups w/ manila-manage's update-host
15:36:56 <gouthamr> https://review.opendev.org/749172
15:37:01 <gouthamr> #link https://review.opendev.org/749172
15:37:39 <gouthamr> this one builds on carthaca's bugfix to include share groups in the host-update command
15:38:58 <tbarron> does carthaca have cycles to look it over?
15:40:29 <gouthamr> carthaca may be afk
15:40:38 <gouthamr> i'll ask on the review..
15:40:57 <carthaca> I can have a look again - I thought only the releasenote changed
15:41:17 <tbarron> carthaca++
15:41:31 <gouthamr> carthaca: yes, just the release note from your previous review
15:41:34 <gouthamr> ty!
15:41:55 <gouthamr> alright, any other bugfixes that we need on the etherpad?
15:42:15 <gouthamr> and to pay review attention to/track?
15:42:39 <dviroel> added another one
15:42:55 <gouthamr> Improve migration_get_progress error handling
15:43:01 <gouthamr> #link https://review.opendev.org/#/c/744145/
15:43:36 <tbarron> as dviroel noted, needs rebase and release note but
15:43:43 <tbarron> seems good otherwise to me
15:43:54 <gouthamr> +1 ty
15:45:03 <carthaca> I will address those
15:45:19 <gouthamr> awesome.. lets take a quick look at the bugs tagged for M-3 that didn't get attention
15:45:24 <gouthamr> #link https://launchpad.net/manila/+milestone/victoria-3
15:46:18 <gouthamr> 24 bugs didn't get addressed - and we'll target RC1 by default
15:46:53 <gouthamr> that's a lot - i will open up wallaby-1 on LP for bugs that are low prio
15:47:14 <gouthamr> but i'll need folks that are working on them to actively retarget these
15:47:54 <gouthamr> that said, some of these are DOC bugs that may already have patches in review
15:48:37 <tbarron> https://review.opendev.org/#/c/745402/ has W+2 but got stuck?
15:49:18 <tbarron> looking at high prio not merged
15:49:29 <gouthamr> tbarron: it needs a change in the devstack-plugin-ceph - jobs broke recently and vkmc has a patch here: https://review.opendev.org/#/c/749726/
15:49:41 <tbarron> ah
15:50:49 <gouthamr> we got to remind yoctozepto to re-review
15:51:01 <vkmc> I pinged eharney earlier today
15:51:08 <vkmc> will ping other people too
15:51:38 <gouthamr> thanks vkmc
15:51:50 <vkmc> np
15:52:08 <gouthamr> anything else?
15:52:53 <gouthamr> okay lets move on
15:53:00 <gouthamr> #topic Bugs (vhari)
15:53:11 <vhar> gouthamr, o/
15:53:19 <gouthamr> vhar \o
15:53:21 <vhar> got a new bug
15:53:22 <vhar> #link https://bugs.launchpad.net/manila/+bug/1895361
15:53:23 <openstack> Launchpad bug 1895361 in OpenStack Shared File Systems Service (Manila) "[RFE] NetApp - Improve user experience on Adaptive QoS" [Undecided,New] - Assigned to Douglas Viroel (dviroel)
15:53:25 <vhar> to triage
15:54:00 <gouthamr> ack
15:54:11 <tbarron> vhar: I asked for this one, just wanted a tracker
15:54:34 <tbarron> from my POV it's up to the NetApp folks when they want to schedule the work on it
15:54:49 <tbarron> doesn't *have* to be before release
15:55:03 <vhar> tbarron, ack .. can we set importance at this time ?
15:55:19 <dviroel> yeah, we may land it partially during the week, not sure yet tbarron
15:55:23 <tbarron> up to them but I'd say low
15:56:21 <vhar> dviroel, any thoughts?
15:56:46 <dviroel> lets consider RC for now
15:57:03 <dviroel> its a low, as tbarron said
15:57:17 <dviroel> will do my best :)
15:57:19 <vhar> cool, done
15:57:34 <vhar> dviroel++  ty :)
15:57:43 <tbarron> dviroel++
15:58:23 <carloss> dviroel++
15:58:24 <vhar> gouthamr, that's a wrap for bugs .. will list current bugs with  rc1 target in ethercalc
15:58:35 <vhar> thanks all :)
15:58:38 <gouthamr> awesome thanks vhar
15:58:43 <gouthamr> #topic Open Discussion
15:58:45 <tbarron> vhar++
15:58:56 <vhar> de nada :)
15:59:08 <dviroel> :)
15:59:35 <gouthamr> to recap, we have RC1 next week - and a lot of bugs will be targeted to it, so please pay attention to reviews; and we'll have a bug squash meeting at 1500 UTC on Monday (21st Sep 2020)
15:59:42 <gouthamr> so hope to see you all there
16:00:04 <gouthamr> thanks for all the efforts through the last mile of this release :)
16:00:21 <gouthamr> timecheck, lets take any further discussion to #openstack-manila
16:00:26 <gouthamr> see you all o/
16:00:28 <dviroel> thanks!
16:00:30 <gouthamr> #endmeeting