15:01:34 <gouthamr> #startmeeting manila
15:01:34 <openstack> Meeting started Thu Nov 12 15:01:34 2020 UTC and is due to finish in 60 minutes. The chair is gouthamr. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:38 <openstack> The meeting name has been set to 'manila'
15:01:50 <carloss> o/
15:01:57 <gouthamr> courtesy ping: ganso vkmc dviroel lseki tbarron andrebeltrami felipe_rodrigues
15:01:59 <carthaca> hi
15:02:00 <vhari> hi
15:02:03 <vkmc> hi
15:02:04 <maaritamm> o/
15:02:04 <dviroel> o/
15:02:23 <gouthamr> hello o/
15:02:58 <gouthamr> thanks for joining, lets get going
15:03:03 <gouthamr> #topic Announcements
15:03:38 <gouthamr> first off, vhari has posted a notification to openstack-discuss regarding next week's bug squash event
15:03:52 <gouthamr> #link http://lists.openstack.org/pipermail/openstack-discuss/2020-November/018629.html (bug squash on 19th Nov 2020, no IRC meeting)
15:04:43 <gouthamr> we will be hosting a sync-up call in the place of this irc meeting on that day
15:05:03 <gouthamr> so please bookmark the call URL:
15:05:14 <gouthamr> #link https://meetpad.opendev.org/ManilaW-ReleaseBugSquash (Jitsi room for the bugsquash)
15:05:50 <gouthamr> and do take a look at the list of bugs that have been put together - many of them are assigned, and have been looked at at some point in the past
15:06:03 <gouthamr> #link https://ethercalc.openstack.org/birpr9a6bd0b (bug list for the bug squash)
15:07:10 <gouthamr> vhari's added bugs here that have been ascertained to need api/db changes; something we were uncomfortable doing during the last bug squash event
15:07:39 <gouthamr> so we can use the sync call to discuss any of these bugs, and brainstorm
15:08:14 <gouthamr> i'm hoping you can all make it and we have a successful bug squash! :)
15:08:43 <vhari> ty gouthamr . pls feel free to flag any other candidate bugs for the event
15:09:18 <gouthamr> ^ +1, if there's some bug you're looking to tackle, please bring it (or add it to the ethecalc above)
15:09:29 <vkmc> +1
15:09:47 <gouthamr> ty for planning this vhari :)
15:10:27 <gouthamr> alright, any questions/concerns?
15:10:32 <vhari> gouthamr, yw .. excited to squash some bugs together :)
15:11:06 <gouthamr> great!
15:11:29 <gouthamr> next up, we have an OpenStack community meeting today, at 1600 UTC
15:12:01 <gouthamr> #link http://lists.openstack.org/pipermail/openstack-discuss/2020-November/018646.html (OpenStack Community Meeting on Nov 12, 1600 UTC)
15:12:34 <gouthamr> we should expect to see some Victoria project updates, and have a general Q&A session
15:12:52 <gouthamr> so please join in if you can!
15:13:48 <gouthamr> and finally, maaritamm has posted a prioritized list of OSC commands that are left
15:13:59 <gouthamr> #link http://lists.openstack.org/pipermail/openstack-discuss/2020-November/018633.html (Priorities for implementing the OSC share commands)
15:14:30 <vkmc> maaritamm++
15:15:29 <gouthamr> i'd like for us to take a look at this list, and do share your views on the priority of commands for implementation
15:16:07 <gouthamr> as we know this has been a multi-cycle effort for us, and the committer/reviewer bandwidth is limited - so having a priority hugely helps!
15:16:55 <vkmc> there are a few patches up for review already
15:17:08 <vkmc> :)
15:17:46 <gouthamr> she's super fast! maaritamm++
15:18:24 <gouthamr> great, that's a wrap on announcements for today, anyone else got any
15:18:26 <gouthamr> ?
15:19:04 <gouthamr> alright, excuse me while i make an ad hoc topic
15:19:35 <gouthamr> #topic No remaining IRC meetings in November
15:20:33 <gouthamr> So, as mentioned prior, the next IRC meeting on 19th Nov has been canceled and we'll be meeting on a Jitsi call instead
15:21:33 <gouthamr> the week after that is a holiday week, at least here in the US - and i wanted to ask if we should go ahead and take a break
15:22:19 <gouthamr> (and possibly other countries)
15:22:55 <gouthamr> are there any concerns with taking this break?
15:23:35 <carloss> ++ for the break :)
15:24:24 <gouthamr> ty carloss, the only thing i can think of is that milestone-1 is the week after
15:25:10 <gouthamr> we have no release deliverables, but, it's a bug fix milestone
15:26:27 <gouthamr> so if folks want to talk about bugs, we'd have to do that on #openstack-manila or the openstack-discuss mailing list
15:27:33 <gouthamr> alright, lets take an AI
15:27:58 <gouthamr> #action gouthamr will send an email to openstack-discuss canceling the two IRC meetings remaining in Nov
15:29:19 <gouthamr> we've run through the agenda pretty much, lets move down our regular schedule
15:29:23 <gouthamr> #topic Bugs (vhari)
15:29:31 <gouthamr> back to you, vhari :)
15:29:55 <vhari> gouthamr, we have a number of new bugs on our radar to triage today!
15:30:01 <vhari> first off ..
15:30:06 <vhari> #link https://bugs.launchpad.net/manila/+bug/1904015
15:30:07 <openstack> Launchpad bug 1904015 in OpenStack Shared File Systems Service (Manila) "Manila overwrite existing Ceph users" [Undecided,New]
15:30:30 <gouthamr> oh this one comes from the openstack-discuss list
15:30:38 <gouthamr> #link http://lists.openstack.org/pipermail/openstack-discuss/2020-November/018684.html (Manila user overwriting existing Ceph users)
15:30:40 <vhari> ack ..
15:31:33 <vkmc> interesting
15:33:13 <gouthamr> and a pretty ugly bug, since a user can break other services
15:33:36 <gouthamr> if they can discover the cephx user used to configure these services
15:34:20 <gouthamr> vhari: i can investigate this bug and respond
15:34:51 <vhari> gouthamr, sounds good ..
15:35:07 <gouthamr> i think we can set this to medium, and bump up the severity if we can confirm it does indeed mess with the infrastructure
15:35:44 <vkmc> sounds good
15:35:59 <vkmc> not sure if this should be handled in ceph side or in manila side
15:36:56 <gouthamr> good point, i think we do some evictions and denials in the driver today based on things we know shouldn't work
15:37:14 <gouthamr> i'll do some more digging and we can talk, vkmc
15:37:32 <vkmc> gouthamr, cool
15:37:43 <vhari> cool, moving on
15:37:55 <vhari> #link https://bugs.launchpad.net/manila/+bug/1903922
15:37:56 <openstack> Launchpad bug 1903922 in OpenStack Shared File Systems Service (Manila) "Generic driver fails CIFS online extension test " [Undecided,New]
15:38:25 <gouthamr> ah i reported this one, and the rca isn't complete
15:38:40 <vhari> gouthamr, ack and you posted repro config
15:38:57 <gouthamr> my bad on the timing here - i enabled cifs testing in the generic driver a while ago, and we merged the patch with this failure
15:39:35 <gouthamr> right now, it also blocks upgrading the CI job to focal fossa
15:40:09 <gouthamr> #link https://review.opendev.org/762218/ ([ci] Switch generic driver job to focal fossa)
15:42:19 <gouthamr> i can keep this in my backlog and work on it opportunistically since we don't have any dedicated generic driver maintainers
15:42:39 <gouthamr> but, if anyone's willing to help - i'd more than appreciate it!
15:44:28 <gouthamr> share extensions in the generic driver are disruptive and clients may need to remount depending on how long cinder takes to perform the extension and if the client has a hard mount, and we're able to complete the whole transaction within their stale mount timeout
15:45:11 <gouthamr> s/are disruptive/can be disruptive
15:45:35 <gouthamr> so we might have a workaround - i'll test it and post it on the bug
15:46:35 <gouthamr> for triage though, i think this is a medium and it's not user reported - likely this is something that breaks only on our CI
15:47:55 <vhari> gouthamr, done ..
15:48:00 <gouthamr> ty vhari
15:48:09 <vhari> we have time to look at one more new bug ..
15:48:13 <vhari> #link https://bugs.launchpad.net/manila/+bug/1900752
15:48:14 <openstack> Launchpad bug 1900752 in OpenStack Shared File Systems Service (Manila) "cifs without security service error not helpful" [Undecided,New]
15:48:58 <gouthamr> hmmm, this is a tricky one
15:49:20 <gouthamr> it's really up to the drivers if CIFS shares support security services
15:49:45 <gouthamr> Generic, Windows and HPE for instance can work without it (Generic doesn't support security services yet)
15:50:16 <gouthamr> ONTAP and the Dell/EMC drivers *need* Active Directory
15:50:21 <vkmc> agree though that the error message should be more helpful
15:50:43 <carloss> vkmc ++
15:50:53 <vkmc> "create: An unknown error occurred." is very... shady
15:50:55 <gouthamr> def agree that this can be signalled with a user message, maybe we can make it generic and have the drivers raise a particular exception
15:51:06 <vkmc> not sure where it is raised
15:51:09 * gouthamr overuses the word generic
15:51:20 <vkmc> and if we have enough info to craft a better user message for this error
15:51:56 <gouthamr> i don't think we currently do - backends seem to be raising a ShareBackendException of sorts and the share manager is logging the information
15:54:01 <gouthamr> we could prevent share creation if we had this info prior - but, the api service doesn't know which specific backend's going to get the request
15:57:01 <gouthamr> anyone willing to take a look at this and see what can be done? since it affects netapp, dell/emc and possibly other vendor backends afaict, i think this should be a medium priority bug at least
15:57:42 <carloss> I can take a look and find some options
15:57:55 <gouthamr> ty carloss
15:58:03 <carloss> then I can bring the options to the table and we can discuss them
15:58:12 <carloss> yw :)
15:58:16 <gouthamr> ++
15:58:17 <vhari> carloss++
15:58:20 <vhari> gouthamr, all caught up triaging new bugs ... thx all for participating :)
15:58:29 <gouthamr> thank you vhari!
15:58:35 <gouthamr> #topic Open Discussion
15:58:49 <gouthamr> we have all of two minutes :)
15:59:01 <gouthamr> any final thoughts?
15:59:51 <vkmc> I'm thought-less
15:59:58 <gouthamr> :D alright, thank you all for attending - hope you can make it to the community meeting that's happening next, and the manila bugsquash event next week
16:00:11 <gouthamr> lets take further thoughts to #openstack-manila
16:00:14 <gouthamr> #endmeeting