15:00:52 <gouthamr> #startmeeting manila
15:00:53 <openstack> Meeting started Thu May 13 15:00:52 2021 UTC and is due to finish in 60 minutes.  The chair is gouthamr. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:54 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:57 <openstack> The meeting name has been set to 'manila'
15:01:01 <carloss> o/
15:01:01 <dviroel> o/
15:01:02 <ecsantos> o/
15:01:04 <felipe_rodrigues> hi
15:01:07 <fabiooliveira> o/
15:01:09 <caiquemello> o/
15:01:27 <gouthamr> courtesy ping: ganso vkmc tbarron
15:01:45 <gouthamr> hello folks o/
15:02:04 <tbarron> Hi
15:02:19 <gouthamr> thanks for joining, lets get started
15:02:23 <gouthamr> #topic Announcements
15:03:12 <gouthamr> been a slow week, no major announcements
15:03:18 <gouthamr> we're a couple of weeks away from M-1
15:03:53 <gouthamr> please ensure bugs/blueprints targeted to m-1 and assigned to you are ack'ed
15:04:00 <haixin> o/
15:04:07 <gouthamr> o/ haixin
15:04:12 <gouthamr> any other announcements?
15:05:13 <gouthamr> #topic stable/train to EM
15:05:55 <tbarron> gouthamr: I just added that one since it seemed worth getting the team's thinking ...
15:06:10 <gouthamr> ack, ty tbarron
15:06:25 <gouthamr> the stable maintenance team is trying to transition stable/train to EM - a phase where we'll no longer produce releases
15:06:30 <gouthamr> #link http://lists.openstack.org/pipermail/openstack-discuss/2021-May/022287.html
15:06:36 <gouthamr> #link https://review.opendev.org/c/openstack/releases/+/790754
15:06:54 <gouthamr> we've several open changes
15:06:56 <gouthamr> #link https://review.opendev.org/q/project:openstack/manila+status:open+branch:stable/train
15:07:16 <gouthamr> none in manila-ui or python-manilaclient
15:08:14 <gouthamr> CI failed on all of these patches, however, the failure isn't related to these patches but to the test infra
15:09:21 <gouthamr> we've an option to approve the final release to be made with code that's merged
15:09:56 <tbarron> " After the transition stable/train will be still open for bug fixes,
15:09:56 <tbarron> > but there won't be any official releases."
15:10:50 <gouthamr> +1
15:11:33 <gouthamr> do we think any of these open changes _must_ be in the release?
15:13:48 <gouthamr> okay, hearing no objections on the release then..
15:14:01 <tbarron> well I think distributions (red hat, inspur, etc.) will likely just cherry-pick any must have fixes anyways at this point
15:14:14 <gouthamr> +1
15:14:23 <tbarron> and upstream train users could do the same really
15:15:01 <carloss> I guess there is some of the changes in the list that could be useful to have...
15:15:32 <carloss> i.e. Fix manila OverQuota issue while managing shares
15:16:21 <gouthamr> certainly - still want to pursue these to closure
15:16:35 <tbarron> Yes, so we should still merge these.  The question is whether they need to be in a "release."
15:17:45 <tbarron> I was thinking it's OK if they are not, but I want to make sure that if there are reasons that we should hold up the final EM release and make sure they are in *first* that those come out in the conversation here.
15:18:39 <gouthamr> i've recheck'ed an old CI fix change: https://review.opendev.org/c/openstack/manila/+/773188
15:19:05 <tbarron> ah, so we might be able to merge these near term then
15:19:46 <gouthamr> if that fixes the issue, we can approve the blocked changes, but we don't need to hold up the release for this..
15:20:05 <carloss> +1
15:20:32 <gouthamr> alright
15:21:52 <gouthamr> #agreed ship stable/train with merged changes as of 13 May 21, follow up open stable/train branch changes by fixing up CI
15:22:34 <gouthamr> no further new topics for today
15:22:43 <gouthamr> #topic Bug Triage (vhari)
15:23:19 <gouthamr> vhari isn't here today but has put the untriaged list together for us - lemme do the round up
15:23:32 <gouthamr> #link https://etherpad.openstack.org/p/manila-bug-triage-pad-new (Bug Triage etherpad)
15:23:45 <gouthamr> #link https://bugs.launchpad.net/manila/+bug/1928241
15:23:45 <openstack> Launchpad bug 1928241 in OpenStack Shared File Systems Service (Manila) "NetApp driver DHSS mode fails to create share on a new added pool" [Undecided,New]
15:24:54 <gouthamr> this bug feels like deja vu
15:25:29 * vkmc sneaks in
15:26:17 <gouthamr> felipe_rodrigues: so can the driver check assigned aggregates on the vserver in the driver call to choose compatible backends?
15:26:17 * tbarron pretends he didn't notice
15:27:07 <felipe_rodrigues> yeah.. that would be the solution
15:27:09 * gouthamr slides aside in the last bench, shares a cookie with vkmc - what's the gossip in the hallway?
15:27:24 <vkmc> xD
15:27:53 <gouthamr> felipe_rodrigues: awesome, makes sense..
15:28:09 <gouthamr> lets triage this, will you be owning this bug?
15:28:24 <felipe_rodrigues> yeah
15:28:39 <felipe_rodrigues> I can do it
15:30:51 <gouthamr> ty, think this can be a "low" - you don't see new aggregates added (or the aggr search pattern change) very often
15:30:58 <gouthamr> but annoying when it happens
15:31:18 <carloss> +1
15:31:23 <gouthamr> felipe_rodrigues: target to xena-1 or 2?
15:31:39 <felipe_rodrigues> 2
15:31:59 <gouthamr> ty, done
15:32:09 <gouthamr> #link https://bugs.launchpad.net/manila/+bug/1928055
15:32:09 <openstack> Launchpad bug 1928055 in OpenStack Shared File Systems Service (Manila) "[DOC] Response code of share snapshot creation is incorrect" [Undecided,New]
15:32:46 <gouthamr> oh, good find
15:33:12 <gouthamr> low-hanging-fruit too
15:35:35 <gouthamr> #link https://opendev.org/openstack/manila/src/commit/896c88d6b7dd497ca56d4446e11cff060ea917d3/manila/api/v1/share_snapshots.py#L169-L170
15:36:11 <gouthamr> if anyone's looking to fix this up, let me know
15:37:07 <gouthamr> good first issue too, if you're onboarding someone
15:37:17 <gouthamr> carloss ^ :)
15:38:17 <carloss> yeah, for sure... I'd say it would be a good first patch for fabiooliveira :)
15:38:59 <fabiooliveira> :)
15:39:06 <carloss> I can work with him on this
15:39:07 <gouthamr> awesome - you just got volun-told fabiooliveira
15:39:26 <carloss> xD
15:40:07 <thefuture> XD
15:40:21 <gouthamr> carloss: i'll let you adjust the bug priority, milestone - fabiooliveira, you can claim this bug by clicking the pen next to "Unassigned" and clicking "Assign me"
15:40:39 <gouthamr> hey there paul from thefuture
15:40:52 <gouthamr> #link https://bugs.launchpad.net/manila/+bug/1927823
15:40:52 <openstack> Launchpad bug 1927823 in OpenStack Shared File Systems Service (Manila) "netapp driver should report home state to prevent scheduling on aggr not home" [Undecided,New]
15:41:24 <carloss> oops, I guess I don't have such permissions yet
15:41:35 <carloss> to set the milestones and such :)
15:42:16 <thefuture> Hi
15:42:34 <gouthamr> oh, i'll fix that up carloss
15:43:34 <carloss> ty :)
15:43:44 <gouthamr> carloss: can you try now?
15:43:46 * tbarron had been wanting to say something like 'kiwi_36 is the future' and now he can
15:44:13 <carloss> yes, now I'm able to
15:44:17 <carloss> ty gouthamr
15:44:22 <gouthamr> you're welcome
15:44:25 <tbarron> carloss++
15:45:04 <gouthamr> carloss: ^ regarding this bug - again something that shouldn't happen very often
15:45:43 <gouthamr> its possible, like carthaca suggests, that the driver removes the pool from the manila scheduler
15:45:53 <gouthamr> if it detects this state of maintenance
15:46:51 <carloss> > regarding this bug - again something that shouldn't happen very often
15:46:51 <carloss> +1
15:47:09 <carloss> yeah, that would be a good solution
15:48:46 <carloss> I can get someone to fix it, but I'd say priority is still low
15:48:58 <gouthamr> awesome ty carloss, carthaca
15:49:27 <gouthamr> carloss: set the milestone when you assign this
15:49:35 <gouthamr> #link https://bugs.launchpad.net/manila/+bug/1920937
15:49:35 <openstack> Launchpad bug 1920937 in OpenStack Shared File Systems Service (Manila) "Netapp non-disruptive migration of cifs shares export location broken" [Undecided,New]
15:49:44 <gouthamr> oh boy, lots of netapp bugs today
15:49:51 <carloss> xD
15:50:06 <gouthamr> carloss will start day drinking at this rate
15:51:13 <gouthamr> i'm surprised this wasn't caught in CI
15:52:12 <carloss> me too... but we have had bugs with CIFS shares in the past for replication too, because we were always trying to create them even when there was no need to
15:52:50 <dviroel> hum, there is no migration tests enabled with CIFS there, iirc
15:53:15 <gouthamr> carloss: so a similar fix may be needed here ..
15:53:32 <gouthamr> dviroel: not even API?
15:53:46 <gouthamr> scenario tests are still nfs-only
15:53:51 <dviroel> no
15:53:54 <gouthamr> (which we should fix some day)
15:54:00 <carloss> that's bad :/
15:54:20 <carloss> we need to test migration in our CI for CIFS as well
15:54:21 <dviroel> because upstream tempest tests don't consider netapp limitation on migrating within the same share server
15:54:23 <carloss> another action item :)
15:55:02 <dviroel> and the test can fail depending on the destination pool
15:55:21 <dviroel> but netapp has an internal migration test, that filters compatible pools
15:55:29 <dviroel> but isn't enable for CIFS
15:55:45 <dviroel> there is no CIFS + internal enabled, iirc
15:56:33 <gouthamr> i see
15:56:47 <carloss> you're correct, dviroel... just confirmed that in some reports
15:56:56 <gouthamr> dviroel: do you know if we have a tracker for "upstream tempest tests don't consider netapp limitation on migrating within the same share server"
15:57:32 <dviroel> don't know
15:57:37 <gouthamr> i vaguely recall something along these lines, but i thought the tests don't care about backends - they'll just find a compatible pool
15:58:12 <dviroel> yep, and migration doesn't have a compatibility check, like share server migration has
15:58:47 <dviroel> check-only
15:58:56 <gouthamr> ack
15:59:12 <gouthamr> okay, carloss i'll follow up with you about triaging this bug
15:59:20 <carloss> ack
15:59:33 <gouthamr> lets wrap up
15:59:37 <gouthamr> #topic Open Discussion
15:59:43 <gouthamr> ^ barely a minute
15:59:58 <gouthamr> but if you want to register something in the meeting minutes, now's your chance
16:00:35 <gouthamr> if not, Eid Mubarak to those celebrating! thanks for joining the meeting today!
16:00:49 <gouthamr> see you on #openstack-manila, and here next week
16:00:51 <gouthamr> #endmeeting