15:00:27 <gouthamr> #startmeeting manila
15:00:27 <opendevmeet> Meeting started Thu Jun 17 15:00:27 2021 UTC and is due to finish in 60 minutes.  The chair is gouthamr. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:27 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:27 <opendevmeet> The meeting name has been set to 'manila'
15:00:34 <carloss> o/
15:00:38 <dviroel> o/
15:00:44 <caiquemello> o/
15:00:56 <vhari> hi
15:01:01 <kafilat> o/
15:01:14 <gouthamr> courtesy ping: ganso vkmc tbarron felipe_rodrigues ecsantos vhari
15:01:23 <felipe_rodrigues> hi
15:01:28 <ecsantos> o/
15:01:45 <vkmc> o/
15:01:56 <gouthamr> hello folks!
15:02:20 <gouthamr> thank you for joining! here's our agenda for today: https://wiki.openstack.org/wiki/Manila/Meetings#Next_meeting
15:02:23 <gouthamr> lets get started
15:02:28 <gouthamr> #topic Announcements
15:02:31 <tbarron> hi
15:02:57 <fabiooliveira> o/
15:03:26 * gouthamr was hunting for a link
15:04:02 <gouthamr> wanted to give a shout out to vkmc archanaserver ashrod98 and diablo_rojo for today's openinfra.live talk
15:04:21 <gouthamr> if anyone's got a link to the live stream that just ended, please add it here :)
15:04:31 <vhari> How to Start Contributing Upstream to OpenInfra https://www.youtube.com/watch?v=4kGtM4J_hjM 
15:04:38 <vhari> :)
15:04:45 <gouthamr> vhari++
15:05:04 <gouthamr> #link https://www.youtube.com/watch?v=4kGtM4J_hjM  (How to Start Contributing Upstream to OpenInfra)
15:05:40 <vkmc> :D
15:05:44 <vhari> vkmc++
15:05:45 <gouthamr> if you didn't get a chance to attend, please check it out; our community was well represented! :)
15:05:48 <vkmc> thanks gouthamr++
15:06:59 <gouthamr> there's a lot to take away from that talk..
15:07:33 <gouthamr> on our regular announcements :), we're 16 weeks away from the Xena release
15:07:41 <gouthamr> #link https://releases.openstack.org/xena/schedule.html (Xena Schedule)
15:07:51 <gouthamr> Next week is our spec submission deadline
15:08:18 <gouthamr> if you're thinking about writing a spec/lite-spec, this is the last call
15:09:13 <gouthamr> that's all i had for announcements today
15:09:16 <gouthamr> does anyone else have any?
15:10:45 <gouthamr> thank you all for participating in the bug squash last week!
15:11:23 <gouthamr> and for vhari, vkmc for the efforts in organizing it. I definitely enjoyed our very first collab review for the release
15:11:24 <vhari> gouthamr, we had a great turnout  \o/
15:11:33 <vhari> thanks everyone!
15:12:14 <gouthamr> we'll discuss some untriaged bugs later in this meeting - and we must be able to share some statistics/summary with you next week
15:12:53 <gouthamr> lets move down our agenda
15:13:00 <gouthamr> #topic Manila UI stable CI problems
15:13:33 <gouthamr> we had users report a peculiar problem with manila-ui downstream, that wasn't easy to reproduce
15:13:59 <gouthamr> the issue is described in https://bugs.launchpad.net/manila-ui/+bug/1931641
15:14:09 <gouthamr> #link https://bugs.launchpad.net/manila-ui/+bug/1931641 (Unable to select share networks with share types that have a hyphen in their name)
15:14:36 <gouthamr> #link https://review.opendev.org/c/openstack/manila-ui/+/796384 (Fix parsing names in switched fields)
15:15:26 <gouthamr> the fix is really a workaround
15:15:47 <gouthamr> we've rarely back-ported fixes to older stable branches in manila-ui
15:16:24 <gouthamr> but this is one of those critical bugs for end users that needs to be addressed all the way back to stable/train
15:17:08 <gouthamr> so, looking at the backports, i ran into a familiar issue on the stable branches for manila-ui
15:17:48 <gouthamr> the lower-constraints job fails
15:18:20 <gouthamr> the failure is legitimate; some of the lower bounds of the requirements we claim aren't really co-installable
15:19:08 <gouthamr> we've approached this by painstakingly fixing them up on stable branches for the manila repo
15:19:38 <gouthamr> however, i'm not convinced if the effort is worth it for anyone
15:20:34 <gouthamr> iirc we fixed requirement and lower-constraints files for stable branches of manila and python-manilaclient repos
15:21:31 <gouthamr> and disap fixed the development branch of manila-ui earlier this year: https://review.opendev.org/c/openstack/manila-ui/+/767397
15:22:57 <gouthamr> post these, we had a discussion as a community to verify who cares about lower bounds testing
15:23:15 <gouthamr> this discussion was summarized here
15:23:23 <gouthamr> #link http://lists.openstack.org/pipermail/openstack-discuss/2021-March/021204.html ([all][tc] Dropping lower-constraints testing from all projects)
15:24:14 <gouthamr> since we have the job working on the development branches in all the repos we maintain, i don't want to discuss dropping the job across the repos
15:24:29 <gouthamr> i wanted to check however, if we're okay dropping them in manila-ui
15:25:06 <gouthamr> the main reason is that backports here have been rare
15:26:05 <gouthamr> and second is the learning we have from the community-wide discussion that lower-constraints testing the way we do is less useful to consumers
15:27:40 <gouthamr> we could also take a bigger blanket discussion of dropping it across all stable branches - something that some other project teams have done
15:28:05 <tbarron> fwiw I agree with this.  We need to focus on fixing test infra issues where fixing test failures makes our core product better and
15:28:33 <tbarron> I don't see gain commensarate with maintenance effort for this on the stable branches
15:29:35 <gouthamr> ++ it makes lesser sense as we go back to the really old branches we are talking about
15:29:51 <vkmc> ++ agree too
15:30:05 <carloss> ++
15:30:43 <gouthamr> does it make sense to vote on this and drop the jobs across all stable branches?
15:33:06 <gouthamr> #startvote Should we drop lower-constraints testing on all stable branches of manila repos? Yes, No
15:33:06 <opendevmeet> Begin voting on: Should we drop lower-constraints testing on all stable branches of manila repos? Valid vote options are Yes, No.
15:33:06 <opendevmeet> Vote using '#vote OPTION'. Only your last vote counts.
15:33:25 <gouthamr> ^ please go ahead :)
15:33:27 <tbarron> #vote yes
15:33:30 <carloss> #vote Yes
15:33:36 <tbarron> #vote yes
15:33:36 <opendevmeet> tbarron: yes  is not a valid option. Valid options are Yes, No.
15:33:38 <tbarron> testing
15:33:43 <dviroel> #vote Yes
15:33:48 <ecsantos> #vote Yes
15:33:53 <tbarron> #vote Yes
15:33:58 <vkmc> #vote yes
15:34:26 <gouthamr> #vote Yes
15:34:33 <fabiooliveira> #vote Yes
15:34:56 <caiquemello> #vote Yes
15:35:45 <gouthamr> waiting another minute
15:37:03 <gouthamr> #endvote
15:37:04 <opendevmeet> Voted on "Should we drop lower-constraints testing on all stable branches of manila repos?" Results are
15:37:04 <opendevmeet> Yes (8): dviroel, caiquemello, gouthamr, tbarron, carloss, fabiooliveira, ecsantos, vkmc
15:37:22 <tbarron> good, it only let me vote once
15:37:32 <gouthamr> awesome, thanks everyone; i've patches ready for train--->victoria on manila-ui
15:37:44 <gouthamr> #link https://review.opendev.org/q/topic:%22drop-lower-constraints-testing%22+(status:open%20OR%20status:merged)
15:38:09 <gouthamr> #agreed we're dropping lower-constraints testing on all stable branches across manila repositories
15:38:37 <gouthamr> if you see missing branches, let me know, or go ahead and submit a fix if you like
15:39:12 <gouthamr> code deletions are fun
15:39:19 <vkmc> :D
15:40:12 <gouthamr> cool, anything else regarding $topic?
15:40:29 <gouthamr> #topic Reviews needing attention
15:40:34 <gouthamr> #link https://etherpad.opendev.org/p/manila-xena-review-focus
15:40:53 <gouthamr> it looks like everything on here is still getting worked on, or waiting for review
15:41:08 <gouthamr> if there are any more, please add them to the list
15:41:38 <gouthamr> reviewers (telling myself as well), please take a look at this list and lets wrap these up
15:42:06 <gouthamr> lets move on to bug triage since we know we left some for this meeting
15:42:11 <gouthamr> #topic Bugs (vhari)
15:42:21 <gouthamr> o/ vhari - the floor is yours
15:42:44 <vhari> gouthamr, there were no new bugs in 2 weeks :D
15:42:51 <gouthamr> \m/
15:42:53 <vkmc> :D
15:43:01 <gouthamr> our work is done
15:43:10 <vhari> so, we can pick up where we left off at bug squash
15:43:12 * gouthamr not so fast
15:43:42 <vhari> we can take a look at #link https://bugs.launchpad.net/manila/+bug/1881865
15:44:27 <vhari> and pace through the list as time permits
15:44:33 <gouthamr> ack
15:44:33 <gouthamr> #link https://bugs.launchpad.net/manila/+bug/1881865
15:45:14 * gouthamr rebases the fix
15:45:44 <gouthamr> carloss: o/ this fix is not exercisable in isolation, no?
15:46:30 <gouthamr> so i kinda see haixin's point of combining the snapshot querying into this
15:47:00 <carloss> yeah
15:47:31 <carloss> me too...
15:47:47 <carloss> I gues I even mentioned breaking this change into two in the past
15:48:05 <gouthamr> haha, okay this is ripe for re-review then
15:48:09 <carloss> but haixin's made his point explaining that it would be nice to have both in a single patch
15:48:27 <carloss> yep :)
15:49:25 <gouthamr> awesome, thanks for bubbling this up vhari
15:49:33 <gouthamr> we'll get this one reviewed and merged
15:49:50 <vhari> cool gouthamr
15:49:57 <vhari> time for one more
15:49:59 <vhari> #link https://bugs.launchpad.net/manila/+bug/1818569
15:50:51 <vhari> proposed fix merged .. can be close if no more thought on it
15:51:15 <vhari> #link https://bugs.launchpad.net/manila/+bug/1818569
15:52:46 <gouthamr> hmm, i recall this bug
15:52:59 <gouthamr> but don't recall discussing at a ptg per the bug report
15:54:45 <gouthamr> the problem here is that the access rule de-duplication code doesn't seem to work with high concurrency
15:55:43 <tbarron> The reason I did that experiment was that we saw the issue intermittently in CI
15:55:44 <gouthamr> i think the duplicate rules get past the check happening in the database in parallel and avoid each other - which i can see happening, there's nothing preventing that code to run in parallel
15:55:49 <gouthamr> oh
15:56:02 <tbarron> Dunno if we still do much though
15:56:32 <gouthamr> not latelyt
15:56:41 <tbarron> It may not be a likely customer scenario
15:57:06 <gouthamr> but, if its easily reproducible with the script you have in the bug report - its a corner case that we ought to fix
15:57:35 <tbarron> Yeah, it's worth fixing, just questioning why I set it to Medium
15:58:47 <gouthamr> ack, we can set to Low, anyone looking for a good concurrency bug to fix?
15:59:37 <kiwi_36> I can pick it up gouthamr
15:59:46 <gouthamr> o/ kiwi_36
15:59:56 <gouthamr> ++ awesome, please grab it
16:00:09 <kiwi_36> \o
16:00:24 <gouthamr> alright, we're at the top of the hour
16:00:31 <gouthamr> no time for open discussion today
16:00:43 <gouthamr> please hop on over to #openstack-manila if you want to chat about anything else
16:00:47 <gouthamr> thank you all for attending!
16:00:51 <gouthamr> stay safe
16:00:54 <gouthamr> #endmeeting