15:01:41 <gouthamr> #startmeeting manila
15:01:41 <opendevmeet> Meeting started Thu Dec 16 15:01:41 2021 UTC and is due to finish in 60 minutes.  The chair is gouthamr. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:41 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:41 <opendevmeet> The meeting name has been set to 'manila'
15:01:45 <carloss> o/
15:01:46 <felipe_rodrigues> o/
15:01:50 <fabiooliveira> o/
15:01:51 <andrebeltrami[m]> o/
15:01:55 <tbarron> hi
15:01:56 <caiquemello[m]> o/
15:01:59 <kafilat> o/
15:01:59 <archanaserver> o/
15:02:00 <sfernand> hi
15:02:06 <nahimsouza[m]> o/
15:02:09 <angiolucci> o/
15:02:29 <gouthamr> courtesy ping: ganso vkmc dviroel ecsantos vhari
15:02:33 <vhari> hi
15:02:57 <gouthamr> hello o/ thanks for joining, here's our agenda for today: https://wiki.openstack.org/wiki/Manila/Meetings#Next_meeting
15:02:59 <LeoCampelo> o/
15:03:28 <gouthamr> lets begin with
15:03:30 <gouthamr> #topic Announcements
15:03:38 <vkmc> o/
15:03:45 <gouthamr> Manila Specifications Freeze is this week
15:04:02 <ecsantos[m]> o/
15:04:08 <gouthamr> Yoga M-2 is on Jan 07
15:04:14 <gouthamr> #link https://releases.openstack.org/yoga/schedule.html
15:04:29 <simondodsley> o/
15:04:35 <gouthamr> as it does this time of the year, deadlines are creeping up on us :)
15:05:27 <gouthamr> as we discussed last week, please have your specs posted, but i'm not looking at this weekend as a merge deadline due to the holidays...
15:06:22 <gouthamr> its going to be hard to find review bandwidth these need, so we'll try to get these merged asap
15:06:32 <sfernand> yep, felipe_rodrigues  made some changes to gansos spec.. I will sent him a message asking for reviews
15:06:47 <gouthamr> great, thank you sfernand
15:07:25 <gouthamr> no other news from my end, we may be able to squeeze one more meeting in 2021
15:07:44 <gouthamr> but lets talk about that during open discussion today
15:07:57 <gouthamr> anyone else got any announcements to share?
15:08:48 <gouthamr> lets move down our light agenda then :)
15:08:53 <gouthamr> #topic Reviews needing attention
15:08:57 <gouthamr> #link https://etherpad.opendev.org/p/manila-yoga-review-focus
15:09:57 <gouthamr> carloss and i have combed through this list and we triaged some languishing reviews
15:10:27 <gouthamr> carloss: do you want to bring up the specific ones we need help with?
15:10:42 <carloss> yes, there are some we could bring up during this meeting :D
15:11:24 <carloss> 821162: remove usage of six library in driver layer and the corresponding test | https://review.opendev.org/c/openstack/manila/+/821162
15:11:29 <carloss> ^ is the first of them
15:11:55 <carloss> this is part of the effort to remove six from our code base
15:12:11 <carloss> this is the change that addresses that removal from basically all share drivers :D
15:12:40 <carloss> so we'd like to call out the attention of all driver maintainers in this call to please take a look on this change and ensure that their CI is voting green
15:13:21 <carloss> this isn't supposed to break anything, but it is good to ensure :)
15:13:23 <felipe_rodrigues> I added myself to reviewrs list
15:13:28 <gouthamr> ++
15:14:06 <carloss> felipe_rodrigues++ :)
15:14:42 <carloss> and there's another one we could use some attention/tests with NetApp backends :)
15:15:05 <carloss> 804578: Add "share-network" option for replica create API. | https://review.opendev.org/c/openstack/manila/+/804578
15:15:40 <sfernand> I can take that
15:15:40 <carloss> there has been some discussion around this and we'd like to have activity on these changes again
15:15:49 <carloss> awesome, thanks sfernand
15:16:31 <carloss> the reason we ask NetAppers is because it still is the only third party driver using replication on DHSS=True and that could be impacted by this change
15:16:59 <carloss> so the ones I'd like to call the attention to were these two :D
15:17:07 <carloss> thanks gouthamr
15:17:43 <gouthamr> good stuff carloss..
15:18:22 <gouthamr> on the others in the pad, you may have seen a poke either on the review or on irc to get things moving
15:19:15 <gouthamr> if you've signed up to (or have been voluntold to :D) review anything, please finish up your review and update the pad
15:21:38 <gouthamr> since the release train never stops, these specifications could use your eyes and brain matter: https://review.opendev.org/q/project:openstack/manila-specs+status:open :)
15:22:15 <gouthamr> any other patches to highlight here?
15:23:16 <gouthamr> #topic Bug Triage (vhari)
15:23:29 <vhari> gouthamr, o/
15:23:34 <gouthamr> o/ vhari
15:23:40 <vhari> let's dive in
15:23:49 <vhari> #link https://bugs.launchpad.net/manila/+bug/1954354
15:24:11 <vhari> looking for minor triage on this new bug
15:24:41 <gouthamr> deja vu
15:26:03 <gouthamr> we need a couple of things from the reporter: the openstack release they're running, and the version of ceph
15:27:10 <gouthamr> the error looks similar to
15:27:11 <gouthamr> https://bugs.launchpad.net/manila/+bug/1838936
15:27:49 * dviroel|rover o/
15:28:06 * dviroel|rover is in another meeting
15:28:33 <gouthamr> the last comment over there captures why this happens: https://bugs.launchpad.net/manila/+bug/1838936/comments/12
15:29:07 <gouthamr> let me ask these questions on the bug, vhari
15:29:20 <vhari> gouthamr, will do
15:29:46 <vhari> next up
15:29:47 <vhari> #link https://bugs.launchpad.net/manila/+bug/1916102
15:30:09 <gouthamr> ah an unassigned bug from our bugsquash
15:30:11 <vhari> this is a bugsquash bug .. looking for any updates from NEU
15:30:23 <vhari> meeting
15:31:00 <gouthamr> yes, the student working on this got busy
15:31:59 <gouthamr> the fix is super simple though, it's dropping the first part of this condition here
15:32:01 <gouthamr> https://github.com/openstack/manila/blob/c29fa635a1cd722b02f08c5cd7481ec647364a2c/manila/api/v1/security_service.py#L110
15:33:07 <gouthamr> anyone looking to take this up? :)
15:34:06 <carloss> 🦗
15:34:06 <gouthamr> vhari: i'll grab this and post a patch up
15:34:15 <vhari> gouthamr++
15:34:26 <vhari> gouthamr, so that's a wrap for bugs today
15:34:30 <carloss> gouthamr++
15:34:42 <gouthamr> thank you vhari :)
15:35:01 <vhari> gouthamr, yw
15:35:05 <vhari> :)
15:35:15 <gouthamr> #topic Open Discussion
15:36:31 <gouthamr> our next scheduled meeting is on 23rd Dec
15:37:00 <gouthamr> i'd like to round up on initial spec reviews as much as possible
15:37:23 <gouthamr> however, folks would likely be off with it being this close to the end of the year
15:39:12 <gouthamr> any thoughts on keeping the next week's irc meeting as is
15:40:01 <gouthamr> we do have a protocol of making no decisions when there's no quorum
15:40:57 <carloss> I think we could check how many of us would be around
15:41:03 <carloss> and try to antecipate the quorum :)
15:41:20 <fabiooliveira> ++
15:41:31 <felipe_rodrigues> ++
15:41:57 <andrebeltrami[m]> ++
15:42:15 <gouthamr> does the ++ indicate that you're around? :)
15:42:37 <andrebeltrami[m]> yes in my case kk
15:42:37 <felipe_rodrigues> ++ = good idea carloss
15:42:41 <felipe_rodrigues> my case
15:42:49 <fabiooliveira> no, just that I support the idea
15:43:07 <gouthamr> lol fabiooliveira
15:43:11 <vhari> :)
15:43:12 <sfernand> hahahahha!
15:43:27 <sfernand> kk == haha
15:43:59 <gouthamr> "yeah sure you guys have the meeting, i'm going to be busy binging on christmas movies" :'D
15:44:03 <gouthamr> i would plan on canceling the meeting on 30th though - which is probably a shutdown time for many
15:44:09 <gouthamr> any objections there?
15:44:29 <felipe_rodrigues> no, from my part
15:44:34 <carloss> nope gouthamr :)
15:44:37 <vhari> ++ on 30th meeting
15:45:06 <gouthamr> alright, i'll send out a notification on the ML
15:45:19 <vhari> ++ on  Christmas movies" :'D
15:45:32 <gouthamr> #agreed we'll keep the IRC meeting on 23rd as usual, but cancel the one on 30th Dec 2021
15:45:40 <felipe_rodrigues> ++
15:46:10 * fabiooliveira 👀
15:46:15 * gouthamr hums 🎵 its the most wonderful time of the year
15:47:10 <gouthamr> anything else for today? :)
15:48:21 <gouthamr> alright, lets wrap this up
15:48:25 <gouthamr> #link https://www.youtube.com/watch?v=aAkMkVFwAoo
15:48:31 <gouthamr> thanks for joining everyone
15:48:35 <vhari> anyone interested can watch Santa's journey here :) https://www.noradsanta.org/en/
15:48:46 <carloss> thanks gouthamr :)
15:48:48 <gouthamr> ooh
15:49:18 <gouthamr> see you here next week, if not, in 2022!
15:49:25 <gouthamr> #endmeeting