15:00:13 <carloss> #startmeeting manila
15:00:13 <opendevmeet> Meeting started Thu Apr 28 15:00:13 2022 UTC and is due to finish in 60 minutes.  The chair is carloss. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:13 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:13 <opendevmeet> The meeting name has been set to 'manila'
15:00:28 <andrebeltrami[m]> o/
15:00:39 <fabiooliveira> o/
15:00:40 <haixin> o/
15:00:40 <carloss> courtesy ping: ganso vkmc dviroel tbarron felipe_rodrigues ecsantos vhari fabiooliveira gouthamr
15:00:47 <maaritamm> o/
15:00:48 <archanaserver> o/
15:00:51 <felipe_rodrigues> o/
15:00:56 <ecsantos[m]> o/
15:00:57 <ashrodri> o/
15:00:58 <lucasmoliveira059> o/
15:00:58 <vhari> hi
15:01:05 <caiquemello[m]> hi
15:01:11 <gouthamr> o.
15:01:12 <gouthamr> o/
15:01:18 <LeoCampelo> o/
15:01:37 <dviroel|rover> o/
15:02:06 <carloss> o/ hi everyone!
15:02:10 <carloss> it's good to see you here :)
15:02:22 <carloss> first, thank you gouthamr for running last week's meeting :D
15:02:39 <carloss> good turnout - let's get started with today's agenda:
15:02:39 <gouthamr> \o/
15:02:44 <carloss> #link https://wiki.openstack.org/wiki/Manila/Meetings#Next_meeting
15:03:18 <carloss> #topic Announcements
15:03:25 <carloss> Next week is the Z-1 bugsquash
15:03:38 <carloss> #link https://releases.openstack.org/zed/schedule.html
15:04:15 <carloss> as we agreed over the PTG, we would have our first bugsquash of the year over Z-1 milestone
15:04:28 <carloss> time is flying and Z1 is next week!
15:04:55 <gouthamr> you're scaring us
15:05:02 <gouthamr> Z1 is May 20, no? :)
15:05:16 <carloss> ooh yes :D
15:05:29 <vkmc> :'D
15:05:31 <andrebeltrami[m]> hahhaa
15:05:34 <gouthamr> but we get your point - pretend its next week :P
15:05:38 <vkmc> so close
15:05:42 <carloss> fixing my statement: we agreed bugsquash would be close to Z1
15:05:43 <carloss> xD
15:06:03 <vhari> :D
15:06:09 <carloss> sorry about that
15:06:14 <carloss> haha
15:06:44 <carloss> one of the main things we could do over this bugsquash is to look over the stale bugs and see if they are still relevant
15:07:02 <carloss> and if they are not relevant anymore, we could mark them as expired due to inactivity
15:07:07 <carloss> or continue working on it
15:07:28 <carloss> this leads me to another point and also brings a question to my head:
15:07:51 <carloss> I think some bugs might be removed from the preliminary list (which I'll be sharing in a bit)
15:08:12 <carloss> they might be removed because they might be marked as incomplete
15:08:34 <vhari> carloss, ack the list is wip atm
15:08:36 <carloss> in that case, we could use a regular list of bugs targeted for z1 and try to make progress on them as well
15:08:55 <vhari> carloss++
15:09:10 <carloss> what do you think?
15:09:34 <carloss> in that way, we can have bugs for all of us even if we don't work in a bug that is not in the stale bug list :)
15:11:25 <gouthamr> ack; would that list be the ones we've already targeted to z1?
15:11:27 <vkmc> ++
15:11:28 <gouthamr> i like this re-triage on stale bugs
15:11:37 <gouthamr> that we can do collectively
15:12:04 <carloss> yes gouthamr
15:12:28 <carloss> for Z-1, I got the list form launchpad and added it here:
15:12:31 <carloss> #link https://ethercalc.openstack.org/ffer3l7pnx2u
15:12:43 <carloss> for z-1 targeted bugs
15:13:05 * gouthamr prays to the ethercalc gods on the sidelines
15:13:40 <carloss> haha, me too
15:14:33 <carloss> and we have a preliminary list for stale bugs here:
15:14:33 <carloss> #link https://ethercalc.openstack.org/1nesczgjufb9
15:14:50 <carloss> it's still a wip - and thanks vhari for putting the list together  :)
15:15:27 <vhari> yw carloss :)
15:16:53 <carloss> good - so we can stick to this then... we can go over the list of stale bugs and work on the ones we will be keeping
15:17:06 <carloss> but also use the z-1 bug  and try to close some bugs by z1 :)
15:18:00 <carloss> on meeting dates I was thinking of something like:
15:18:00 <carloss> Kick off on Monday at 15:00 - 16:00 UTC (May 2nd)
15:18:00 <carloss> Mid term check on Thursday at 15:00 - 16:00 UTC (May 5th Manila meeting slot)
15:18:00 <carloss> Wrap up on Friday May 6th at 15:00 - 15:30 UTC
15:18:00 <carloss> Do you agree with the proposed time slots?
15:18:53 <felipe_rodrigues> agree
15:18:55 <fabiooliveira> yes
15:19:14 <gouthamr> ++
15:19:53 <carloss> great!
15:20:01 <carloss> #Action carloss will send an email to the ML communicating the decisions we took
15:20:09 <carloss> that's all I had for announcements
15:20:23 <carloss> anyone else have an announcement?
15:20:32 <andrebeltrami[m]> o/
15:20:43 <carloss> please go ahead andrebeltrami[m] :)
15:20:54 <andrebeltrami[m]> It's my last manila meeting as NetApper (again!). I would like to thanks the manila community and also my NetApp teammates for this time together again. Also, we are close to have the zuulv3 live o////. Let's get Netapp CI green and healthy, caiquemello++ and ecsantos++!! I see you around :D
15:21:09 <gouthamr> i feel he had that memorized
15:21:41 <andrebeltrami[m]> to not tears on the keyboard during the meeting
15:21:42 <andrebeltrami[m]> hahaha
15:21:47 <felipe_rodrigues> thank you andrebeltrami, you have helped us a lot!
15:21:53 <gouthamr> andrebeltrami[m]: welp, sad to see you leave :(
15:22:06 * dviroel|rover deja vu
15:22:14 * carloss deja vu
15:22:31 <carloss> sad to see you leave again andrebeltrami[m]
15:22:40 <carloss> I wish you all the best in your journey
15:22:49 <ashrodri> andrebeltrami[m]++
15:23:04 <carloss> thank you for your participation
15:23:08 <caiquemello[m]> Thank you andrebeltrami !!!
15:23:12 <gouthamr> andrebeltrami[m]: on one hand, it's awesome you came back to work on zuulv3, maybe you'll come back when zuul grows older
15:23:23 <gouthamr> andrebeltrami[m]: :P  it was great to have you back, thank you and all the best!
15:23:28 <felipe_rodrigues> dont be sad, he will be back soon 😜
15:23:47 <carloss> another deja vu on this meeting felipe_rodrigues? :)
15:23:56 <felipe_rodrigues> maybe hahaha
15:23:59 <caiquemello[m]> hahaha
15:24:02 <carloss> :)
15:24:06 <andrebeltrami[m]> ty all, for sure gouthamr ! I'll try to stay close. I love this community haha
15:24:27 <carloss> yes, please keep in touch andrebeltrami[m] :)
15:24:44 <vhari> andrebeltrami[m], best of luck, see you around :)
15:25:00 <carloss> alright, anyone else with an announcement?
15:26:02 * carloss hopes there are no other announcements like andrebeltrami[m]'s :/
15:26:10 * carloss will take silence as a no
15:26:20 <carloss> #topic OpenStackSDK - where are we?
15:26:28 <carloss> gouthamr/ashrodri - floor is yours!
15:27:00 <gouthamr> thanks carloss; we pushed this in view of more audience last week
15:27:23 <gouthamr> ashrodri: do we have an updated taiga board to share?
15:27:37 <ashrodri> yes sir!  https://tree.taiga.io/project/ashrod98-openstacksdk-manila-support/kanban
15:28:01 <ashrodri> Ive updated the "ready for review" column and the "in progress" columns to include links per card
15:28:27 <ashrodri> I still have to double check my old spec and the "new" column to make sure we included all the resources/actions
15:28:55 <ashrodri> but for the most part it is up to date. we have 8 patches ready for review and 6 in progress
15:29:05 <gouthamr> that's great! :)
15:29:19 <gouthamr> ashrodri++ thanks for painstakingly tracking this down
15:30:01 <gouthamr> we probably need some more stories in the "new" column to capture API changes from the last couple of releases
15:30:40 <gouthamr> but, the in-review and in-progress patches can use some help
15:31:25 * fabiooliveira 👀
15:31:45 <gouthamr> if you have some bandwidth to explore this project, please review these open patches.. and you could take them over as well
15:32:21 <ashrodri> ill probably go down the list of in-review patches to make sure there arent any merge conflicts and refresh the zuul logs later today so thell be ready for you :)
15:32:33 <gouthamr> ++
15:32:39 <carloss> ++ :)
15:33:12 <gouthamr> so we could do another status check in a few weeks and see where we are in reducing this backlog
15:34:18 <carloss> sounds like a good idea gouthamr
15:34:21 <gouthamr> let ashrodri/me know if you have any questions; the two of us started an activity to go over one patch per week :) it's fun
15:35:22 <carloss> awesome, ashrodri++, gouthamr++ :)
15:36:06 <gouthamr> that's all i had -- anything else on $topic ashrodri?
15:36:18 <ashrodri> nothing on my end thanks
15:36:37 <carloss> thank you!
15:36:44 <carloss> on to the next topic...
15:36:51 <carloss> #topic Secure RBAC testing tracker and call for help
15:36:57 <carloss> vhari, floor is yours :D
15:37:03 <vhari> ty carloss
15:37:18 <vhari> #link https://docs.google.com/spreadsheets/d/1lzZYJF1HSuI9WZgAQeTWpBY2sByh3vXAG57KviWgbf0/edit?usp=sharing
15:37:52 <vhari> we created a  list of v2 APIs to work off of for the upcoming RBAC automation community effort
15:38:47 <gouthamr> vhari++
15:38:48 <vhari> as you can see tests can be developed and tracked according to scope and roles
15:39:05 * gouthamr inspiring how organized ashrodri and vhari are with these trackers
15:39:17 <vhari> :)
15:39:49 <vhari> this is a big effort and anyone interested if welcome to contribute
15:40:09 <vhari> lkuchlan, worked on the intial patches and we started to update the list
15:40:18 <vhari> to avoid dup effort
15:40:48 <vhari> carloss and us  talked about a refresher meeting
15:41:06 <vhari> to get the effort off the ground ..
15:41:29 <vhari> any thoughts on this?
15:41:57 <gouthamr> ++ i'm probably voluntelling here - but this is an effort for which vhari/lkuchlan are looking to mentor 1x1, and pair-program as well -- so if you're looking to flex your tempest muscles, this is a good opportunity :)
15:42:26 <vhari> gouthamr++   :)
15:43:06 <vhari> the list is self managed and easy to use ..
15:44:18 <vhari> if you like to work on an API or part of it .. you can fill in the appropriate section
15:45:30 <carloss> this is indeed a good opportunity to deep dive on tempest
15:46:01 <carloss> thank you for bringing this up
15:46:06 <vhari> carloss, that's all we wanted to share with the community about this
15:46:16 <vhari> wy
15:46:26 <carloss> awesome vhari! thanks :D
15:46:53 <carloss> on to the next topic:
15:47:01 <carloss> #topic Review Focus
15:47:16 <carloss> #link https://etherpad.opendev.org/p/manila-zorilla-review-focus (Review Focus Etherpad)
15:47:24 <carloss> so we do have our review focus etherpad now
15:47:53 <carloss> and I added the spec for the oversubscription enhancements that haixin proposed :)
15:48:36 <carloss> if you would like to get some attention from reviewers in a change you have
15:48:44 <carloss> please add the change to the review focus etherpad
15:49:24 <carloss> we'll be constantly looking at it over the meetings... I also intend to keep the etherpad updated with the current status of the changes
15:50:28 <carloss> time is a bit tight today, so let's go to the next topic
15:50:33 <carloss> #topic Bug Triage (vhari)
15:50:41 <carloss> #link https://etherpad.openstack.org/p/manila-bug-triage-pad-new (Bug Triage etherpad)
15:51:18 <vhari> ty carloss
15:51:28 <vhari> #link https://bugs.launchpad.net/manila/+bug/1970661
15:51:59 <vhari> looking for minor triage for this
15:52:44 <gouthamr> ah yes, this came from a downstream triage; curiously the "suppress_errors_in_cleanup" flag is enabled for a bunch of jobs in manila-tempest-plugin
15:53:02 <gouthamr> i popped it off the cephfs-native job, and it caught this bug
15:53:55 <gouthamr> the test attempts to create an access rule with ceph client user "admin" --- the driver prevents this attempt since "admin" is a reserved ceph user (and not created via manila)
15:54:51 <gouthamr> so the test passes.. but, as part of teardown, we want to delete the share the test created, and prior to deletion, manila asks the driver to delete all rules on the share
15:55:14 <gouthamr> the rule for "admin" was never applied, the driver fails
15:55:33 <gouthamr> our expectation is that deny_access doesn't fail if the rule doesn't exist
15:56:32 <gouthamr> i mean, the driver could log a warning but it must allow manila to cleanup the rule
15:56:59 <gouthamr> there's no workaround for this
15:57:15 <gouthamr> and i can't delete a share with a "bad" rule on cephfs
15:57:19 <gouthamr> so its pretty annoying
15:57:25 <carloss> > i mean, the driver could log a warning but it must allow manila to cleanup the rule
15:57:25 <carloss> ++
15:58:31 <carloss> did you caught this only on tempest or managed to reproduce it manually as well gouthamr?
15:58:59 <gouthamr> actually on tempest, but the scenario is surely reproducible manually
15:59:21 <carloss> cool
15:59:25 <gouthamr> create cephfs share, allow-access to "admin", access rule transitions to "error", attempt to delete share, fails
16:00:14 <gouthamr> grr, time check
16:00:34 <gouthamr> i think a medium would work for this bug (low-hanging-fruit too)
16:00:41 <carloss> yes, a medium would work
16:00:46 <carloss> ++
16:00:53 <vhari> ++
16:01:37 <carloss> let's finish the assignee and finish triaging for this in #openstack-manila :D
16:01:45 <carloss> thank you all for attending folks
16:01:53 <carloss> see you in #openstack-manila
16:02:03 <carloss> #endmeeting