15:00:48 <gouthamr> #startmeeting manila
15:00:48 <opendevmeet> Meeting started Thu Apr 24 15:00:48 2025 UTC and is due to finish in 60 minutes.  The chair is gouthamr. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:48 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:48 <opendevmeet> The meeting name has been set to 'manila'
15:01:26 <Sai> o/
15:01:31 <gouthamr> hello everyone
15:01:47 <gouthamr> courtesy ping: dviroel carthaca msaravan pulluri ashrodri
15:01:50 <zgoggin> o/
15:01:54 <carthaca> hi
15:02:49 <gouthamr> Sai: seems like you have a new nick, can you update the ping list here: https://wiki.openstack.org/wiki/Manila/Meetings
15:03:02 <gouthamr> lets get started
15:03:05 <gouthamr> #topic Announcements
15:03:16 <Sai> Sure Goutham, thank you.
15:03:42 <gireesh> hi
15:03:49 <gouthamr> firstly, welcome back to this meeting from a short hiatus.. we did have an intense PTG week a couple of weeks ago
15:04:04 <gouthamr> carloss summarized our discussions to this mailing list post:
15:04:10 <gouthamr> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/message/LZYVJKTELNOHGN6CB4SXV33H7CHM4SMN/ (Manila Flamingo PTG Summary)
15:04:48 <gouthamr> you'll find the rest of the PTG summaries on the mailing list, or in this handy blog post diablo_rojo's created:
15:04:52 <gouthamr> #link https://www.openstack.org/blog/openstack-at-the-april-2025-ptg-all-things-epoxy-flamingo/ (All PTG Summaries)
15:05:27 <kpdev> hi
15:05:30 <gouthamr> if you were looking to catch up to recordings of the Manila PTG sessions, they've been uploaded here:
15:05:41 <gouthamr> #link https://www.youtube.com/watch?v=MLXkBRhViS0&list=PLnpzT0InFrqADxXi_dtPqfWLtyXDUdDvq (YouTube Playlist of the Flamingo PTG)
15:06:32 <gouthamr> please feel free to respond to the ML to discuss anything specific, and ofcourse this is a good venue too
15:07:39 <gouthamr> we've started working on the action items we highlighted..
15:08:51 <gouthamr> there are probably a couple of AIs there that don't yet have owners... we'll discuss these in future meetings, but, if you're reading this and have some bandwidth to spare, i'd love to get help with these unclaimed AIs
15:10:07 <gouthamr> close on the heels of the PTG, carloss proposed manila specific deadlines to the Flamingo release schedule:
15:10:09 <gouthamr> #link https://releases.openstack.org/flamingo/schedule.html (Flamingo Schedule with Manila specific deadlines)
15:11:03 <gouthamr> we're currently 23 weeks away from release week, and the significant upcoming deadlines are:
15:11:39 <gouthamr> May 12 - May 16: Flamingo milestone 1
15:11:39 <gouthamr> this is a bug target deadline for us..
15:11:51 <gouthamr> #link https://launchpad.net/manila/+milestone/flamingo-1 (Manila bugs targeted to Flamingo 1)
15:12:43 <gouthamr> we've nothing targeted in python-manilaclient:
15:12:43 <gouthamr> #link https://launchpad.net/python-manilaclient/+milestone/flamingo-1
15:13:13 <gouthamr> and there's one targeted in manila-ui, already closed:
15:13:13 <gouthamr> #link https://launchpad.net/manila-ui/+milestone/flamingo-1 (manila UI bugs targeted to Flamingo 1)
15:13:17 <gouthamr> we
15:13:57 <gouthamr> are three weeks away from this deadline, so more could come.. but, if you own any bug and are not planning to get it closed out in Flamingo-1, please re-target to a later milestone
15:14:53 <gouthamr> in a little over a month, we'll have our first bug squash of the release.. we'll discuss specific dates/times soon
15:15:12 <gouthamr> that's all the announcements i had today.. does anyone else have any?
15:16:43 <gouthamr> no new topics on the agenda today, lets go through our sticky topics:
15:16:50 <gouthamr> #topic Review Focus
15:16:56 <gouthamr> #link https://etherpad.opendev.org/p/manila-flamingo-review-focus
15:17:52 <gouthamr> i think all the specs have had a refresh, and in need of reviews
15:18:36 <gouthamr> since we discussed these at the PTG, things can be fresh in our minds
15:19:34 <gouthamr> carthaca Sai and carloss: thanks for iterating on the encryption spec with kpdev
15:19:44 <gouthamr> are you fine with the latest changes?
15:20:13 <kpdev> yes, haixin had given +2, but gone while addressing latest comments. Haixin, can you please check again ?
15:20:49 <gouthamr> ack, he'll likely read scrollback when he returns to his computer
15:20:54 <gouthamr> gireesh kpdev: can i have your eyes on the share backup spec: https://review.opendev.org/c/openstack/manila-specs/+/942694
15:21:33 <gireesh> sure Goutham
15:21:53 <gouthamr> ty
15:22:10 <kpdev> ack
15:22:57 <Sai> > are you fine with the latest changes?
15:22:57 <Sai> I am yet to review today's updated spec but mostly we are aligned!! No worries.
15:23:05 <gouthamr> good stuff, ty
15:23:16 <gouthamr> on the subnet force deletion spec: https://review.opendev.org/c/openstack/manila-specs/+/932637
15:23:17 <Sai> Thank you!
15:23:27 <gouthamr> ashrodri carthaca could you please take a look again?
15:23:50 <gouthamr> Sai gireesh this might be of interest to you too ^
15:23:50 <carthaca> yes, will do
15:24:46 <gouthamr> sylvand did mention they have implemented this and they use NetApp ONTAP - so i suppose this has been thought of well..
15:25:39 <gouthamr> the last spec: https://review.opendev.org/c/openstack/manila-specs/+/933558
15:25:39 <gouthamr> chaunm needs to look at the latest review comments there
15:25:40 <Sai> > Sai gireesh this might be of interest to you too ^
15:25:40 <Sai> Sure, will take a look goutham
15:26:00 <gouthamr> but it'd be a good idea to add any more comments that he can address together!
15:27:20 <gouthamr> in the review list, there are a couple of long pending tempest plugin changes
15:27:43 <gouthamr> one of these is from lkuchlan, but others from kpdev can be reviewed by lkuchlan / vhari
15:28:01 <gouthamr> any specific review to be highlighted here, today?
15:29:34 <gouthamr> thank you for the reviews everyone
15:29:36 <gouthamr> lets move on
15:29:40 <gouthamr> #topic Bug Triage (vhari)
15:29:46 <gouthamr> #link https://etherpad.openstack.org/p/manila-bug-triage-pad-new (Bug Triage etherpad)
15:30:38 <gouthamr> #link https://bugs.launchpad.net/manila/+bug/2108851 (migration get progress APIs use POST)
15:31:32 <gouthamr> i agree, this is indeed poor design in hindsight
15:32:01 <gouthamr> we copied the share migration pattern into the server migration APIs too
15:33:35 <gouthamr> wouldn't be terribly hard for us to introduce new APIs with our micro-versioning strategy, and have the client consume the new APIs from a specific micro-version
15:34:12 <gouthamr> but, we got to be mindful about things that are not python-manilaclient SDK/CLI
15:34:35 <gouthamr> i can tack a [rfe] on the title here, and think this is medium priority
15:34:51 <gouthamr> does anyone want to own this?
15:37:02 <gouthamr> sounds like a good task for an intern
15:38:28 <gouthamr> #action add https://bugs.launchpad.net/manila/+bug/2108851 to intern backlog
15:39:19 <gouthamr> these backlogs are publicly tracked on the OpenStack wiki and individual taiga boards when a task needs to be broken down into parts
15:39:29 <gouthamr> i don't have the wiki handy
15:39:41 <gouthamr> will share it on the bug once i find it
15:40:00 <gouthamr> any contentions for the bug importance?
15:40:37 <gouthamr> #link https://bugs.launchpad.net/manila/+bug/2106314 ([DOC] Update CLI commands in shared-file-system-crud-share.rst)
15:41:09 <gouthamr> ^ a doc bug, we can set the importance to "low" like the others
15:41:22 <gouthamr> and olamidepeterojo has submitted a fix
15:41:29 <gouthamr> so i'll target this to Flamingo-1
15:42:08 <gouthamr> #link https://bugs.launchpad.net/manila/+bug/2106582 (Update access rule causes nfs-ganesha service crash (CephFS driver))
15:42:16 <gouthamr> yikes
15:42:34 <gouthamr> seems like an issue with the Ceph Manager API rather than Manila itself
15:42:56 <gouthamr> amniik's solution looks like a good workaround
15:43:48 <gouthamr> it slows things down slightly because of that extra round trip, very much like we used to do in the Ceph drivers in the past
15:44:24 <gouthamr> i would rate this medium, and since the fix/workaround exists, target this to Flamingo-1 as well.. my thought is to report a ceph tracker too
15:44:49 <gouthamr> its kinda silly if there are smarts on the ceph API that drop off if the API is called again..
15:45:02 <gouthamr> we did expect idempotency there..
15:45:34 <gouthamr> any other thoughts here?
15:46:57 <gouthamr> okay that's a wrap for bugs
15:46:59 <gouthamr> #topic Open Discussion
15:47:26 <gouthamr> so OpenStack turns 15 this year
15:47:48 <gouthamr> that's a big milestone for software :D as big as when we wrapped around the alphabet for release names
15:47:56 <gouthamr> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/3OXCG23XDX3GLBLFS5YWBTPM4UL7WRCA/ (We are OpenStack)
15:48:06 <gouthamr> ^ this is a pretty cool way to celebrate
15:48:46 <gouthamr> #link https://www.openstack.org/blog/celebrating-15-years-of-openstack/ (list of OpenStack Birthday parties)
15:49:32 <zgoggin> will there be a cake? :)
15:49:42 <gouthamr> i would hope :D
15:51:15 <gouthamr> alright anyone, anything else for today's meeting?
15:52:48 <gouthamr> let's wrap up! thank you all for joining..
15:52:56 <gouthamr> see you here next week, and in #openstack-manila in the meantime
15:53:03 <gouthamr> #endmeeting