19:10:44 <kgriffs> #startmeeting marconi
19:10:45 <openstack> Meeting started Thu May 23 19:10:44 2013 UTC.  The chair is kgriffs. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:10:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:10:48 <openstack> The meeting name has been set to 'marconi'
19:10:53 <kgriffs> #topic bugs
19:11:07 <kgriffs> #link https://bugs.launchpad.net/marconi
19:11:31 <kgriffs> so, Flavio and I have started chipping away at some of these
19:11:44 <kgriffs> malini: anything in this list you would like to highlight?
19:12:26 <kgriffs> I was thinking we could just prioritize the undecided real quick
19:13:13 <kgriffs> so, sorting by number ,descending
19:13:39 <kgriffs> random 404's - would you say that's high or critical?
19:14:01 <malini> high as in - when will it be fixed?
19:14:31 <kgriffs> I'd say, how important it is to get this done for a "beta" release
19:14:56 <malini> It is important to get this one fixed
19:15:24 <kgriffs> seems like this one is a blocker for load testing
19:15:27 <malini> The 404s spike up when the number of users is large
19:15:30 <malini> yes
19:15:49 <malini> I have been able to repro thos only with tsung
19:15:52 <kgriffs> ok, but it isn't like a hole in our feature implementation, like some of the others
19:16:04 <kgriffs> how about "high" for priority?
19:16:09 <malini> works for me
19:16:37 <kgriffs> next
19:16:38 <kgriffs> https://bugs.launchpad.net/marconi/+bug/1177979
19:16:49 <kgriffs> #link https://bugs.launchpad.net/marconi/+bug/1177979
19:17:00 <kgriffs> I think medium is OK here
19:17:07 <malini> yeap
19:17:13 * kgriffs does that
19:17:33 <kgriffs> #link https://bugs.launchpad.net/marconi/+bug/1177976
19:17:41 <kgriffs> same here, methinks
19:18:06 <kgriffs> ditto for the next
19:18:11 <malini> tht got me thinking- so max msg size per request will be 4kb 8 50 ?
19:18:17 <kgriffs> #link https://bugs.launchpad.net/marconi/+bug/1177971
19:18:24 <malini> ** 4kb * 50 ?
19:18:36 <kgriffs> max request body, you mean?
19:18:44 <malini> yes..
19:18:49 <malini> guess it'll have to be
19:18:53 <kgriffs> that's right, plus a little overhead
19:18:57 <malini> ok
19:19:21 <kgriffs> for 2000 simultaneous requests, that comes out to be around 400 MB
19:19:35 <malini> ok
19:20:38 <kgriffs> if we up that limit, to 64K then we definitely need to support streaming deserialization of the JSON (right now everything is buffered since we just use json.read)
19:20:43 <kgriffs> (BTW)
19:21:11 <kgriffs> #link https://bugs.launchpad.net/marconi/+bug/1177952
19:21:15 <kgriffs> medium on that as well
19:21:34 <malini> yeap
19:21:38 <kgriffs> although some of these things have security consequences.
19:21:59 <kgriffs> I'm not saying we don't need to get them done for the gold release, just trying to see where to focus for a beta
19:22:20 <kgriffs> OK, so I'll set input validation bugs to medium
19:22:26 <malini> none of these are show stoppers
19:22:54 <kgriffs> Oh, here's one
19:22:55 <kgriffs> https://bugs.launchpad.net/marconi/+bug/1165102
19:23:12 <malini> tht one could be a high
19:23:22 <kgriffs> we better get that done for beta since it's spec'd in the API
19:23:31 <malini> agreed
19:23:52 <kgriffs> is there a blueprint for modifying the syntax to using query param instead?
19:23:54 * kgriffs looking
19:24:33 <kgriffs> I guess that just falls under v1-api
19:24:47 <kgriffs> so, anyone have an objection to changing this:
19:25:13 <malini> not me
19:25:49 <kgriffs> cool
19:25:55 <kgriffs> so it would look something like:
19:26:20 <kgriffs> myqueue/messages?ids=[95109,142358,1243098]
19:26:50 <kgriffs> is OK?
19:27:08 <malini> are we also going to change how the location is returned when we post multiple messages?
19:27:20 <kgriffs> yes
19:27:26 <malini> cool
19:27:28 <kgriffs> it would have to follow suit
19:28:19 <kgriffs> #agreed change get list of specific messages URL to put IDs in a query string param, vs. as the resource name in the path
19:28:45 <kgriffs> OK, all set with bugs?
19:28:52 <kgriffs> #link https://bugs.launchpad.net/marconi
19:28:58 <malini> yes
19:29:10 <kgriffs> #topic QA cluster
19:29:22 <kgriffs> oz_akan: I can haz updatez?
19:29:34 <oz_akan> sure
19:30:06 <oz_akan> new test environment is almost ready, except marconi configuration which we will do after the meeting with Malini
19:30:21 <kgriffs> OK
19:30:23 <kgriffs> excellent
19:30:27 <kgriffs> one thought
19:30:29 <oz_akan> so we have web and mongodb configuration under Salt and I will soon create a git repo for that
19:30:42 <kgriffs> OK
19:30:47 <kgriffs> where will that repo live?
19:30:50 <oz_akan> I am working on documenting it
19:30:58 <oz_akan> that is a question, I would ask to you
19:31:13 <kgriffs> mordred: ping
19:31:29 <kgriffs> mordred: ^^^
19:32:20 <kgriffs> I'm not sure. I think of it as a reference for deploying, but other people might want to do it in chef or puppet
19:33:11 <kgriffs> hey vkmc_
19:33:26 <oz_akan> sure, salt is in python so I think it will be adapted by openstack sooner or later
19:33:41 <kgriffs> oz_akan - maybe ask in #openstack-infra ?
19:33:44 <vkmc_> hey kgriffs!
19:33:45 <oz_akan> I think infrastructure people are even open to port all puppet to salt
19:33:52 <oz_akan> yes I asked yesterrday
19:33:54 <malini> there is a ci-salt repo in stackforge..But hasnt been updated in a while
19:33:55 <kgriffs> oic
19:34:38 <kgriffs> i mean, you can ask whether this repo should live under stackforge or just under rackspace org or something
19:35:08 <kgriffs> wow, I didn't realize salt was taking over the world. :D
19:35:25 <kgriffs> hey, if that happens, you can contribute to updating etherpad.openstack.org
19:35:29 <kgriffs> (nudge nudge, wink wink)
19:35:54 <kgriffs> ok, so that's great you've made so much progress
19:36:02 <kgriffs> I can't wait to have a real cluster to hammer. :D
19:36:36 <kgriffs> at that point, we should also give out the info to the community so they can try it out, write non-python client libs, etc.
19:37:16 <oz_akan> yes
19:37:17 <kgriffs> #oz_akan to send out a not to dev list inviting people to pummel our QA/reference deployment
19:37:27 <kgriffs> let me try that again
19:37:39 <kgriffs> to send out a not to dev list inviting people to pummel our QA/reference deployment
19:37:41 <oz_akan> I am working on a document about it
19:37:42 <kgriffs> crap
19:37:53 <kgriffs> #action oz_akan to send out a not to dev list inviting people to pummel our QA/reference deployment
19:37:59 <kgriffs> oz_akan: perfect.
19:38:08 <kgriffs> ok
19:38:13 <kgriffs> one more thing I thought of earlier today
19:38:31 <kgriffs> it would be great to have hardening in there already if not done already
19:39:32 <oz_akan> not done yet
19:39:37 <kgriffs> could be a subsequent release of the salt states
19:39:39 <oz_akan> it is more like having the service up
19:39:42 <oz_akan> sure
19:39:47 <oz_akan> that is the point
19:39:49 <kgriffs> sounds like a plan
19:40:02 <kgriffs> can you also add HAVAGE to that
19:40:03 <kgriffs> ?
19:40:19 <oz_akan> what is HAVAGE?
19:40:33 <kgriffs> http://www.issihosts.com/haveged/
19:41:01 <kgriffs> virtualized guests generally have poor entropy
19:41:05 <kgriffs> so they need a little help
19:41:27 <oz_akan> ok you need this package to be installed?
19:41:29 * kgriffs trying to get used to using the meetbot commands
19:41:31 <kgriffs> #link http://www.issihosts.com/haveged/
19:41:47 <kgriffs> correct
19:42:10 <kgriffs> I think it can contribute entropy to /dev/urandom - not sure if that happens by default
19:44:07 <mordred> kgriffs: pong
19:44:36 <kgriffs> mordred: hey, oz_akan was wondering where his salt scripts for Marconi should live. I'll let him explain. :)
19:44:50 <mordred> ah - gotcha
19:45:06 <mordred> I think at the moment they would make sense to put into a stackforge project
19:45:32 <oz_akan> "marconi-salt" would be a good repo name
19:46:03 <oz_akan> or we could have it as a folder under marconi
19:46:25 <oz_akan> but that might slow down things
19:48:09 <kgriffs> if it goes in stackforge does it get wired up to gerrit & friends?
19:50:28 <kgriffs> oz_akan: can you follow up with mordred?
19:50:36 <kgriffs> (we need to move on)
19:50:54 <kgriffs> #action oz_akan to find a home for marconi-salt
19:50:59 <oz_akan> kgriffs: ok
19:51:20 <kgriffs> one more thing on the topic of security. Do you have some hardening guides handy?
19:51:46 <kgriffs> I've referenced NSA before, but didn't see RHEL 6 yet.
19:51:48 <kgriffs> #link http://www.issihosts.com/haveged/
19:52:01 <oz_akan> guess, pasted wrong link
19:52:02 <kgriffs> sorry
19:52:04 <kgriffs> wrong link
19:52:10 <kgriffs> #link http://serverfault.com/questions/368055/anything-close-to-an-nsa-guide-for-securing-rhel-6
19:53:23 <kgriffs> anyway, something to keep on your radar
19:53:29 <kgriffs> moving right along...
19:53:33 <oz_akan> kgriffs: this is kind of at the very end of my todo list, next I want to create Malini's benchmarking environment
19:53:38 <oz_akan> ok got that
19:53:51 <kgriffs> makes sense
19:55:01 <kgriffs> looking at the agenda, we'll skip down to polling modes, since the others I'd like to get flaper87's thoughts on and he couldn't make it
19:55:11 <kgriffs> #topic 	•	BP: https://blueprints.launchpad.net/python-marconiclient/+spec/polling-modes in the client
19:55:24 <kgriffs> #link https://blueprints.launchpad.net/python-marconiclient/+spec/polling-modes
19:55:33 <kgriffs> vkmc_: thoughts?
19:56:26 <kgriffs> I guess this is assuming there is a blocking/greenlet-aware polling loop
19:57:56 * kgriffs watches a tumbleweed roll by
19:59:28 <vkmc_> kgriffs, not much I can suggest now, I'm from my phone just to keep up with the meeting :)
19:59:36 <kgriffs> no worries
19:59:56 <kgriffs> just mostly wanted to raise awareness of that, since it is something we want to promote
20:00:06 <kgriffs> OK, we are out of time folks
20:00:09 <kgriffs> parting thoughts?
20:00:29 <malini> bye bye :)
20:00:39 <kgriffs> ok, thanks everyone
20:00:52 <kgriffs> next week, same bat-time, same bat-channel.
20:00:59 <kgriffs> #endmeeting