16:05:34 <kgriffs> #startmeeting marconi
16:05:35 <openstack> Meeting started Mon Sep 16 16:05:34 2013 UTC and is due to finish in 60 minutes.  The chair is kgriffs. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:05:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:05:38 <openstack> The meeting name has been set to 'marconi'
16:05:47 <kgriffs> #topic Review actions from teh last time
16:05:56 <kgriffs> #link http://eavesdrop.openstack.org/meetings/marconi/2013/marconi.2013-09-09-16.06.html
16:06:10 <flaper87> yo yo yo
16:06:11 <kgriffs> 2c.
16:06:14 <flaper87> hello team
16:06:29 <kgriffs> looks like teh megan_w is MIA
16:06:33 * flaper87 will have to step out before the meeting ends, sorry guys
16:06:40 <flaper87> I'll stay as much as possible
16:06:43 <flaper87> anyyyyyway
16:07:04 <kgriffs> anybody notice a graduation tracking page go up on the wiki?
16:07:08 * kgriffs looks
16:07:36 <acabrera> I haven't seen anything like that.
16:07:39 <kgriffs> hmm, not seeing one
16:07:44 <kgriffs> Let me take care of it
16:07:45 * flaper87 neither
16:07:58 <kgriffs> #action kgriffs  to create a graduation tracking page
16:08:11 <kgriffs> 4b.
16:08:17 <kgriffs> flaper87: ^^^
16:08:42 <kgriffs> flaper87 to register a blueprint for tsung configs
16:08:43 <flaper87> kgriffs: done
16:08:47 <kgriffs> excellent
16:09:06 <kgriffs> malini: 2c
16:09:15 <flaper87> #link https://blueprints.launchpad.net/marconi/+spec/tsung-configs
16:09:29 <acabrera> +1 for link
16:10:06 <malini> kgriffs: sorry, what is 2c ?
16:10:20 <kgriffs> register bp for tsung XMLs
16:10:32 <malini> flaper87 did tht
16:10:32 <kgriffs> http://eavesdrop.openstack.org/meetings/marconi/2013/marconi.2013-09-09-16.06.html
16:10:37 <kgriffs> kk
16:10:53 <kgriffs> oops, just noticed we had duplicate actions - i remember now
16:10:54 <kgriffs> :p
16:11:07 <kgriffs> okie-dokie
16:11:13 <kgriffs> moving right along
16:11:27 <kgriffs> #link https://wiki.openstack.org/wiki/Meetings/Marconi#Agenda
16:11:31 <kgriffs> #topic bugs
16:11:36 <acabrera> Bring on the bugs.
16:11:36 <flaper87> damn, guys, gotta step out now
16:11:40 <flaper87> I'll read the logs later
16:11:42 <flaper87> sorry about that
16:11:48 <acabrera> dang. See ya later, flaper87!
16:12:00 <kgriffs> kk, no worries
16:12:16 <kgriffs> #link http://goo.gl/uKe5gp
16:13:17 <kgriffs> so, are any of these in progress that aren't so indicated (incorrect status)?
16:14:11 <kgriffs> looks ok
16:14:14 <acabrera> not that I'm aware of.
16:14:17 <kgriffs> ok
16:14:25 <acabrera> malini may have started looking into testscenarios.
16:14:39 <kgriffs> malini: ^^^ ?
16:14:43 <malini> I just had a quick review
16:14:50 <kgriffs> #link https://bugs.launchpad.net/marconi/+bug/1226081
16:14:50 <malini> Plan to start working on it next week
16:15:07 <malini> So its not ready to change status yet
16:15:08 <kgriffs> ok, when you do, it would be great if you could update the status to "in progress"
16:15:17 <malini> sure
16:15:22 <malini> will do
16:15:30 <kgriffs> so, for the _next_marker one: https://bugs.launchpad.net/marconi/+bug/1218602
16:15:55 <kgriffs> The status on that is my first attempt didn't prove fruitful. I have something else in mind that should work a lot better.
16:16:00 <kgriffs> not started on it, tho
16:17:19 <kgriffs> the idea is to use a side-counter but increment it AFTER inserting the message, with a little heuristic to detect when a worker crashes before incrementing and sync the counter. This will also allow us to use Mongo's built-in TTL, if I'm not mistaken
16:17:35 <zyuan> side-counter lgtm
16:17:41 <kgriffs> anyway, the end result is we won't have to do an expensive find/sort on the messages collection
16:18:01 <acabrera> +1
16:18:03 <kgriffs> kk
16:18:06 <kgriffs> moving on
16:18:34 <kgriffs> #link https://bugs.launchpad.net/marconi/+bug/1203000
16:18:49 <kgriffs> so, Flavio is questioning whether this one is necessary after all
16:19:19 <kgriffs> see his last comment here: https://review.openstack.org/#/c/37869/
16:19:32 <kgriffs> #link https://review.openstack.org/#/c/37869/
16:20:04 <acabrera> I remember that discussion. The current process for creating a marconi venv is pretty straightforward.
16:20:23 <acabrera> create venv, install deps, do marconi things
16:20:27 <kgriffs> so, I'd like everyone to noodle on it and we can vote next week wether to this is something we want in marconi
16:20:33 <kgriffs> acabrera: agreed
16:20:48 <kgriffs> ok, so anything else on the topic of bugs?
16:20:49 <kgriffs> malini?
16:20:59 <malini> no
16:21:07 <kgriffs> #topic Proxy
16:21:13 <kgriffs> acabrera: status?
16:21:21 <acabrera> The mighty proxy~
16:21:33 <acabrera> There are plenty of patches needing review.
16:21:41 * acabrera goes link hunting
16:21:53 <acabrera> #link https://review.openstack.org/#/c/43909/ (start here)
16:21:59 <acabrera> #link https://review.openstack.org/#/c/44356/
16:22:00 <zyuan> and going to have more...
16:22:04 <acabrera> #link https://review.openstack.org/#/c/44364/
16:22:08 <acabrera> #link https://review.openstack.org/#/c/46328/
16:22:14 <acabrera> #link https://review.openstack.org/#/c/46375/
16:22:16 <acabrera> and one more for testing
16:22:22 <acabrera> As for status, in short...
16:22:36 <acabrera> The marconi proxy has a working proof of concept. The next steps are:
16:22:51 <acabrera> 1. Migrate to oslo.cache to remove all the Redis-specific details from the implementation/
16:23:04 <acabrera> 2. Finalize a storage driver implementation. MongoDB is close.
16:23:20 <acabrera> 3. Implement hierarchical caching by taking (1) and (2)
16:23:25 <acabrera> Those are the key components.
16:23:39 <acabrera> I've been tackling (1) today.
16:23:49 <acabrera> It's been slow going as I learn how to navigate oslo.config.
16:23:53 <acabrera> Esp. from the python-cli.
16:24:35 <amitgandhi> can zyuan help pick up 2 or 3
16:25:01 <acabrera> Yes - I'd recommend 2. He's been addressing marconi-proxy testing needs.
16:25:05 <kgriffs> ok, assuming you just using the standard oslo.cache interface, we can plug in lru/redis/uwsgi/whatever when they are ready. I have those on my TODO list, fwiw.
16:25:06 <amitgandhi> or is zyuan still busy on tests
16:25:24 <kgriffs> #action kgriffs to work on cache backends
16:25:37 <acabrera> kgriffs: awesome - I'll be using straight oslo.cache. I won't need more than that interface, AFAICT.
16:25:44 <kgriffs> #action acabrera to migrate proxy to oslo.cache
16:25:50 <acabrera> +1
16:26:00 <zyuan> what's the status of 2?
16:26:06 <kgriffs> #action acabrera to finalize storage driver implementation/interface
16:26:46 <acabrera> zyuan: There's an interface, the CFG stuff is mostly done, there are schemas, indices, and implementations for the interface.
16:26:52 <acabrera> IIRC, the only thing missing was select()
16:27:09 <zyuan> the non-forwarding part of tests is done
16:27:16 <kgriffs> #action acabrera to use oslo.cache to cache catalog driver responses
16:29:00 <acabrera> Any other thoughts on the proxy? I'm moving forward with the current plan, full-speed ahead, otherwise. :)
16:30:19 <kgriffs> acabrera: are you going to maintain a blacklist? If so, how?
16:30:31 <kgriffs> (for backend nodes)
16:30:44 <kgriffs> (may be haproxy or webheads themselves)
16:31:23 <acabrera> I haven't designed that portion yet. However, I would like to address that aspect after the current actions are wrapped up.
16:32:16 <acabrera> The basic flow would be to remove a node from the nodes list after seeing enough failures from it.
16:33:09 <kgriffs> acabrera: ok, let's discuss that in #openstack-marconi when are ready to tackle it
16:33:17 <acabrera> thanks, kgriffs
16:33:36 <kgriffs> ok, the next one was an API audit, but I wanted flaper87 to be here for that
16:33:42 <kgriffs> s/one/topic
16:34:15 <kgriffs> which brings us to…
16:34:17 <kgriffs> #topic Open discussion
16:35:07 <acabrera> This is more time for open discussion than we've ever had. :P
16:35:24 <kgriffs> FYI, we will discuss/plan a notifications service at the HKG summit
16:35:44 <kgriffs> if you have thoughts on it anytime, pls. ping al-maisan
16:36:21 <kgriffs> the idea is to make it part of marconi initially; if/when it gets big we will split it out to it's own project, but it will need to get incubated on it's own if that happens
16:36:39 <acabrera> +1
16:36:57 <acabrera> it's related enough that I don't have any problems growing it with marconi until it needs to leave the nest.
16:37:03 <kgriffs> kk
16:37:20 <kgriffs> in other news, I plan to bump the max falcon version in requirements.txt to 0.1.7
16:37:32 <kgriffs> that way we get OPTIONS support (thanks to zyuan!)
16:37:53 <acabrera> awesome
16:37:57 <kgriffs> and everyone is aware that the repo has moved, right?
16:38:00 <kgriffs> (for Marconi)
16:38:03 <acabrera> yes
16:38:04 <zyuan> yes...
16:38:07 <malini> yes
16:38:08 <zyuan> git review failed
16:38:26 <acabrera> It's caused a little chaos with git review, but nothing too bad. :P
16:38:30 <kgriffs> #link https://github.com/openstack/marconi
16:38:48 <kgriffs> yeah, looks like we are blocked on pypi timing out last i checekd
16:39:00 <kgriffs> ok, anything else guys?
16:39:12 <acabrera> hmm...
16:39:42 <kgriffs> btw, the gerrit links also changed if you didn't notice
16:39:56 <kgriffs> #link https://review.openstack.org/#/q/status:open+project:openstack/marconi,n,z
16:40:02 <kgriffs> #link https://review.openstack.org/#/q/status:open+project:openstack/python-marconiclient,n,z
16:40:18 <acabrera> heh, yeah - lots of minor breaking changes by the migration
16:40:26 <zyuan> ah!
16:40:33 <acabrera> still, it means we got *migrated*. :D
16:40:43 <zyuan> need to reconfigure git review?
16:40:53 <acabrera> yup, zyuan
16:41:00 <kgriffs> there is a patch pending to do that
16:41:02 <acabrera> Do we have a patch in for that yet?
16:41:05 <acabrera> Ahh, there.
16:41:27 <kgriffs> blocked on global requirements
16:41:33 <kgriffs> which is blocked on pypi heat package
16:41:37 <acabrera> #link https://review.openstack.org/#/c/46628/
16:41:39 <kgriffs> which is blocked by YOUR FACE
16:41:46 * kgriffs is kidding
16:41:54 <acabrera> sounds like it's perma-blocked, in that last case. ;P
16:42:17 <zyuan> hmm. i did so
16:42:30 <zyuan> but jenkins seems to be broken
16:42:36 <kgriffs> ok guys, anything else? we can wrap up early and give you an extra 15 minutes of your life back.
16:42:36 <zyuan> ok, i see
16:43:06 <acabrera> nah. all marconi-related matters have been addressed, AFAICT
16:44:26 <kgriffs> #endmeeting