16:19:47 <kgriffs> #startmeeting marconi
16:19:48 <openstack> Meeting started Mon Sep 23 16:19:47 2013 UTC and is due to finish in 60 minutes.  The chair is kgriffs. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:19:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:19:51 <openstack> The meeting name has been set to 'marconi'
16:20:17 <kgriffs> looks like Flaper87 is MIA so we will need to push off the API audit one more week. :p
16:20:19 <kgriffs> otherwise
16:20:28 <kgriffs> #link https://wiki.openstack.org/wiki/Meetings/Marconi#Agenda
16:20:35 <kgriffs> #topic actions from last time
16:20:48 <kgriffs> #link http://eavesdrop.openstack.org/meetings/marconi/2013/marconi.2013-09-16-16.05.html
16:21:07 <kgriffs> 1b.
16:21:08 <kgriffs> https://wiki.openstack.org/wiki/Marconi/Incubation/Graduation
16:21:09 <kgriffs> done
16:21:54 <cppcabrera> 3{g, h, i} all under review - implemented
16:23:04 <kgriffs> ok
16:23:19 <kgriffs> 3f - we decided to punt on cache backends for now and just use memcached
16:23:26 <cppcabrera> +1
16:23:30 <kgriffs> but I am still planning to contribute to oslo.cache
16:24:02 <cppcabrera> it
16:24:21 <cppcabrera> it's fun to get new functionality in. oslo.cache is a pleasure to work with, so far.
16:24:25 <cppcabrera> fwiw
16:27:11 <kgriffs> ok
16:27:14 <kgriffs> moving on
16:28:35 <kgriffs> #topic Bugs
16:28:49 <kgriffs> #link http://goo.gl/uKe5gp
16:30:01 <kgriffs> so, we need to get some traction on those high bugs
16:30:29 <kgriffs> which means, we need to get a bunch of pending patches merged
16:30:35 <kgriffs> so we can move on to these other bugs
16:30:42 <cppcabrera> oh yes.
16:30:46 <kgriffs> malini: any new bugs to triage?
16:30:50 <cppcabrera> I',m surprised the non-ascii name bug is still a thing. :P
16:30:57 <malini> no new ones
16:31:09 <kgriffs> ok
16:31:23 <kgriffs> #topic proxy status
16:31:32 <kgriffs> cppcabrera: ^^^
16:31:43 <cppcabrera> Phew, lots to report on that!
16:31:47 <cppcabrera> lemme lay down the links
16:32:42 <cppcabrera> I spoke to flaper87 this morning about the state of the proxy and we reached a consensus that the current approach to proxy dev is good.
16:32:50 <cppcabrera> Namely, tracking issues and fixing them in later patches.
16:33:00 <cppcabrera> The best news I have to give is that the proxy interface is solidifying
16:33:33 <cppcabrera> This means that we'll be able to *actually* review a patch for what it is without worrying about whether particular issues are fixed in pending, child patches
16:33:42 <cppcabrera> So first links - the storage driver impl.
16:33:50 <cppcabrera> #link https://review.openstack.org/#/c/47399/ (memory driver, interface, tests)
16:34:02 <cppcabrera> #link https://review.openstack.org/#/c/47402/ (mongodb driver)
16:34:21 <cppcabrera> I received flaper87's blessing this morning on those two, with the caveat that issues are noted and addressed soon after.
16:34:26 <cppcabrera> Issues are recorded here:
16:34:32 <cppcabrera> #link https://etherpad.openstack.org/marconi-proxy-issues
16:34:54 <cppcabrera> Once those two patches are merged, things get closer to stability, and definitely so on the storage end.
16:35:01 <cppcabrera> The remaining two feature patches are...
16:35:20 <cppcabrera> #link https://review.openstack.org/#/c/47475/ (move to oslo.cache)
16:35:32 <cppcabrera> #link https://review.openstack.org/#/c/47642/ (bootstrap, mirror queues transport structure)
16:35:46 <cppcabrera> There are also several testing patches sitting in the review queue.
16:35:53 <cppcabrera> So the tl;dr of the proxy status
16:36:00 <cppcabrera> #info The proxy is stabilizing
16:36:13 <cppcabrera> #info The most recent feature patches need review
16:36:16 <cppcabrera> Ah, one more thing!
16:36:37 <cppcabrera> I put together a spec document this morning to 1) facilitate review and 2) have documentation on this thing
16:36:43 <cppcabrera> #link https://wiki.openstack.org/wiki/Marconi/specs/proxy/v1
16:37:05 <cppcabrera> The next steps on it are to address issues that are discovered through review and toughen up the testing.
16:37:12 <cppcabrera> Any questions or thoughts?
16:37:51 <ametts> malini: You putting together proxy tests based on cppcabrera's wiki link above?
16:38:14 <amitgandhi> has testing begun (in other words, has this been deployed to test env yet?)
16:38:25 <malini> ametts: SInce it is a behind the scenes thing, the functional tests remain unchanged
16:38:48 <malini> we'll run perf tests with proxy & make sure we dont see 404s etc
16:39:08 <cppcabrera> amigandhi: it's not yet set up on a test env, though I worked with oz_akan on that on Friday
16:39:10 <ametts> malini: What about the register partition/list partition calls, etc.
16:39:10 <ametts> ?
16:40:10 <malini> I missed those :-$ ..will add tests for those
16:40:25 <cppcabrera> +1 malini - thanks!
16:40:36 <amitgandhi> proxy forwarding endpoints need to be kept up to date with marconi endpoints correct?
16:40:49 <cppcabrera> that's correct, amitgandhi.
16:40:58 <ametts> kgriffs:  Looks like flaper87 has signed off on some of these proxy patches -- you think you can review them soon?
16:41:01 <cppcabrera> As long as the routes match, all the proxy does is send the request along.
16:41:23 <kgriffs> ametts: yep
16:41:28 * amitgandhi wonders if marconi proxy can be standalone and renamed something more generic - OpenStack Proxy lol
16:42:06 <cppcabrera> amitgandhi: not a chance, haha. It performs some marconi specific handling in some intercepted routes. :P
16:42:12 <cppcabrera> namely, the queue portion of it
16:42:31 <amitgandhi> ok
16:42:50 <kgriffs> cppcabrera: rough estimate of size of work remaining?
16:43:05 * ametts was just about to ask that
16:43:10 <cppcabrera> it's feature complete as of the last link pending, so...
16:43:16 <cppcabrera> testing and docs remain
16:43:36 <ametts> cppcabrera:  You said "stabilizing", not "stable".  :)
16:43:58 <ametts> Just testing and bug fixing then?
16:44:25 <cppcabrera> yes, except for possibly host black listing
16:44:47 <cppcabrera> which means - a host is removed from a partitions list of valid hosts if it fails a certain number of times
16:44:55 <ametts> Looks like Jenkins barfed on this one: https://review.openstack.org/#/c/47642/
16:45:40 <cppcabrera> I suspect jenkins is being weird on that one (I'm not sure why). I just issued a recheck request.
16:45:52 <cppcabrera> so back to that estimate -
16:46:10 <cppcabrera> between a week and two weeks of testing
16:46:20 <cppcabrera> which includes some wiggle room for bug fixes
16:46:22 <cppcabrera> there will be bugs
16:46:26 <cppcabrera> I guarantee it. :P
16:46:59 <ametts> But if the code is written, we can have more people swarming on testing+bug fixes methinks.
16:47:07 <cppcabrera> +1 ametts
16:47:17 <cppcabrera> it gets much easier now that we have a core proxy to build on
16:47:48 <cppcabrera> (jenkins is happy now)
16:47:50 <amitgandhi> swarming on testing, bug fixing, benchmarking
16:48:22 <cppcabrera> we haven't laid out any actions this time... >.>
16:48:30 <cppcabrera> #action kgriffs to review pending proxy patches
16:48:37 <ametts> Ok, looks like all eyes are on kgriffs now to get these reviewed -- so the rest of us have something to test against.
16:49:06 * ametts is calling the airlines to tell them he can't board the plane until this is done
16:49:24 <kgriffs> LOL
16:49:45 * amitgandhi wonders what kgriffs will do for 2.5 hours on the plane other than reviews
16:49:59 * kgriffs has *no idea*
16:50:40 <cppcabrera> lol
16:50:57 <kgriffs> #topic open discussion
16:50:59 <kgriffs> anything else?
16:51:23 <cppcabrera> hmm...
16:51:37 <kgriffs> BTW, the Pecan vs. Falcon thing sort of blew up again over the past few days
16:51:42 <cppcabrera> +1 for discussing the reqs on -infra, kgriffs.
16:52:33 <amitgandhi> everyone is against falcon?
16:52:39 <ametts> kgriffs:  Were there any conclusions?
16:53:12 <kgriffs> TL;DR they were worried we were going to not use Pecan "just because" it would be "too hard to switch"
16:53:42 <kgriffs> I reassured them that nothing could be further from the truth, that we are planning on writing a Pecan driver during incubation, and if it is awesome and fast enough we will use it
16:54:24 <kgriffs> if it can't do what we need, we will either help to fix Pecan or there will need to be some consensus in the broader community that it's OK to have 3 frameworks in OpenStack (Pecan, Falcon, swob)
16:54:31 <ametts> I didn't realize that part of Marconi was plugable?  Or would this be an alternate "transport
16:54:35 <ametts> " driver?
16:54:39 <kgriffs> alternative transport
16:55:20 * ametts just realized we could benchmark Marconi with Falcon against Marconi with Pecan if we had that.
16:55:29 <cppcabrera> wsgi_falcon, wsgi_pecan
16:55:32 <kgriffs> Personally, I am promoting objectivity and pragmatism. I think that what a project uses should be based on that, within reason of course
16:57:11 <kgriffs> I understand the benefits of minimizing dependency chaos, and not reinventing the wheel. However, you shouldn't sacrifice important requirements in a project for that; seems like there should be a happy medium
16:57:40 <kgriffs> anyway, we will continue to discuss and I'm sure we can get everyone involved to agree to a reasonable outcome.
16:57:45 <ametts> kgriffs has a bee in his bonnet. :)
16:57:48 * kgriffs feels like a politician
16:58:04 <kgriffs> heh
16:58:06 <kgriffs> so, last thing -
16:58:24 <kgriffs> I got approval to get a hash function in as an exception to the freeze on global-reqs.
16:58:27 <kgriffs> HOWEVER
16:58:43 <kgriffs> we need to check out crc32 and perhaps siphash to be sure that mmh3 is what we want to use.
16:58:51 <kgriffs> I promised to look into that and get back to -infra
16:58:59 <amitgandhi> btw which marconi talk was approved (link?)
16:59:00 <ametts> cool beans
16:59:14 <kgriffs> (1 minute)
17:00:24 <kgriffs> anyone have the link handy?
17:00:47 <cppcabrera> no. :/
17:01:08 <ametts> There wasn't a link in the acceptance email.  Might not be posted yet.
17:01:44 <kgriffs> ok, well, they were basically dupe's so not a big deal
17:01:49 <kgriffs> anything else?
17:01:55 <kgriffs> (out of time)
17:03:30 <kgriffs> #endmeeting