15:11:04 <kgriffs> #startmeeting marconi
15:11:05 <openstack> Meeting started Tue Dec 17 15:11:04 2013 UTC and is due to finish in 60 minutes. The chair is kgriffs. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:11:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:11:09 <openstack> The meeting name has been set to 'marconi'
15:11:22 <kgriffs> #link https://wiki.openstack.org/wiki/Meetings/Marconi#Agenda
15:11:34 <kgriffs> #topic review actions from teh last times
15:11:46 * flaper87 partially did one
15:11:49 <kgriffs> #link http://eavesdrop.openstack.org/meetings/marconi/2013/marconi.2013-12-10-15.05.html
15:12:07 <flaper87> I partially got in contact with Everett
15:12:21 <malini> o/
15:12:29 <flaper87> Which means, I pingged him, recognized him, told him I needed to speak with him and then forgot
15:12:36 <kgriffs> heh
15:12:48 <kgriffs> flaper87: maybe you can try to schedule a G+ session with him some time
15:12:54 <flaper87> I mean, we agreed on meeting the day after but neither of us was there...
15:12:56 <kgriffs> flaper87: do you have his email?
15:12:57 <flaper87> kgriffs: good idea
15:13:00 <flaper87> I don't
15:13:09 <kgriffs> flaper87: kk, I'll sent it to you
15:13:10 <flaper87> I think that will speed it up
15:13:13 <flaper87> kgriffs: thanks!
15:14:48 <kgriffs> kk
15:15:08 <kgriffs> alcabrera is MIA
15:15:17 <kgriffs> so I'll go
15:15:29 <kgriffs> play with swob:
15:15:34 <kgriffs> yay, I did that!
15:16:06 <kgriffs> TL;DR - swob is a slimmed-down version of webob
15:16:26 <kgriffs> implements much of the webob Request and Response interfaces
15:16:32 <kgriffs> the implementation is quite different
15:16:54 <kgriffs> seems to have been optimized some, which isn't surprising I guess, given swift's requirements
15:17:14 <kgriffs> in fact, I found a few ideas that can be used to improve Falcon
15:17:29 <flaper87> hehe, I was going to ask that
15:17:46 <flaper87> kgriffs: glad to hear that
15:17:50 <kgriffs> flaper87: not a ton of things, but a 2-3 ideas that were useful
15:18:05 <kgriffs> so, the other thing I wanted to know, was whether it was a drop-in replacement for webob
15:18:07 <flaper87> did you test it performance wise ?
15:18:09 <kgriffs> the answer is: no
15:18:20 <kgriffs> it is missing a lot of stuff that I'm certain Pecan depends on
15:18:22 <flaper87> kgriffs: gtk
15:18:27 <kgriffs> and a few methods behave slightly differently
15:18:51 <kgriffs> flaper87: I tested performance a little bit. but just the request object. was comparable to falcon.Request
15:19:03 <kgriffs> maybe a few microseconds different
15:19:37 <kgriffs> so, there you have it
15:20:01 <kgriffs> food for thought, anyway
15:20:10 <kgriffs> oh, I also peaked and webob source code
15:20:13 <kgriffs> and it is FUUUUGLY
15:20:16 <kgriffs> wow
15:20:25 <flaper87> hahahahahhaa
15:20:27 <kgriffs> how something like that could become so popular is beyond me. :p
15:20:39 <kgriffs> I guess because it "worked" for the most part. And people are lazy.
15:20:46 <kgriffs> heh
15:21:02 * kgriffs is lazy too, but perhaps in a different way
15:21:25 <kgriffs> flaper87: seriously, it does crazy stuff like spool the input stream to a temp file
15:21:26 <flaper87> lazy + not curious users = webob's success
15:21:35 <flaper87> kgriffs: WTF?
15:21:41 * flaper87 (plop)
15:22:22 <mpanetta> eww
15:22:27 <kgriffs> and enough layers of abstraction to make an EJB dev proud
15:22:31 * kgriffs digresses
15:22:45 <kgriffs> aaaanyway
15:22:49 <kgriffs> it is what it is
15:22:58 <kgriffs> but at least we now know what we are dealing with
15:23:43 <flaper87> yeah, I agree!
15:23:44 <kgriffs> #info swob is not a drop-in replacement for webob in pecan, but may be used by apps that are only using the web-servicey portion of webob with a little work
15:23:49 <kgriffs> ok, next
15:23:50 <kgriffs> confirm whether or not query params are ok in json-home URI templates
15:24:00 <flaper87> well, a good thing to do would be contribute to pecan by making it use swob
15:24:45 <kgriffs> flaper87: possibly. Not sure how they would feel about that because I know Doug is big on using "standard" things
15:24:53 <kgriffs> wrt json-home
15:25:09 <kgriffs> #info json-home-03 mentions level-3
15:25:31 <kgriffs> #info level-3 URI templates include query param definition
15:25:54 <kgriffs> flaper87: so, afaict, it seems that query params are fine in json-home "href-template" fields
15:26:07 <kgriffs> i didn't find anything explicitly disallowing them
15:26:13 <kgriffs> just that they are level-3 URI templates
15:26:28 <flaper87> kgriffs: mmh, but I remember reading it wasn't recomemded or covered
15:26:31 <flaper87> or something like that
15:26:33 <flaper87> mmh, 2 secs
15:26:43 <kgriffs> flaper87: if you can find the reference, I'm all eyes
15:26:48 * flaper87 is doing so
15:28:15 <flaper87> mmh, maybe I read that in an older version or something
15:28:18 <flaper87> I just found: http://tools.ietf.org/html/draft-nottingham-json-home-03#appendix-B.6
15:28:29 <flaper87> which doesn't seem to refer to query params
15:28:36 <flaper87> but other kind of 'complex queries'
15:28:46 <flaper87> I'm glad query params are allowed
15:28:53 <flaper87> that makes it even easier
15:29:00 <flaper87> #link http://tools.ietf.org/html/draft-nottingham-json-home-03#appendix-B.6
15:29:12 <kgriffs> ok, well we can run with that assumption for now and adjust later if need be
15:29:13 <kgriffs> :p
15:29:21 <kgriffs> perils of implementing an RFC
15:29:34 <kgriffs> #action kgriffs to create bp for notifications based on brainstorming session
15:29:39 <kgriffs> didn't do that yet ^^^
15:29:41 <kgriffs> it's a beast
15:29:57 <kgriffs> I'm hoping to finally get some time this week
15:30:09 <kgriffs> kgriffs to write v1.1 api spec
15:30:23 <kgriffs> I started on this - am about 50% done
15:30:44 <flaper87> kgriffs: I think you can use cpallares patch as a reference / base for that
15:31:01 <kgriffs> I'll send the rough draft to the ML
15:31:27 <kgriffs> flaper87: ah, I was going off the etherpad from the summit and the /next wiki page
15:31:37 <kgriffs> I will see about reconciling that with the patch as well
15:31:58 <kgriffs> #action kgriffs to finish up v1.1 api spec
15:32:20 <kgriffs> ok, anything else wrt actions from last time?
15:33:19 <kgriffs> #topic icehouse roadmap
15:33:47 <kgriffs> so, I put together this rough draft and wanted to get some quick feedback on it: https://wiki.openstack.org/wiki/Marconi/roadmaps/icehouse
15:34:53 <kgriffs> what is out of place or missing or just plain wrong?
15:34:54 <flaper87> looks good. We should probably link the bps there
15:35:02 <flaper87> and mark those that are implemented
15:35:21 <ametts> Several of these are started already.
15:35:31 <ametts> Is there any value in estimating a % complete?
15:35:38 <flaper87> and lets make sure it's clear that those are Ith requirements not graduation requirements
15:35:45 <flaper87> ametts: I don't think so
15:35:58 <flaper87> in LPs bps, you can set slow progress, good progress or implemented
15:36:11 <flaper87> I think that's an enough estimate of where the bp work is standing
15:36:18 <kgriffs> well, I don't want to reinvent launchpad here - that is the only thing that made me hesitate about adding links and status
15:36:40 <flaper87> kgriffs: that's a good poitn
15:36:46 <flaper87> point
15:37:09 <ametts> Yeah, we just need some sort of visibility to keep aware of where we're okay, where we're falling behind, etc.
15:37:17 <flaper87> #action flaper87 to submit patches for client Messages and Claims
15:37:19 <kgriffs> maybe useful, but as a first step I just wanted to have a big overall picture of what we want to accomplish so everyone is pulling in the same direction
15:37:48 <flaper87> #link https://blueprints.launchpad.net/marconi/icehouse
15:38:18 <flaper87> I think that's the link we should be looking at, as far as blueprints are concerned.
15:38:24 <flaper87> there are other things represented in bugs
15:38:28 <flaper87> and other in etherpads
15:38:34 <flaper87> so, I do find that wiki page valuable
15:38:42 <flaper87> and I agree with you with not reinventing LP there
15:38:58 <flaper87> Maybe just add the links to the various queries in LP
15:38:59 <kgriffs> maybe a high-level "progress" tag on each item could be useful, to ametts' point
15:39:10 <flaper87> Ith Bugs: link
15:39:14 <flaper87> Ith BPS: https://blueprints.launchpad.net/marconi/icehouse
15:39:15 <kgriffs> flaper87: ah, that would be cool: sounds like you just volunteered!
15:39:16 <flaper87> etc
15:39:20 <flaper87> LOOOL
15:39:22 * flaper87 does that
15:39:24 <ametts> So Priority == Essential on the bp page is equivalent to the Icehouse required items?
15:39:51 <kgriffs> i think pretty much essential and high are required, but essential is do-or-die
15:39:51 <flaper87> ametts: yeah, essential basically means, w/o it, there ain't be any Ith release for Marconi
15:40:54 <kgriffs> anyway, I can try to track high-level progress on the various items on this page. Perhaps create umbrella blueprints for each one. let me think on that
15:41:22 <ametts> So there's an assignee on all Essential & High Items right now. Anything need extra attention?
15:41:43 <kgriffs> let's go through those next
15:42:02 <kgriffs> #topic Review Graduation BPs/Bugs
15:42:43 <kgriffs> #link https://blueprints.launchpad.net/marconi/+spec/change-marconi-structure
15:42:52 <kgriffs> flaper87: ^^
15:42:58 <kgriffs> status?
15:43:17 <flaper87> mmh, I already marked it as Implemented, didn't I ?
15:43:21 * flaper87 clicks
15:43:32 <flaper87> yup, that's done
15:43:40 <kgriffs> oops, yeah
15:43:43 <kgriffs> sorry I missed that
15:43:46 <kgriffs> carry on
15:43:57 <kgriffs> #link https://blueprints.launchpad.net/marconi/+spec/heat-template
15:44:03 <flaper87> I think there's nothing else to change right now. I've already some other things that I'd like to restructure in mind, but lets first graduate
15:44:05 <flaper87> :D
15:44:12 <kgriffs> so... there are some patches in heat
15:44:23 <flaper87> Yeah, that's blocked by the client library
15:44:38 <flaper87> we need to make it pip-installable and full-featured
15:44:45 <flaper87> I already added an action item on me
15:45:05 <flaper87> I'll implement the things left by next week
15:45:33 <flaper87> and I'll talk to Everret
15:45:37 <kgriffs> https://review.openstack.org/#/c/61035/
15:45:39 <flaper87> or Everett
15:45:41 <flaper87> mmh
15:45:42 <kgriffs> https://review.openstack.org/#/c/61036/
15:45:51 <flaper87> #link https://blueprints.launchpad.net/marconi/icehouse
15:45:54 <flaper87> erm
15:46:00 <flaper87> #link https://review.openstack.org/#/c/61035/
15:46:07 <flaper87> #link https://review.openstack.org/#/c/61036/
15:47:02 <kgriffs> ok, I dropped those links on the whiteboard for the bp as well
15:47:07 <flaper87> kk
15:47:16 <flaper87> we can request to mention the bp in the review
15:47:30 <flaper87> cross-project bps are fine...
15:47:30 <kgriffs> ah, that would be good
15:48:51 <kgriffs> next
15:49:03 <kgriffs> pecan framework
15:49:11 <kgriffs> #link https://blueprints.launchpad.net/marconi/+spec/pecan-framework
15:49:15 <alcabrera> o/
15:49:21 <kgriffs> alcabrera: you're alive!
15:49:30 <flaper87> kgriffs: that's not on the wiki page
15:49:36 <flaper87> the pecan bp
15:49:36 <alcabrera> kgriffs: yup, more or less.
15:49:38 <flaper87> alcabrera: good morning
15:49:43 <alcabrera> flaper87: morning!
15:49:45 <kgriffs> flaper87: ah, good catch
15:50:12 <kgriffs> flaper87: wait, yes it is
15:50:14 <kgriffs> under essential
15:50:20 <kgriffs> "Evaluate Pecan/WSME (POC)"
15:50:53 <flaper87> erm, sorry
15:51:02 * flaper87 left his glasses at home
15:51:02 <kgriffs> ametts: the pecan thing is something that needs some TLC
15:51:14 <kgriffs> nobody has had the bandwidth to take it on
15:51:18 <flaper87> I'm not *that* blind but my head is exploding now!
15:51:32 * kgriffs gives flaper87 a helmet to keep his brains in
15:51:38 <flaper87> LOOOL
15:51:49 <ametts> kgriffs: noted. I'll see if we can find some extra eyes.
15:51:54 <ametts> (and hands)
15:51:59 <ametts> (maybe a brain)
15:52:05 <alcabrera> lol
15:52:05 <kgriffs> braaaaaains!
15:52:07 <flaper87> LOL
15:52:13 <alcabrera> pecan zombies... hmm...
15:52:21 <kgriffs> so, one quick note wrt pecan
15:52:44 <kgriffs> a POC is fine - just enough to know what we are dealing with and be able to benchmark some common operations
15:53:21 <ametts> kgriffs: Makes sense. So the swob/webob stuff is irrelevant to this bp?
15:53:56 <alcabrera> ametts: yes. my understanding is that pecan is implemented on top of webob, but we'd be working with the pecan layer for the POC
15:54:02 <kgriffs> ametts: it was relevant in that we were going to see if we could swap out webob for swob within pecan with little to no work
15:54:07 <kgriffs> but, doesn't look like that is viable
15:54:12 <ametts> got it
15:54:53 <kgriffs> maybe something we could contribute to pecan later - but we would need to convince people that swob is the new webob, so to speak. And I'm not sure whether swift guys are interested in that direction (TBD)
15:54:59 <kgriffs> aaaanyway
15:55:30 <kgriffs> last one, then we are out of time
15:55:42 * kgriffs needs to put fewer items on the agenda
15:55:47 <kgriffs> #link https://blueprints.launchpad.net/marconi/+spec/sql-storage-driver
15:56:13 <flaper87> kgriffs: Yeela starte working on the driver already
15:56:21 <flaper87> we need to review the patch she pushed
15:56:30 <flaper87> #action ask yeela to attend to Marconi's meetings
15:56:36 <kgriffs> +1
15:56:39 <flaper87> #action flaper87 to ask yeela to attend to Marconi's meetings
15:56:41 <kgriffs> so, I reviewed the tables
15:56:51 <kgriffs> looks like she subsequently refreshed that patch
15:56:52 <flaper87> I think she addressed your comments
15:56:55 <kgriffs> so we need to take another pass
15:57:04 <flaper87> I also replied to one of your comments
15:57:10 <flaper87> and I added a note to the new one
15:57:32 <flaper87> w.r.t the Locked table
15:57:45 <flaper87> Anyway, we can talk about that offline
15:57:49 <kgriffs> kk
15:58:24 <kgriffs> flaper87: btw, I would like to get someone from the Trove team to help review these patches as well
15:58:52 <flaper87> kgriffs: more eyes don't heart
15:58:57 <flaper87> hurt
15:58:57 <kgriffs> At the summit I was talking to an operator who was tearing their hair out over the poorly implemented SQL driver in a particular project (I won't mention any names)
15:59:00 <flaper87> fuck that
15:59:02 <flaper87> T_T
15:59:25 <kgriffs> flaper87: heh - so, I have someone in mind. I will point him towards the patch. He is a SQL meister
15:59:34 <flaper87> kgriffs: awesome, thanks!
15:59:34 <alcabrera> cool
15:59:42 <kgriffs> #topic open discussion
15:59:44 <kgriffs> one minute: go!
16:00:02 <flaper87> blah blah blah blah blah blah blah!!! And Merry Christmas!
16:00:14 <alcabrera> yay~
16:00:14 <flaper87> (next tuesday is Dec 24th)
16:00:17 <kgriffs> ah yes
16:00:27 <kgriffs> so, anyone going to cry if we skip the mtg next week?
16:00:30 <flaper87> kgriffs: btw, I think it's not necessary to send meeting reminders
16:00:33 <flaper87> to the m-l
16:00:36 <adrian_otto> all done?
16:00:57 <kgriffs> flaper87: I was trying to decide about that. Seems like there are so many projs now it is getting spammy, so maybe better to stop
16:01:01 <kgriffs> adrian_otto: yep!
16:01:04 <kgriffs> #endmeeting