15:03:06 <flaper87> #startmeeting Marconi
15:03:07 <openstack> Meeting started Tue Jan 21 15:03:06 2014 UTC and is due to finish in 60 minutes.  The chair is flaper87. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:03:10 <openstack> The meeting name has been set to 'marconi'
15:03:23 <flaper87> alcabrera: yo
15:03:25 <flaper87> good morning
15:03:33 <alcabrera> hey!
15:03:37 <flaper87> 'sup people?
15:03:40 <flwang> hey
15:03:42 <flaper87> how are your queues doing ?
15:04:00 <alcabrera> my queues are tired... :P
15:04:15 <flaper87> alcabrera: LOL
15:04:17 <flaper87> :D
15:04:24 <flaper87> so, first item
15:04:33 <flaper87> actually
15:04:34 <amitgandhi> o/
15:04:35 <flaper87> #link https://wiki.openstack.org/wiki/Meetings/Marconi#Agenda
15:04:42 <flaper87> that's today's agenda
15:04:56 <flaper87> #topic I-2 Status
15:04:59 <flaper87> #link https://launchpad.net/marconi/+milestone/icehouse-2
15:05:25 <flaper87> #link https://blueprints.launchpad.net/marconi/+spec/pecan-framework
15:05:27 <alcabrera> icehouse 2 - coming soon to an OS near you.
15:05:30 <flaper87> balajiiyer: ^ ?
15:05:43 <flaper87> I guess that should be moved to i-3
15:05:55 <alcabrera> yes, definitely.
15:05:59 <balajiiyer> flaper87: yes, i3
15:06:12 <flaper87> awesome, the rest of the bps are implemented
15:06:17 <flaper87> now, bugs
15:06:17 <alcabrera> #link https://wiki.openstack.org/wiki/Icehouse_Release_Schedule
15:06:22 <flaper87> :S :S :S :S
15:06:32 <flaper87> #info i-2 bps implemented
15:07:08 <flaper87> #link https://bugs.launchpad.net/marconi/+bug/1258591
15:07:10 <flaper87> alcabrera: ^
15:07:13 <flaper87> any update?
15:07:31 <alcabrera> the update is - no progress. :/
15:07:46 <flaper87> alcabrera: np, moving it to i-3
15:07:51 <alcabrera> kk
15:08:00 <flaper87> #link https://bugs.launchpad.net/marconi/+bug/1258618
15:08:02 <flaper87> alcabrera: ^ ?
15:09:11 <flaper87> alcabrera: Do you want me to un-assign you so that other folks interested can pick that bug up?
15:09:14 <flaper87> alcabrera: still there?
15:09:15 <flaper87> :D
15:09:30 <alcabrera> yes
15:09:39 <alcabrera> I was looking at sharding for a moment, heh
15:09:42 <alcabrera> now lemme see...
15:09:44 <flaper87> hehe, ok ok :D
15:10:11 <alcabrera> yeah, unassign that flaper87. I'd love to advise on the fix, but I can't do it at the moment.
15:10:13 <alcabrera> :)
15:10:27 <flaper87> ok, done
15:10:30 <alcabrera> cool
15:10:32 <flaper87> moved to i-3 as well
15:10:40 <flaper87> kgriffs: goood morning
15:10:46 <kgriffs> o/
15:10:48 <flaper87> #link https://bugs.launchpad.net/marconi/+bug/1243899
15:10:48 <kgriffs> sorry guys
15:10:50 <kgriffs> baby was sick last night
15:10:51 <flaper87> flwang: updates?
15:11:05 <flaper87> kgriffs: np, hope he/she is better now
15:11:08 <alcabrera> kgriffs: dang. Hope the little one feels better soon.
15:11:14 <kgriffs> thanks
15:11:22 <malini> kgriffs: soory to hear that :(
15:11:27 <flaper87> flwang: around?
15:11:33 <kgriffs> he seems a little better this morning - stomach bug or something.
15:11:34 <kgriffs> aaaanyway
15:11:35 <flwang> flaper87: yep, I'd like to raise the discussion about the /health
15:11:52 <flaper87> flwang: sure, lets talk about that later. Do you have updates about https://bugs.launchpad.net/marconi/+bug/1243899
15:12:05 <flaper87> #chair kgriffs
15:12:06 <openstack> Current chairs: flaper87 kgriffs
15:12:25 <flwang> flaper87: nope, I may have to fix it in i3 if it's ok for you guys
15:12:32 <flaper87> kgriffs: we're going through the bug list: https://launchpad.net/marconi/+milestone/icehouse-2
15:12:35 <kgriffs> kk
15:13:07 <flaper87> #link https://bugs.launchpad.net/marconi/+bug/1239834
15:13:08 <flwang> flaper87: sorry about that
15:13:12 <flaper87> kgriffs: want to take over?
15:13:17 <flaper87> flwang: np
15:13:20 <kgriffs> sure
15:13:22 <flwang> was distracted by some other stuff
15:13:24 <kgriffs> let's seee
15:13:39 <flaper87> I think we should move that one
15:13:44 <flaper87> I've no info about it
15:13:49 <flaper87> the last comment is kgriffs'
15:14:16 <kgriffs> ok, we can move the attribute bug - I'll do that
15:14:29 <kgriffs> next: Health endpoint should be admin only
15:14:45 <kgriffs> so, that is going into v1.1 now, right?
15:14:55 <flaper87> kgriffs: yeah + /ping
15:15:05 <flaper87> flwang: did you want to say something about /healt ?
15:15:38 <chandankumar_> kgriffs, donot take that bug, sorry i will do that https://bugs.launchpad.net/marconi/+bug/1239834
15:16:03 <flwang> flaper87:  after last meeting, we discussed that a little bit, I'd like to get more thoughts about what should we expose by the new api
15:16:09 <kgriffs> chandankumar_: oh, can you do it today?
15:16:22 <chandankumar_> kgriffs, i will try my best
15:16:24 <kgriffs> we only have until end of the day before the i-2 tag
15:16:33 <flaper87> chandankumar_: the question was whether move it to -3
15:16:47 <chandankumar_> move it to -3
15:16:50 <kgriffs> kk
15:16:58 <flaper87> also, lets remember the gate is..... 'stressed'
15:17:00 <flaper87> :D
15:17:00 <flwang> flaper87: i'd like to know what's the 'health' metrics instead of 'performance' metrics
15:17:09 <flaper87> so, I'm not sure many patches will make it
15:17:44 <flaper87> flwang: health => I feel good, performance => Look how good i'm doing
15:17:45 <flaper87> :D
15:17:50 <kgriffs> flaper87: yeah, we will just have to see what we get over the next few hours.
15:18:24 <kgriffs> flwang: wrt health
15:18:57 <kgriffs> I would say that you can base health of of operational stats as well as "i am alive"
15:19:14 <kgriffs> so, you could say that as long as I am responding to requests under X ms, I am healthy
15:19:38 <kgriffs> basically you want to expose key performance indicators (KPIs)
15:19:58 <kgriffs> then the operator can set up their monitoring/alerting system to trigger on those
15:20:11 <kgriffs> so, to summarize
15:20:39 <kgriffs> /ping says "I'm alive"
15:20:56 <kgriffs> and /health says "here are my vital signs"
15:21:16 <kgriffs> flwang: does that make sense?
15:21:24 <chandankumar_> kgriffs, flaper87 thank you
15:21:31 <flwang> kgriffs: thanks the suggestion. so basically, we'd like to provide some KPI with /health, right?
15:21:45 <kgriffs> right
15:21:56 <kgriffs> let's keep it is simple the first iteration
15:22:06 <kgriffs> I'd say pick 3 KPIs
15:22:15 <flwang> uptime?
15:22:16 <kgriffs> (3-5)
15:22:27 <flwang> response times and reqs/sec?
15:22:36 <kgriffs> flwang: let's break out that discussion in #openstack-meeting-alt
15:22:43 <kgriffs> (and pull in some ops guys)
15:22:49 <kgriffs> oops
15:22:51 <flwang> ok, sure
15:22:59 <kgriffs> I meant, break out in #openstack-marconi
15:23:09 <flwang> kgriffs: got it
15:24:06 <kgriffs> #action flwang to get suggestions for KPIs for health from ops folks
15:24:09 <kgriffs> kk
15:24:15 <kgriffs> next
15:24:28 <flaper87> flwang: thanks :)
15:24:33 <kgriffs> flaper87: mind if I move the health endpoint bug to i-3, since v1.1 api is in i-3?
15:24:45 <flaper87> kgriffs: np, lets move it
15:24:46 <kgriffs> flwang: yes, thanks!
15:25:01 * kgriffs does that
15:25:18 <kgriffs> alcabrera: Cached shard state is not updated/deleted when shard is updated/deleted
15:25:41 <alcabrera> I need to double check that, kgriffs.
15:25:43 <kgriffs> alcabrera: will that get done in the next few hours?
15:26:01 <alcabrera> hmmmm
15:26:03 <kgriffs> #link https://bugs.launchpad.net/marconi/+bug/1258618
15:26:14 <alcabrera> Let me get back to you on that.
15:26:16 * alcabrera checks code
15:26:17 <kgriffs> ok
15:27:10 <kgriffs> next: Autoreconnect not handled in all cases
15:27:21 <kgriffs> so, this one is waiting on the atomic batch insert patch
15:27:32 <alcabrera> kgriffs: sure, I can fix that bug in the next hour (re: cached shard state)
15:27:33 <kgriffs> malini: any chance that patch will get benchmarked in the next few hours?
15:27:39 <kgriffs> alcabrera: cool, thanks!
15:27:46 <malini> kgriffs: I just ran it now & have the results
15:27:52 <malini> was abt to update the patchset
15:27:56 <kgriffs> ah, cool
15:27:57 <kgriffs> thanks!
15:28:33 <malini> kgriffs: sorry..it took me long to get to it..Have lot of other stuff going on
15:28:38 <flaper87> we'll need another patch besides the batch one
15:28:40 <flaper87> right ?
15:28:46 <kgriffs> so, the autoreconnect fix may slip into i-3, we'll see
15:28:48 <kgriffs> flaper87: right
15:28:54 <kgriffs> but it will be fairly simple
15:28:55 <flaper87> then yeah, i-3
15:29:16 <kgriffs> next: hecking whether queue exists adds latency
15:29:28 <kgriffs> so, i just noticed there were some gate errors on that patch
15:29:32 <kgriffs> I need to look into that
15:29:43 <flaper87> I just submitted a patch updating our cache code
15:29:50 <kgriffs> flaper87: cool
15:29:56 <flaper87> rm common/cache add openstack/common/cache
15:30:00 <kgriffs> it would be good to get that in for i-2
15:30:11 <flaper87> if jenkins is happy, we can merge it in
15:30:15 <kgriffs> next: [wsgi] Duplicate config options relating to max Content-Length
15:30:24 <kgriffs> flaper87: sounds like a plan!
15:30:39 <kgriffs> so, that config patch sort of morphed into a grab-bag of fixes
15:30:43 <flaper87> but if we had to choose between this and other more important patch, I'd pick the more important (gate load wise)
15:30:54 <kgriffs> flaper87: kk
15:32:20 <kgriffs> tbh, I think that if all we got landed in time were the shard state and the atomic posts, I'd be OK with that.
15:32:37 <kgriffs> malini: did https://review.openstack.org/#/c/67320/ degrade performance significantly?
15:32:38 <kgriffs> ?
15:32:51 <malini> kgriffs: yes
15:33:08 <malini> & for some strange reason other API calls were also slowed down, not just post messages
15:33:22 <kgriffs> hmmm
15:33:23 <kgriffs> ok
15:33:27 * kgriffs sad panda
15:33:32 <malini> :(
15:33:35 <flaper87> brb
15:33:36 <kgriffs> ok, well, I'll look into that
15:34:07 <kgriffs> malini: can you do another round of testing, just to be sure?
15:34:13 <malini> kgriffs: sure
15:34:33 <kgriffs> so... it looks like that may slip into i-3 if I can't find anything obvious to fix wrt performance
15:34:53 <kgriffs> ok, anything else anyone wants to discuss for i-2?
15:35:17 <kgriffs> #topic Heat template status update
15:36:09 <kgriffs> I see this has a -1 on it: https://review.openstack.org/#/c/61036/
15:36:40 <kgriffs> flwang: do you know the status of this? Is Liang in the channel?
15:37:12 <flwang> kgriffs: sorry, i don't sure, since now Liang is taking over it
15:37:25 <kgriffs> flwang: what is his irc nick?
15:37:48 <flwang> kgriffs: liang
15:37:51 <kgriffs> heh
15:37:51 <flwang> iirc
15:38:41 <kgriffs> ok
15:39:20 <flwang> I can catch him tomorrow
15:39:25 <kgriffs> flwang: that would be cool
15:39:31 <kgriffs> Just want to keep this patch moving forward
15:39:37 <flwang> and have a sync with flaper87
15:40:04 <kgriffs> #action flwang to follow up on heat patch with liang
15:40:18 <kgriffs> #topic SQLAlchemy status update
15:40:36 <kgriffs> so, I haven't seen much activity on that work lately
15:40:43 <kgriffs> makes me nervous. :p
15:42:09 <kgriffs> flaper87: have you heard from Yeela lately (not sure if I spelled her name correctly)
15:43:21 * kgriffs watches a tumbleweed roll by
15:43:51 <kgriffs> flaper87: can you follow up with Yeela?
15:44:20 <kgriffs> I would like to see this driver land in the next few weeks
15:44:25 * alcabrera notices everyone is so busy lately
15:44:36 <kgriffs> alcabrera: srsly.
15:45:21 <kgriffs> alcabrera: let's leave this on the agenda for next time. we may need someone else to step up if Yeela doesn't have the bandwidth.
15:46:16 <kgriffs> #topic SQLalchemy storage driver strategy
15:46:26 <kgriffs> alcabrera: what was this one about, do you recall?
15:46:47 <alcabrera> let's see...
15:47:14 <alcabrera> I vaguely remember this being about how we were going to break up the remaining work for the sqlalchemy driver
15:47:41 <alcabrera> kgriffs: we may need to decide to move forward with it sooner, or to punt it for beyond icehouse.
15:47:45 <kgriffs> oh, so between shard stuff and queue stuff, for example?
15:47:56 <alcabrera> yes, things of that nature. :)
15:48:00 <kgriffs> ok
15:48:02 <kgriffs> hmmm
15:48:32 <kgriffs> alcabrera: can you make a note to chase down yeela and get this sorted?
15:48:42 <kgriffs> flaper87 should have some contact info
15:48:52 <alcabrera> kgriffs: sure thing
15:48:55 <kgriffs> thanks!
15:49:02 <alcabrera> flaper87: let's talk about this later
15:49:09 * flaper87 just got back
15:49:13 <flaper87> sorry guys
15:49:15 <flaper87> erm
15:49:21 <alcabrera> no worries
15:49:26 <kgriffs> #action alcabrera to work with ykaplan and flaper87 to come up with a plan to reboot the SQL driver work
15:49:38 <flaper87> alcabrera: sqla ? sure, lets talk about that right after the meeting
15:49:54 <alcabrera> cool, thanks!
15:50:00 <kgriffs> #topic tempest-integration
15:50:02 <kgriffs> malini: status?
15:50:21 <malini> It is stalled at this point :(
15:50:26 <malini> I am not getting any reviews
15:50:29 <kgriffs> oh
15:50:41 <malini> I need a couple of devstack patches merged
15:50:52 <malini> I pinged in openstack-infra, no luck yet :(
15:51:03 <kgriffs> malini: ah, they are probably swamped with i-2
15:51:14 <malini> the qa folks need those patches merged before they'll merge my tempest patch
15:51:19 <kgriffs> oic
15:51:43 <malini> I hope I can get some folks to review it after i-2
15:52:02 <kgriffs> malini: ok, try again friday/monday
15:52:11 <kgriffs> ping jaypipes
15:52:13 <malini> I will
15:52:25 <malini> jaypipes is qa, rt?
15:52:35 <malini> We need some infra help, before tht
15:52:51 <kgriffs> #action malini to follow up with infra after i-2 lands
15:52:55 <kgriffs> malini: mmm, not sure
15:53:03 <kgriffs> I thought he was infra, but I could be wrong
15:53:08 <kgriffs> flaper87: do you know?
15:53:10 <malini> I'll check again & follow up
15:53:23 <flaper87> kgriffs: infra
15:53:25 <kgriffs> kk
15:53:33 <malini> cool!!
15:53:55 <kgriffs> #topic pecan-framework
15:54:00 <kgriffs> balajiiyer: status?
15:54:13 <balajiiyer> kgriffs: going slow.
15:54:46 <balajiiyer> updated BP milestone to i3
15:55:07 <kgriffs> ok
15:55:19 <kgriffs> balajiiyer: btw, have you done anything with Falcon in the past?
15:55:39 <balajiiyer> kgriffs: small apps during hackathons, yes
15:55:42 <kgriffs> ok
15:56:06 <kgriffs> it would be great if you could take notes about your experience using Pecan
15:56:21 <kgriffs> how easy it is to learn, how productive you feel using it, etc.
15:56:41 <balajiiyer> kgriffs: Ok. can I also take notes about stevedore? ;)
15:56:45 <kgriffs> yes
15:56:47 <kgriffs> please do
15:56:52 <kgriffs> :)
15:57:33 <kgriffs> so, obviously part of your learning curve is just the semantics of Marconi
15:57:51 <kgriffs> but, I'd like to get a view into the part that involves the framework and stuff
15:57:55 <kgriffs> one last thing
15:58:14 <kgriffs> you may wish to also use WSME
15:58:14 <balajiiyer> kgriffs: yes, I have a standalong pecan app running that delivers mock endpoints
15:58:31 <kgriffs> that is something that the oslo team is pushing pretty hard along with pecan
15:58:36 * flaper87 has to notes to add
15:58:40 <flaper87> to the meeting
15:58:44 <flaper87> not the pecan discussion
15:58:45 <flaper87> :D
15:58:45 <kgriffs> kk
15:58:46 <balajiiyer> kgriffs: Im spending a lot of time trying to fit that into marconi framework
15:58:52 <kgriffs> oic
15:58:54 * flaper87 is sick of that discussion
15:58:56 <flaper87> :D
15:59:00 <kgriffs> for sure!
15:59:04 <flaper87> (just kidding and being pedantic)
15:59:06 <flaper87> hahaha
15:59:09 * kgriffs doesn't think it should even be an issue
15:59:24 <kgriffs> ok
15:59:26 <kgriffs> last item
15:59:28 <kgriffs> #topic docs
15:59:29 <kgriffs> so...
15:59:39 <flaper87> 1 min left
15:59:40 <kgriffs> turns out having user and operator docs is a req. for graduation now
15:59:53 <kgriffs> just FYI
16:00:16 <kgriffs> so, i made a bp
16:00:25 <kgriffs> see also:
16:00:27 <kgriffs> #link http://git.openstack.org/cgit/openstack/governance/tree/reference/incubation-integration-requirements
16:00:32 <kgriffs> #topic open discussion
16:00:39 <kgriffs> 30 seconds. :p
16:01:00 <flaper87> the -2 cut will be the first tarball creation for marconi, right?
16:01:07 <kgriffs> flaper87: yep
16:01:13 <flaper87> cool, so that everyone knows
16:01:15 <flaper87> :D
16:01:25 <flaper87> also, we may be interviewed in today's TC meeting
16:01:25 <kgriffs> ok, anything else?
16:01:32 <flaper87> not written on stone though
16:01:34 <flaper87> that's it
16:01:37 <kgriffs> flaper87: right, thanks for the reminder
16:01:58 <alcabrera> thanks for the meeting, everyone.
16:02:06 <kgriffs> that is 3pm EST, btw
16:02:09 <kgriffs> (that meeting)
16:02:17 <alcabrera> #info TC Meeting @ 3pm EST
16:02:21 <balajiiyer> in this room?
16:02:23 <adrian_otto> please #endmeeting
16:02:37 <kgriffs> balajiiyer: in #openstack-meeting I believe
16:02:44 <kgriffs> k guys, thanks!
16:02:49 <flaper87> o/
16:02:54 <kgriffs> #endmeeting