15:01:01 <flaper87> #startmeeting Marconi
15:01:02 <openstack> Meeting started Tue Feb 11 15:01:01 2014 UTC and is due to finish in 60 minutes.  The chair is flaper87. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:06 <openstack> The meeting name has been set to 'marconi'
15:01:11 <flaper87> alcabrera: do you have the agenda?
15:01:15 <flaper87> :D
15:01:20 <alcabrera> yes I do. :)
15:01:32 <alcabrera> #link https://wiki.openstack.org/wiki/Meetings/Marconi#Agenda
15:01:41 <alcabrera> very packed - we'll have much discussion today
15:01:55 <flaper87> #info flaper87 could get fuel out of his coffee... It's soooo deeply dark
15:02:01 <alcabrera> lol
15:02:11 <alcabrera> that will be the highlight of today's meeting
15:02:21 <flaper87> lets get started
15:02:24 <flaper87> #topic summit
15:02:37 <malini> yayyy ATL
15:02:39 <alcabrera> so, let's submit a talk(s)
15:02:41 <flaper87> so, the idea would be to do a joint talk for the summit as we did last year
15:02:45 <alcabrera> #link https://etherpad.openstack.org/p/marconi-icehouse-talk
15:02:53 <flaper87> we've this week to submit the proposal
15:03:12 <flaper87> the idea would be not to do an introductory talk because we expect folks to be already familiar with Marconi
15:03:21 <flaper87> (at least those attending to the summit)
15:03:30 <flwang> flaper87: +1
15:03:32 <alcabrera> +1
15:03:37 <flaper87> what we would like to do is present Marconi for realz
15:03:48 <flaper87> Real examples, deployments and code. That is.
15:03:55 <alcabrera> We've got great titles so far
15:03:55 <flwang> how about the best practice in Rackspace ?
15:03:57 <malini> what abt a demo which wud replace some other queue used in OS with Marconi?
15:04:09 <malini> Without raising controversioes of course
15:04:23 <flaper87> malini: good idea but I'd avoid that :(
15:04:41 <flaper87> I think there's no way to do it without having people saying "YOU'RE REPLACING MY DEAR RABBIT"
15:04:42 <malini> yeah..will create too much heated discussions
15:04:42 <alcabrera> flwang: I heard that oz_akan from Rackspace might be presenting on deploying Marconi (best practices, too)
15:04:57 * flaper87 would happily eat that rabbit at lunch
15:05:00 <flwang> alcabrera: cool, I will join
15:05:11 * flaper87 hopefully didn't offend any vegan nor vegetarian in this channel
15:05:23 <flaper87> so, there's an ehterpad that alcabrera already linked
15:05:27 <alcabrera> battle of the queues might be an event held elsewhere. :)
15:05:29 <flaper87> lets all contribute there
15:05:46 <flaper87> We should agree on something by EOD
15:05:57 <flaper87> and submit the proposal today / tomorrow
15:06:00 <flwang> may I get another Marconi T-shirt this time :)?
15:06:06 <malini> where's the etherpad? sorry I am so out of touch with tempest going on
15:06:18 <amitgandhi> https://etherpad.openstack.org/p/marconi-icehouse-talk
15:06:20 <flwang> https://etherpad.openstack.org/p/marconi-icehouse-talk
15:06:22 <flaper87> flwang: just if you put yourself in the queue
15:06:24 <flaper87> :D
15:06:44 <flaper87> #link https://etherpad.openstack.org/p/marconi-icehouse-talk
15:06:46 <flaper87> malini: ^
15:06:49 <flwang> flaper87: coool, pls put me in the queue, amen
15:06:53 <alcabrera> +1 about submitting by tomorrow EOD
15:07:01 <flaper87> queue.post(flwang)
15:07:01 <malini> thanks you for the link!
15:07:02 <alcabrera> who wants to write the proposal for the joint talk?
15:07:17 * flaper87 is burried in stuff
15:07:18 <alcabrera> I'm happy to volunteer.
15:07:23 <flaper87> alcabrera: it's yours
15:07:26 <alcabrera> cool
15:07:30 <alcabrera> action-ize me flaper87
15:07:32 <flaper87> #action alcabrera to write the talk proposal
15:07:37 <balajiiyer> +1 on contributing for the talk
15:07:47 <balajiiyer> alcabrera: I will chip in
15:07:49 <flaper87> any other comment?
15:08:05 <alcabrera> alright, and there's
15:08:09 <alcabrera> err, one more
15:08:19 <alcabrera> I'll see if oz_akan wants to submit an ops-marconi proposal
15:08:24 <alcabrera> action-ize me on that, too.
15:08:27 <flaper87> alcabrera: that would be awesome
15:08:59 <flaper87> #action alcabrera to force oz_akan to submit an ops-marconi talk proposal. Use brute force if necessary
15:09:02 <balajiiyer> thinking out loud - can oz 's talk be a workshop?
15:09:02 <alcabrera> #info contribute towards a great marconi proposal https://etherpad.openstack.org/p/marconi-icehouse-talk
15:09:15 <alcabrera> lol flaper87
15:09:32 <alcabrera> hmm
15:09:34 <flaper87> balajiiyer: it could, not sure how much he hast to say about it
15:09:36 <alcabrera> I wonder...
15:09:41 <flaper87> workshops are normally >1h
15:09:51 <malini> we shud let oz decide how he wants to do it (A)
15:09:59 <alcabrera> +1 malini
15:10:01 <balajiiyer> we will ask him to do it real sloooooow
15:10:06 <balajiiyer> ;)
15:10:18 <alcabrera> alright :D
15:10:21 <flaper87> t h i s  i s  m a r c o n i
15:10:23 <alcabrera> I'd say we're ready to move on
15:10:24 <flaper87> like that?
15:10:27 <flaper87> ok, moving on
15:10:32 <flaper87> #topic sqlalchemy
15:10:33 <alcabrera> sqlalchemy ->
15:10:38 <alcabrera> w00t
15:10:41 <flaper87> alcabrera: SO haskelized
15:10:48 <flaper87> alcabrera: floor is yours
15:10:48 <alcabrera> lol
15:10:56 <alcabrera> map (review) patches
15:10:58 <alcabrera> anyway
15:11:00 <alcabrera> :D
15:11:16 <alcabrera> we've got some lovely patches sitting in the review queue for sqlalchemy
15:11:31 <alcabrera> #link https://review.openstack.org/#/c/70202/
15:11:41 <flaper87> alcabrera: +1
15:11:45 <flaper87> thanks for the effort there
15:11:47 <alcabrera> #link https://review.openstack.org/#/c/70946/
15:11:56 <alcabrera> #link https://review.openstack.org/#/c/71335/
15:12:00 <alcabrera> and...
15:12:09 <alcabrera> #link https://review.openstack.org/#/c/70947/
15:12:12 <malini> https://review.openstack.org/#/q/status:open+project:openstack/marconi+branch:master+topic:bp/sql-storage-driver,n,z
15:12:23 <alcabrera> malini: even better!
15:12:23 <malini> hope tht has all of it
15:12:27 <flaper87> #link https://review.openstack.org/#/c/72677/
15:12:37 <flaper87> so, I went ahead and worked on the message controller
15:12:37 <alcabrera> that's all 5 of them
15:12:55 <flaper87> it should be complete now but it depends on the queue controller and the claim one (which we don't have yet)
15:13:07 <alcabrera> sweet
15:13:08 <flaper87> so, that review is likely to fail but we could start putting some eyes there
15:13:11 <alcabrera> thanks, flaper87!
15:13:18 <flaper87> on the other hand we should all work on reviewing alcabrera patches
15:13:23 <alcabrera> #info flaper87 made great progress on message controller
15:13:29 <flaper87> those are independent and ready to be merged
15:13:35 <alcabrera> +1
15:13:36 <flaper87> well,ready to be reviewed
15:13:38 <flaper87> :D
15:13:44 <flaper87> we'll see alcabrera, we'll see
15:13:46 <flaper87> :P
15:13:49 <alcabrera> #info shard driver ready for review
15:13:51 <alcabrera> lol
15:14:09 <alcabrera> so, schedule-wise...
15:14:19 <flaper87> also, alcabrera patches have some things I'd love to base mine (and the queue's controller) on
15:14:29 <flaper87> so, lets focus on those reviews and start testing the driver
15:14:34 <alcabrera> we're doing alright
15:14:43 <alcabrera> I'll finish the catalogue driver by tomorrow EOD
15:14:44 <flaper87> alcabrera: agreed, we'll make it
15:14:47 <alcabrera> and then we're all caught up
15:14:51 <alcabrera> +1 flaper87
15:15:00 <alcabrera> #info sqlalchemy on schedule
15:15:05 <alcabrera> malini: any thoughts on testing?
15:15:22 <malini> I will start working on adding the gating jobs today
15:15:42 <flaper87> malini: AWESOME!
15:15:43 <alcabrera> thanks! That'd be awesome. :)
15:15:47 <flaper87> cpallares: welcome :)
15:15:51 <malini> first one will be for mongo - since we already have everything in place for tht
15:15:54 <cpallares> o/
15:16:08 <flaper87> malini: sounds good
15:16:13 <flaper87> is there anything blocking you?
15:16:21 <malini> no..just me :)
15:16:26 <malini> tht can be easily unblocked
15:16:50 <flaper87> #action malini to unblock herself
15:16:51 <malini> I have been focussing on getting the tempest stuff merged
15:17:05 <malini> So havent been able to spend time on the gating jobs yet
15:17:36 <flaper87> malini: once we complete the work on sqlalchemy, we could help you out if there are still pending things
15:17:51 <malini> cool  :)
15:17:57 <alcabrera> sweet
15:18:03 <flaper87> any other comment?
15:18:08 <alcabrera> I'm good.
15:18:15 <alcabrera> Next up is another hot topic
15:18:22 <flaper87> #topic API v1.1
15:18:28 <alcabrera> kgriffs is missing out. :(
15:18:36 <malini> just a quick tempest update before tht?
15:18:43 <flaper87> #action to beat kgriffs for not being around
15:18:48 <alcabrera> sure thing, malini
15:18:53 <flaper87> #topic tempest update
15:19:08 <malini> I think I am really close - but keeps moving an inch away each time
15:19:13 <malini> :|
15:19:26 <malini> I submitted another patch y'day for devstack https://review.openstack.org/#/c/72412/
15:19:55 <alcabrera> #link https://review.openstack.org/#/c/63449/
15:19:57 <alcabrera> #link https://review.openstack.org/#/c/72412/
15:19:59 <alcabrera> getting close
15:20:12 <malini> Have two +2s , so might get merged soon - but it needs another patch to be merged before 72412 can be merged
15:20:13 <flaper87> not sure why there are to +2s and no approve
15:20:23 <alcabrera> #info malini making good progress on marconi/temptest integration
15:20:25 <flaper87> malini: feel free to ping them on irc
15:20:34 <malini> flaper87: I already am
15:20:39 <flaper87> malini: awesome
15:20:44 <malini> https://review.openstack.org/#/c/69497/ might end up as a blocker for us
15:21:02 <alcabrera> hmmm
15:21:07 <alcabrera> refactoring patch!
15:21:17 <malini> yeah..
15:21:35 <malini> But I'll keep pinging folks so we can get tempest merged
15:21:36 <alcabrera> well, hopefully that comes along quickly
15:21:38 <alcabrera> we'll see
15:21:44 <flaper87> malini: +1
15:21:56 <malini> tht's it for tempest update
15:22:15 <flaper87> malini: thanks a lot for the update and the hard work there
15:22:21 <malini> as far as grad req go
15:22:33 <malini> we need to have a 'basic devstack gate job in place'
15:22:45 <flaper87> ok
15:22:53 <malini> So hopefully we'll be covered with the basic tempest patch merged
15:23:07 <flaper87> malini: awesome! That would cover API v1
15:23:08 <flaper87> right?
15:23:20 <flaper87> Do you think moving to API v1.1 will be hard ?
15:23:23 <malini> right now all we have is a basic create queue
15:23:33 <malini> flaper87: moving to 1.1 wont be hard
15:23:37 <flaper87> cool
15:23:41 <malini> is 1.1 needed to graduate?
15:23:42 <flaper87> that makes me happy
15:23:47 <alcabrera> malini: no
15:23:54 <flaper87> no but it is for icehouse
15:24:04 <flaper87> I mean, it would be nice to release 1.1 as part of icehouse
15:24:10 <flaper87> hence, we need to test it
15:24:15 <alcabrera> #info extending tempest test suite to include v1.1 not expected to be difficult
15:24:19 <malini> tht shud be do-able
15:24:25 <flaper87> cool beans
15:24:46 * flaper87 doesn't know where "cool beans" comes from but he learned that from kgriffs
15:24:57 <malini> :D
15:25:01 <alcabrera> lol
15:25:02 <flaper87> anyway, moving on
15:25:04 <alcabrera> yup
15:25:06 <flaper87> #topic API v1.1
15:25:08 <alcabrera> back to api v1.1
15:25:21 <flaper87> #link https://wiki.openstack.org/wiki/Marconi/specs/api/v1.1
15:25:27 <flaper87> that's the spec
15:25:37 <flaper87> I imagine you know it all
15:25:42 <alcabrera> hahaha
15:25:46 <alcabrera> on good days, yes
15:25:47 <flaper87> :P
15:26:02 <alcabrera> I added sharding to that document last week
15:26:09 <flaper87> so, I took a quick look and it seems to be in good shape
15:26:12 <alcabrera> so we're offering quite a jump in power
15:26:17 <alcabrera> going from 1.0 -> 1.1
15:26:37 <alcabrera> I agree that it looks good
15:27:13 <flaper87> Something that makes me happy is that we're not doing any change to the schema in the database
15:27:29 <alcabrera> that's often a good sign - we have a good foundation
15:27:31 <flaper87> for the record, we're going to basically copy v1 into v1.1 and change it
15:27:45 <alcabrera> +1
15:27:48 <flaper87> that's not what we want to do in the long run but it's the best we can do now
15:27:58 * alcabrera forsees much refactoring
15:28:02 <flaper87> during June, I'd like us to dedicate some time figuring out a better way to do that
15:28:15 <flaper87> hopefully the experiment cpallares is working on will be of great help there
15:28:24 <alcabrera> oh yes
15:28:46 <cpallares> \o/
15:28:47 <flaper87> AFAIK, cpallares said it's all done and she's been using it for a couple of weeks already
15:28:51 <flaper87> OOOOOOOOPSSSSSSSSSSS
15:28:53 <flaper87> she's here
15:28:56 <alcabrera> lol
15:29:18 <cpallares> lol
15:29:25 <cpallares> it needs tweaking
15:29:26 <flaper87> so, does anyone have comments w.r.t the API spec ?
15:29:35 <alcabrera> not I
15:29:41 <flaper87> Lets make sure we make those comments NOW
15:29:41 <alcabrera> oh
15:29:43 <alcabrera> one thing
15:29:49 <flaper87> and by now I mean before implementing it
15:29:51 <flaper87> :P
15:29:57 <flaper87> alcabrera: gp
15:29:58 <flaper87> go
15:30:04 <alcabrera> returning an empty default body things like GET messages is great
15:30:06 <alcabrera> instead of 204
15:30:06 <malini> ha sit already been emailed out to openstack-dev ML ?
15:30:11 <malini> has it *
15:30:15 <alcabrera> it simplifies the handling a bit
15:30:28 <alcabrera> default reprs are a nifty idea we should do more of in the future
15:30:46 <alcabrera> that's it
15:30:52 <alcabrera> malini: I'm not sure... flaper87?
15:31:04 <flaper87> it hasn't been sent to the m-l yet
15:31:23 <alcabrera> we should action-ize that - who wants to write email? :D
15:31:23 <flaper87> alcabrera: +1 for empty default bodies
15:31:30 * alcabrera looks at ghostly kgriffs
15:31:35 <flaper87> #action send the v1.1 spec to the mailing list
15:31:40 <alcabrera> hehe
15:31:55 <alcabrera> alright, so let's move on to specific v1.1 items
15:32:06 <flaper87> comments?
15:32:33 <flaper87> #topic health endpoint
15:32:38 <flaper87> flwang: alcabrera floor is yours
15:32:39 <alcabrera> flwang: regarding v1.1 /health, it seems like the way to go is to start a v1_1 directory and implement it there
15:33:09 <flwang> alcabrera: ok
15:33:15 <alcabrera> so what we have now is marconi.queues.transport.wsgi. We need is marconi.queues.transport.wsgi.v1 and marconi.queues.transport.wsgi.v1_1
15:33:27 <alcabrera> thoughts?
15:33:37 <alcabrera> does this align with our v1.1 strategy alright?
15:33:46 <flaper87> alcabrera: that sounds like a plan
15:33:52 <alcabrera> cool
15:33:54 <alcabrera> so that
15:33:56 <alcabrera> 's two steps
15:34:01 <flaper87> I can do pacakage moving thing if you guys want
15:34:05 <alcabrera> 1. separate our current API into v1
15:34:11 <alcabrera> 2. implement health in v1_1
15:34:14 <alcabrera> flaper87: that'd be awesome!
15:34:16 <alcabrera> yes, please
15:34:18 <alcabrera> :D
15:34:35 <flwang> alcabrera: agree and we may need to implement the /ping first
15:34:43 <flaper87> #action flaper87 to put the wsgi transport under the v1 version and clone it to v1_1
15:34:56 <alcabrera> cool
15:35:13 <alcabrera> #action flwang to continue work on /health and /ping for v1.1
15:35:27 <alcabrera> any other thoughts?
15:35:33 <flaper87> not from me
15:35:40 <flwang> alcabrera: cool
15:35:43 <alcabrera> sweet
15:35:52 <alcabrera> flaper87: grace not required - the floor is yours
15:35:54 <alcabrera> :D
15:35:57 <flwang> I will implement the /ping endpoint first
15:35:58 <flaper87> #topic Grace not required
15:36:00 <flaper87> SOOOOO
15:36:13 <malini> tht is disgraceful
15:36:20 <flaper87> I found out today (and don't laugh at me) that we require grace
15:36:34 <alcabrera> it gets me every time, hehe
15:36:38 <flaper87> I don't think that makes much sense TBH
15:36:39 <malini> :D
15:36:46 <alcabrera> agreed
15:36:50 <flaper87> first impression from a user stand point is: WTF?
15:36:55 <flaper87> the second is: What should I use?
15:37:05 <alcabrera> and all under the covers
15:37:08 <flaper87> the third is: I'll put whatever comes to my mind in 3 2 1 ...
15:37:08 <alcabrera> ttl = ttl + grace
15:37:11 <alcabrera> the magic secret
15:37:14 <alcabrera> which is confusing
15:37:15 <flaper87> exactly
15:37:25 <flaper87> so, we should accept it but not require it
15:37:31 <alcabrera> +1
15:37:45 <alcabrera> I'd even go so far as suggesting we remove it from the public API for v1.1 or v2.0
15:37:50 <alcabrera> it's an implementation detail
15:37:56 <alcabrera> we can offer wiggle room internally
15:37:58 <alcabrera> configurable and all
15:38:00 <flaper87> mmh
15:38:04 <alcabrera> but users should only need to care about TTL
15:38:09 <flaper87> so, the change I was proposing was for v1.1
15:38:19 <flaper87> but if we think removing it makes more sense then fine
15:38:20 <malini> so have a default grace value, but use config value if provided?
15:38:29 <flaper87> although, removing it requires a major release
15:38:31 <flaper87> maybe
15:38:49 <alcabrera> I'm advocating: mark as deprecated in public API v1.1, remove in v2.0
15:38:56 <flaper87> alcabrera: +1
15:38:59 <flaper87> sounds like a plan
15:39:06 <flaper87> lets see what kgriffs thinks
15:39:10 <alcabrera> yup
15:39:12 <alcabrera> to address malini
15:39:15 <alcabrera> 's question
15:39:43 <alcabrera> For now, users have to provide it. The plan is to make it optional, and use a deployment-time/config option to replace it. The operator decides the wiigle grace.
15:39:50 <alcabrera> *wiggle
15:40:33 <flaper87> I don't quite remember why we thought that requiring it makes sense
15:40:39 <malini> alcabrera: thanks!! that makes sense
15:40:39 <flaper87> I'm pretty sure there's a reason
15:40:50 <alcabrera> we'll find out from kgriffs later. ;)
15:40:51 <flaper87> but it doesn't make sense to me now
15:40:55 <flaper87> alcabrera: yeha
15:40:57 <flaper87> yeah
15:41:08 <alcabrera> so let me info this and let's move on. :D
15:41:23 <alcabrera> #info /claims grace to be deprecated in v1.1 and removed in v2.0
15:41:44 <flaper87> awesome, thanks
15:41:47 <flaper87> moving on
15:41:51 <alcabrera> let's talk about gacks and pops, flaper87
15:41:58 <flaper87> #topic Add gack and/or pop
15:42:03 <flaper87> #topic Add gack and/or pop to API v1.1
15:42:05 <flaper87> :D
15:42:17 <alcabrera> could you elaborate on these two ideas, flaper87?
15:42:18 <flaper87> First, let me explain what gack and pop are
15:42:36 <flaper87> Gack (not exacly the best name) is basically get and ack
15:42:53 <flaper87> the idea behind it is to be able to get a message and make sure *no one else will*
15:43:15 <flaper87> when getting a message and then claiming it it is possible that some other client would try to do the same
15:43:25 <flaper87> this means that a message could be delivered more than once
15:43:33 <alcabrera> doesn't /claim already fetch the message(s) for you?
15:43:33 <flaper87> and the jobs executed twice
15:43:40 <flaper87> mmh, does it ?
15:43:44 <flaper87> :D
15:43:46 <alcabrera> I thought so. :P
15:43:48 * alcabrera checksa
15:44:10 <alcabrera> #link https://wiki.openstack.org/wiki/Marconi/specs/api/v1.1#Claim_Messages
15:44:11 <flaper87> If it does then that covers gack which is awesome
15:44:12 <alcabrera> yes, it does
15:44:19 <flaper87> I bet it is a mix of claim + limit
15:44:26 <flaper87> ah ok, v1.1
15:44:28 <flaper87> ok ok
15:44:31 <alcabrera> so gack == claim?limit=1
15:44:37 <flaper87> yeah
15:44:48 <flaper87> I'd say we don't need it then.
15:44:54 <alcabrera> #info gack is already provided as /claim?limit=1
15:44:55 <flaper87> folks can claim 1 message
15:45:10 <flaper87> next one, and alcabrera I'm sure as hell we don't have it, is pop
15:45:11 <flaper87> :D
15:45:19 <flaper87> this is basically get-and-delete
15:45:32 <alcabrera> heh
15:45:41 <alcabrera> so atomic get-and-delete
15:45:45 <flaper87> yeah
15:45:53 <flaper87> this is pretty useful for things like kombu
15:46:09 <flaper87> where you want to get a message out of the queue and you don't want to make another call to delete it
15:46:24 <alcabrera> hmmm
15:46:29 <flaper87> Avoiding those 2 calls we would make the client life easier and Marconi's server load lower
15:46:44 <alcabrera> there's a tricky point there I worry about, having used marconi extensively recently
15:46:53 <flaper87> shoot
15:47:03 <alcabrera> So, a worker claims a message
15:47:14 <alcabrera> that worker maybe does somethings
15:47:27 <alcabrera> then crashes before deleting the message after doing those things
15:47:42 * alcabrera tries to think this through more clearly
15:47:55 <alcabrera> The gist of it: I'm worried that -
15:48:03 <malini> alcabrera: tht is exactly what I am thinking too
15:48:13 <malini> I cannot think of an use case
15:48:15 <flaper87> so, if the worker uses pop, it doesn't have to delete the message from the queue. The message will be deleted when it gets the message
15:48:16 <alcabrera> if claim-and-delete is used, the task might never really get processed if a worker crashes
15:48:26 <alcabrera> *get-and-delete
15:48:27 <malini> it sounds like a claim with delete built in
15:48:33 <flaper87> alcabrera: ah yeah but that's up to the implementation
15:48:41 <flaper87> I mean, we can't protect the client from that
15:48:44 <alcabrera> hmmm
15:48:45 <flaper87> that's up to the client
15:48:46 <alcabrera> true
15:48:49 <alcabrera> so
15:48:51 <alcabrera> given that
15:48:56 <alcabrera> I'm in favor of this pop behavior
15:48:57 <flaper87> what we can is give it an easier way to do claim->delete
15:49:09 <alcabrera> given that clients can still manually do things if they want to separate the claim from the delete
15:49:20 <flaper87> indeed
15:49:26 <alcabrera> cool
15:49:31 <alcabrera> what do you think, malini?
15:49:33 <flaper87> I mean, a client could also do: claim->delete and then crash
15:49:45 <flaper87> so, we won't ever be able to protect them from that
15:49:57 <flaper87> we can make it easier for them to shoot their own feet though
15:49:58 <flaper87> :P
15:50:01 <alcabrera> heh
15:50:03 <malini> if it crashes after processing, we are ok
15:50:16 <alcabrera> kk
15:50:19 <malini> the message is not lost in tht case
15:51:12 <flaper87> Thing is that get-and-delete is a common pattern and doing claim->delete will be expensive for both the client and marconi
15:51:55 <flaper87> #info pop seems to be a good idea. It needs further discussion and it may make sense to have it for v1.1
15:51:55 <alcabrera> I'm in favor of pop as an optimization, since alternate operations are still available
15:51:58 <alcabrera> +1
15:52:04 <alcabrera> that's the info I would've given. :D
15:52:05 <flaper87> any other comment?
15:52:07 <malini> flaper87: agreed abt more ops being expensive..will do some homework on kombu to understand an use case
15:52:10 <alcabrera> none form me
15:52:12 <alcabrera> *form
15:52:14 <alcabrera> ...
15:52:16 <alcabrera> *from
15:52:23 <alcabrera> next
15:52:25 <flaper87> #topic Open Discussion
15:52:39 <alcabrera> yup - +1 for open discussion
15:52:45 <alcabrera> we don't have much time left to review BPs/bugs
15:53:04 <flaper87> So, at the next summit, kgriffs said he wants to offer beers, food and whatever we want
15:53:12 <flaper87> he told me to share this with y'all
15:53:15 <alcabrera> lol
15:53:22 <malini> :D
15:53:27 <alcabrera> this kgriffs fellow is very generous
15:53:29 <alcabrera> <3
15:53:36 <flaper87> #action Everyone to thank kgriffs for being so nice and paying for whatever we need at the next summit
15:53:43 <alcabrera> yaaay
15:53:50 <alcabrera> #info this kgriffs fellow is very generous
15:53:52 <alcabrera> better
15:53:54 <flaper87> so, I've been burried in stuff lately
15:53:54 <alcabrera> ah
15:54:06 <malini> we are getting buried in snow ;)
15:54:07 <cpallares> lol
15:54:07 <flaper87> but I'd ask everyone to do an extra efford and review the sqlalchemy patches
15:54:17 <flaper87> give them some priorities over other things
15:54:44 <flaper87> not sure why I said "some priorities" but anyway, you got my point
15:55:00 <flaper87> malini: it hasn't snowed much here this winter :(
15:55:09 <alcabrera> two non-sqlalchemy patches want review love, too
15:55:14 <alcabrera> #link https://review.openstack.org/#/c/68267/
15:55:27 <alcabrera> ^^ guard against bad URI in shard registration
15:55:28 <alcabrera> and...
15:55:36 <alcabrera> #link https://review.openstack.org/#/c/70463/
15:55:43 <alcabrera> cleanup limit configs - great refactoring
15:55:44 <flaper87> alcabrera: dude, stop coding, you're burrying us all with reviews
15:55:49 <alcabrera> lol
15:55:52 <alcabrera> ;D
15:56:17 <flaper87> so, any other comment ?
15:56:33 <flaper87> any cat that needs to be rescued ?
15:56:41 <alcabrera> yaks need shaving?
15:56:45 <alcabrera> *needing
15:56:57 <flaper87> ok, that's all folks!
15:56:59 <alcabrera> I think we're good.
15:57:02 <alcabrera> thanks for joining!
15:57:05 <flaper87> thanks everyone and see you in #openstack-marconi
15:57:07 <flaper87> #endmeeting