15:00:32 <kgriffs> #startmeeting marconi
15:00:33 <openstack> Meeting started Tue Mar  4 15:00:32 2014 UTC and is due to finish in 60 minutes.  The chair is kgriffs. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:34 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:37 <openstack> The meeting name has been set to 'marconi'
15:00:42 <flaper87> 'SUP PEOPLEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEE?????????????????
15:00:48 <kgriffs> roll call
15:00:50 <kgriffs> o/
15:00:57 <malini> \o/
15:01:06 <flaper87> o/
15:01:09 <alcabrera> hey all!
15:01:12 <balajiiyer> o/
15:01:15 <saikrishna_> hi all!
15:01:32 <flwang> o/
15:01:40 <flaper87> wow, so many folks
15:01:49 <alcabrera> we grow every few weeks. :)
15:01:50 <flaper87> It brings tears to my eyes
15:01:56 * alcabrera hands out the poptarts
15:02:10 <malini> alcabrera: the dentist would love tht
15:02:16 <alcabrera> lol
15:02:19 <alcabrera> oh yes
15:02:21 <alcabrera> [$]
15:02:31 <kgriffs> #topic actions from last time
15:02:46 <alcabrera> #link http://eavesdrop.openstack.org/meetings/marconi/2014/marconi.2014-02-18-15.04.html
15:02:48 <kgriffs> just one was noted
15:02:49 <kgriffs> balajiiyer to follow up with Megan and get us a case study for the summit talk
15:02:52 * flaper87 remembers last time actions once in a week
15:03:00 <alcabrera> not much action last time - how unusual!
15:03:04 <flaper87> guess what, it always happens on Tuesdays at 15:00 UTC
15:03:09 <balajiiyer> kgriffs: can we carry forward it to this week?
15:03:10 <kgriffs> heh
15:03:17 <kgriffs> #action balajiiyer to follow up with Megan and get us a case study for the summit talk
15:03:32 <kgriffs> #topic i-3
15:03:51 <alcabrera> Oh yeah - i3 is close
15:03:53 <alcabrera> very close
15:03:58 <flaper87> like hours close
15:03:58 <malini> it is here!
15:04:23 <kgriffs> flaper87: last time they cut it the following morning. Will they cut during the TC meeting this time do you think?
15:04:28 <kgriffs> sorry, not TC meeting
15:04:30 <kgriffs> release meeting
15:04:43 <kgriffs> I know last time was a special case because of zuul
15:04:45 <flaper87> kgriffs: no, it usually closes at some late time in the west coast
15:04:54 <flaper87> so the cut will happen in the morning
15:05:02 <kgriffs> oh good!
15:05:04 <flaper87> but we should block patches today
15:05:15 <flaper87> those that are not worth shipping with i-3
15:05:21 <kgriffs> ok
15:06:08 <kgriffs> I am going to blitz v1.1 over the next few hours. If I can't get all the patches in by the next 3 hours, let's say v1.1 is going to be an experimental feature
15:06:19 <kgriffs> people will have to go get HEAD to play with it at the summit
15:06:31 <flaper87> sure thing
15:06:52 <kgriffs> ok. sorry, I'm an eternal optimist. :p
15:06:58 <kgriffs> other patches?
15:07:07 <kgriffs> #link https://launchpad.net/marconi/+milestone/icehouse-3
15:07:33 <flwang> kgriffs: /health ?
15:07:54 <flaper87> flwang: I think we should hold it until after i-3
15:08:11 <flaper87> and I'm not sure whether it makes sense to let it land after the FF
15:08:13 <flwang> flaper87: do that mean Juno ?
15:08:14 <flaper87> what do you think?
15:08:24 <kgriffs> hmm
15:08:49 <flwang> flaper87: if you guys believe its overall shape is ok, how about lets try to land it before 6 Mar
15:08:57 <alcabrera> have we solidified the health/ping semantics?
15:09:04 <flwang> i-3 but after FF
15:09:06 <alcabrera> if we have, then I'm favorable towards letting it land soon
15:09:14 <alcabrera> and making small fixes to it as needed
15:09:18 <flwang> and yes, it depends on the overall v1.1 status
15:09:23 <kgriffs> are we "allowed" to land features after i-3 but still for icehouse?
15:09:23 <flaper87> ok, lets work on that
15:09:39 <flaper87> kgriffs: you mean after FF
15:09:47 <kgriffs> flaper87: that's what I mean
15:09:50 <kgriffs> FF for i-3
15:09:50 <flaper87> kgriffs: yest but only if a Feature Freeze Exception is granted
15:09:58 <flwang> 4 Mar is FF, 6 Mar is i-3
15:10:09 <kgriffs> ok
15:10:10 <kgriffs> hmmm
15:10:11 <flwang> https://wiki.openstack.org/wiki/Icehouse_Release_Schedule
15:10:12 <alcabrera> I gotta run guys. I think I'll be back in time for the last 10 minutes of this meeting!
15:10:22 <flaper87> flwang: lets work on getting it ready and then ask a Feature Freeze if necessary
15:10:30 <alcabrera> my basic thoughts: api v1.1 and tempest need help
15:10:30 <flaper87> alcabrera: kk, ttyl
15:10:32 <alcabrera> o/
15:10:49 <flwang> flaper87: ok
15:10:51 <kgriffs> flaper87: yep, I was just under the impression that FF for the last milestone was also FF for the icehouse release, which seems to be correct
15:10:58 <malini> we also need somebody to start working on sqlalchemy tests
15:11:14 <flaper87> kgriffs: yep
15:11:20 <flaper87> malini: mmh, what tests?
15:11:31 <flaper87> there are tests for sqlalchemy already
15:11:35 <malini> the gate jobs against diff backends
15:11:37 <flwang> flaper87: +1
15:11:50 <malini> flaper87: we have only unit tests, rt?
15:12:00 <flaper87> malini: oh ok, yeah, I'll help you creating some gates for that
15:12:00 <flwang> malini: you mean functional test?
15:12:04 <flaper87> malini: nope, functional too
15:12:05 <malini> we need the functional tests running against diff backends
15:12:31 <malini> flaper87: tht is cool..I didnt know tht !!
15:12:38 <flaper87> malini: I'll help you getting the sqlalchemy gate setup
15:12:39 <flwang> kgriffs: seems we're still missing the func test against v1.1
15:12:40 <malini> I'll chk it out
15:12:46 <flaper87> malini: I replaced all the sqlite tests with sqlalchemy
15:12:47 <flaper87> :)
15:12:51 <kgriffs> flwang: yes we are
15:12:53 <flwang> flaper87: malini: cound me
15:13:22 <flwang> kgriffs: do you think it's a blocker for landing the v1.1?
15:13:26 <malini> I was planning to start working on fun tests for 1.1, if somebody can tackle the gate part..I have a good idea of what/how to do tht
15:13:30 <flwang> kgriffs: if so, seems we can't make it
15:14:16 <flwang> malini: count me, after I complete the /health
15:14:32 <malini> flwang: awesome! thabks!
15:14:35 <kgriffs> flwang: well, our only possible solution would be to add functional tests to the mainline and if we find any bugs, we would need to backport those to the icehouse RC
15:14:35 <malini> thanks! *
15:15:22 <flwang> kgriffs: make sense for me, thanks for the clarification
15:15:34 <kgriffs> ok, so I would like to propose a 2-hour super hero sprint
15:15:39 <kgriffs> lots of code, lots or reviewing
15:15:54 <flaper87> kgriffs: sounds good
15:16:00 <kgriffs> then we meet back in #openstack-marconi and decide what our final bp
15:16:05 <flwang> kgriffs: +1
15:16:05 <kgriffs> set of bp's will be
15:16:30 <flaper87> kgriffs: we could probably make today's meeting shorter and use that time for coding too
15:16:34 <kgriffs> ok
15:16:39 <kgriffs> let's speed this along then
15:16:47 * kgriffs seconds flaper87's motion
15:16:53 <kgriffs> #topic tempest
15:16:55 <flwang> flaper87: competing with time?
15:16:59 <kgriffs> malini: status?
15:17:15 <malini> I have a patch outstanding to address the devstack issue
15:17:22 <flaper87> flwang: I'm always competing with time :P
15:17:32 <kgriffs> malini: have you confirmed it will work?
15:17:34 <malini> https://review.openstack.org/77832
15:17:36 <flaper87> malini: mind giving a summary of the latest findings
15:17:41 <flaper87> ?
15:17:57 <malini> kgriffs: it does work on a brand new devstack install when I tried..so hope it'll work
15:18:09 <flaper87> malini: cool
15:18:13 <malini> I pinged a few core reviewers..but havent heard back yet
15:18:25 <malini> flaper87: Its basically a workaround till we figure the stdout issue
15:18:42 <flaper87> looks like a fix to me
15:18:44 <flaper87> :P
15:18:59 <kgriffs> flaper87: the gist is that something still requires stdout but we can't figure out what
15:19:05 <malini> flaper87: hmm…I would like to know why ..but can live with this for now
15:19:11 <kgriffs> we tried monkey-patching sys.stdout and nobody called write on it
15:19:23 <flaper87> mmhh, that's interesting
15:19:34 <flaper87> what's even more interesting is that all projects are using the same logging module
15:19:45 <flaper87> so, I can't think OTOH what's wrong with marconi
15:19:46 <kgriffs> so, we got logging to stop using stdout
15:19:53 <malini> flaper87, flwang: if you are buddies with any devstack core reviewers, try bribing them to look at the patch ;)
15:19:53 <kgriffs> so I don't think it's logging any more
15:19:55 <kgriffs> something else
15:20:12 <malini> flaper87: I think there is something different
15:20:28 <malini> only ceilometer & us specify the log dir in devstack scripts
15:20:30 <kgriffs> anyway, if we can get this to land and revisit for Juno, that would be WUNDERBAR
15:20:50 <flaper87> malini: mmhh
15:20:52 <flaper87> ok
15:21:09 <flaper87> malini: and now you know what project I copied our devstack code fromn
15:21:11 <flaper87> :D
15:21:16 <malini> :D
15:21:17 <kgriffs> devstack does crazy stuff with FD redirects
15:21:17 <flaper87> from*
15:21:17 <flwang> malini: may i know the patch link? I will see what I can do
15:21:29 <flaper87> ok, moving forward
15:21:31 <kgriffs> yep
15:21:32 <malini> flwang: https://review.openstack.org/#/c/77832
15:21:40 <flwang> malini: thanks
15:21:49 <malini> flwang: thank You!!
15:21:57 <kgriffs> kk
15:22:01 <kgriffs> let's git-r-done
15:22:15 <kgriffs> #topic documentation
15:22:18 <kgriffs> balajiiyer: ^^^
15:22:33 <balajiiyer> kgriffs: Latest patch set 20 needs some review
15:22:53 <flaper87> balajiiyer: gtk
15:22:58 <malini> balajiiyer: can you post the review link plz?
15:23:06 <balajiiyer> https://review.openstack.org/#/c/72001/
15:23:16 <balajiiyer> There was a trademark issue on 19, that was fixed.
15:23:20 <flaper87> #link https://review.openstack.org/#/c/72001/
15:23:43 <balajiiyer> We also have operations doc now
15:24:17 <kgriffs> balajiiyer: is that part of the same patch?
15:24:18 <balajiiyer> Oz will be submitting a patch today
15:24:21 <kgriffs> oic
15:24:22 * flaper87 wants an operation gummy bears
15:24:27 <kgriffs> ok, let's get these merged today
15:24:28 <cpallares> lol
15:24:42 <kgriffs> if needed, please file bugs for minor nits and we will follow up
15:24:52 <kgriffs> let's make sure the major stuff is OK
15:25:01 <flwang> kgriffs: +1
15:25:12 <balajiiyer> kgriffs: ok
15:25:21 <kgriffs> #topic sqlalchemy
15:25:32 <flaper87> IT'S DONEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEE
15:25:35 <kgriffs> w00t
15:25:40 <flwang> haha
15:25:41 <kgriffs> this one should be done right? https://blueprints.launchpad.net/marconi/+spec/sql-sharding-controllers
15:25:48 <balajiiyer> flaper87: awesome
15:25:56 <flaper87> kgriffs: yeah, alej completed the sharding part
15:26:05 <kgriffs> ETOO_MANY_EES
15:26:11 <flaper87> we need to test it carefully with other backends now
15:26:14 <kgriffs> k, I will update that bp
15:26:18 <flaper87> kgriffs: you mean, EEEEEEEEEEEEEEEEEEETOMANYEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEE
15:26:31 <kgriffs> heh
15:26:33 <flwang> kgriffs: I would suggest to make sqlalchemy as the default backend to be more friendly for the new comer
15:26:43 <flwang> kgriffs: flaper87: make sense?
15:26:48 <flaper87> so, I'll help amlini with getting the gate done for that
15:26:53 <flaper87> flwang: it is the default backend
15:27:04 <flwang> flaper87: now?
15:27:07 <flaper87> yes
15:27:08 <flwang> flaper87: coooooooooooool
15:27:15 <flaper87> haha
15:27:27 <kgriffs> can I mark as implemented the SQL Storage Driver?
15:27:29 <flaper87> it's funny how I swapped it and people still thinks they're using sqlite
15:27:30 <kgriffs> I assume so...
15:27:33 <flaper87> muahahahah muahahha muahahaha
15:27:35 <flaper87> :D
15:27:35 <flwang> flaper87: I'm always using mongodb, so i'm not aware of that
15:27:44 <flaper87> well, they're using sqlite but through sqla
15:27:49 <alcabrera> lol
15:27:55 * alcabrera returns sooner than expected
15:27:56 <flaper87> kgriffs: yeah, mark it as done
15:28:00 <flaper87> alcabrera: coool, wb
15:28:04 <alcabrera> kgriffs: +1 for sql marked as done
15:28:13 <flwang> alcabrera: $$$$$$
15:28:20 * ametts is going to try it with Microsoft Access
15:28:24 <alcabrera> at this point, it's just bug fixes, since it's functionally feature complete
15:28:29 <flaper87> alcabrera: hahahahahahahaha
15:28:32 <flaper87> hahaha
15:28:33 <kgriffs> ametts: that's crazy talk!
15:28:35 <flaper87> ametts: ^
15:28:49 <alcabrera> ametts: try out the experimental Microsoft Excel backend. :P
15:28:55 <kgriffs> #topic pecan
15:29:13 <balajiiyer> kgriffs: working on perf benchmarks
15:29:26 <balajiiyer> I have numbers with tsung, wrking with ab now
15:29:31 <kgriffs> This can land after the FF, but I want to make sure we are on track to deliver a good, objective report
15:30:04 <balajiiyer> kgriffs: yeah, have to do some due diligence before I can publish numbers, will have it by end of this week
15:30:30 <kgriffs> balajiiyer: rock on
15:30:37 <alcabrera> cool
15:30:46 <alcabrera> #note balajiiyer making good progress on evaluating pecan
15:31:10 <alcabrera> any other thoughts on this topic?
15:31:23 <kgriffs> The more things we can quantify, the better
15:31:55 <balajiiyer> Im using mongodb as the storage driver, and possibly look at in-memory storage drivers
15:31:59 <balajiiyer> any other ideas what else I can do?
15:32:32 <flaper87> balajiiyer: sqlalchemy + mysql
15:32:39 <alcabrera> flaper87: +1
15:32:50 <alcabrera> so, another thought came to mind
15:32:58 <balajiiyer> Im treating this as 'Marconi in Pecan', vs 'Marconi in Falcon', so Im swapping out transport drivers, keeping everything else a constant.
15:33:24 <balajiiyer> flaper87: ok
15:33:29 <alcabrera> There's a lot of talk of performance, and I understand that's a point of interest. It's one of the easier things to measure objectively.
15:33:50 <alcabrera> I'm very interested in the subjective side of the equation, too
15:34:01 <alcabrera> how easy is it to extend marconi using one vs. the other?
15:34:07 <alcabrera> Things of that nature.
15:34:13 <flaper87> balajiiyer: also, lets make sure we come up with some ideas as to how both pecan and falcon can be improved
15:34:18 <alcabrera> I understand that's hard to be objective about, though. :/
15:34:45 <flaper87> the whole point is not just to find out which is faster, easier etc but to come up with an idea of how we can contribute back to both communities regardless of our final choice
15:34:54 <alcabrera> good words, flaper87
15:34:57 <balajiiyer> alcabrera: yeah, I have a set of evaluation criteria, that is one of those.
15:35:17 <flwang> flaper87: +1
15:35:17 <alcabrera> people will continue to use pecan and falcon for their own projects. Let's try to make both more awesome
15:35:36 <kgriffs> good thoughts
15:35:58 * flaper87 for president
15:36:10 <alcabrera> #note pecan+falcon: how can we make both better? Share feedback with community
15:36:15 * alcabrera votes flaper87 - every time
15:36:49 <balajiiyer> *takes notes*
15:37:10 <flaper87> ok, open discussion and then code ?
15:37:25 <alcabrera> api v1.1 discussion is next, I believe
15:37:45 <flaper87> yeah, we were thinking to make the meeting shorter this week and do a full code immersion
15:37:50 <alcabrera> ah
15:37:52 <alcabrera> okay
15:37:59 <alcabrera> sounds good to me
15:38:01 <kgriffs> #note Goals for Pecan evaluation include: identify areas of improvement for both frameworks where we can contribute, provide guidance on when to use each framework, deliver metrics, and provide well-thought-out arguments for subjective metrics
15:38:12 <flaper87> not sure what kgriffs thoughts are about moving the v1.1 discussion to the enxt meeting
15:38:36 <kgriffs> oh, I'm pretty much ignoring today's agenda. :p
15:38:40 <flaper87> LOL
15:38:44 <kgriffs> crunch time
15:38:45 <flaper87> hahaha
15:38:48 <flaper87> ROFL
15:39:07 <kgriffs> ok, let me just emphasize this point and then let's get to work
15:39:38 <kgriffs> Imagine if we could rewind 18 months or so
15:39:46 <kgriffs> and our team were the ones floating the idea of Pecan
15:40:30 <kgriffs> now, what kind of a report would we create and circulate to other OS teams?
15:40:53 <kgriffs> maybe that isn't quite the right thought experiment, but you get the idea
15:41:28 <kgriffs> actually
15:41:33 <alcabrera> kind of fuzzy
15:41:35 <kgriffs> let's adjust this
15:41:54 <kgriffs> so, here is how I would personally go about introducing pecan
15:42:17 <kgriffs> first, I would find a different project and ask them to basically do what we are doing
15:42:33 <kgriffs> I would want an "outside" opinion
15:42:58 <kgriffs> and I would consider carefully a set of criteria
15:43:19 <kgriffs> then I would take the results to the community and see if I could get another project to give Pecan a try
15:43:43 <kgriffs> preferably a core (AKA "kernel") project: network, storage, compute
15:44:15 <alcabrera> what that tells me, is that this is only the beginning of the evaluation question
15:44:44 <alcabrera> what would API v3 in Nova look like with Falcon is the first thing that comes to mind
15:44:50 <alcabrera> things of that nature
15:45:01 <alcabrera> I'm favorable towards an ongoing experiment
15:45:22 <alcabrera> tool diversity is a powerful thing
15:45:27 <alcabrera> that's it from me
15:46:05 <flaper87> sounds good to me too
15:46:22 <kgriffs> I tried to argue last year for a broader evaluation period on the ML. Not that I think Falcon is inherently "better" but that this is how you create standards in a community; you do it organically and with evaluations, gathering the data over time and working towards a rough consensus.
15:46:27 <kgriffs> But, I was shouted down
15:46:51 <alcabrera> :(
15:46:54 <kgriffs> in any case, I am trying to keep our evaluation as objective and serious as possible
15:47:11 <balajiiyer> *hopes to deliver*
15:47:12 <kgriffs> that is why I explicitly wanted balajiiyer to lead that effort.
15:48:08 <kgriffs> he is brand new to openstack, and started with little to no experience in either framework
15:48:40 <kgriffs> and I have been telling everyone every chance I get to quantify things, be open-minded, and let's do this the right way
15:49:17 <kgriffs> Ideally, we would take our findings to the community and see if we can get another project to do the same excercise
15:50:08 <kgriffs> Could everyone come back and say Falcon totally sucks and nobody wants to use it?
15:50:19 <kgriffs> sure.
15:51:13 <kgriffs> but I suspect the answer is going to be more gray than that and we will find that arguing over which is better: forks or knives
15:51:33 <kgriffs> ...is just silly and a huge waste of time
15:52:04 <kgriffs> whenever someone asks me what framework they should use for their new project, I say: try both and decide which one works best for you, your team, and your project
15:52:16 <alcabrera> +1
15:52:18 <kgriffs> I honestly do
15:52:31 <kgriffs> All I am asking is for promoters of other frameworks to do the same
15:52:41 <kgriffs> this is how you build a community
15:52:55 <flwang> kgriffs: +1
15:52:55 <kgriffs> and yes, I am well aware this is all going on the record.
15:53:07 <kgriffs> someone needed to recognize the elephant in the room
15:53:07 * alcabrera cheers
15:53:40 <alcabrera> #note kgriffs advocates for open-minded evaluation of tools and technologies
15:54:10 <kgriffs> ok, sorry, this ended up taking the full hour after all.
15:54:18 <kgriffs> #topic open discussion
15:55:05 <flaper87> #link https://plus.google.com/events/ckjhm8rggnqvrnspftna845kubk
15:55:23 <alcabrera> oh yeah
15:55:25 <flaper87> Marconi hangout
15:55:26 <alcabrera> March 27
15:55:39 <flwang> flaper87: I will watch it
15:55:50 <alcabrera> #note Marconi G+/Hangout happening March 27
15:56:03 <malini> what is tht for?
15:56:21 <flwang> general or any best practice
15:56:54 <kgriffs> ok, so everyone have a good idea of what they will focus on the next 2 hours
15:57:19 <flwang> I have watched all the Marconi I can get from youtube, including kgriffs', flaper87 and alcabrera's, haha
15:57:27 <kgriffs> oh oh. :)
15:57:39 <kgriffs> #endmeeting