15:01:46 <kgriffs> #startmeeting marconi
15:01:47 <openstack> Meeting started Tue Mar 18 15:01:46 2014 UTC and is due to finish in 60 minutes.  The chair is kgriffs. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:48 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:51 <openstack> The meeting name has been set to 'marconi'
15:02:22 <kgriffs> #topic role-call
15:02:23 <kgriffs> o/
15:02:23 <alcabrera> o/
15:02:26 <sriram> o/
15:02:28 <alcabrera> race condition
15:02:30 <flwang> o/
15:02:31 <kgriffs> s/role/roll
15:02:49 <alcabrera> role: poptart distributor
15:02:49 <tjanczuk> o/
15:02:53 <mpanetta> o/
15:02:57 <tjanczuk> Folks, I am new here.
15:03:02 <kgriffs> tjanczuk: welcome!
15:03:14 * kgriffs gives tjanczuk his first pop-tart
15:03:43 <kgriffs> alcabrera: is amit around?
15:03:49 <gokrokve> \o
15:03:54 <alcabrera> not at his desk, kgriffs
15:03:57 <alcabrera> I saw him earlier
15:03:57 <kgriffs> kk
15:04:00 <tjanczuk> My name is Tomasz Janczuk, since recently I work for HP. Previously I worked for Microsoft (12 years) and did a startup. You can find me at http://github.com/tjanczuk, http://tomasz.janczuk.org, and @tjanczuk.
15:04:06 <alcabrera> tjanczuk: welcome!
15:04:18 <vkmc> o/
15:04:20 <gokrokve> Hi Tomasz!
15:04:32 <cpallares> o/
15:04:34 <kgriffs> node, eh?
15:04:36 <tjanczuk> I am spelunking Marconi, and will have a few questions about plans and directions if you don't mind.
15:04:43 * kgriffs likes node and their community
15:04:46 <tjanczuk> Yes, node ;)
15:05:00 <kgriffs> tjanczuk: ok, we should have some time during open discussion
15:05:11 <tjanczuk> great, thanks
15:05:18 <kgriffs> #link https://wiki.openstack.org/wiki/Meetings/Marconi#Agenda
15:05:24 <kgriffs> #topic pecan evaluation
15:05:36 <kgriffs> #link https://wiki.openstack.org/wiki/Marconi/pecan-evaluation
15:05:38 <alcabrera> mmm, pecans
15:05:42 <alcabrera> they are most delicious
15:05:45 <kgriffs> so, Balaji stayed up all night to finish this
15:05:51 <kgriffs> he is sleeping now
15:05:52 <kgriffs> :)
15:06:01 <alcabrera> sleeping next to me - with his eyes open! :D
15:06:05 <sriram> hah.
15:06:19 <kgriffs> balajiiyer: d00d, I thought you were in teh bed
15:06:27 * kgriffs wonders if balajiiyer is human
15:06:56 <balajiiyer> kgriffs: apparently you cant sleep through the morning if you have a toddler at home. 'daddy wake up, brush your teeth'
15:07:02 <kgriffs> LOOOOL
15:07:20 <kgriffs> so, first off, a GREAT BIG THANK YOU to Balaji!
15:07:38 * sriram claps
15:07:43 * alcabrera cheers
15:07:51 <kgriffs> #info Balaji kicks a**
15:08:12 <balajiiyer> You are very welcome folks, couldnt have done without you all
15:09:36 <balajiiyer> kgriffs: can you add that link to the bp?
15:09:52 <kgriffs> balajiiyer: sure
15:09:55 <mpanetta> Yay!  It was a good read too :)
15:10:16 <gokrokve> That is great. Reading this now.
15:11:30 <kgriffs> balajiiyer: can you change the bp to "implemented"?
15:11:52 <balajiiyer> kgriffs: done
15:12:05 <kgriffs> thanks
15:12:27 <alcabrera> w00t
15:12:40 <mpanetta> Sweetness!
15:13:13 <kgriffs> balajiiyer: so, it looks like if performance were equal, the decision matrix would still favor Falcon?
15:14:01 <balajiiyer> balajiiyer: I would think so. Development experience is better with Falcon while writing ReST APIs
15:14:23 <flwang> kgriffs: w00t
15:14:31 <kgriffs> balajiiyer: ok, you may want to call that out since it sounds like you are basing your recommendation mostly on perf
15:14:44 <sriram> yeah doing the math, Pecan comes out at 387 if performance were equal.
15:15:44 <kgriffs> FWIW, I've heard the same thing anecdotally from lots of people who try Falcon.
15:17:31 <kgriffs> ok, so as Pecan as a framework continues to improve, I think we should consider re-evaluating for our 2.0 API
15:17:37 <kgriffs> that is my proposal
15:17:44 <alcabrera> sounds fair
15:17:46 <alcabrera> ah
15:17:50 <alcabrera> on that note
15:18:06 <alcabrera> question: what can Pecan do to improve? what can Falcon do to improve?
15:18:14 <alcabrera> what are some solid recommendations for each framework?
15:18:26 <kgriffs> balajiiyer: maybe you could make a couple bullet lists?
15:19:27 <kgriffs> otherwise, anyone object to posting this to the ML?
15:19:34 <alcabrera> no objections from me
15:19:45 <kgriffs> would we put it under [marconi] or... ?
15:20:05 <alcabrera> hmmm
15:20:11 <alcabrera> it has that flavor
15:20:17 <alcabrera> since queues were used for benchmakring
15:20:19 <alcabrera> but also
15:20:21 <alcabrera> [wsgi]
15:20:24 <alcabrera> seems very relevant
15:20:34 <tjanczuk> On the topic of performance, were there some performance measurements done for Marconi under different scale situations (#queues, #requests etc)? I could not find much browsing on the web.
15:20:43 <ametts> Is there a [pecan] now that it's in stackforge?
15:21:27 <alcabrera> ametts: there is
15:21:42 <balajiiyer> kgriffs: I would put it under Marconi, since this evaluation is done for 'Marconi', and I evaluated only the features that were required for Marconi
15:21:53 <alcabrera> example: http://lists.openstack.org/pipermail/openstack-dev/2014-March/029099.html
15:22:05 <balajiiyer> iow, the evaluation is specific to marconi
15:23:31 <amitgandhi> i agree it should be in marconi
15:23:42 <alcabrera> so as far tagging, it seems [marconi][pecan] might be the most eye-catching
15:23:45 <alcabrera> and relevant
15:23:50 <alcabrera> *far -> for
15:23:52 <kgriffs> tjanczuk: we have done some, but perhaps not published them as broadly as we should have. I would welcome further work in that area.
15:24:50 <kgriffs> #note need to do more performance tests, vary number of queues, requests, etc. and publish them
15:25:11 <tjanczuk> kgriffs: is there any data you could share?
15:25:14 <kgriffs> tjanczuk: it may make sense to make that a Juno bp - feel free to register one
15:26:11 <kgriffs> tjanczuk: you can ping balajiiyer and malini in #openstack-marconi after the mtg. I believe they have some tsung tests they can share that includes all the message operations.
15:26:53 <amitgandhi> at some point it may just make sense to build a complete pecan driver, and a set of benchmark tests for marconi, and have them run periodically.  And deployers can then just choose between falcon or pecan themselves.
15:27:06 <tjanczuk> thanks
15:27:17 <kgriffs> balajiiyer: ok, so can you add some bullets for recommendations to the wiki, and then post to the ML?
15:27:45 <balajiiyer> kgriffs: ok, will do
15:27:49 <kgriffs> #action balajiiyer to post pecan eval to the ML
15:27:51 <flwang> amitgandhi: seems a big effort :D
15:29:15 <amitgandhi> flwang: it is, but also periodically running benchmark tests is also a big effort.  i guess its relative between just building a pecan driver or keep on benchmarking
15:30:27 <alcabrera> we need to eventually automate our benchmarking system, much like speed.pypy.org (http://speed.pypy.org/)
15:30:32 <amitgandhi> +1
15:30:50 <alcabrera> that's valuable, regardless of whether we choose to support new storage/transport drivers
15:30:58 <kgriffs> +1
15:31:07 <kgriffs> I think we may even already have a bp to do that
15:31:13 <kgriffs> we'll triage that once Juno opens
15:31:41 <alcabrera> cool
15:32:05 <kgriffs> #topic ATL summit
15:32:06 <alcabrera> #note consider automating benchmarking infra; very valuable
15:32:19 <alcabrera> the ATL summit - coming soon!
15:32:22 <kgriffs> yes
15:32:25 <sriram> +1
15:32:34 <kgriffs> everyone have their session proposals in?
15:33:18 <kgriffs> if not, please do that this week
15:33:19 <kgriffs> :)
15:33:28 <balajiiyer> I submitted one for 'Notifications', it says it is 'Unreviewed'. Who reviews and approves it?
15:33:56 <flwang> kgriffs will be the guru :D
15:34:17 <balajiiyer> o kcool
15:35:48 <cpallares> is the hardware hacking still happening? :P
15:35:48 <kgriffs> #link http://summit.openstack.org/
15:35:59 <kgriffs> technically, you have until April 20 to submit
15:36:15 <kgriffs> I'm just trying to encourage everyone to get them in early
15:36:18 <kgriffs> :D
15:36:30 <kgriffs> anything else on this topic people want to bring up?
15:36:37 <flwang> kgriffs: i have posted the signed messages idea
15:36:50 <kgriffs> flwang: nice, thanks
15:37:09 <mpanetta> cpallares: I got my led strips in, let the hardware hacking happen! :P
15:37:31 <cpallares> mpanetta: woooh!
15:37:57 <mpanetta> I was going to bring them to work today, but decided against it...
15:38:20 <kgriffs> so, I think there will be a team meet-and-greet on the evening of the 10th for folks who are in town
15:38:30 <kgriffs> we should find a time during the week as well to go do dinner together
15:39:03 <alcabrera> +1
15:39:08 <cpallares> +2
15:39:13 <kgriffs> rock on
15:39:16 <kgriffs> #topic Review updates to the API v1.1 spec: remove metadata, pop semantics, lazy queue create (kgriffs)
15:39:37 <kgriffs> I think we should wait on this until next week when Flavio can be here
15:39:51 <kgriffs> is that cool with everyone?
15:39:52 <flwang> kgriffs: +1
15:40:06 <ametts> +1
15:40:48 <alcabrera> works for me
15:40:57 <balajiiyer> +1
15:40:57 <sriram> +1
15:41:22 <kgriffs> ok. Some folks had questions regarding the metadata thing, specifically. I think metadata would be fairly easy to implement with topics; we just have a different table for that and only lazy-add records if/when user sets metadata for a given topic
15:41:33 <kgriffs> but anyway, everyone think on that and please review the current spec
15:41:49 <kgriffs> #link https://blueprints.launchpad.net/marconi/+spec/api-v1.1
15:42:04 <kgriffs> it doesn't have metadata endpoints right now, but I am leaning towards adding them back
15:42:51 <kgriffs> #topic review actions from last time
15:42:58 <kgriffs> Looks like we just had one: flaper87 to add a bug for sqla GC
15:43:03 <kgriffs> iirc, that is done
15:43:13 <kgriffs> anything else from last week people want to mention?
15:43:45 <balajiiyer> kgriffs: I will continue to follow up with megan_w on customer stories for ATL summit
15:43:54 <kgriffs> thanks!
15:44:01 <megan_w> kgriffs: sounds good
15:44:09 <kgriffs> in other news, I believe we finally squashed the devstack bug causing marconi-server to crash
15:44:16 <amitgandhi> w00t!
15:44:18 <balajiiyer> yay
15:44:31 <kgriffs> kudos to mpanetta and malini!
15:44:43 <alcabrera> thanks to mpanetta for wrapping this daemonic issue up, and malini for carrying it all the way to completion. :)
15:45:00 <kgriffs> #topic Review Graduation BPs/Bugs
15:45:09 <kgriffs> here is my hit list:
15:45:15 <kgriffs> 1. merge docs
15:45:24 <kgriffs> 2. get gate working with mysql backend
15:45:43 * kgriffs wonders if that is it)
15:46:26 <kgriffs> 3. fix pypy issue that is blocking #1
15:46:43 <alcabrera> that pypy issue... :(
15:46:50 <flwang> kgriffs: I think there are 3 docs patches we need to merge and most of them are ready
15:47:31 <kgriffs> flwang: is that sphinx patch one of them?
15:47:39 <flwang> kgriffs: yes
15:47:58 <flwang> sphinx patch can fix the doc gate failure
15:48:35 <kgriffs> ok, but we still have the pypy thing which seems to be unrelated
15:49:00 <kgriffs> I need a volunteer to help track down the pypy thing
15:49:09 <flwang> kgriffs: yep, it's a blocker
15:49:57 <kgriffs> ok, if anyone has time today or tomorrow to assist, please do. Flavio has started looking at it too.
15:50:25 <flwang> kgriffs: I will keep an eye on that
15:50:26 <alcabrera> I'm looking as I can. I found a nova thread on the ML
15:50:31 <alcabrera> http://lists.openstack.org/pipermail/openstack-dev/2014-March/029508.html
15:50:38 <alcabrera> that relates to this pypy issue
15:50:40 <kgriffs> flwang, alcabrera: thanks for your help!
15:50:42 <alcabrera> it's known, thankfully
15:50:44 <alcabrera> :)
15:51:49 <adrian_otto> paste.openstack.org/show/73701/
15:52:01 <adrian_otto> that might help with your pypy concern
15:52:39 <kgriffs> adrian_otto: thanks!
15:52:39 <adrian_otto> trouble is new setuptools don't install properly through pip
15:52:51 <kgriffs> alcabrera: can you try submitting a patch with that?
15:52:51 <alcabrera> thanks, adrian_otto. I just saw this in the launchpad bug
15:52:52 <adrian_otto> causing the sudden breakage
15:52:55 <alcabrera> kgriffs: will do
15:53:01 <alcabrera> #link https://bugs.launchpad.net/openstack-ci/+bug/1290562
15:53:09 <alcabrera> #link http://paste.openstack.org/show/73701/
15:53:48 <kgriffs> ok folks, don't forget out graduation review is this afternoon during the TC meeting.
15:53:56 <kgriffs> #topic open discussion
15:54:23 <tjanczuk> I was curious what the plan is rearding AMQP, STOMP, and MQTT, if any?
15:54:32 <flwang> kgriffs: any outlook for the graduation? :)
15:56:53 <kgriffs> flwang: I am going through the latest requirements now, and will post our status in #openstack-marconi soon, but I think we are looking pretty good.
15:57:14 <flwang> kgriffs: cool
15:57:35 <tjanczuk> kgriffs: any chance we can talk for a few minutes at #openstack-marconi right after this meeting?
15:57:50 <kgriffs> tjanczuk: we are looking at AMQP for Juno. It will mean allowing a driver to only support a subset of the API, and we may need to add some stuff to v1.1 or v2.0 to help with mapping the semantics.
15:58:27 <kgriffs> tjanczuk: sure, the team is very active in our IRC channel, so feel free
15:58:56 <kgriffs> tjanczuk: wrt STOMP and MQTT, I don't think those have been discussed yet
15:59:26 <kgriffs> ok everyone, thanks!!!!
15:59:29 <alcabrera> o/
15:59:30 * kgriffs hands out pop-tarts
15:59:33 <alcabrera> I'll gather minutes.
15:59:39 <kgriffs> thanks man
15:59:41 <kgriffs> #endmeeting