15:00:14 <kgriffs> #startmeeting marconi
15:00:14 <openstack> Meeting started Tue Mar 25 15:00:14 2014 UTC and is due to finish in 60 minutes.  The chair is kgriffs. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:18 <openstack> The meeting name has been set to 'marconi'
15:00:20 <kgriffs> #topic roll call
15:00:21 <kgriffs> o/
15:00:29 <balajiiyer> o/
15:00:40 <flwang> \o/
15:00:44 <cpallares> o/
15:00:46 <alcabrera> \\o//
15:00:47 <oz_akan_> hey
15:00:50 <sriram> \o o/
15:00:58 <malini> o/
15:01:17 * alcabrera notices all of Marconi's team members are named after ascii-waving figures
15:02:05 <megan_w> o/
15:02:28 <alcabrera> #link https://wiki.openstack.org/wiki/Meetings/Marconi#Agenda
15:02:30 <kgriffs> thanks everyone for coming!
15:02:36 <kgriffs> #topic graduation review
15:03:00 <kgriffs> so, a few gaps I wanted to mention that weren't called out elsewhere
15:03:19 <kgriffs> first, everyone please sign up here: https://ask.openstack.org
15:03:30 <amitgandhi> o/
15:03:32 <kgriffs> and watch the "marconi" tag. I think it will email you
15:03:56 <kgriffs> participation there is a graduation requirement
15:04:15 <kgriffs> any questions?
15:04:21 <alcabrera> #action everyone sign up for ask.openstack.org
15:04:21 * malini signed up now
15:04:29 <alcabrera> #link https://ask.openstack.org
15:04:42 * kgriffs gives malini +5 bonus points
15:04:43 * sriram is signed up
15:05:03 <kgriffs> rock on. Like I said, please help me watch for questions there.
15:05:04 <malini> sriram gets +10 bonus points ;)
15:05:13 <kgriffs> pretty please with a cherry on top
15:05:15 <kgriffs> :)
15:05:17 <balajiiyer> *notices marconi is not in the tag cloud*
15:05:26 * alcabrera joined
15:05:35 * sriram woot
15:05:35 <balajiiyer> need more questions for marconi ;)
15:05:35 <malini> balajiiyer: I see marconi
15:05:53 <kgriffs> balajiiyer: there are just 1-2 questions so far, but that should be changing over the next several months as we work to get higher visibility
15:05:57 <balajiiyer> malini: I checked the tag cloud on the home page
15:06:12 * amitgandhi is signed up
15:06:18 <kgriffs> well, and heck, feel free to post your questions there and encourage friends and family too as well
15:06:18 <malini> balajiiyer: my home is probably different from yours ;)
15:06:32 <kgriffs> if we answer common questions "in the open" we build up a nice FAQ
15:06:40 <sriram> +1
15:07:08 <amitgandhi> our faq etherpad should move some of it to here
15:07:11 <kgriffs> so, when people ask something in IRC or on the ML, maybe we should direct them to Ask for certain types of Q's
15:07:20 <kgriffs> amitgandhi: good idea!
15:07:38 <kgriffs> anything an end-user or an operator would want to know, I guess
15:08:55 <kgriffs> #action everyone to cross-post FAQ for end users and operators on ask.openstack.org
15:09:18 <kgriffs> ok, next gap
15:09:19 <malini> are we allowed to do tht in ask? i.e Marconi team creating questions and answers vs questions coming from outside Marconi team?
15:09:51 <malini> Question for ask maybe
15:10:21 <amitgandhi> malini: if its valuable information i say yes
15:10:31 <amitgandhi> if its a sales pitch then prob not
15:11:01 <kgriffs> right, no astroturfing or whatever the correct term is
15:11:17 <kgriffs> but if it is a good, honest question, no reason to just post there and a different team member can answer
15:12:05 <flwang> kgriffs: yes, it's just a q&a system can be leveraged to track some useful info
15:12:09 <kgriffs> It's basically StackOverflow for marconi
15:12:16 <malini> cool
15:12:16 <flwang> kgriffs: +1
15:12:39 <kgriffs> anyway, only ask something there if you've heard the question come up a couple times in the wild and/or encourage the original questioner to post over there
15:12:49 <kgriffs> ok, next gap
15:12:50 <kgriffs> "Project must provide a 2+ person team that will handle the project specific vulnerability process"
15:13:01 <kgriffs> I need 2 volunteers for this one
15:13:16 <kgriffs> https://wiki.openstack.org/wiki/Vulnerability_Management
15:13:16 <malini> Is this security related?
15:13:19 <alcabrera> what does this even mean?
15:13:21 <kgriffs> malini: yes
15:13:21 <alcabrera> ah
15:13:23 <alcabrera> thanks for the link
15:13:28 <alcabrera> #link https://wiki.openstack.org/wiki/Vulnerability_Management
15:13:38 <kgriffs> so, they need help with patches, threat modeling, whatever
15:13:52 <malini> I emailed sriram who works in OSSG y'day, if he is interested in helping us with Security.
15:13:52 <alcabrera> very good page
15:14:26 <malini> He is interested in joining us, & will join us in openstack-marconi later (meeting time doesnt work for him)
15:14:32 <kgriffs> oic
15:14:52 <kgriffs> so, I can help with this as well
15:14:52 <malini> He might be a good person to help us with the open security bps as well
15:15:17 <kgriffs> but, my time is limited. too many fingers in too many pies. :p
15:15:27 <kgriffs> so, I'd like to still get two other volunteers besides myself
15:15:52 <kgriffs> ok, well, think on it and we will crystalize that committee next week
15:15:58 <kgriffs> sound good?
15:16:01 <amitgandhi> might be good to pull jdp into this too as he has interest (we can talk offline about it kgriffs)
15:16:03 <alcabrera> +1 for time to think and crystallize
15:16:08 <kgriffs> amitgandhi: kk
15:16:15 <kgriffs> amitgandhi: ping me after
15:16:16 <alcabrera> oh yes, jdp -- good suggestion, amitgandhi
15:16:33 <kgriffs> #action crystalize security swat team for Marconi
15:16:58 <kgriffs> one more gap
15:17:00 <kgriffs> "Project should have engaged with marketing team to check suitable official name"
15:17:35 <kgriffs> I asked around and the suggestion was to just show up at their next meeting and ask
15:17:41 * amitgandhi hopes we dont have to change to macaroni
15:17:46 <kgriffs> their mailing list is closed to non-subscribers
15:17:59 <kgriffs> amitgandhi: stop it! You're making me hungry!
15:18:06 <alcabrera> macaroni and openstack cheese
15:18:12 <kgriffs> mmmm
15:18:15 <sriram> hah
15:18:37 <flwang> OpenStack Messaging Service (Marconi)
15:18:51 <kgriffs> megan_w: do you have time on thursday at 11 central to attend the next marketing team meeting?
15:19:04 <megan_w> kgriffs: yes, i'll plan to attend
15:19:48 <kgriffs> ok, here is the info on the team and meeting time
15:19:48 <kgriffs> https://wiki.openstack.org/wiki/Governance/Foundation/Marketing
15:19:50 <kgriffs> #link https://wiki.openstack.org/wiki/Governance/Foundation/Marketing
15:19:59 <kgriffs> #action megan_w to attend marketing meeting
15:20:10 <megan_w> thanks
15:20:22 <kgriffs> megan_w: they should have an open discussion time at the end and we can ask them about that graduation requirement
15:20:35 <kgriffs> thanks for your help!
15:20:36 <megan_w> sounds good
15:20:38 <megan_w> np
15:20:56 <kgriffs> I'll try to be there too.
15:21:04 <kgriffs> #action kgriffs to attend marketing meeting
15:21:30 <kgriffs> ok, so those are the remaining gaps that I am aware of at this point.
15:22:01 <kgriffs> I noticed some more patches to the governance requirements doc, but I think we are already doing those
15:22:32 <alcabrera> #info gaps summary: ask participation, vulnerability handling team, marketing counsel <-> marconi name
15:23:15 <kgriffs> otherwise, as everyone is aware, we have been working on an etherpad to collect everyones thoughts on "what's next"
15:23:45 <kgriffs> #link https://etherpad.openstack.org/p/marconi-incubation-round-2
15:23:55 <kgriffs> please continue editing and contributing there.
15:24:18 <kgriffs> We will need to start crystalizing all this soon
15:24:49 <kgriffs> #action everyone to provide feedback on the incubation pad and discuss questions/ideas/concerns
15:24:55 <kgriffs> make sense?
15:25:07 <alcabrera> yup
15:25:14 <alcabrera> I'll take a look some time today. :)
15:25:14 <flwang> kgriffs: yes
15:25:21 <kgriffs> thanks!
15:25:26 <kgriffs> #topic ATL summit
15:25:47 <kgriffs> anyone have anything they want to mention on this topic?
15:26:05 <megan_w> i'll be there if you guys need any business-y support
15:26:25 <kgriffs> sweet
15:26:27 <malini> megan_w: we need more money ;)
15:26:30 <megan_w> i'm also working to get some use cases/testimonies together of people using marconi in productions
15:26:33 <alcabrera> lol, malini
15:27:01 <flwang> megan_w: is there any sessions about best practice of Marconi?
15:27:22 <megan_w> flwang: not sure
15:27:22 <flwang> deployment, GUI support, operations, etc
15:27:23 <kgriffs> flwang: you mean an OS talk or workshop?
15:27:29 <kgriffs> sorry
15:27:31 <flwang> kgriffs: yep
15:27:33 <kgriffs> s/OS/summit
15:27:49 <amitgandhi> oz_akan_ is doing the ops/deployment stuff right?
15:27:50 <kgriffs> so, I'm glad you brought that up. reminds me that I needed to tell everyone
15:28:02 <flwang> kgriffs: I'm going to start some work about this, so just curious if there is a session I can get some useful info :D
15:28:15 <kgriffs> for whatever reason, not a single one of the proposed talks was accepted by the track chairs
15:28:37 <kgriffs> and the workshop was accepted as an "alternate" in case a different workshop is cancelled
15:28:39 <alcabrera> We have "Hands On w/ Marconi" as an alternate
15:28:42 <flwang> kgriffs: so? we only have design session slots?
15:28:43 <alcabrera> yup
15:28:54 <amitgandhi> flwang: GUI support is almost there - i think horizon work was mostly done, but ran into some keystone related issues...
15:28:59 <kgriffs> so, we have the following venues
15:29:06 <kgriffs> 1. marconi design sessions
15:29:34 <kgriffs> 2. other projects design sessions (several projects are interested in integrating with marconi)
15:29:41 <flwang> amitgandhi: cool, thanks for that info
15:29:58 <flwang> amitgandhi: will it be completed in Icehouse?
15:30:01 <kgriffs> 3. there are some kind of 15 minutes talks going on - not sure if they are "summit" or some parallel conference that happens to be in the same location. :p
15:30:13 <kgriffs> flaper87 is watching for more info about #3
15:30:40 <amitgandhi> flwang: prob not.  last i heard jay-atl was working with flavio on the way marconi - keystone integration was happening.  I think that work has stalled
15:30:59 <kgriffs> 4. Project "Pod". Each project gets a dedicated hang-out / mini unconference table
15:31:06 <flwang> kgriffs: AFAIK, some companies are interested in porting Marconi in production env, so it would be super cool to have an operations session
15:31:36 <kgriffs> flwang: oz_akan_ proposed a talk on that. Maybe we can trim it to 15 minutes
15:31:46 <kgriffs> (to get it into venue #3)
15:32:09 <flaper87> o/
15:32:10 <flwang> kgriffs: it would be nice, thanks
15:32:11 <flaper87> back
15:32:22 <kgriffs> flwang: I think we should do a few screencasts and put them on the wiki too
15:32:42 <flwang> kgriffs: good idea, I can work with oz_akan_ to make it happen
15:32:49 <kgriffs> rock on
15:32:55 <kgriffs> I added a note to the etherpad
15:32:59 <flwang> kgriffs: because I'm trying to setup it :)
15:33:21 <kgriffs> during Juno I want to totally rock out on our docs
15:33:28 <flwang> more production deployment, more feedbacks, more stable
15:33:34 <kgriffs> flwang: cool, let's get that recorded
15:33:40 <flwang> kgriffs: love it
15:33:49 <kgriffs> even if it just used pop-up bubbles rather than voice over, that would be super awesome
15:33:59 <flaper87> actually, lemme take that back. gtg again! (I started the FAQ here https://etherpad.openstack.org/p/draft-marconi-faq add comments )
15:34:09 <kgriffs> flaper87: ttfn
15:34:21 <kgriffs> #link https://etherpad.openstack.org/p/draft-marconi-faq
15:34:30 <kgriffs> speaking of docs, heh
15:34:50 <kgriffs> alcabrera, megan_w, malini: can you help with the FAQ?
15:34:58 <alcabrera> kgriffs: sure thing
15:35:00 <kgriffs> flwang: you too
15:35:00 <malini> kgriffs: of course
15:35:01 <megan_w> sure
15:35:02 <kgriffs> :D
15:35:30 <kgriffs> #action core team to contribute to the FAQ
15:35:38 <sriram> +1 for the FAQ, I'll help around where I can as well.
15:35:55 <malini> sriram: wooot
15:36:46 <kgriffs> #topic review updates to the API v1.1 spec
15:36:54 <kgriffs> darn, flaper87 is MIA again.
15:36:57 * kgriffs sad panda
15:37:15 <alcabrera> we'll never get to have nice things. :(
15:37:20 <kgriffs> let's review pop semantics today
15:37:26 <alcabrera> works for me
15:37:41 <kgriffs> "Added new "pop" semantics for claiming and deleting messages in a single request. Note that this should only be used when an application is OK with the risk of missing a message when a worker crashes."
15:38:12 <kgriffs> so, a little background
15:38:26 <kgriffs> this idea arose independently from two sources
15:38:49 <kgriffs> first, was the request to add it because it would make it easier to map marconi semantics to AMQP
15:39:33 <kgriffs> second, I actually spoke with someone who is planning to use Marconi and they requested this feature for processing certain kinds of events, and they were willing to make the durability tradeoff
15:39:57 <kgriffs> my first stab at this was adding it to the DELETE messages operation:
15:40:01 <kgriffs> #link https://wiki.openstack.org/wiki/Marconi/specs/api/v1.1#Delete_Multiple_Messages
15:40:26 <alcabrera> would that be a multi-pop, kgriffs?
15:40:29 <kgriffs> I'd like to get everyones thoughts and suggestions
15:40:45 <kgriffs> alcabrera: yes, you can set pop=N
15:40:55 <alcabrera> gotcha -- interesting
15:40:57 <kgriffs> alcabrera: that was also requested by the user
15:41:02 <alcabrera> so, my initial thoughts
15:41:09 <alcabrera> are that this POP functionality is valuable
15:41:16 <alcabrera> I've used a variant of it already
15:41:29 <alcabrera> which a sort of claim and delete one at a atime
15:41:32 <flwang> kgriffs: is it a new endpoint?
15:41:45 <alcabrera> **which is a
15:42:11 <kgriffs> flwang: no, it is adding additional semantics to the existing messages resource
15:42:46 <flwang> delete-bulk?
15:42:56 <flwang> or like pop-bulk?
15:43:50 <kgriffs> yeah. basically, you can delete all messages, a few by ID, or N. In the last case, the deleted messages are returned to you, and there is a guarantee that nobody else will delete those same messages.
15:44:07 <kgriffs> "pop specifies a certain number of messages to pop off the queue, which is equivalent to claiming and deleting those messages atomically (therefore guaranteeing once-and-only-once delivery)"
15:44:13 <sriram> I think pop makes it much easier to issue a request, rather than supply a large number of ids.
15:44:39 <megan_w> sriram: agreed
15:44:52 <vkmc> o/ *catching up*
15:44:57 <kgriffs> depends on what you are trying to do
15:44:58 <alcabrera> vkmc: :)
15:45:01 <kgriffs> vkmc: hi!
15:45:02 <malini> kgriffs: pop will be done in a single call ?
15:45:09 <vkmc> Adding a pop function certainly simplifies automation, I like that!
15:45:48 <alcabrera> HTTP DELETE /queues/{q}/messages?ids=[1, 2, 3]&pop=3 -- what would this do?
15:46:14 <alcabrera> does 'pop' gather from the front of the queue?
15:46:20 <kgriffs> malini: yes, a single call. you trade off the safety of the two-phase claim+delete for improved performance/convenience
15:46:25 <flwang> kgriffs: yep, what's the http url looks like?
15:46:30 <sriram> alcabrera: +1 good question
15:47:18 <vkmc> Yeah, it may be confusing to use pop with ids
15:47:22 <kgriffs> http DELETE marconi.example.org/queues/videos/messages?pop=10
15:47:35 <kgriffs> if you specify both ids and pop, pop is ignored
15:47:37 <malini> But DELETE currently just returns a 204
15:47:41 <kgriffs> you really are supposed to use one or the other
15:47:47 <alcabrera> hmmm
15:48:07 <alcabrera> tempts me in the direction of a new endpoint
15:48:08 <malini> we probably want to return a message & delete it
15:48:19 <kgriffs> I'm not super happy about having the exclusive-or semantic, but this was the best I thought of so far short of coming up with a new resource
15:48:27 <alcabrera> HTTP POST /queues/videos/pop?n=10
15:48:37 <alcabrera> or even
15:48:42 <malini> why not just claim?
15:48:51 <alcabrera> HTTP POST /queues/videos/messages/pop?n=10
15:49:03 <malini> HTTP CLAIM /queues/videos/pop?n=10
15:49:15 <alcabrera> because CLAIM isn't an HTTP verb, malini. :(
15:49:24 <malini> grr.. :D
15:49:27 <alcabrera> hehe
15:49:37 <sriram> so does popping follow any order here?
15:49:46 <malini> I will drink more coffee before next meeting ;)
15:49:50 <kgriffs> malini: because the client doesn't want to make two requests, and also this semantic may make it easier to support broker-based backends, in which case I guess we would say for those backends the two-step claim isn't available?
15:50:02 <alcabrera> I'd love to avoid overloading endpoints. Different functionality should have a different interface.
15:50:31 <kgriffs> well, technically, there isn't anything wrong with coming up with custom HTTP verbs, but I know people will say WAH?! if we do that. :p
15:51:12 <kgriffs> alcabrera: mmm, noted. However, remember this isn't RPC over HTTP either. We have to work in terms of resources, and IDK that a "pop" resource makes any sense.
15:51:23 <alcabrera> hmmm
15:51:26 <alcabrera> fair enough
15:51:33 <kgriffs> there may be another way, don't get me wrong
15:51:46 <kgriffs> we just need to work within the architectural style we've chosen
15:52:15 <amitgandhi> +1 for not having a resource called pop
15:52:27 <kgriffs> #info try to find a way to not have mutually exclusive query string params on a single resource
15:52:28 <alcabrera> PopResource
15:52:30 <alcabrera> heh
15:53:10 <kgriffs> let me play with it and we can revisit next time
15:53:26 <alcabrera> +1
15:53:49 <flwang> pop most like an action, not a new resouse
15:54:14 <kgriffs> yep
15:54:22 <flwang> so i prefer to don't implement it with a new endpoint
15:54:27 <sriram> yeah
15:54:31 <kgriffs> ok, last thing - we have a couple days before rc1 is cut.
15:54:45 <kgriffs> Let's discuss the remaining bugs in #openstack-marconi
15:54:51 <kgriffs> #topic open discussion
15:55:10 <malini> can we start doing some retros in g+ ?
15:55:21 <malini> what we are doing well, where we can improve?
15:55:34 <malini> especially focusing around graduation
15:55:55 <kgriffs> malini: how often would you propose?
15:56:12 <malini> every  3 weeks /month
15:56:44 <kgriffs> milestone releases are about every 4 i think
15:56:56 <kgriffs> that may be a natural time to do them, but may not be often enough
15:57:02 <alcabrera> I'm partial to once a month
15:57:05 <flwang> sounds like reflections :)
15:57:12 <alcabrera> I really like the idea of a retro/reflections
15:57:13 <malini> flwang: yes :)
15:57:17 <alcabrera> for team-marconi
15:57:31 <kgriffs> so, +1 for retrospectives
15:57:52 <flwang> +1
15:57:57 <kgriffs> we would have two parts: (1) reflect on our development process and community
15:58:08 <kgriffs> (2) up-periscope on graduation
15:58:15 <megan_w> +1
15:58:17 <malini> kgriffs: +1
15:58:22 <kgriffs> monthly sounds good
15:58:40 <alcabrera> +1
15:58:47 <alcabrera> in some sense
15:58:54 <alcabrera> flaper87 is having such a thing in two days
15:59:05 <alcabrera> the marconi g+ hangout
15:59:07 <malini> But tht's more of an FAQ , rt?
15:59:14 <alcabrera> it might be
15:59:16 <malini> this is for the team to reflect
15:59:23 <alcabrera> I've lost track of the vision behind that particular hang out. >.>
15:59:31 <alcabrera> Though, I like it. :)
15:59:34 <kgriffs> ok, g+ is useful until we get full. Also you trade having logs for higher-bandwidth communication.
15:59:48 <malini> am ok with anything where we can talk, rather than type
15:59:55 <alcabrera> and human-to-human voice
15:59:58 <kgriffs> visual?
16:00:14 <malini> visual wud be nice to have, not mandatory
16:00:35 <flwang> google hangouts
16:00:49 <kgriffs> #action set up monthly v&v meetings
16:00:53 <alcabrera> +1
16:00:54 <megan_w> FWIW, g+ doesn't work great past 8 people
16:00:55 <malini> flwang: has a 10 person limit
16:00:58 <kgriffs> #action kgriffs to set up monthly v&v meetings
16:01:21 <kgriffs> ok, let's continue this chat over in #openstack-marconi
16:01:22 <amitgandhi> we'll all hangout by malini's machine
16:01:25 <amitgandhi> ;-)
16:01:27 <kgriffs> #endmeeting