15:01:37 <kgriffs> #startmeeting marconi
15:01:38 <openstack> Meeting started Tue May  6 15:01:37 2014 UTC and is due to finish in 60 minutes.  The chair is kgriffs. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:40 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:43 <openstack> The meeting name has been set to 'marconi'
15:01:44 <kgriffs> #topic roll call
15:01:47 <kgriffs> o/
15:01:56 <vkmc> o/
15:01:59 <cpallares> o/
15:02:41 <malini> o/
15:02:44 <sriram> o/
15:02:49 <balajiiyer> o/
15:02:55 <amitgandhi> o/
15:03:53 <kgriffs> flwang, alcabrera?
15:04:02 <alcabrera> here. :)
15:04:28 <kgriffs> #link https://wiki.openstack.org/wiki/Meetings/Marconi#Agenda
15:04:38 <kgriffs> #topic Review actions from last time
15:04:49 <kgriffs> #link http://eavesdrop.openstack.org/meetings/marconi/2014/marconi.2014-04-29-15.01.html
15:05:13 <kgriffs> 1. malini will document pop in v1.1 api 2x's, once with each param (pop & ids), for realz this time
15:05:21 <malini> for realz, I did
15:05:32 <kgriffs> #note malini is for realz
15:05:51 <alcabrera> yay, malini!
15:06:12 <malini> two weeks, for a wiki update! I am not so sure of the yayy :D
15:06:25 <kgriffs> 2. everyone to work on getting the wiki ready for the summit
15:07:06 <kgriffs> so, I noticed that https://wiki.openstack.org/wiki/Marconi has sprouted a few more sections
15:08:01 <alcabrera> yup!
15:08:12 <alcabrera> I pitched in the tiniest bit and researched oslo.messaging
15:08:23 <alcabrera> Obulpathi investigated the SQS/SNS angle, I believe
15:08:40 <amitgandhi> i wonder about that Out of Scope section and how it contradicts our notifications talk at the summit
15:09:18 <kgriffs> Cool, thanks! I started work on a new home page here to start organizing the content better. https://wiki.openstack.org/wiki/Marconi/home
15:09:46 <kgriffs> amitgandhi: good point, I can edit that. Ideally we can get everyone refactored under the new home page before then, but just in case...
15:10:45 * amitgandhi liking new home page
15:11:30 <kgriffs> I'll talk more about the new site structure in a few minutes...
15:11:34 <kgriffs> moving on...
15:11:53 <kgriffs> 3. Obulpathi to procure Mac & Cheese and organize a party to slap QR codes on them
15:12:07 <malini> Obulpathi is out of town this week
15:12:19 <kgriffs> so, I've been exchanging some emails with balajiiyer on this - he will take care of organizing this
15:12:30 <balajiiyer> *nods head*
15:12:33 <kgriffs> balajiiyer: right? :)
15:12:35 <malini> lie
15:12:41 <malini> I dont see balajiiyer nodding
15:12:45 <sriram> lol
15:13:11 <kgriffs> #action balajiiyer to take care of mac and cheese, flyers, and labels for Udoo giveaway
15:13:25 <balajiiyer> As a health advocate, I really hate buying mac & cheese, but I can take this one for the team :)
15:13:32 <kgriffs> balajiiyer: feel free to enlist whoever sits nearest to you in the office. ;)
15:14:08 <kgriffs> balajiiyer: just get the "Certified organic, free-roaming Macaroni & Cheese"
15:14:17 <balajiiyer> kgriffs: lol
15:14:32 <kgriffs> 4. kgriffs to create landing page on the wiki
15:14:57 <kgriffs> I um...will be working on this today.
15:15:01 <kgriffs> #action kgriffs to create landing page on the wiki
15:15:16 <kgriffs> 5. balajiiyer and mpanetta to order udoo boards
15:16:16 <balajiiyer> kgriffs: Im just not buying it yet, let the contest begin, lets the patches flow in. I will then order them and ship it to winners.
15:16:26 <kgriffs> makes sense
15:16:26 <malini> Just In Time!
15:16:30 <kgriffs> drop-ship FTW!
15:16:41 <kgriffs> 6. malini and kgriffs to get an evite out for the team meetup at the summit
15:16:54 <kgriffs> I am working on this still - should go out today/tomorrow
15:17:04 <kgriffs> malini: can you get me a list of email addresses for the invitees?
15:17:08 <malini> kgriffs: what abt emailing the devlist & cc/bcc the invitees?
15:17:19 <malini> kgriffs: sure..will get tht to you
15:17:29 <cpallares> re #5: Shouldn't we have at least one to show at the table or something?
15:17:34 <kgriffs> malini: mmm, I can send to the dev list as well
15:18:11 <malini> kgriffs: In case somebody else in interested in joining us..I saw emails from QA team abt meetups in the ML
15:18:16 <kgriffs> cpallares: that would certainly wet some appetites. balajiiyer, what do you think?
15:18:32 <kgriffs> malini: makes sense
15:18:35 <alcabrera> good idea, cpallares!
15:18:55 <alcabrera> malini: leveraging the ML sounds like a good idea, too
15:18:57 <kgriffs> we would need to order it, like, right after this meeting.
15:19:20 <balajiiyer> kgriffs: cpallares ok, good thought, on it. Will get one.
15:20:30 <kgriffs> #action balajiiyer to order 1 Udoo board to show off at the summit
15:20:46 <kgriffs> 7. malini to make check-tempest-dsvm-marconi voting + add a voting gate-tempest-dsvm-marconi
15:20:54 <amitgandhi> is there going to be enough time to prep that board for marconi?
15:21:10 <malini> w.r.t #7 ummm.I did not do tht
15:21:13 <kgriffs> amitgandhi: do we need to do anything other than display the board?
15:21:25 <malini> will submit a patch this week
15:21:35 <kgriffs> #action malini to make check-tempest-dsvm-marconi voting + add a voting gate-tempest-dsvm-marconi
15:21:37 <amitgandhi> kgriffs: ok
15:22:22 <kgriffs> #topic Introducing two Rackspace Summer Interns
15:22:34 * kgriffs picks up the floor and gives it to balajiiyer
15:22:39 <alcabrera> yay!
15:22:48 <sriram> woot :)
15:22:50 <cpallares> \o/
15:22:56 <cpallares> intern takeover
15:23:02 <balajiiyer> kgriffs: Team please meet abettadapur_
15:23:14 <balajiiyer> Alex Bettadapur!
15:23:21 <malini> yayyy!!!!
15:23:22 <abettadapur_> hello!
15:23:26 <alcabrera> abettadapur_: hey! :D
15:23:26 <malini> welcome abettadapur_!!!!
15:23:33 <cpallares> hello abettadapur_!
15:23:41 <alcabrera> cpallares: you know it - interns will take over *everything*
15:23:50 <sriram> welcome abettadapur_ !!
15:23:59 <amitgandhi> welcome abettadapur_ =)
15:24:00 * cpallares still plans for world domination
15:24:14 <vkmc> Hi abettadapur_! :)
15:24:50 <balajiiyer> abettadapur_ is just finished his second year BS in Computer Science at GA Tech. He is a summer intern at Rackspace.
15:25:33 <balajiiyer> I have another intern, but he is not starting until May 27.
15:26:05 <balajiiyer> so, I just have abettadapur_ to introduce today.
15:26:58 <balajiiyer> malini and abettadapur_ had a talk this morning about marconi this morning and he will be working on API v1.1 to start with.
15:27:10 <kgriffs> welcome abettadapur_. I'm sure we will find plenty of interesting things for you to dig into. :D
15:27:23 <malini> abettadapur_ already knows quite a bit a bout our APIs :)
15:27:32 <abettadapur_> I have started to write some functional tests for v1.1 this morning
15:27:41 <abettadapur_> lots to go through though
15:27:52 <kgriffs> rock on. glad to have you!
15:28:05 <amitgandhi> wow jumping right in, nice!
15:28:12 <kgriffs> #topic Proposal to change program name
15:28:47 <kgriffs> so, I don't know if we are ready to vote on the name yet, but here's the background
15:29:09 <kgriffs> "queues service" seems to make people think "provision-me-a-rabbitmq-as-a-service"
15:29:36 <kgriffs> also, we will be moving away from the notion of a "queue" in the future, and thinking more along the lines of ephemeral "topics"
15:29:42 <kgriffs> plus, we are adding notifications
15:30:05 <kgriffs> so... I'd like to propose we come up with a new program name while it is still (relatively) easy to change it.
15:30:20 <kgriffs> suggestions?
15:30:57 <sriram> messaging?
15:31:18 <kgriffs> "OpenStack Messaging Service"
15:31:19 <balajiiyer> messaging conflicts with Oslo.messaging, right?
15:31:22 <alcabrera> flaper87 suggested Messaging
15:31:25 <malini> I see some devstack patches coming :(
15:31:27 <sriram> since we are going to be focussing on the message themselves from now on, rather than the queues.
15:31:43 <kgriffs> oslo.messaging should really be oslo.rpc, except there is this deprecated RPC thing. #fail
15:31:44 <alcabrera> kgriffs: good point re: oslo.messaging
15:31:49 <alcabrera> and yeah
15:31:53 <kgriffs> noted
15:31:54 <alcabrera> oslo.rpc is what it *really* is
15:32:02 <vkmc> But all the messages have different topics, right?
15:32:05 <alcabrera> naming, the hardest problem
15:32:48 <vkmc> Maybe we could focus on the topic idea rather than the messages
15:32:52 <amitgandhi> "Openstack Message Service"
15:32:54 <kgriffs> vkmc: the idea is that you can post a message to N topics
15:33:01 <amitgandhi> that way its not messaging (ala oslo.messaging)
15:33:15 <kgriffs> and then you can list/claim from one topic at a time. iirc
15:33:32 <amitgandhi> but then "message service" sounds like "massage service" #fail
15:33:34 <balajiiyer> Instead of 'service', can we use the term 'bus' ?
15:33:42 <vkmc> +1 amitgandhi
15:34:07 <amitgandhi> like azure?
15:34:11 <balajiiyer> 'Openstack Message Bus'
15:34:11 <kgriffs> amitgandhi: no problem, we'll just give away massage gift cards next summit
15:34:32 <kgriffs> balajiiyer: I kinda like that one
15:34:52 <balajiiyer> *wonders whether Cloud Queues will have to change name too*
15:35:09 <sriram> will there be a name conflict?
15:35:10 <sriram> http://messagebus.com/
15:35:11 * amitgandhi azure calls theirs "Azure Service Bus
15:35:32 <megan_w> sriram: looks like it will be an issue
15:36:02 <sriram> hmm, this is hard.
15:36:07 <balajiiyer> 'Openstack message Train' :)
15:36:16 <malini> lets come up with some suggestions & vote on it next meeting
15:36:32 <amitgandhi> i feel with using "messages" the use case becomes "I want to send a message, what product should i use", and we want be considered by users who want a "queue"
15:36:42 <amitgandhi> s/want/wont
15:37:14 <amitgandhi> http://azure.microsoft.com/en-us/services/messaging/
15:37:30 <amitgandhi> hmmm azure has "Azure Service Bus" and "Azure Queue Service"
15:37:33 <alcabrera> malini: +1
15:37:38 <alcabrera> naming is hard - let's nap on it
15:37:50 <kgriffs> https://etherpad.openstack.org/p/marconi-scratch
15:37:53 <kgriffs> put your ideas there
15:38:00 <alcabrera> we've got: Service Bus, Messaging, Service, ...
15:38:02 <kgriffs> ...please? :D
15:38:02 <alcabrera> and etherpad
15:38:09 <alcabrera> because kgriffs is on top of this! :D
15:38:12 <alcabrera> *an
15:38:41 <kgriffs> #topic Support the OSSG
15:38:54 <malini> kgriffs: Is this name intended to replace 'queuing'?
15:39:19 <kgriffs> #topic program name
15:39:24 <kgriffs> #link https://wiki.openstack.org/wiki/Programs
15:39:36 <kgriffs> currently "Queue service"
15:39:43 <kgriffs> man, no wonder people are confused.
15:41:20 <amitgandhi> what about the legal hurdles around "Marconi" - megan_w?
15:41:39 <malini> kgriffs: Sorry, I made you change topic back to naming
15:42:02 <kgriffs> lol
15:42:18 <kgriffs> I'll wait a sec to see if megan_w is online, then move on
15:42:46 <balajiiyer> 1 Mississippi
15:43:01 <megan_w> sorry
15:43:24 <megan_w> sounds like we're at the mercy of the company who is using "marconi" legal's team
15:43:32 <megan_w> we're just waiting to hear back
15:43:38 <kgriffs> ok
15:43:57 <kgriffs> #topic Support the OSSG
15:44:32 <kgriffs> so, the OSSG has some great goals, but are having trouble getting traction. I would like us to lead by example here
15:44:49 <kgriffs> our first mission, should you choose to accept it: https://bugs.launchpad.net/marconi/+bug/1315115
15:45:16 <amitgandhi> OSSG?
15:45:31 <alcabrera> openstack security group, I believe
15:45:39 <amitgandhi> ah security group
15:45:45 <amitgandhi> =)
15:45:59 <alcabrera> amitgandhi: https://wiki.openstack.org/wiki/Mailing_Lists#Security
15:46:01 <alcabrera> :)
15:46:14 <kgriffs> someone from the OSSG was going to be here, but they are MIA
15:46:22 <kgriffs> (here in this meeting)
15:46:43 <kgriffs> in any case, any volunteers for taking this bug for juno-1 ?
15:46:46 <balajiiyer> Just noticed launchpad describes our program as - 'OpenStack Message Queuing Service (Marconi)' :)
15:49:35 <kgriffs> ok, well, I am going to schedule the bug for juno-1 and would like someone to pick it up. I can do it, but want to make sure others have the opportunity. :D
15:50:11 <kgriffs> # topic Cut a new python-marconiclient release for PyPI
15:50:21 <kgriffs> this is a quick one
15:50:45 <kgriffs> now that we have a library that supports all of v1.0 and has baked a bit, we are going to release a 0.0.1 "beta" version
15:51:19 <kgriffs> the process has changed since we did 0.0.1a1 so I have to jump through some hoops to get gerrit to let me push the appropriate tag
15:52:03 <kgriffs> I need to document the process, but it is similar to this: https://wiki.openstack.org/wiki/Savanna/How_To_Release
15:52:06 <kgriffs> #link https://wiki.openstack.org/wiki/Savanna/How_To_Release
15:53:35 <kgriffs> #topic Write the Docs!
15:53:50 <kgriffs> #link https://etherpad.openstack.org/p/marconi-wiki-sitemap
15:54:06 <kgriffs> #link https://wiki.openstack.org/wiki/Marconi/home
15:54:15 <kgriffs> so, I need LOTS of help in writing the docs
15:54:19 <kgriffs> :D
15:54:20 <kgriffs> :D
15:54:22 <kgriffs> :D
15:54:31 <alcabrera> hehe
15:54:33 <alcabrera> oh yes
15:54:38 <kgriffs> The etherpad is really for brainstorming
15:54:38 <alcabrera> there's much documentation to write
15:54:54 <kgriffs> I created a new home page to start sussing things out
15:55:01 <alcabrera> I'm going to try to drop some in over the SUmmer on storage driver creation
15:55:07 <alcabrera> third party support and such
15:55:13 <kgriffs> alcabrera: +1
15:55:35 <malini> kgriffs: when do you need this done?
15:55:56 <kgriffs> so, I need several people to help feel out some of the contributor sections and beef up the user guide so we can make it easier for people to win Udoo boards
15:56:03 <kgriffs> s/feel/fill
15:56:22 <kgriffs> malini: I would like some sections done before the summit, such as "your first patch"
15:56:32 <vkmc> I could help with the contributors part
15:56:52 <kgriffs> I need someone to also figure out a way to publish the API reference to the wiki or as RST (user guide) this week.
15:57:36 <kgriffs> #action vkmc to start writing "getting started" section of the Contributor's Guide
15:57:49 <vkmc> :D
15:58:10 <malini> kgriffs: Can you identify the before summit sections, so we can rally around that?
15:58:21 <kgriffs> yes
15:58:44 <kgriffs> The "getting started" guide for new contributors
15:58:55 <kgriffs> that has several sections people can work on
15:59:15 <kgriffs> the last one is less important for the summit (write the docs)
15:59:17 <prashanthr_> i can also join in.
15:59:38 <kgriffs> #action prashanthr_ to help with getting started guide
15:59:44 <alcabrera> yay!
15:59:52 <alcabrera> thanks, prashanthr_, vkmc
15:59:56 <kgriffs> prashanthr_, vkmc, malini we need a list of "low-hanging fruit" work items
16:00:08 <kgriffs> for now, just make a manual list
16:00:19 <kgriffs> and link it under "your first patch"
16:00:24 <malini> ok
16:00:29 <malini> I'll find a few easy stuff
16:00:41 <kgriffs> #action malini to make list of candidates for "your first patch"
16:00:50 <vkmc> Cool :)
16:00:58 <kgriffs> finally, I need someone to play with Maven and get the API reference published somewhere
16:01:00 <prashanthr_> :)
16:01:52 <kgriffs> everyone, please be cognizant of the URI scheme and name pages accordingly.
16:02:03 <kgriffs> make things hierarchical
16:02:13 <kgriffs> all lower-case (except for the initial "Marconi")
16:02:21 <kgriffs> and separate words with "-" not "_"
16:02:48 <kgriffs> ok, we are out of time folks
16:02:53 <kgriffs> 30 seconds
16:02:57 <kgriffs> #topic open discussion
16:03:30 <vkmc> I was wondering if we could add something like this in the wiki http://developer.rackspace.com/blog/openstack-marconi-api.html
16:03:41 <vkmc> I found it extremely useful
16:04:08 <vkmc> I know it's the basics, but for people just getting started is great
16:04:09 <cpallares> vkmc: +1
16:04:17 <prashanthr_> yes that's really useful.
16:04:27 <abettadapur_> I agree, this was helpful yesterday
16:04:47 <alcabrera> sounds wonderful
16:04:50 <kgriffs> That article is linked from the new home page, but I agree it should go somewhere - either user guide or wiki
16:04:51 <alcabrera> let's at least link it
16:04:51 <vkmc> I would like to add it if you all agree
16:04:59 <malini> vkmc: +1
16:05:03 <alcabrera> vkmc: +1
16:05:06 <kgriffs> vkmc: sure, let's find a logical home
16:05:23 <kgriffs> #action vkmc to find a home for http://developer.rackspace.com/blog/openstack-marconi-api.html within the docs
16:05:23 <vkmc> Great! :)
16:05:29 <kgriffs> thanks everyone!
16:05:32 <kgriffs> #endmeeting