15:00:09 <kgriffs> #startmeeting marconi
15:00:09 <openstack> Meeting started Tue Jun 24 15:00:09 2014 UTC and is due to finish in 60 minutes. The chair is kgriffs. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:13 <openstack> The meeting name has been set to 'marconi'
15:00:21 <kgriffs> #topic roll call
15:00:26 <kgriffs> \o/
15:00:26 <alcabrera> o/
15:00:33 <malini1> o/
15:00:34 <sriram> \o
15:01:04 <kgriffs> look at all these slackers. ;)
15:01:23 <malini1> :D
15:01:30 <kgriffs> I suppose flaper87 is busy getting spoiled at MongoDB World
15:01:41 <malini1> hellp prashanthr_!
15:01:48 <malini1> hello*
15:01:53 <prashanthr_> HI malini1:)
15:01:59 <prashanthr_> Hi all :)
15:02:00 <kgriffs> vkmc: here?
15:02:37 <kgriffs> quick, let's make a bunch of decisions while nobody is looking. mooohaha
15:02:59 <malini1> I remember flaper87|afk agreeing to do all of j-2 work
15:03:07 <kgriffs> perfect
15:03:08 <kgriffs> #topic review actions from last time
15:03:15 <kgriffs> #link http://eavesdrop.openstack.org/meetings/marconi/2014/marconi.2014-06-17-15.05.html
15:03:47 <kgriffs> OK, I will forward flaper87's actions to next week.
15:03:52 <kgriffs> #action flaper87 to do the plumbing for spec
15:03:58 <kgriffs> #action flaper87 talk to flwang and find a meeting time that works for him
15:04:08 <kgriffs> #action kgriffs announc the new meeting times in the mailing-list
15:04:18 <kgriffs> kgriffs to write a wiki page with possible review comment tags
15:04:32 <kgriffs> #link https://wiki.openstack.org/wiki/Reviewer_Guide_(Marconi)
15:04:34 <kgriffs> done
15:04:57 <kgriffs> this is just a start, of course; we'll need to experiment and tweak as we go
15:05:14 <sriram> looks good :)
15:05:21 <kgriffs> #info review guide created and linked from home page
15:06:37 <vkmc> o/ here!
15:06:40 <kgriffs> ok, so I'd love it if everyone good take a look, start trying some prefixes, and then we can discuss how it's going in a couple weeks
15:06:55 <kgriffs> #info kgriffs is going to be on holiday next week
15:07:03 <kgriffs> #info flaper87 will be chairing next week's meeting
15:07:03 <malini1> ok
15:07:23 <kgriffs> cool beans, thanks!
15:07:25 <kgriffs> next
15:07:39 <kgriffs> malini1 and vkmc to experiment with tools/bots for improving review velocity
15:08:20 <malini1> cpallares found a page which will get us the review stats easily for all patches
15:08:26 <vkmc> ^^
15:08:51 <malini1> #link http://status.openstack.org/reviews/
15:08:58 <malini1> See marconi branch reviews
15:09:26 <malini1> Our plan is to somehow use these, if reviews continue to be bottleneck
15:09:48 <malini1> For now, we have not done anything much
15:10:10 <sriram> looks like the scores are weighted, so its already prioritized.
15:10:16 <malini1> yes
15:10:36 <malini1> vkmc: did I miss anything?
15:11:02 <kgriffs> do you know how the score is calculated?
15:11:22 <vkmc> yes yes... it's a sum of the kind of patch (bug, bp) and how much has been in the queue
15:11:29 <vkmc> malini1, you didn't :)
15:11:47 <kgriffs> so, older ones get higher scores?
15:11:55 <sriram> yes
15:12:23 <vkmc> yes kgriffs
15:12:30 <kgriffs> this could be handy:
15:12:32 <kgriffs> #link http://status.openstack.org/reviews/reviewday.json
15:12:42 <vkmc> if you hover over the score you can see the values for the patch set
15:13:14 <kgriffs> #info reviewday score is based on kind of patch + age
15:14:03 <kgriffs> so....
15:14:15 <kgriffs> I think reviews are still not getting done as timely as they could be
15:14:26 <kgriffs> I have some thoughts about that but I'll save them for open discussion
15:14:44 <kgriffs> malini to make a list of work items for the rename and ask infra what things we need to include outside of code changes
15:14:45 <malini1> sounds good
15:14:56 <malini1> can we move that over to next week?
15:15:00 <malini1> :-$
15:16:41 <malini1> kgriffs: ?
15:17:08 <kgriffs> yeah
15:17:13 <kgriffs> #action malini to make a list of work items for the rename and ask infra what things we need to include outside of code changes
15:18:19 <kgriffs> #topic Updates on blueprints
15:18:55 <kgriffs> #link https://launchpad.net/marconi/+milestone/juno-2
15:19:09 <kgriffs> malini: tempest integration
15:19:46 <malini1> kgriffs: The last patch to cover positive tests for all APIs is out for review
15:19:58 <malini1> It has a +2 from one core reviewer as of today
15:20:05 <kgriffs> go go go!
15:20:19 <malini1> I'll ping somebody if I don't get another one by EOD today
15:20:26 <kgriffs> sounds good. nice work!
15:20:35 <malini1> thanks kgriffs :)
15:21:05 <kgriffs> skipping rename project since we just touched on that in actions
15:21:18 <kgriffs> API V1.1 - Treat a Missing Queue the Same as an Empty Queue
15:21:28 <kgriffs> need someone to take this
15:21:46 <sriram> I can take it up.
15:21:54 <sriram> what does it entail though?
15:22:10 <sriram> I thought lazy queues already did that?
15:23:02 <kgriffs> maybe. I guess just make sure that we have all operations covered
15:23:28 <sriram> ok
15:24:16 <kgriffs> next
15:24:21 <kgriffs> kgriffs: homedoc changes
15:24:43 <kgriffs> I'm waiting until everything has landed, then I was going to do a final sweep to make sure the homedoc is correct
15:24:56 <kgriffs> let me change the status to "blocked"
15:25:26 <malini1> I think abettadapur also has an outsatnding patch for this?
15:25:44 <malini1> https://review.openstack.org/#/c/96159/
15:25:47 <malini1> #link https://review.openstack.org/#/c/96159/
15:25:58 <kgriffs> yeah, that rings a bell
15:26:35 <kgriffs> Let me add that patch to the whiteboard
15:27:05 <kgriffs> nevermind - it's already there. :p
15:27:10 <malini1> :)
15:27:27 <kgriffs> next
15:27:28 <kgriffs> API v1.1 - Remove the endpoint to check if a queue exists
15:27:32 <kgriffs> need someone to take this
15:27:40 <kgriffs> #link https://blueprints.launchpad.net/marconi/+spec/api-v1.1-remove-check-queue-existence
15:28:10 <malini1> I can
15:28:37 <malini1> removing is always easy :-P
15:28:42 <sriram> ha
15:28:45 <kgriffs> ok - can you just assign yourself there?
15:29:04 <malini1> done
15:29:16 <kgriffs> thanks!
15:29:17 <kgriffs> next
15:29:32 <kgriffs> API v1.1 - Functional Tests
15:29:44 <kgriffs> I'm thinking push this to j-3 since it depends on having everything implemented
15:29:55 <kgriffs> thoughts?
15:29:57 <malini1> abettadapur has a patch outstanding for this
15:30:14 <sriram> yes
15:30:18 <malini1> if we can get tht reviewed & merged, it'll help us add tests as we add features
15:30:36 <kgriffs> i have to admit, I haven't looked at it yet...
15:31:09 <abettadapur> :D. it splits up the tests with new baseclasses
15:31:16 <abettadapur> similar to the work i did with the unit tests
15:31:19 <kgriffs> oic
15:31:21 <malini1> #link https://review.openstack.org/#/c/93295/
15:31:24 <kgriffs> ok, so this is laying the ground work
15:31:29 <abettadapur> basically
15:33:20 <kgriffs> abettadapur: cool. I went ahead and assigned you to it and moved this bp to complete in j-3, although we will continue working on it during j-2
15:34:12 <kgriffs> let's see... flwang is probably still sleeping right now
15:34:25 <kgriffs> He has API v1.1 Request Document Changes and the related one
15:34:57 <kgriffs> I may ask to see if he wants to free up one of those if he isn't going to have enough bandwidth to work on it for j-2
15:35:45 <kgriffs> Is Dave in teh house?
15:36:08 <kgriffs> anybody know what's going on with msgpack?
15:36:26 <malini1> not me :(
15:36:32 <sriram> nope
15:36:53 <vkmc> peoplemerge working on it, right?
15:37:07 <kgriffs> peoplemerge: ping
15:37:26 <kgriffs> vkmc: yep, that's Dave Thomas
15:37:38 <kgriffs> iirc
15:37:38 <flaper87> o/
15:38:05 <kgriffs> flaper87: oh, we were just talking about how you must be off getting spoiled by MongoDB Inc.
15:38:13 <flaper87> hahahhahahaha
15:38:16 <vkmc> oh cool :)
15:38:39 <kgriffs> next
15:38:52 <kgriffs> prashanthr_: Redis Storage Driver (Basic)
15:39:50 <prashanthr_> kgriffs: Hi. I have got the driver working completely for API's v1.0 and v1.1 on my private branch
15:40:03 <prashanthr_> Now the review for the code has begun :)
15:40:11 <prashanthr_> doing it controller by controller.
15:40:56 <kgriffs> cool!
15:41:18 <flaper87> prashanthr_: aewsome
15:41:22 <kgriffs> How soon do you think we will be able to try it? I'd like to benchmark it.
15:42:01 <prashanthr_> I think within a week we must be able to get it all up.
15:42:02 <prashanthr_> The queue and message controllers have been reviewed.
15:42:27 <flaper87> prashanthr_: did you create it as an external driver?
15:42:32 <sriram> prashanthr_: are they in a separate repo?
15:42:42 * flaper87 1, sriram 0
15:42:57 <prashanthr_> Yeah i did the initial coding in a seperate repo
15:43:55 <flaper87> prashanthr_: awesome
15:44:02 <kgriffs> it would be neat if the driver were a standalone package and you could just pip install it, then let stevedore do it's magic and find it
15:44:10 <sriram> cool!
15:44:18 <flaper87> kgriffs: I think that's what he did
15:45:02 <prashanthr_> Here is the private repo: https://github.com/PrashanthRaghu/marconi-redis/
15:45:25 <kgriffs> mmm, looks like a fork openstack/marconi
15:45:45 <prashanthr_> yes it's a fork of marconi.
15:46:03 <flaper87> oh, mmh. well, if it's going into the code base, I guess it kinda makes sense. Although, I agree with Kurt
15:46:57 <kgriffs> we'll have to discuss this another time, but we need to think about our driver strategy
15:47:03 <kgriffs> they can live in three places
15:47:12 <kgriffs> first, in openstack/marconi
15:47:19 <flaper87> kgriffs: I mentioned in the channel earlier today that I'd love to have a driver-less marconi repo
15:47:20 <kgriffs> second, create a new project called openstack/marconi-drivers
15:47:26 <flaper87> move everything outside marconi
15:47:33 <flaper87> so that people can choose what they want to install
15:47:34 <kgriffs> third, they could just be fully third-party on github
15:47:40 <flaper87> kgriffs: each driver would need its own repo
15:47:47 <kgriffs> oic
15:47:52 <flaper87> and that's fine with openstack's repo policies, AFAICT
15:48:00 <prashanthr_> kgriffs: The second idea looks nice.
15:48:01 <malini1> tht wud be a lot of repos :(
15:48:18 <flaper87> FWIW, we'll create repos for the drivers we *want* to maintain
15:48:36 <flaper87> other drivers that are not going to be maintained by the core team can live outside
15:48:38 <kgriffs> i think we will have a few official ones and then 3rd-parties are always welcome to do their own things outside the openstack GH org
15:48:50 * flaper87 1, kgriffs 0
15:48:55 <flaper87> :P
15:48:55 <kgriffs> dang
15:49:05 <kgriffs> I need to adjust my temporal distortion field generator
15:49:11 <flaper87> LOOOOL
15:49:17 <flaper87> that's quite a name
15:49:22 <kgriffs> TDFG
15:49:30 <flaper87> good topic for a "Internet of Things" talk
15:49:43 <kgriffs> that would be one heck of a demo
15:49:55 <kgriffs> ok, nice work prashanthr_!
15:50:05 <kgriffs> looking forward to taking it for a spin. :D
15:50:11 <flaper87> indeed, nice work, prashanthr_
15:50:26 <kgriffs> next
15:50:28 <kgriffs> Support Py3K
15:50:29 <prashanthr_> thank you kgriffs and flaper87 :).
15:51:04 <kgriffs> re py3k, did that last patch get merged?
15:51:13 <flaper87> AAzza: ?
15:51:15 <flaper87> ^
15:51:21 <kgriffs> looks like it did
15:51:22 <flaper87> I think it did
15:51:24 <flaper87> I don't see it
15:51:30 <sriram> I think so, py3k gate is passing :D
15:51:48 <flaper87> FYI, this is happening: https://review.openstack.org/#/c/101709/
15:52:01 <kgriffs> OH MY HECK!
15:52:03 <kgriffs> so cool
15:52:06 <flaper87> pls, +1
15:52:08 <flaper87> :D
15:52:15 <kgriffs> how many other projects are passing right now?
15:52:23 <flaper87> py3k ?
15:52:30 <flaper87> Some oslo libraries for sure
15:52:37 <flaper87> but I don't think any of the server projects are
15:53:01 <kgriffs> moohaha
15:53:07 <flaper87> hahahhahahaha
15:53:10 <flaper87> ROFL
15:53:16 <malini1> great job AAzza!!
15:53:26 <flaper87> +!
15:53:28 <flaper87> +1
15:53:31 <AAzza> hey, it was not difficult)
15:53:47 <malini1> AAzza: then everybody else wud have had it too ;)
15:53:48 <flaper87> AAzza: it's still a great job
15:54:01 <vkmc> +1 AAzza :)
15:54:08 <kgriffs> very tedious. really appreciate the work you did. :D
15:54:37 <flaper87> open discussion?
15:54:39 <flaper87> :P
15:54:50 <kgriffs> almost
15:54:50 <flaper87> IIRC we've 6mins left
15:54:58 <flaper87> unless I went to a 30 TZ
15:55:02 <kgriffs> flaper87: iirc you were going to take this?
15:55:02 <kgriffs> Migrate a Queue Between Pools
15:55:12 <kgriffs> #link https://blueprints.launchpad.net/marconi/+spec/queue-migration
15:55:26 <flaper87> kgriffs: correct, I still want to but before working on that we need to get flavors done
15:55:35 <flaper87> I should create a dependency on launchpad
15:55:40 <kgriffs> ok. Mind assigning yourself?
15:55:48 * flaper87 does that right away
15:55:54 <kgriffs> last bp to check on: Basic Benchmarking
15:55:57 <kgriffs> sriram: ^^^
15:56:02 <sriram> yes here.
15:56:24 <sriram> I incorporated changes wrt oslo config and made bench a console script
15:56:51 <sriram> I'd like to get some more reviews.
15:57:09 <sriram> But its starting to look good :)
15:57:38 <sriram> kgriffs: ^
15:58:02 <flaper87> sriram: kgriffs is there a chance we can split the benchmarking work?
15:58:14 * flaper87 hijacks the topic and jumps into open-discussion
15:58:16 <flaper87> :P
15:58:23 <kgriffs> heh
15:58:26 <kgriffs> #topic open discussion
15:58:35 <kgriffs> flaper87: what did you have in mind?
15:59:00 <flaper87> so, AAzza completed her work on py3k and I was talking with her about the benchmark tool and how bad we need it
15:59:33 <kgriffs> i think we can. let's discuss in the team channel
15:59:34 <flaper87> so, in order to make it easier for both AAzza and sriram to work on that, I was thinking if we could split that blueprint somehow
15:59:38 <flaper87> awesome
15:59:40 <flaper87> thanks
15:59:42 <flaper87> that's it
15:59:46 <kgriffs> real quick before we wrap up
15:59:47 <sriram> I'm ok with it :)
16:00:01 <kgriffs> I need everyone to go read this:
16:00:03 <kgriffs> #link http://www.joelonsoftware.com/articles/fog0000000022.html
16:00:26 <malini1> kgriffs: you are asking us to task switch ;)
16:00:42 <kgriffs> I was thinking if you are waiting on a code patch to merge, don't start a new one - first go do lots of reviews
16:00:47 * flaper87 pocketized it
16:01:00 <flaper87> that's how it should be done
16:01:04 <vkmc> I wanted to ask your opinions about dropping pylint... let me know in #marconi
16:01:26 <flaper87> developers should have a small number of patches in the queue and review a whole bunch of them
16:01:27 <kgriffs> let's help eachother focus more. if reviews take too long, then people have to multitask even more while they wait
16:01:36 <kgriffs> flaper87: +1
16:02:01 <kgriffs> vkmc: ok, let's discuss in breakout after this.
16:02:04 <kgriffs> thanks everyone!
16:02:07 <kgriffs> #endmeeting