15:02:16 <kgriffs> #startmeeting marconi
15:02:17 <openstack> Meeting started Tue Jul 15 15:02:16 2014 UTC and is due to finish in 60 minutes.  The chair is kgriffs. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:21 <openstack> The meeting name has been set to 'marconi'
15:02:35 <kgriffs> #link https://wiki.openstack.org/wiki/Meetings/Marconi#Agenda
15:03:03 <kgriffs> #topic new meeting time
15:04:34 <kgriffs> so, if we want to keep the meeting time on the same day yet accommodate people on opposite sides of the planet, 1900 is our best bet
15:04:38 <kgriffs> 1900 UTC
15:05:00 <kgriffs> a little later would be better, but that conflicts with TC and project release meetings
15:05:11 <kgriffs> that is 7am NZT
15:05:20 <peoplemerge_> yay
15:05:23 <kgriffs> flwang says that is a little early, but he could try to make it work
15:05:49 <kgriffs> other thing we could try is move to a different day and do it at 2000 or 2100 UTC
15:06:27 <kgriffs> let's assign something to someone who isn't here
15:06:30 <kgriffs> :D
15:06:58 <kgriffs> #action flaper87 or kgriffs to send out email to finalize new team meeting time/day
15:07:18 <kgriffs> so yeah, we'll have to get some feedback from everyone on that. I'd like to start meeting at the new time starting next week
15:07:34 <kgriffs> any suggestions/questions/comments/rude remarks before we move on?
15:08:08 <kgriffs> #topic Juno-2 ends July 24!
15:08:26 <kgriffs> any questions? :D
15:08:47 <kgriffs> #link https://launchpad.net/marconi/+milestone/juno-2
15:08:55 <malini> want to go thru the list of pending stuff?
15:09:11 <kgriffs> yeah, we will do that in a minute once we get through "Extra things" on the agenda
15:09:58 <kgriffs> oh, also, FWIW, I updated the roadmap - moved some stuff out of j-2.
15:10:00 <kgriffs> #link https://wiki.openstack.org/wiki/Roadmap_(Marconi)
15:10:10 <kgriffs> anyway, we need REVIEWS
15:10:54 <kgriffs> I'm personally going to be spending a lot of time on reviews this week. I'd love to see everyone else pitching in as well so we can get patches merged quickly
15:10:55 <kgriffs> also
15:10:59 <kgriffs> if you have a patch pending
15:11:04 <malini> last I checked, many of the pending reviews had some kinda -1
15:11:09 <kgriffs> please update it quickly once you get teh reviewz
15:11:14 <malini> then kgriffs went ahead & submitted a few more patches
15:11:21 <kgriffs> heh
15:11:43 <prashanthr_> kgriffs: Sure. I have done it just today.
15:12:08 <kgriffs> I will say... I tend to skip patches that have a -1 from Jenkins
15:12:34 <kgriffs> so please, get those fixed ASAP!
15:13:12 <kgriffs> and please, ping me or another core reviewer if you are waiting on a review. we have lots of distractions and so it can be helpful to get some pokes. :D
15:13:44 <kgriffs> cool?
15:13:48 <prashanthr_> kgriffs: Sure :)
15:14:17 <kgriffs> #topic API test organization
15:14:21 <peoplemerge_> will do.
15:15:00 <kgriffs> #link https://github.com/openstack/marconi/tree/master/tests/unit/queues/transport/wsgi
15:15:08 <peoplemerge_> :)
15:15:12 <kgriffs> so....
15:15:47 <kgriffs> if you look at, e.g., test_v1_1.py
15:16:09 <kgriffs> we have all kinds of two-liner classes like this
15:16:34 <kgriffs> class TestClaimsMongoDB(v1_1.TestClaimsMongoDB):
15:16:34 <kgriffs> url_prefix = URL_PREFIX
15:17:44 <kgriffs> It seems silly to write our real tests in a base class that is already specific to a certain version of the API, and then simply inherit from it under "tests" so that testunit will find it
15:18:27 <kgriffs> the original reason for the model as it now stands was to share the same base classes between 1.0 and 1.1, and then set a few class variables for minor variations in the test (e.g., url prefix)
15:19:31 <kgriffs> however, now that we have copy-pasted all the base class tests between v1.0 and v1.1, this model seems like a waste of time
15:19:43 <kgriffs> thoughts?
15:19:50 <malini> we need to revisit the whole copy paste approach
15:19:54 <malini> it works for now
15:19:59 <malini> but is a lot of duplication
15:20:22 <kgriffs> good point
15:20:35 <sriram> hmm, we would probably need to do some analysis on which test belonging where.
15:20:39 <peoplemerge_> as a new dev, it confused me.
15:20:49 <malini> I think we should revisit our entire test structure
15:21:17 <malini> we have some tests in base.py - define what tests qualify to live there (if at all)
15:21:21 <peoplemerge_> couldn't we just move the test classes and mixin the url?
15:21:42 <kgriffs> couple things
15:21:43 <malini> peoplemerge_: as in specify the version in the actual tests?
15:22:15 <kgriffs> first of all, I don't see what the url_prefix class variable is buying us at this point, since we already have duplicated the tests for 1.1
15:22:33 <peoplemerge_> malini: --^
15:22:57 <kgriffs> second of all, I think if we are sticking with the duplicated tests for now, we should just move them directly under the tests folder
15:23:05 <kgriffs> longer term
15:23:12 <kgriffs> I agree with malini
15:23:20 <kgriffs> we need to rethink tests
15:23:28 <kgriffs> lots of things about that
15:23:38 <kgriffs> unit vs. functional
15:23:41 <kgriffs> where they live
15:23:45 <kgriffs> how to DRY
15:23:47 <kgriffs> etc.
15:24:09 <malini> is it an accident tht kgriffs thoughts look like a triangle?
15:24:34 * peoplemerge_ lol
15:24:39 <kgriffs> :D
15:24:51 <vkmc> lol
15:24:58 <sriram> haha
15:25:07 <kgriffs> TBH, I don't think we have time in Juno to do it, but I would like to see it as a major theme in K
15:25:21 <kgriffs> I mean, the major test redux
15:25:25 <malini> kgriffs: +1
15:25:26 <prashanthr_> :D
15:25:37 <kgriffs> we could do some smaller moves
15:25:46 <kgriffs> in j-3
15:25:52 <peoplemerge_> +1
15:26:04 <malini> kgriffs: +1
15:26:12 <kgriffs> ok. mind if I schedule a bug?
15:26:31 <kgriffs> and malini: can you create a bp or something to help us remember the major refactoring work to do in K
15:26:37 <malini> sure
15:26:45 <kgriffs> #action kgriffs to schedule a bug
15:26:57 <malini> There is also some chatter in the ML abt creating a common functional test structure for individual projects. We can be the guinea pigs, if we are anyways doing the revamp
15:27:08 <kgriffs> #action malini to create a blueprint and start a wiki page or etherpad to keep track of ideas for testing redux
15:27:55 <kgriffs> ok
15:28:04 <kgriffs> next topic is "Move or copy _TRANSPORT_LIMITS_OPTIONS to pool catalog?" but I need flaper87|afk to be around for that.
15:28:33 <kgriffs> #topic Review actions from last time
15:28:51 <kgriffs> heh. looks like there weren't any
15:29:01 <kgriffs> malini: btw, I moved rename the project to j-3
15:29:13 <malini> saw that ..thx :)
15:29:26 <kgriffs> #topic Updates on blueprints
15:29:36 <kgriffs> #link https://launchpad.net/marconi/+milestone/juno-2
15:29:45 <kgriffs> malini: Tempest integration
15:29:58 <malini> We have the graduation req complete (AFAIK)
15:30:08 <malini> We now have coverage for all v1 APIs positive tests
15:30:20 <malini> But Tempest will be an ongoing effort
15:30:37 <malini> Next steps are v1.1 APIs & CLI tests
15:30:44 <malini> But tht'll be for j-3
15:31:27 <malini> But we really need the TC blessing to confirm tht we have met the grad reqs for Tempest - which I hope we'll do at the mid review
15:32:59 <malini> tht's all I had
15:33:04 <malini> concerns/questions?
15:33:06 <kgriffs> is this blueprint complete then?
15:33:12 <kgriffs> are there other blueprints for those other items?
15:33:23 <malini> yes - I'll create a new bp for other items
15:33:37 <kgriffs> ok. can you mark this bp as complete as well?
15:33:54 <malini> sure..doing it now
15:34:10 <kgriffs> I think it is important to celebrate our progress, and completing blueprints is one way to do that. :D
15:34:26 <kgriffs> sriram: API V1.1 - Treat a Missing Queue the Same as an Empty Queue
15:34:39 <sriram> Yeah, I checked that.
15:34:39 <malini> applause plzzz….The tempest bp is now 'Implemented'
15:34:45 <sriram> its working as expected.
15:34:46 <vkmc> \o/
15:34:51 * kgriffs claps loudly
15:34:55 <peoplemerge_> :D
15:35:00 <sriram> I'll go ahead and mark that as done. :)
15:35:01 * prashanthr_ Appalause :)
15:35:09 <kgriffs> sriram: w00t
15:35:20 <kgriffs> malini: API v1.1 - Remove the endpoint to check if a queue exists
15:35:38 <malini> I haven't started on tht yet..
15:35:58 <malini> But since it is removing existing functionality - I hope tht will be easy to get done
15:36:42 <malini> I will submit a patch for it by tomorrow - or is it too ambitious?
15:38:15 <kgriffs> sounds good
15:38:21 <malini> cool
15:38:41 <kgriffs> kgriffs: API v1.1 Homedoc changes
15:39:01 <kgriffs> this is a catch-all to sanity-check the homedoc once all the other changes are done
15:39:07 <kgriffs> I think this may slip to j-3
15:39:13 <malini> Alex has an outstanding patch for tht
15:39:14 <kgriffs> since it depends on everything else being stable
15:39:19 <sriram> exception handling :P
15:39:36 <kgriffs> malini: oh darn, that never got merged?
15:39:39 * kgriffs hides
15:39:49 <kgriffs> ok, something else that needs teh reviewz!
15:41:10 <malini> It needs some updates from Alex - to address reviews
15:41:34 <kgriffs> next
15:41:34 <kgriffs> API v1.1 header changes.
15:41:45 <malini> tht one also has a patch from Alex :D
15:41:49 <kgriffs> yep
15:42:05 <kgriffs> #link https://review.openstack.org/#/c/102007/
15:42:09 <kgriffs> let's get that reviewed ASAP
15:42:30 <kgriffs> kgriffs: API v1.1 Response Document Changes
15:42:33 <kgriffs> not started
15:42:43 <kgriffs> hope to get a patch for that in a day or two
15:42:51 <kgriffs> kgriffs: API v1.1 Request Document Changes
15:42:58 <kgriffs> halfway done
15:43:01 <kgriffs> got a pending patch
15:43:07 <kgriffs> please review!
15:43:08 <kgriffs> :D
15:43:43 <kgriffs> flaper87|afk: Support different types - flavors - of queues
15:44:06 <kgriffs> iirc, Flavio asked for some eyes on this: https://review.openstack.org/#/c/98793
15:44:27 <kgriffs> I'm pretty sure flavors is going to slip to j-3
15:45:02 <kgriffs> esp. since it is going to require moving queue management to the control plane
15:45:40 <kgriffs> flwang: API v1.1 - Provide more detailed info with /health
15:45:55 <kgriffs> I saw some code from flwang submitted yesterday
15:46:02 <kgriffs> again, please review!
15:46:17 <kgriffs> the plan is to provide two things
15:46:25 <kgriffs> overall message stats for an entire pool
15:46:35 <kgriffs> and a "deep health check"
15:46:48 <kgriffs> the deep check will basically do a message lifecycle test
15:46:58 <kgriffs> peoplemerge_: API v1.1 - Support application/x-msgpack
15:47:04 <peoplemerge_> thx for prioritizing the reviews, I wanted to take some on but didn't know which were (not) important.
15:47:08 <peoplemerge_> kgriffs: yes
15:47:28 <peoplemerge_> submitted test code for review only
15:47:51 <peoplemerge_> got the hang of the review process
15:48:24 <peoplemerge_> will start implementation Thu/Fri
15:49:22 <peoplemerge_> kgriffs: the last patchset can be reviewd (#..)
15:49:58 <peoplemerge_> https://review.openstack.org/#/c/106687/
15:50:10 <peoplemerge_> no sorry
15:51:15 <peoplemerge_> https://review.openstack.org/#/c/105830/4
15:51:28 <kgriffs> ok, thanks!
15:52:13 <kgriffs> you
15:52:24 <kgriffs> have probably seen these links, but we have some tips and tricks on the wiki
15:52:24 <kgriffs> https://wiki.openstack.org/wiki/Your_First_Patch_(Marconi)
15:52:38 <kgriffs> https://wiki.openstack.org/wiki/Your_First_Review_(Marconi)
15:53:02 <kgriffs> prashanthr_: Redis Storage Driver (Basic)
15:53:19 <prashanthr_> kgriffs: All the controllers for redis storage driver
15:53:22 <peoplemerge_> kgriffs: have some other issues around implementation but can take them offline
15:53:24 <prashanthr_> are up for review now
15:53:31 <peoplemerge_> kgriffs: thx reading...
15:53:45 <prashanthr_> I guess we must have them for j-2. Just waiting for reviews
15:53:53 <prashanthr_> Test cases are also setup.
15:54:11 <peoplemerge_> when should I try to get impl done to have time for reviews by j2?
15:54:33 <prashanthr_> https://review.openstack.org/#/c/97178/ - Queue and Message Controllers.
15:54:33 <prashanthr_> https://review.openstack.org/#/c/97701/ - Adding global dependencies.
15:54:33 <prashanthr_> https://review.openstack.org/104055 - Adding claims controllers
15:54:33 <prashanthr_> https://review.openstack.org/#/c/104058/ - Implements Pools and Catalogue controllers for Redis
15:54:42 <prashanthr_> The following are the code patches
15:54:47 <prashanthr_> for the individual controllers
15:54:53 <kgriffs> hmm.. usually takes a couple days to get a patch merged, even when we have lots of people doing reviews
15:55:05 <kgriffs> peoplemerge_: ^^^
15:55:32 <kgriffs> prashanthr_: great, nice work! Let's get those reviews
15:55:35 <peoplemerge_> k
15:55:52 <prashanthr_> kgriffs: Sure. Thank you :)
15:55:55 <kgriffs> we really should get everything merged by next wed
15:56:09 <kgriffs> so we have a day for smoke testing or whatever
15:56:22 <prashanthr_> kgriffs: That would really be awesome. Yes a smoke test will really help.
15:56:23 <kgriffs> sriram: Basic Benchmarking
15:56:27 <sriram> kgriffs: yes
15:56:35 <sriram> https://review.openstack.org/#/c/98875/ -> the patch is here
15:56:51 <sriram> The enivronment is setup here : 166.78.236.4
15:57:17 <sriram> I have done some performance tweaking : https://gist.github.com/kgriffs/4027835
15:57:17 <kgriffs> prashanthr_: I think even the basic driver could be useful for single-app/private cloud deployments. Just a thought.
15:57:39 <kgriffs> cool
15:57:44 <prashanthr_> kgriffs: Totally agreed.
15:57:56 <kgriffs> FWIW, I am researching those and more kernel tweaks for a future blog post. stay tuned. :D
15:58:07 <sriram> so need we need to get it merged, for the next process to continue.. reporting patch
15:58:13 <sriram> kgriffs: woohoo! :)
15:58:14 <sriram> awesome
15:58:35 <kgriffs> cool, thanks sriram. reviews please!
15:58:45 * kgriffs wonders whether anyone else is noticing a trend
15:59:10 <kgriffs> ok, I will move "Reporting of Generated Benchmarks" to j-3
15:59:42 <kgriffs> sriram: with this, let's for the first patch do the "simplest thing that could possibly work"
15:59:43 <kgriffs> https://blueprints.launchpad.net/marconi/+spec/gen-bench-reports
16:00:28 <kgriffs> ok folks, we are outa time
16:00:33 <sriram> cool
16:00:34 <kgriffs> any final thoughts?
16:00:37 <kgriffs> #topic open discussion
16:00:57 <kgriffs> 10 seconds. :)
16:01:20 <kgriffs> #endmeeting