#openstack-marconi: marconi-api-http

Meeting started by kgriffs at 16:10:52 UTC (full logs).

Meeting summary

    1. https://wiki.openstack.org/wiki/Marconi/specs/api/next (kgriffs, 16:10:58)

  1. Return an href for deleting all claimed messages with a single call (kgriffs, 16:11:28)
    1. do not support bulk delete of claimed messages (kgriffs, 16:21:26)

  2. Allow PUTing metadata when creating a queue (kgriffs, 16:21:31)
  3. Set queue options for defaults, such as message and claim TTL. (kgriffs, 16:27:02)
  4. homedoc should return relative URIs or encode version in href-template (kgriffs, 16:30:56)
    1. http://www.ietf.org/rfc/rfc1808.txt (kgriffs, 16:36:56)
    2. https://bugs.launchpad.net/marconi/+bug/1245656 (kgriffs, 16:38:31)
    3. fix href-template paths in home doc in v1.0; don't wait for 1.1 (kgriffs, 16:39:27)

  5. 204 vs. 200 + empty array (kgriffs, 16:44:17)
    1. https://bugs.launchpad.net/marconi/+bug/1245656 (kgriffs, 16:44:54)
    2. ACTION: fvollero to take care of bug #1245656 (kgriffs, 16:45:21)
    3. https://wiki.openstack.org/wiki/Marconi/specs/api/v1#List_Messages (kgriffs, 16:48:09)
    4. return an empty array on listing options when no items are available, plan for v1.1 (kgriffs, 16:54:58)

  6. Consistency around response envelope for /messages vs /messages?ids (kgriffs, 16:55:17)
  7. Response envelopes in general - don't return raw arrays (to allow for extensions) (kgriffs, 17:25:47)
    1. encapsulate arrays in objects to make resource representations extensible (kgriffs, 17:31:03)

  8. Return full URIs in location/content-location headers (rather than relative ones) (kgriffs, 17:31:25)
    1. Continue to return partial URIs (kgriffs, 17:41:02)

  9. Is content-location header really necessary? (kgriffs, 17:41:08)
  10. Polling model is based on the assumption of a "streaming" interaction model. Is there a place for a "point in time" listing model, where you don't always get a "next" href? (kgriffs, 17:45:40)
    1. revisit for v2 API (kgriffs, 17:46:31)

  11. Query parameters are usually considered to be "optional", and yet DELETE queues/my-queue/messages requires an "ids" parameter. Some options: (kgriffs, 17:47:50)


Meeting ended at 17:49:48 UTC (full logs).

Action items

  1. fvollero to take care of bug #1245656


Action items, by person

  1. fvollero
    1. fvollero to take care of bug #1245656


People present (lines said)

  1. kgriffs (165)
  2. flaper87 (103)
  3. alcabrera (50)
  4. zyuan (50)
  5. fvollero (17)
  6. ametts (12)
  7. malini (5)
  8. cpallares (4)
  9. openstackgerrit (3)
  10. openstack (3)


Generated by MeetBot 0.1.4.