15:01:55 <flaper87> #startmeeting Marconi Team Meeting
15:01:56 <openstack> Meeting started Tue May 20 15:01:55 2014 UTC and is due to finish in 60 minutes.  The chair is flaper87. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:58 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:00 <openstack> The meeting name has been set to 'marconi_team_meeting'
15:02:02 <flaper87> adrian_otto: no worries :)
15:02:10 <flaper87> #topic Roll Call
15:02:12 <kgriffs> o/
15:02:19 <flaper87> #chair kgriffs
15:02:19 <Obulpathi> o/
15:02:19 <balajiiyer> o/
15:02:20 <openstack> Current chairs: flaper87 kgriffs
15:02:20 <sriram> o/
15:02:25 <flaper87> kgriffs: go ahead :)
15:02:28 <flaper87> o/
15:02:30 <mpanetta> <--
15:02:33 <megan_w> heyo
15:02:36 <alcabrera> o/
15:02:46 <AAzza> o/
15:03:23 <flaper87> first and foremost. It was really great to finally meet you all!
15:03:28 <kgriffs> yay!
15:03:35 <mpanetta> Yes :)
15:03:37 <tjanczuk> yes!
15:03:38 <sriram> yes! :)
15:03:46 <flaper87> We need more contributors so we can keep doing the same thing every summit :D
15:03:52 <malini> o/
15:03:54 <flaper87> but don't tell malini
15:03:56 <flaper87> oooooooooooopsssssssssssssss
15:03:58 <alcabrera> haha
15:04:01 <Obulpathi> hahaha
15:04:01 <megan_w> haha
15:04:07 <malini> Thank you znc!
15:04:12 <flaper87> damnit
15:04:20 <malini> flaper87:  :-P
15:04:22 <flaper87> but you just joined
15:04:25 <flaper87> znc is not that smart
15:04:27 <flaper87> :D
15:04:30 * flaper87 thinks
15:04:45 <kgriffs> #topic conference retrospective
15:05:39 <cpallares> \o/
15:05:43 <cpallares> o/
15:05:45 <kgriffs> First off, I have to apologize - I haven't had a chance to write up the roadmap we discussed on Friday. I'll get that done today and send an email to the ML.
15:05:58 <tjanczuk> I have a picture if you need it
15:06:18 * ametts thinks kgriffs should run the easel chart through an OCR reader
15:06:19 <flaper87> tjanczuk: we took all those papers w/ us :P
15:06:34 <flaper87> tjanczuk: well, I took them down and made kgriffs carry them around :D
15:06:36 <flaper87> hahaha
15:06:39 <kgriffs> tjanczuk: thanks; I've got one too. I'll try to post all the pics of the board as well.
15:07:06 <kgriffs> generally speaking, how does everyone feel about the summit?
15:07:11 <megan_w> in general, there seemed to be confusion in the rest of the community about marconi under/over cloud
15:07:14 <malini> still on?
15:07:32 <megan_w> people didn't seem to know if they were suppose to use it between services
15:07:45 <tjanczuk> I think there was also a bit of confusion around whether Marconi attempts to be the message server for rest of marconi or for end users, or both
15:07:54 <tjanczuk> sorry, for rest of openstack
15:07:58 <megan_w> right
15:08:01 <sriram> yes, The people I talked to at the summit had the same question.
15:08:14 <kgriffs> that's been a point of confusion for quite a while. We need to clear that up once and for all.
15:08:14 <Obulpathi> +1
15:08:27 <tjanczuk> and the answer is...?
15:08:29 <megan_w> do we have clarity amongst ourselves yet?
15:08:29 <flaper87> I don't think we will
15:08:42 <flaper87> we need to put that in the FAQ (which I think it is)
15:08:45 <kgriffs> I think an entry on the FAQ and a mention on the home page should help.
15:08:48 <flaper87> and point people there
15:08:51 <flaper87> kgriffs: >.>
15:09:16 <flaper87> me starts his brain firewall
15:09:22 <kgriffs> I think it is mentioned in one or two answers in the FAQ
15:09:22 <kgriffs> but
15:09:38 <kgriffs> maybe we should call it out specifically as a standalone question?
15:09:45 <Obulpathi> +1
15:10:06 <flaper87> kgriffs: sounds good, I thought it was
15:10:34 <kgriffs> #note basically, we should say that is is primarily over cloud but we have requests from people who want to use it as an event aggregator and normilizer
15:11:13 <flaper87> We're targetting the over cloud but we're not planning to prevent people to use it in the under cloud
15:11:13 <kgriffs> I can take a first stab at it. Then I'll need others to help me edit it for clarity.
15:11:29 <ametts> +1
15:11:31 <megan_w> if its primarily over cloud, then we need to make sure our roadmap isn't filled with aggregator/normalizer items
15:11:31 <flaper87> kgriffs: actionize it or it ain't happen :D
15:11:52 <malini> On tht note, one of TC memebers concern was 'we are not integrated to other products'
15:11:55 <flaper87> megan_w: what aggregators ? you mean the notification?
15:12:03 <tjanczuk> So what was the deal with gathering notification requirements from other open stack teams? Isn't that a bit contradictory?
15:12:05 <kgriffs> #action kgriffs to address over vs. under cloud in FAQ, mention on home page
15:12:08 <malini> So probably we shud clarify tht it is not our intent?
15:12:12 <flaper87> To be clear, by under cloud I mean "replacing rabbitmq"
15:12:21 <megan_w> sorry, i mean we shouldn't focus on features needed for the aggregate and normalize use case
15:12:50 <flaper87> I think it is fair for other projects to consume Marconi (Telemetry, trove, swift, etc)
15:13:10 <flaper87> but I don't think Marconi is a drop-in replacement for rabbitmq in openstack
15:13:26 <megan_w> got it
15:13:30 <ametts> flaper87, kgriffs: Should we clarify our AMQP plans wrt to not "replacing rabbmq"?
15:13:32 <kgriffs> I don't think so either, but it may make sense in a complimentary role
15:13:57 <kgriffs> ametts: I'll try to make that clear in the FAQ
15:14:09 <flaper87> ok, lets move on
15:14:24 <flaper87> besides that, I think the summit was very positive for marconi
15:14:34 <flaper87> community wise and project wise
15:14:57 <malini> w.r.t QA, we need to refactor the functional tests to be Tempest friendly
15:15:03 <flaper87> #info I started this thread: http://lists.openstack.org/pipermail/openstack-dev/2014-May/035341.html
15:15:06 <malini> The neutron folks have a POC
15:15:19 <Obulpathi> POC?
15:15:31 <flaper87> malini: what does that mean? We should probably discuss it further off-line
15:15:40 <malini> flaper87: sure
15:15:43 <abettadapur> proof of concept
15:15:50 <ametts> flaper87:  Can you really call it a thread if yours is the only message? :)
15:15:53 <flaper87> not sure why tempest needs us to refactor our functional tests
15:15:59 <Obulpathi> abettadapur: thanks
15:16:03 <flaper87> ametts: LOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOL
15:16:10 <kgriffs> megan_w: I think that much of what people will want to do with notifications in the overcloud will apply to the internal notifications use cases; let's see how much we can accomplish with the same code
15:16:11 <flaper87> ametts: a hope-for-a-thread
15:16:17 <malini> flaper87: tempest doesnt need us to..But will help us avoid some duplication of effort
15:16:24 <megan_w> sounds good
15:16:40 <malini> flaper87: it'll be using tempest http libs etc.
15:16:52 <malini> flaper87: lets chat more in #openstack-marconi
15:17:00 <flaper87> malini: mmmh, that alone scares the hell out of me
15:17:03 <flaper87> malini: sure
15:17:21 <malini> flaper87: me too :D
15:17:59 <flaper87> next topic ?
15:18:20 <kgriffs> #action kgriffs to document roadmap and send to ML for feedback
15:18:55 <kgriffs> #topic Change the program name
15:19:25 <flaper87> kgriffs: project*
15:19:28 <kgriffs> https://etherpad.openstack.org/p/marconi-scratch
15:19:46 <kgriffs> so, we need a new "code name"
15:20:21 <kgriffs> after we figure that out, we also need a new "regular" name
15:20:52 <flaper87> Program: Queuing, Project: Marconi. We're discussing Marconi now, right?
15:21:04 <megan_w> any sort of theme we want to portray in our name?
15:21:16 <kgriffs> flaper87: right, Marconi
15:21:17 <malini> do we need something tht will encompass notifications too?
15:24:46 <kgriffs> swift, sahara, nova, etc. don't have much to do with what their projects actually do. let's not try too hard.
15:25:33 <notmyname> (marconi is a really great name for a system that broadcasts messages to listeners)
15:25:46 <notmyname> kgriffs: also, are you saying swift is slow?!?!? ;-)
15:26:12 <kgriffs> notmyname: that's *precisely* what I was implying. :)
15:26:26 <kgriffs> unfortunately, someone owns the Marconi trademark...
15:26:45 <malini> will somebody do the vetting tht our new name wont have legal issues too?
15:26:52 <megan_w> yes
15:26:54 <megan_w> i'll do that
15:27:13 <megan_w> marketing recommended we come up with three options and submit them for legal review
15:27:38 <malini> great!
15:28:13 <kgriffs> take your pick
15:28:13 <kgriffs> https://en.wikipedia.org/wiki/List_of_rivers_in_India
15:28:48 <malini> kgriffs: which of those can you remember the easiest?
15:28:57 <notmyname> carrier (as in pigeon), {copper | fiber} (as in what carries messages), express (as in the pony express)
15:28:59 <malini> qn open to all non-Indians
15:29:29 <malini> notmyname: Cuprum
15:29:57 <kgriffs> copper
15:29:58 <kgriffs> hmmm
15:29:59 <kgriffs> not bad
15:30:29 <megan_w> yeah, i like copper too
15:31:07 <malini> Can we call it Cuprum ? the Latin name http://en.wikipedia.org/wiki/Copper
15:31:28 <mpanetta> Hmm
15:31:57 <malini> we are too creative with names!
15:32:26 <Obulpathi> Cuprum +1
15:32:44 <tjanczuk> In Polish, "Cuprum" has a very close connotation to the end of the intestinal tract opposite of mouth. But I can survive it.
15:32:59 <kgriffs> ROFL
15:33:12 <vkmc> lol
15:33:12 <kgriffs> tjanczuk: what is
15:33:14 <flaper87> people, lets get some votes on the etherpad
15:33:16 <kgriffs> "river" in polish?
15:33:23 <tjanczuk> rzeka
15:33:26 <megan_w> ok, why don't we pick one "river" name, one message carrier name, and maybe one more
15:33:27 <malini> tjanczuk: we definitely dont want Cuprum, in tht case
15:33:31 <kgriffs> flaper87: let's get a final, master list.
15:33:55 <megan_w> then if legal says they are all free, we can do a vote
15:33:55 <kgriffs> Let me make a new list at the bottom. Everyone put your 2 favorites on it
15:33:58 <flaper87> yup, that's what I meant. I put some +1 on the ones I like
15:34:17 <tjanczuk> One last one: tamtam. It is used for sending signals. and as far as I can tell it is trademark free.
15:34:20 <abettadapur> river = rzeka(polish) = rio(spanish) ...
15:35:56 <malini> I like tamtam
15:36:11 <cpallares> Zaqar = messaging god in Mesopotamian mythology
15:36:28 <megan_w> cpallares: thats cool
15:36:33 <mpanetta> Oh sweet
15:36:45 <alcabrera> Zaqar, nice
15:36:45 <mpanetta> There is a messaging god? hah that is cool.
15:36:51 <sriram> Zaqar sounds really cool!
15:37:32 <kgriffs> hmm
15:37:33 <kgriffs> rio
15:37:35 <kgriffs> not bad either
15:37:50 <megan_w> ok, are we cool with submitting copper, raven, and zaqar?
15:37:51 <kgriffs> but, probably trademarked all over the place
15:38:01 <malini> how do u pronous Zaqar?
15:38:02 <megan_w> or do we want to keep it open a while longer?
15:38:03 <AAzza> how zaqar is pronaunced?)
15:38:05 <malini> pronounce*
15:38:10 <malini> hard via IRC :D
15:38:16 <megan_w> zah-car?
15:38:17 <mpanetta> I am guessing like za car?
15:38:18 <abettadapur> za - kar?
15:38:18 <malini> AAzza: same concern
15:38:19 <mpanetta> yeah
15:38:39 <tjanczuk> Did anyone think of putting up to to a vote via twtpoll?
15:39:30 <malini> Tamtam will work well with notifications too https://www.google.com/search?q=Tamtam&es_sm=91&tbm=isch&tbo=u&source=univ&sa=X&ei=-3Z7U-PlEY2VqAbwuYHgDw&ved=0CEMQsAQ&biw=1152&bih=551
15:39:57 <abettadapur> people seem to like naav
15:40:09 <malini> I dont like how it sounds :(
15:40:11 <flaper87> naav FTW
15:40:15 <flaper87> :P
15:40:23 <megan_w> ok, copper, naav, zaqar?
15:40:40 <flaper87> megan_w: looks like, I like those 3
15:40:40 <alcabrera> "nube" would amuse me greatly
15:40:43 <malini> Tamtam & Zaqar are tied megan_w
15:40:46 <flaper87> and sounds like folks do too
15:40:47 <alcabrera> megan_w: yup
15:40:48 <megan_w> we could always submit 5 and then vote after legal reviews them
15:40:58 <malini> except someone rigged the vote for Zaqar
15:41:00 <mpanetta> alcabrera: nube?
15:41:01 <cpallares> alcabrera: how do you pronounce nube?
15:41:10 * cpallares reads it as noob
15:41:11 <alcabrera> nube -> cloud (spanish)
15:41:13 <alcabrera> noo-beh
15:41:13 <cpallares> ah
15:41:15 <mpanetta> Ah!
15:41:18 <abettadapur> hehe
15:41:26 <abettadapur> lack of language context there
15:41:34 <alcabrera> :)
15:41:39 <kgriffs> meldung
15:41:45 <kgriffs> = message in German
15:41:50 <malini> kgriffs: sounds a lil yuck
15:41:53 <cpallares> LOL
15:41:53 <kgriffs> lol
15:41:58 <kgriffs> mell-doong
15:42:06 <malini> not so bad now
15:42:06 <megan_w> time check... 19 minutes left in meeting
15:42:12 <flaper87> oooook, I guess we have our options
15:42:16 <flaper87> megan_w: btw, thanks a lot :)
15:42:17 <kgriffs> but yeah, nobody will know how to say it right
15:42:35 <kgriffs> megan_w: if they will check 5, let's do that
15:42:39 <mpanetta> That is half the fun heh
15:42:43 <megan_w> cool
15:42:49 <megan_w> i'll take this from here then
15:42:57 <kgriffs> #action megan_w to check trademarks for our shortlist of names
15:43:31 <kgriffs> #topic open discussion
15:43:52 <tjanczuk> I'd like to touch on AMQP, in particular 0.9 vs 1.0
15:44:03 <flaper87> I want to propose changing the "Open Discussion" topic with "Open Party"
15:44:09 <flaper87> tjanczuk: shoot
15:44:30 <tjanczuk> I think someone mentioned during the summit there was some community feedback gathered around this? Can you point me to it?
15:44:59 <flaper87> tjanczuk: it was probably me, I'll get the emails from the mailing list
15:45:10 <flaper87> there are also IRC logs from oslo meetings
15:45:25 <flaper87> and well, the session we had last week at the summit
15:45:46 <tjanczuk> During the session I felt I did not have the data you did, hence my question now.
15:45:53 <kgriffs> flaper87: maybe you can do a summary and include that on a wiki page for the AMQP driver blueprint?
15:46:19 <flaper87> kgriffs: sounds like a good thing to have
15:46:37 <kgriffs> flaper87: is there a blueprint yet?
15:46:54 <flaper87> tjanczuk: sure, probably because I've been working closely in the amqp 1.0 implementation. I'll make sure you get the same info I have
15:47:01 <flaper87> (which is all up there)
15:47:05 <flaper87> kgriffs: I believe so, 2 secs
15:47:08 <tjanczuk> What AMQP 1.0 product are you planning to use?
15:47:31 <kgriffs> #action flaper87 to summarize 0.9 vs. 1.0 discussion in the context of openstack, add to AMQP driver bp, send to ML
15:47:37 <flaper87> I'm planning to use a amqp1.0 library. It's called qpid-proton
15:47:52 <flaper87> it can target any broker supporting amqp1.0
15:48:06 <tjanczuk> Does this implement the actual broker logic, or is this a client lib?
15:48:15 <flaper87> kgriffs: https://blueprints.launchpad.net/marconi/+spec/storage-amqp
15:48:30 <flaper87> client library
15:48:59 <flaper87> The broker can be: rabbit+plugin, qpid, apollo, activemq, or even qpid-dispatch with a mix of brokers
15:49:19 <flaper87> well, I wouldn't recommend mixing them but, just sayin'
15:49:20 <tjanczuk> I see. Would this implementation come with a recommendation for an actual broker to use? I think TC's expectation after the Mongo feedback was that there is an actual software stack that is a viable alernative.
15:49:58 <flaper87> tjanczuk: it'll likely be rabbit or qpid
15:50:14 <tjanczuk> rabbit's amqp 1.0 implementation is a toy.
15:50:41 <tjanczuk> So that would make it qpid? If you were deploying it for your mother, what would you use?
15:50:50 <flaper87> tjanczuk: I know, but it's still there. Rabbit and qpid are both supported by the community
15:51:34 <kgriffs> flaper87: can you bring this up with Devandanda and also post our plan to the ML? I would like operators to chime in before we commit.
15:52:16 <flaper87> kgriffs: I can but this has already been discussed community wise. The same library is being used for oslo.messaging
15:52:24 <tjanczuk> Basically I am concerned with this picture: http://www.google.com/trends/explore#q=rabbitmq%2C%20qpid&cmpt=q
15:52:30 <kgriffs> flaper87: is oslo messaging going to remove support for 0.9 then?
15:52:45 <flaper87> kgriffs: not remove support for 0.9 but it'll support 1.0
15:52:47 <tjanczuk> To me this is one data point about what community at large is using.
15:53:28 <tjanczuk> It also cannot be ignored that OpenStack project generally use Rabbit.
15:53:45 <flaper87> tjanczuk: TBH, that says pretty much nothing to me. We've the same in openstack. 80% of the community is using rabbit and the rest is using qpid. However, they both have serious issues
15:55:00 <tjanczuk> I am having a hard time with 80% of community using rabbit and at the same time requesting something else.
15:55:27 <flaper87> I'd like to check w/ folks in the rabbitmq team and get feedback from them about the amqp 1.0 support. Nontheless, I don't think supporting an 0.9 driver in the code base is the right thing to do
15:55:39 <flaper87> tjanczuk: I didn't say the 80% of the community want's amqp 1.0
15:55:44 <flaper87> wants*
15:56:21 <tjanczuk> I understand you didn't. So what did the community actually say?
15:56:22 <kgriffs> if we make a really awesome Redis driver, then people who don't want AGPL can use that if they don't want to deal with AMQP 1.0
15:56:50 <kgriffs> but that will still leave some subset
15:57:32 <kgriffs> ...of operators who want to deploy Marconi on AMQP and are invested in Rabbit
15:57:35 <tjanczuk> From the deployment perspective this is another product to deploy, maintain, and have a know-how about, regardless if this is redis or amqp 1.0 product.
15:57:38 <vkmc> talking about this, I would appreciate your comments on which storage backend you would like to see supported by Marconi... I've wrote a small list with the candidates here https://etherpad.openstack.org/p/storage-backend-marconi
15:58:05 <flaper87> openstack deployments already have a broker deployed
15:58:29 <tjanczuk> ... and that is not an amqp 1.0 product in most cases. it is rabbit.
15:58:41 <kgriffs> tjanczuk: yes, some operators have that concern. Others don't worry so much about adding Redis, since it is already pretty commonly used in app development... also should be more common once we add support for redis to keystone middleware via oslo.cache
15:58:55 <kgriffs> hard to please everyone. :p
15:59:19 <flaper87> every openstack module has a minimum requirement. Either it is a broker, database, cache system etc
15:59:20 <kgriffs> vkmc: let's chat in #openstack-marconi
15:59:38 <flaper87> they're not for free
15:59:40 <tjanczuk> Don't get me wrong, I am not pushing against amqp 1.0 if that is what folks want, I just want to understand the rationale. is this community? Is this technical? Or is this something written between the lines?
15:59:58 <flaper87> tjanczuk: I believe is both
16:00:15 <vkmc> kgriffs, sure!
16:00:17 <flaper87> It's*
16:00:23 <flaper87> time's up guys
16:00:26 <flaper87> great meeting
16:00:26 <alcabrera> yup
16:00:39 <flaper87> Thanks everyone!
16:00:41 <kgriffs> I'll try to get some feedback on AMQP 1.0 from Rackspace ops
16:00:56 <Obulpathi> Thanks and nice meeting you all at the summit
16:00:58 <kgriffs> #action kgriffs, megan_w to get some feedback on AMQP 1.0 from Rackspace ops
16:01:02 <kgriffs> #endmeeting