04:00:55 <samP> #startmeeting masakari
04:00:56 <openstack> Meeting started Tue Aug 22 04:00:55 2017 UTC and is due to finish in 60 minutes.  The chair is samP. Information about MeetBot at http://wiki.debian.org/MeetBot.
04:00:57 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
04:00:59 <openstack> The meeting name has been set to 'masakari'
04:01:06 <samP> Hi all o/
04:01:15 <Dinesh_Bhor> Hi all
04:01:19 <abhishekk> o/
04:01:54 <samP> #link agenda https://wiki.openstack.org/wiki/Meetings/Masakari
04:02:03 <samP> Let's start
04:02:15 <samP> First; about the release
04:02:56 <samP> Thanks to all, we were able to do the 4.0.0.0rc1 on 8/18
04:03:26 <samP> Next tag would be 4.0.0.0rc2, will be on 8/25
04:04:00 <samP> Final release 4.0.0 will be on 8/30
04:04:39 <samP> Now we have stable/pike in a separate branch, we can continue work on master for Queens
04:05:35 <samP> If you have any critical updates for stable/pike please raise them before 8/25
04:06:02 <tpatil> samP: Sure
04:06:19 <samP> 8/29 Masakari IRC team meeting would be the last place to discuss such things
04:06:22 <samP> Thanks
04:06:43 <samP> #topic Bugs
04:07:03 <samP> any bugs to discuss?
04:08:17 <samP> Since we released last week, not much to discuss here. If you have any, please use AOB to discuss them
04:08:31 <samP> Let's goto next item
04:08:46 <samP> #topic Discussion points
04:09:02 <samP> (1) Application for become OpenStack oficial project
04:09:33 <samP> Couldn't finish it. definitely do it today
04:09:39 <samP> sorry..
04:09:54 <samP> (2) Install guide document
04:10:28 <samP> I think patches are up for all documentations. Need to review them.
04:10:41 <rkmrHonjo> ok.
04:10:55 <samP> This include masakari-monitors documentations
04:11:24 <samP> I will and please review them if you have spare time
04:11:41 <samP> (3) recovery method customization
04:12:14 <samP> we need to clarify discussion points with Mistral team at PTG
04:12:32 <tpatil> Mistral etherpad is not open to add this item in the Queen PTG agenda
04:12:49 <samP> tpatil: Thanks.
04:12:57 <tpatil> IMO, For our case, there is no need to restart mistral service
04:13:31 <tpatil> but in future, if we add few actions which might requires you to restart mistral service, then that could be a problem.
04:13:46 <samP> tpatil: you said, some actions would need to restart it.
04:13:52 <tpatil> we will discuss with Mistral community to understand in what instances you need to restart mistral service
04:14:29 <tpatil> samP: For our POC, no need to restart mistral service
04:14:45 <samP> tpatil: great.
04:15:20 <samP> tpatil: But we dont know what will happen future, if some one add new action.
04:15:33 <samP> tpatil: as you said ^^
04:16:07 <samP> tpatil: let's make those clear, So, we could avoid using them.
04:16:17 <tpatil> samP: correct, so we will discuss this point with Mistral community
04:16:25 <samP> tpatil: thanks.
04:17:16 <samP> tpatil: May I ask you to add this item to Mistarl etherpad, when it opens
04:17:33 <tpatil> samP: Will do
04:18:42 <samP> #action tpatil Add item to Mistral PTG etherpad for discuss when we should restart mistral service
04:18:47 <samP> tpatil: thanks
04:19:09 <samP> (4) Find hosts without specifying segments
04:19:21 <samP> rkmrHonjo: any updates on this?
04:19:24 <rkmrHonjo> I have thought about CLI way.(This was my homework in previous meeting.) In my idea...
04:19:50 <rkmrHonjo> If user run "masakari get-host-by-segment <host name>", masakariCLI will do below processes:
04:20:14 <rkmrHonjo> 1. Call segment list API.
04:20:14 <rkmrHonjo> 2. Call host list API for each segments.
04:20:23 <rkmrHonjo> 3. If there is the specified host, masakariCLI will show following columns: segment id, segment name, host id, host name
04:20:41 <rkmrHonjo> For example, "neutron net-list" uses multiple APIs.(Network list API & Subnet list API)
04:21:25 <rkmrHonjo> So, I think that CLI way is not impossible.
04:21:34 <samP> rkmrHonjo: thanks
04:22:12 <samP> Are there any need for get singe host details in masakari?
04:22:30 <samP> I mean without segments?
04:22:52 <samP> For an Ex, monitoring masakari itself
04:23:18 <tpatil> samP: Yes, when you process notification, we get hostname from notification request
04:23:53 <tpatil> samP: but we get the host details using db apis
04:24:00 <tpatil> Dinesh: Please confirm ^^
04:24:09 <samP> tpatil: yes, correct
04:24:10 <Dinesh_Bhor> tpatil: yes correct
04:24:25 <Dinesh_Bhor> it is internal and not the user specific requirement
04:24:29 <samP> but my question is, do we need that on APIs?
04:24:50 <Dinesh_Bhor> I think, No
04:24:53 <tpatil> samP: No
04:25:05 <samP> for an ex, if we want to setup a horizon UI for masakari :)
04:25:26 <samP> probably not..
04:25:58 <samP> OK, then can we agree to go with CLI based solution for this?
04:26:18 <samP> which is proposed by rkmrHonjo
04:26:48 <rkmrHonjo> samP: OK. Should I write bp?
04:27:23 <rkmrHonjo> Ah, I'll write bp. sorry.
04:28:07 <samP> rkmrHonjo: this is a new feature for python-masakariclient, please write a bp
04:28:10 <samP> for this
04:28:16 <rkmrHonjo> samP: Sure.
04:28:55 <samP> if no objection; rkmrHonjo please proceed with CLI based solution.
04:29:39 <tpatil> samP: adding this support in CLI is simplest way to solve this problem
04:29:43 <samP> you will have another chance to raise your objections in BP or code review.
04:29:50 <samP> tpatil: sure.
04:30:46 <samP> #action rkmrHonjo crate BP and process with CLI based solution for "Find hosts without specifying segments"
04:31:48 <samP> rkmrHonjo: I assigned this item to you, is it OK?
04:32:04 <rkmrHonjo> samP: No problem.
04:32:08 <samP> rkmrHonjo: thanks
04:32:24 <samP> (5) Queens Work Items
04:32:52 <samP> I created a etherpad for this/
04:33:34 <samP> #link Queens Work Items https://etherpad.openstack.org/p/masakari-queens-workitems
04:34:02 <samP> Please add new items before 8/28
04:34:15 <samP> We could review them on 8/29 meeting
04:34:27 <tpatil> samP: Ok
04:34:34 <rkmrHonjo> samP: Sure.
04:34:46 <samP> second round would be on 9/5 meeting
04:35:05 <samP> (6) Pike work Items
04:37:01 <samP> we need to re arrange these items
04:38:18 <samP> Let's mark things done with [done] tag and not completed ones with [uncomplete] and skipped to queens ones with [skipped]
04:38:31 <rkmrHonjo> samP: ok.
04:38:44 <samP> I will put those tags, and let's do a review on our next IRC meeting
04:39:05 <samP> I will import skipped and uncomplete items to new Queens etherpad
04:39:46 <samP> Let's have a review on 8/29
04:40:02 <samP> #topic AOB
04:40:15 <samP> AOBs?
04:40:45 <samP> if nothing, we could finish meeting bit early...
04:41:16 <rkmrHonjo> I don't have AOB items.
04:41:44 <tpatil> samP: Nothing from my side too
04:42:14 <samP> OK then, thank you all for attending to this meeting..
04:42:22 <Dinesh_Bhor> thank you all
04:42:26 <samP> have a good day..
04:42:26 <rkmrHonjo> thank you.
04:42:29 <samP> bye..
04:42:30 <tpatil> Thank you all
04:42:36 <samP> #endmeeting