04:00:18 <samP> #startmeeting masakari
04:00:19 <openstack> Meeting started Tue Oct 31 04:00:18 2017 UTC and is due to finish in 60 minutes.  The chair is samP. Information about MeetBot at http://wiki.debian.org/MeetBot.
04:00:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
04:00:22 <openstack> The meeting name has been set to 'masakari'
04:00:29 <samP> Hi all for Masakari
04:00:33 <rkmrHonjo> hi
04:00:35 <Dinesh_Bhor> samP: Hi
04:00:35 <sagara> Hi
04:00:36 <abhishekk> o/
04:00:42 <tpatil> Hi
04:00:47 <samP> Hi all..
04:00:51 <samP> let's start
04:01:10 <samP> #topic High Priority Items
04:01:42 <samP> About the Project Onboarding session, I will do the session
04:02:00 <samP> If you wish to join me, please let me know.
04:02:23 <samP> I will share the slides in ML
04:02:33 <tpatil> samP: Thanks
04:02:46 <samP> tpatil: NP
04:02:58 <samP> #topic Bugs
04:03:10 <samP> #link https://bugs.launchpad.net/masakari/+bug/1728544
04:03:12 <openstack> Launchpad bug 1728544 in masakari "devstack installation of masakari fails with rabbitmq ACCESS_REFUSED" [Critical,In progress] - Assigned to Dinesh Bhor (dinesh-bhor)
04:03:28 <samP> Dinesh_Bhor: thanks for the fix
04:03:35 <Dinesh_Bhor> samP: Np
04:04:30 <samP> we have zuul -1, but its ok. lets wait for jenkins.
04:05:00 <samP> #link https://bugs.launchpad.net/masakari-monitors/+bug/1728527
04:05:01 <openstack> Launchpad bug 1728527 in masakari-monitors "hostmonitor can not monitor pacemaker_remote node via cibadmin query" [Undecided,New]
04:05:06 <rkmrHonjo> samP: In my understanding, Current jenkins is "zuul".
04:05:21 <samP> rkmrHonjo: really?
04:06:05 <rkmrHonjo> samP: Maybe. And, failure of py27 was caused by oslo.context.
04:06:23 <Dinesh_Bhor> rkmrHonjo, samP: The failing test cases should be fixed in this patch: https://review.openstack.org/#/c/513520/1
04:06:48 <samP> Dinesh_Bhor: rkmrHonjo : got it.
04:07:16 <tpatil> Let me check which Oslo.context version is used by masakari
04:07:25 <samP> It seems we still have Jenkins and Zuul. Are Zuul3 issues fixed?
04:07:27 <rkmrHonjo> Dinesh_Bhor: I thought same as you. But, that patch also failed to run py27 when I rechecked today...
04:08:24 <tpatil> oslo.context library should be added in requirements.txt
04:08:35 <rkmrHonjo> Oops, sorry, the patch I rechecked is https://review.openstack.org/#/c/513500/
04:09:13 <samP> tpatil: agree
04:09:33 <tpatil> is it using latest version 2.19.2?
04:10:12 <rkmrHonjo> tpatil: Yes. Current global-requirement blocks 2.19.1, but it doesn't block 2.19.2.
04:10:48 <tpatil> it's using 2.19.2, http://logs.openstack.org/06/516506/1/check/openstack-tox-py27/57a9fa8/tox/py27-5.log, search for oslo.context
04:13:07 <tpatil> samP: We should review this patch and get it merged as early as possible https://review.openstack.org/#/c/513520/
04:13:13 <samP> oslo.context!=2.19.1,>=2.14.0
04:14:07 <tpatil> pwd
04:14:14 <rkmrHonjo> Sorry, after all, I think that Dinesh_Bhor's opinion will be right if it can pass py27 now.
04:14:17 <tpatil> ignore my previous message
04:14:56 <rkmrHonjo> s/py27/py27 unit tests/
04:15:16 <samP> Ben put -1 to WF, till release of new oslo version
04:16:10 <samP> Is new version available? if then we could proceed. I will check and comment
04:16:54 <Dinesh_Bhor> tpatil: If we don't specify a lib in requirement.txt then it refers it from global-requirements.txt. But yes it should be added as a requirement in masakari.
04:17:08 <tpatil> # link : https://github.com/openstack/oslo.context/releases/tag/2.19.2
04:17:17 <rkmrHonjo> samP: Ben's patch depends on https://review.openstack.org/#/c/511026/ . That is merged. And, that is conteined in 2.19.2
04:17:46 <tpatil> oslo.context 2.19.2 is released
04:18:15 <samP> tpatil: rkmrHonjo Dinesh_Bhor: thanks.
04:18:48 <tpatil> samP: there are two ways to fix this problem
04:18:54 <tpatil> 1. Ben's patch
04:19:12 <tpatil> 2. Remove the project attribute from unit tests
04:19:27 <tpatil> need to weigh both these options
04:20:04 <tpatil> rkmrHonjo: Please confirm if #2 is another way to fix the unit tests issue
04:21:06 <rkmrHonjo> tpatil: Ah, ok. I confirm it after this. And, I send a mail about it to devML.
04:21:15 <samP> tpatil: thanks, both are OK, but I prefer #1. It seems correct thing to do.
04:21:19 <tpatil> rkmrHonjo: Thanks
04:21:36 <samP> rkmrHonjo: tpatil thanks
04:22:07 <samP> I will review Ben's patch and lets discuss further in ML
04:22:27 <samP> #link https://bugs.launchpad.net/masakari-monitors/+bug/1728527
04:22:29 <openstack> Launchpad bug 1728527 in masakari-monitors "hostmonitor can not monitor pacemaker_remote node via cibadmin query" [Undecided,New]
04:22:50 <samP> We have new bug reported in masakari-monitors about pacemaker remote
04:23:28 <samP> rkmrHonjo: Could you please take a look at this issue?
04:23:51 <hieulq> hi, I'm the one who filed this bug
04:23:52 <rkmrHonjo> samP: OK, I check it.
04:24:01 <samP> hieulq: Hi
04:24:10 <rkmrHonjo> hieulq: Hi. Thank you for reporting.
04:24:10 <samP> hieulq: Thank you for the report
04:24:51 <hieulq> samP, rkmrHonjo I'm finding another work-around with cibadmin -Q but seems it's impossible
04:25:26 <hieulq> cib.xml only report remote node with crmd='online' attribute if the node is guest node
04:25:39 <samP> hieulq: correct
04:26:02 <hieulq> if we create pcs resource with ocf:pacemaker:remote RA, there would be no crmd attribute in node state tag
04:26:34 <hieulq> we could be turn around with old method from hostmonitor.sh
04:26:43 <hieulq> but seems like this will be a lot of works
04:27:42 <samP> hieulq: I have check this in my environment. I use pacemaker remote and wonder why I miss this!?
04:28:14 <rkmrHonjo> hieulq: I have one question. Did you use python version at first?(or, bash version?)
04:28:47 <hieulq> rkmrHonjo, used to use bash version and now testing with python version
04:29:45 <hieulq> we dont want to use the bash version :)
04:30:18 <rkmrHonjo> hieulq: Thanks. There is a possibility that both version have same bug. But, we will fix only python version.
04:30:44 <rkmrHonjo> Because bash version will be deprecated in near future.
04:31:16 <hieulq> rkmrHonjo, the bash version worked well
04:31:32 <hieulq> because bash version check via grep'ing the status from stdout
04:31:34 <hieulq> https://github.com/openstack/masakari-monitors/blob/master/masakarimonitors/hostmonitor/hostmonitor.sh#L482
04:31:52 <rkmrHonjo> hieulq: Oh, thanks a lot. I check it.
04:31:52 <hieulq> but python version not, it checked via cibadmin query
04:32:34 <hieulq> so I think this should be fixed for next release, because without pacemaker_remote, there could be a blocking point for applying Masakari in production
04:32:35 <samP> hieulq: we need to check cibadmin and find a method to how to get same infor.
04:33:02 <hieulq> thanks samP, I'm also trying too
04:33:26 <samP> hieulq: correct. This is very important issue. Me and rkmrHonjo will look into this
04:33:52 <rkmrHonjo> samP: I got it.
04:34:12 <hieulq> thanks samP and rkmrHonjo :)
04:34:15 <samP> hieulq: if you would like to discuss or share some info please use openstack-dev [masakari]
04:34:28 <hieulq> sure
04:34:53 <samP> because next week or tow, most of us will not available on IRC.
04:35:06 <samP> hieulq: thanks again..
04:35:22 <samP> Any other bugs to discuss?
04:35:52 <rkmrHonjo> #link https://bugs.launchpad.net/masakari/+bug/1724764
04:35:54 <openstack> Launchpad bug 1724764 in masakari "service_type and service_name which is specified in nova_catalog_admin_info are not used" [Undecided,New] - Assigned to takahara.kengo (takahara.kengo)
04:36:08 <samP> rkmrHonjo: thanks for bringing this up
04:36:27 <rkmrHonjo> tpatil: Takahara is improving the bug description of above LP now.
04:36:52 <rkmrHonjo> So please wait a little more.
04:36:59 <tpatil> rkmrHonjo: Ok
04:37:12 <rkmrHonjo> tpatil: thanks.
04:37:18 <samP> rkmrHonjo: OK thank you..
04:37:31 <samP> takahara: thanks
04:37:51 <samP> #topic Discussion points
04:38:07 <samP> (1) Horizon Plugin
04:38:25 <samP> Any updates or any thing to discuss?
04:38:51 <tpatil> Niraj will submit patches to create a repo, it will be done by e.o.d today
04:39:07 <samP> tpatil: sure, Thanks
04:39:22 <samP> (2) Install guide document
04:39:44 <samP> As we discussed, Its better to merge this docs before summit.
04:40:11 <abhishekk> I have fixed review comments given on the patches
04:40:14 <samP> I will review and let's try merge those in this week.
04:40:22 <samP> abhishekk: thanks.
04:41:14 <samP> (3) recovery method customization
04:41:31 <samP> I think this spec will update soon. right?
04:41:45 <tpatil> samP: Yes
04:41:53 <Dinesh_Bhor> samP: yes,
04:42:07 <samP> tpatil: Dinesh_Bhor thank you..
04:42:12 <samP> (4) Find hosts without specifying segments
04:42:36 <rkmrHonjo> samp: Tahakara finished to write the spec according to your opinion.
04:42:52 <rkmrHonjo> Please check it.
04:43:07 <samP> rkmrHonjo: takahara: thanks, I will check it.
04:43:13 <rkmrHonjo> samP: thanks.
04:43:34 <samP> #action samP review https://review.openstack.org/#/c/506986/
04:44:02 <samP> (5) Queens Work Items
04:44:12 <samP> No update from my side.
04:44:25 <samP> (6) BMHA
04:44:31 <samP> No update from my side.
04:44:51 <samP> (7) OpenStack Proposal Bot updates
04:45:46 <tpatil> there are total 3 patches up for review
04:45:55 <samP> Still have some issues. But I will fix and merge existing patches
04:47:06 <samP> #link https://review.openstack.org/#/c/509782/
04:47:13 <samP> #link https://review.openstack.org/#/c/495291/
04:47:25 <samP> #link https://review.openstack.org/#/c/477955/
04:48:02 <samP> #topic AOB
04:48:14 <samP> Any other items to discuss?
04:49:15 <samP> Most of us in summit next week. Therefore, there will be no IRC meeting in next week.
04:49:49 <rkmrHonjo> ok.
04:50:31 <Dinesh_Bhor> okay
04:50:36 <samP> If you need to discuss any thing, please use the openstack-dev ML with [masakari]
04:51:02 <samP> if no other items to discuss, let's finish the meeting for today..
04:51:22 <samP> Thank you all..
04:51:27 <rkmrHonjo> thank you.
04:51:29 <abhishekk> thank you
04:51:36 <tpatil> Thanks
04:51:43 <Dinesh_Bhor> Thank you all
04:51:50 <samP> #endmeeting