04:00:25 <tpatil> #startmeeting Masakari
04:00:26 <openstack> Meeting started Tue May 15 04:00:25 2018 UTC and is due to finish in 60 minutes.  The chair is tpatil. Information about MeetBot at http://wiki.debian.org/MeetBot.
04:00:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
04:00:29 <openstack> The meeting name has been set to 'masakari'
04:00:31 <tpatil> Hi All
04:00:44 <Dinesh_Bhor> Hi
04:00:46 <niraj_singh> Hi
04:00:47 <lkwan_> hi all
04:01:13 <tpatil> Today Sampath is busy so he won't join this meeting
04:01:47 <tpatil> #topic High priority items
04:02:02 <tpatil> Introspective Instance Monitoring
04:02:06 <tpatil> specs are approved
04:02:14 <lkwan_> thanks.
04:02:25 <tpatil> welcome!!!
04:02:38 <tpatil> I have started reviewing masakari monitor patch
04:02:41 <tpatil> #link : https://review.openstack.org/#/c/534958/
04:03:30 <lkwan_> feel free to ping us in IRC for any questions
04:03:52 <tpatil> lkwan_: Sure, I have observed few coding guidelines issues which I post soon on above patch
04:04:20 <lkwan_> np... please do so.
04:04:41 <tpatil> lkwan_: Then I will review code from functional stand point of view
04:05:16 <lkwan_> for python-masakariclient, do we have a working code in stable/queens?
04:05:33 <lkwan_> or any update on openstacksdk?
04:06:08 <tpatil> lkwan_: stable/queens, I will need some time to confirm on this point
04:06:22 <lkwan_> or master is fine
04:06:35 <tpatil> #action: Tushar, check if stable/queens is working fine
04:07:20 <tpatil> for python-masakariclient, we will need to merge this patch
04:07:23 <tpatil> #link : https://review.openstack.org/#/c/557634/3
04:07:31 <tpatil> on master branch
04:08:06 <tpatil> masakari-monitors doesn't require masakariclient anymore
04:08:19 <lkwan_> still missing approval on Workflow
04:08:24 <tpatil> and masakari-monitors requires openstacksdk 0.13.0 which is already out
04:08:48 <tpatil> on that patch, we need another +2 and then someone can set workflow + 1
04:09:04 <tpatil> I will request other core reviewers to approve the patch
04:09:14 <lkwan_> thanks.
04:09:56 <tpatil> #topic Bugs (stuck/critical)
04:10:38 <lkwan_> for the meeting time, as there is no other teams using 03:00 , can someone update irc-meetings/meetings/masakari-team-meeting.yaml
04:10:51 <lkwan_> as we discussed last time?
04:11:34 <tpatil> Sampath will post that patch soon
04:11:39 <lkwan_> thanks
04:11:43 <lkwan_> for the bug, https://bugs.launchpad.net/python-masakariclient/+bug/1756047
04:11:44 <openstack> Launchpad bug 1756047 in python-masakariclient "masakari command failed due to os-service-type1.2.0" [Critical,Confirmed]
04:12:25 <lkwan_> is that https://review.openstack.org/#/c/557634/3 will address all issues?
04:12:40 <tpatil> correct
04:12:44 <lkwan_> does anyone try it out yet?
04:12:52 <lkwan_> test it out?
04:13:14 <Dinesh_Bhor> lkwan_: yes, it is working
04:13:19 <tpatil> yes, Dinesh and I tried it out yesterday and we were able to run masakari commands
04:14:13 <lkwan_> hope that we can get another +2 and then the workflow +1 soon
04:15:06 <tpatil> We will merge this patch today or in worst case by tomorrow
04:15:53 <tpatil> Any other bugs (stuck/critical) open for discussion?
04:16:59 <tpatil> #topic  Discussion points
04:17:10 <tpatil> Horizon Plugin
04:17:37 <tpatil> any updates?
04:17:44 <niraj_singh> Fixed the review comments and uploaded all the patches on community gerrit.
04:18:05 <niraj_singh> Did some UI change and code optimization
04:18:17 <tpatil> niraj_singh: Thanks, We will start reviewing those patches soon
04:18:25 <niraj_singh> ok
04:18:42 <tpatil> Recovery method customization
04:19:07 <tpatil> We are still working on the specs
04:19:41 <tpatil> Ansible support for Masakari
04:19:44 <lkwan_> we would like to follow up about the status of the ‘Masakari ansible roles’ development.
04:19:58 <lkwan_> The OPNFV HA Group that Greg and others work with is interested in integrating Masakari into the next release of OPNFV and needs the ansible work done in order to integrate it into their XCI installer.
04:20:35 <niraj_singh> i am working on testinf part of masakari-api and engine currently
04:20:53 <tpatil> niraj_singh: OK
04:20:55 <lkwan_> date?
04:21:12 <lkwan_> target date to be ready?
04:21:53 <tpatil> lkwan_: We plan to finish it by Rocky release. But presently we are stuck with pacemaker deployment
04:22:07 <tpatil> as of today, you can deploy masakari-api and masakari-engine
04:22:16 <tpatil> GitHub repo: https://github.com/openstack/openstack-ansible-os_masakari
04:22:37 <niraj_singh> yes
04:22:52 <tpatil> we are now working on implementing role for deploying masakari-monitor (only on compute nodes) which requires pacemaker
04:23:48 <lkwan_> any other dependencies ?
04:23:50 <tpatil> niraj_singh: there is already one ansible plugin available outside openstack to deploy pacemaker
04:24:08 <tpatil> niraj_singh: which one is that?
04:24:47 <niraj_singh> yes https://github.com/mrlesmithjr/ansible-pacemaker
04:25:34 <niraj_singh> i am using the above role for pacemaker
04:26:01 <tpatil> lkwan_: pacemaker/corosync
04:26:22 <lkwan_> Overall, is it still on track to deliver in Rocky Milestone-2?
04:26:43 <tpatil> and finally we need multi node setup to test it functionally
04:29:29 <tpatil> lkwan_: if we can use above pacemaker ansible role, then we have some hope to finish it by Rocky-Milestone 2. We have limited resources to work on this feature
04:30:02 <tpatil> the above pacemaker role can only deploy 16 nodes in the cluster as per Readme which makes me worry
04:31:10 <Dinesh_Bhor> PACEMAKER_REMOTE  will help in this.
04:31:36 <Dinesh_Bhor> It allows to scale beyond the corosync 16-node limit.
04:31:59 <Dinesh_Bhor> #link https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/7/html/high_availability_add-on_reference/pacemaker_remote
04:32:36 <niraj_singh> ok
04:32:50 <tpatil> Does it support for all OSes? is it open sourced?
04:33:06 <Dinesh_Bhor> tpatil: yes
04:33:31 <lkwan__> network issue, just rejoin
04:33:52 <tpatil> Dinesh_Bhor: Is there ready made ansible role that we can re-use directly?
04:34:08 <Dinesh_Bhor> tpatil: checking...
04:36:35 <tpatil> niraj_singh: Can we please take some help from openstack-ansible team to find out how to deploy pacemaker/corosync? Is someone already working on it? or we need to develop it from scratch
04:37:22 <Dinesh_Bhor> tpatil: I think we can use the existing pacemaker ansible role and just change the package to be installed to *pacemaker_remote* instead of *pacemaker*.
04:38:18 <niraj_singh> i asked ansible members regarding this. The said there is not any official role for this.
04:38:31 <tpatil> Dinesh_Bhor: Yes, that's one option. Also we need to read the license and confirm if we can use it without any issues.
04:38:36 <niraj_singh> We can use any which satisfies the requirement.
04:38:50 <tpatil> niraj_singh: Ok
04:41:56 <tpatil> niraj_singh: You will also need multiple node setup to test https://github.com/mrlesmithjr/ansible-pacemaker, correct?
04:42:08 <niraj_singh> yes
04:42:31 <tpatil> I will discuss with Sampath about it
04:42:46 <niraj_singh> ok.
04:43:23 <tpatil> for now, let's check ansible-pacemaker ansible role to see if we can use PACEMAKER_REMOTE
04:43:43 <niraj_singh> ok i will got through it.
04:43:52 <tpatil> also contact cluster labs people and ask for their suggestion
04:44:01 <niraj_singh> ok
04:44:47 <tpatil> #topic AOB
04:44:52 <lkwan__> niraj_singh or tpatil,  is it still on track to deliver in Rocky Milestone-2
04:46:30 <tpatil> lkwan__: if we can use above pacemaker ansible role, then we have some hope to finish it by Rocky-Milestone 2. We have limited resources to work on this feature
04:47:02 <tpatil> and finally we need multi node setup to test it functionally
04:47:12 <lkwan__> got it.
04:47:15 <lkwan__> thanks.
04:47:36 <tpatil> Migrate from launchpad to Storyboard
04:47:59 <tpatil> Anyone interested to volunteer this work?
04:48:36 <Dinesh_Bhor> tpatil: I will check this.
04:48:56 <tpatil> Dinesh_Bhor: Great, Thanks
04:49:19 <tpatil> Any other topic left for discussion?
04:50:40 <Dinesh_Bhor> Nothing from my side.
04:50:58 <tpatil> Looks None, Let's end this meeting
04:51:02 <tpatil> Thank you all for your time
04:51:08 <lkwan__> thanks.
04:51:10 <Dinesh_Bhor> Thank you all
04:51:11 <tpatil> #endmeeting