04:00:23 <tpatil> #startmeeting Masakari
04:00:24 <openstack> Meeting started Tue Jun 16 04:00:23 2020 UTC and is due to finish in 60 minutes.  The chair is tpatil. Information about MeetBot at http://wiki.debian.org/MeetBot.
04:00:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
04:00:27 <openstack> The meeting name has been set to 'masakari'
04:00:32 <tpatil> Hi All
04:00:38 <suzhengwei_> hi
04:00:49 <tpatil> FYI: Today, Sampath san is not available.
04:00:57 <tpatil> suzhengwei_: Hi
04:01:20 <tpatil> #topic Critical Bugs
04:01:54 <tpatil> Any critical bugs to be discussed?
04:02:19 <suzhengwei_> https://review.opendev.org/#/c/720623/
04:02:36 <suzhengwei_> expired notifications
04:03:33 <tpatil> If you run masakari-engine on multiple host, then the periodic task has some issues
04:03:38 <tpatil> in the current design
04:03:49 <tpatil> Are you planning to work on it?
04:04:44 <tpatil> I have checked your comment and as per your testing, this is not an issue, is it correct?
04:05:19 <suzhengwei_> I have test it on multiple hosts. Will some one else test uultiple masakari-api/engine too?
04:07:49 <tpatil> I will check with Sampath san if there is any plan to perform such testing on multiple hosts
04:08:19 <suzhengwei_> ok
04:09:25 <suzhengwei_> https://review.opendev.org/#/c/702328/, it needs another +2.
04:10:28 <tpatil> suzhengwei_: Yes, I will ping Sampath san to review this patch
04:10:41 <suzhengwei_> thanks
04:10:52 <tpatil> #action: Sampath san to review patch : https://review.opendev.org/#/c/702328
04:11:42 <tpatil> #topic Victoria Work Items
04:13:23 <tpatil> Add enable option to segment
04:14:01 <tpatil> I have approved the specs, need another +2 from Sampath san
04:14:22 <suzhengwei_> good news
04:15:14 <tpatil> suzhengwei_: Do you have any other update about this work item?
04:15:58 <suzhengwei_> Yes, I have update patch. Due to tempest env, it still failed.
04:16:26 <tpatil> Are you referring to masakari-functional-devstack-multinode Job?
04:17:42 <suzhengwei_> I'm not sure. Recently, other project CI env failed too.
04:18:24 <suzhengwei_> It looks like a CI env problem.
04:18:34 <tpatil> On last PS 13, I can see the above CI job is failing which actually run the functional tests and not tempest tests.
04:19:01 <tpatil> It doesn't seem like issue with your patch
04:19:16 <suzhengwei_> yep
04:20:05 <suzhengwei_> Let's wait CI recovery :)
04:20:15 <tpatil> Apart from this issue, I will review your updated PS soon.
04:20:27 <suzhengwei_> thank you.
04:20:49 <tpatil> Moving next
04:21:00 <tpatil> Spec for host monitor by consul
04:21:18 <tpatil> I will review the updated spec soon
04:21:25 <tpatil> #link : https://review.opendev.org/#/c/734017
04:21:32 <tpatil> I have one question
04:21:58 <tpatil> Are you planning to write functional tests for testing this feature?
04:23:10 <suzhengwei_> Maybe not. I have no experience about functional test.
04:23:32 <tpatil> We need a new CI job similar to masakari-functional-devstack-multinode
04:24:06 <suzhengwei_> yes. Can we ask help from other people?
04:24:13 <tpatil> Ok, I will discuss about it with Sampath san so that someone can help you in adding a new CI job to install Consul on devstack and do the configuration so that functional tests can be run on it.
04:24:51 <suzhengwei_> en
04:25:14 <suzhengwei_> ok
04:26:27 <tpatil> Evacuate non-recovery instances
04:26:38 <tpatil> #link: https://review.opendev.org/#/c/702427/
04:27:17 <tpatil> We had discussed about it in the last meeting and awaiting for Sampath san feedback
04:27:34 <suzhengwei_> yes, I have give a comment to it.
04:27:40 <tpatil> right
04:27:55 <suzhengwei_> But some details should be clear.
04:28:05 <tpatil> I can understand your point from operator's point of view. It's pain to configure the tenant_id
04:28:40 <tpatil> the other proposal is to add a metadata to segment, so that tenant_id can be set in metadata instead of config option.
04:28:51 <tpatil> Let's wait for Sampath san feedback
04:31:14 <tpatil> suzhengwei_: Do you have any more topic for discussion?
04:31:33 <tpatil> if not, let's end this meeting early
04:32:00 <suzhengwei> I have something to talk about.
04:32:15 <tpatil> Please go ahead
04:32:42 <suzhengwei> https://review.opendev.org/#/c/732477/
04:32:54 <suzhengwei> promotion for large scale hosts failure
04:33:50 <tpatil> I will review this spec sometime in this week
04:34:26 <suzhengwei> thanks
04:35:16 <suzhengwei> https://review.opendev.org/#/c/733428/, a little and simple change, would you like to give +2?
04:36:19 <tpatil> done
04:36:38 <suzhengwei> thank you.
04:37:42 <tpatil> Any other topic?
04:39:22 <suzhengwei> none
04:39:56 <tpatil> OK, Let's end this meeting early then
04:40:06 <suzhengwei> Bye
04:40:10 <tpatil> Thank you all
04:40:11 <tpatil> Bye
04:40:20 <tpatil> #endmeeting