07:00:27 <yoctozepto> #startmeeting masakari
07:00:28 <openstack> Meeting started Tue Nov 10 07:00:27 2020 UTC and is due to finish in 60 minutes.  The chair is yoctozepto. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:00:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
07:00:31 <openstack> The meeting name has been set to 'masakari'
07:00:39 <yoctozepto> #topic Roll-call
07:00:46 <yoctozepto> \o/
07:03:05 <yoctozepto> #topic Agenda
07:03:21 <yoctozepto> * Roll-call
07:03:24 <yoctozepto> * Agenda
07:03:27 <yoctozepto> * Announcements
07:03:30 <yoctozepto> ** OpenStack Victoria Release Community Meeting - Thu 2020-11-12 16:00 UTC (yoctozepto presenting Masakari)
07:03:34 <yoctozepto> ** Teams cleanup http://lists.openstack.org/pipermail/openstack-discuss/2020-November/018542.html
07:03:38 <yoctozepto> * Review action items from the last meeting
07:03:42 <yoctozepto> * CI status
07:03:45 <yoctozepto> * Backports pending reviews
07:03:49 <yoctozepto> ** Should we release the non-current stable branches?
07:03:53 <yoctozepto> * Release planning
07:03:56 <yoctozepto> ** Review action items from the Wallaby vPTG https://etherpad.opendev.org/p/masakari-wallaby-vptg
07:04:01 <yoctozepto> * Open discussion
07:04:08 <yoctozepto> #topic Announcements
07:04:22 <yoctozepto> #topic OpenStack Victoria Release Community Meeting - Thu 2020-11-12 16:00 UTC (yoctozepto presenting Masakari)
07:04:30 <yoctozepto> #undo
07:04:31 <openstack> Removing item from minutes: #topic OpenStack Victoria Release Community Meeting - Thu 2020-11-12 16:00 UTC (yoctozepto presenting Masakari)
07:04:47 <yoctozepto> #topic Announcements
07:04:59 <yoctozepto> #info OpenStack Victoria Release Community Meeting - Thu 2020-11-12 16:00 UTC (yoctozepto presenting Masakari)
07:05:28 <yoctozepto> please be informed that this week is the OpenStack Community Meeting for Victoria
07:05:43 <yoctozepto> I will be presenting Masakari so you might be interested
07:06:00 <yoctozepto> other projects will present themselves too
07:06:07 <yoctozepto> feel welcome to join
07:06:37 <yoctozepto> #info Teams cleanup http://lists.openstack.org/pipermail/openstack-discuss/2020-November/018542.html
07:06:46 <yoctozepto> I plan to clean the teams up tomorrow
07:07:14 <yoctozepto> please read the linked message and reply if needed
07:07:56 <yoctozepto> #topic Review action items from the last meeting
07:08:19 <yoctozepto> There were no action items assigned during the previous meeting
07:08:39 <yoctozepto> #topic CI status
07:09:22 <yoctozepto> Masakari not running periodics so hard to tell; generally green
07:10:54 <yoctozepto> #action yoctozepto to add periodic jobs to masakari
07:11:19 <yoctozepto> #topic Backports pending reviews
07:12:37 <yoctozepto> #link https://bit.ly/2UeoIiN
07:13:01 <yoctozepto> so there are those 3 pending for the dashboard
07:13:35 <suzhengwei> I can't access the link https://bit.ly/2UeoIiN
07:13:49 <yoctozepto> oh
07:14:17 <yoctozepto> that is a very important feedback, thank you
07:15:12 <yoctozepto> I (among others) have been shortening the links in places where the long ones are hard to read, but if they are blocked in China, it does not make sense to use them
07:15:24 <yoctozepto> #undo
07:15:25 <openstack> Removing item from minutes: #link https://bit.ly/2UeoIiN
07:15:30 <yoctozepto> #link https://review.opendev.org/#/q/(project:openstack/masakari+OR+project:openstack/masakari-monitors+OR+project:openstack/python-masakariclient+OR+project:openstack/masakari-dashboard)+status:open+-branch:master
07:15:38 <yoctozepto> ugly but worky :D
07:16:45 <suzhengwei> thanks
07:17:33 <yoctozepto> #action yoctozepto to replace bit.ly links with their long forms
07:19:37 <yoctozepto> well, back to the topic - please review those, I will self-approve tomorrow if nobody does before
07:19:50 <yoctozepto> though I would like to avoid that
07:20:13 <yoctozepto> #topic Should we release the non-current stable branches?
07:20:55 <yoctozepto> the topic is the question but also: Do you know of a change worth of backporting that has not been backported?
07:22:00 <suzhengwei_> No. Mostly backpoered.
07:22:37 <yoctozepto> please let me know by tomorrow if you find something worthy of backporting (or just backport yourselves)
07:22:48 <suzhengwei_> ok
07:22:55 <yoctozepto> I will propose stable releases then to let the public benefit from all the accumulated patches
07:23:26 <yoctozepto> (and to show that the project is alive)
07:24:34 <suzhengwei_> ping
07:24:41 <yoctozepto> suzhengwei_: pong
07:25:05 <yoctozepto> #topic Release planning
07:25:19 <yoctozepto> #topic Review action items from the Wallaby vPTG https://etherpad.opendev.org/p/masakari-wallaby-vptg
07:26:20 <yoctozepto> has anyone had a chance to do something about the assigned actions?
07:26:45 * yoctozepto did something, yes
07:27:09 <yoctozepto> well, then, please share, yoctozepto
07:27:49 <yoctozepto> (suzhengwei) Enable/Disable evacuation segment wise +1+1 -- TODO(yoctozepto): check nova and other projects regarding this
07:27:52 <yoctozepto> and so I did
07:28:01 <yoctozepto> the result is on the whiteboard
07:28:15 <yoctozepto> http://codesearch.openstack.org/?q=disabled.*BooleanField&i=nope&files=&repos=
07:28:20 <suzhengwei_> thanks, I will check it later.
07:28:20 <yoctozepto> http://codesearch.openstack.org/?q=disabled.*Column&i=nope&files=&repos=
07:28:25 <yoctozepto> nova and cinder seem to prefer 'disabled' because of the default (disabled=False) making most sense
07:28:28 <yoctozepto> suzhengwei_: thanks!
07:29:00 <yoctozepto> so I felt right that we should rather call it 'disabled' as that is the accepted practice
07:30:10 <yoctozepto> suzhengwei__: unstable connection, huh?
07:30:20 <suzhengwei__> yep
07:30:33 <yoctozepto> suzhengwei__: worry not, you will be able to read all the logs/summary afterwards
07:31:02 <yoctozepto> #action suzhengwei to reflect upon yoctozepto's findings about disabled/enabled
07:31:16 <yoctozepto> the next one I have done is
07:31:26 <yoctozepto> (nautik) Way to disable instance evacuation if operator defaults to evacuating all instances +1+1 -- TODO(yoctozepto): check how it could be possible in the current state
07:31:37 <yoctozepto> DONE(yoctozepto): I confirm it is entirely impossible
07:31:58 <yoctozepto> well, this one was pretty simple; indeed there is no way to have this scenario currently
07:33:27 <yoctozepto> I left an anonymous TODO if anyone wants to pick up and move this further
07:33:38 <yoctozepto> and finally
07:33:39 <suzhengwei__> yes, there is no perfect solution.
07:33:53 <yoctozepto> (yoctozepto/nautik) what do `control_attributes` do? (apparently nothing!) -- TODO(yoctozepto,jopdorp,suzhengwei,nautik): verify in code
07:34:00 <yoctozepto> DONE(yoctozepto):
07:34:04 <yoctozepto> monitors do not care at all
07:34:08 <yoctozepto> engine does not care at all
07:34:14 <yoctozepto> API requires it present and stores it in the database (no further actions on it)
07:34:26 <yoctozepto> this is basically the summary (also available in the etherpad)
07:34:59 <yoctozepto> I doubt others assigned really need to go over this but please feel welcome to do so
07:36:02 <suzhengwei__> me too
07:37:40 <yoctozepto> I left another anonymous TODO for anyone wishing to proceed further
07:37:55 <yoctozepto> that is all I have done regarding the PTG actions
07:38:01 <yoctozepto> anyone else?
07:38:12 <yoctozepto> (mostly asking suzhengwei__ because all others are silent today)
07:38:35 <suzhengwei__> retry check when host failure.
07:39:06 <suzhengwei__> I have a rough code change. https://review.opendev.org/#/c/761704/
07:39:44 <yoctozepto> #link https://review.opendev.org/761499
07:39:46 <yoctozepto> ^ spec
07:40:48 <yoctozepto> #link https://review.opendev.org/761704
07:40:54 <yoctozepto> ^ reference implementation
07:41:05 <yoctozepto> I have updated the PTG etherpad as well with this information
07:41:07 <yoctozepto> thanks suzhengwei__
07:41:34 <suzhengwei__> wait for response from you.
07:41:48 <yoctozepto> I have added the spec to my queue of reviews
07:41:54 <suzhengwei__> thanks
07:42:19 <yoctozepto> anyone else? anything else?
07:42:46 <suzhengwei__> no.
07:43:15 <yoctozepto> #topic Open discussion
07:43:43 <yoctozepto> please let me know if there is anything to discuss at this moment
07:44:35 <yoctozepto> #action yoctozepto to switch masakari focus in launchpad from victoria to wallaby
07:45:04 <yoctozepto> #action yoctozepto to clean teams up
07:45:12 <yoctozepto> #action yoctozepto to release stable branches
07:45:27 <yoctozepto> (I have just done a summary of extra actions for me)
07:48:03 <suzhengwei__> We can finish the meeting earlier:)
07:53:58 <yoctozepto> yeah, I wanted to give others time
07:54:13 <yoctozepto> thank you suzhengwei__ for attending
07:54:17 <yoctozepto> #endmeeting