07:01:49 <yoctozepto> #startmeeting masakari
07:01:49 <openstack> Meeting started Tue Nov 24 07:01:49 2020 UTC and is due to finish in 60 minutes.  The chair is yoctozepto. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:01:50 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
07:01:52 <openstack> The meeting name has been set to 'masakari'
07:02:00 <jopdorp> Here
07:02:01 <yoctozepto> #topic Roll-call
07:02:06 <yoctozepto> \o/
07:02:13 <jopdorp> o/
07:02:24 <suzhengwei> \o/
07:02:37 <jopdorp> :D
07:04:46 <yoctozepto> #topic Agenda
07:04:53 <yoctozepto> * Roll-call
07:04:57 <yoctozepto> * Agenda
07:05:01 <yoctozepto> * Announcements
07:05:05 <yoctozepto> ** New Masakari versions released from stable branches
07:05:09 <yoctozepto> ** Masakari Stein moved to EM (Extended Maintenance) stage
07:05:12 <yoctozepto> ** Teams cleanup has happened http://lists.openstack.org/pipermail/openstack-discuss/2020-November/018542.html
07:05:15 <yoctozepto> * Review action items from the last meeting
07:05:18 <yoctozepto> * CI status
07:05:22 <yoctozepto> * Backports pending reviews
07:05:25 <yoctozepto> * Release planning
07:05:29 <yoctozepto> ** Review action items from the Wallaby vPTG https://etherpad.opendev.org/p/masakari-wallaby-vptg
07:05:32 <yoctozepto> * Open discussion
07:05:39 <yoctozepto> #topic Announcements
07:05:49 <yoctozepto> #info New Masakari versions released from stable branches
07:06:03 <yoctozepto> finally some fixes will reach the stable users
07:06:37 <yoctozepto> #info Masakari Stein moved to EM (Extended Maintenance) stage
07:07:05 <yoctozepto> it's this time of the cycle when we move the oldest stable to EM
07:07:17 <yoctozepto> and it has happened for Masakari as well
07:07:43 <yoctozepto> #info Teams cleanup has happened http://lists.openstack.org/pipermail/openstack-discuss/2020-November/018542.html
07:08:31 <yoctozepto> I did not receive any response from SamP nor Tushar
07:08:42 <jopdorp> ok
07:08:45 <yoctozepto> so I guess we can assume they are the current ghosts in the team
07:08:55 <jopdorp> agreed
07:08:56 <yoctozepto> other ghosts removed though
07:09:09 * yoctozepto very sad about this
07:09:18 <yoctozepto> but what can we do now
07:09:39 <yoctozepto> #topic Review action items from the last meeting
07:09:52 <yoctozepto> #link http://eavesdrop.openstack.org/meetings/masakari/2020/masakari.2020-11-10-07.00.html
07:09:59 <yoctozepto> yoctozepto to add periodic jobs to masakari
07:10:13 <yoctozepto> I've propose a bunch of changes, please review and approve
07:12:25 <yoctozepto> #link https://review.opendev.org/q/topic:%22ci-periodic-jobs%22+(status:open%20OR%20status:merged)
07:12:37 <yoctozepto> yoctozepto to replace bit.ly links with their long forms
07:12:39 <yoctozepto> I did
07:12:48 <yoctozepto> suzhengwei to reflect upon yoctozepto's findings about disabled/enabled
07:12:54 <yoctozepto> suzhengwei: have you had a chance to?
07:14:05 <suzhengwei> a little opinion
07:14:30 <suzhengwei> I notice Keystone uses 'enabled' (default True) in service table.
07:14:59 <yoctozepto> hmm
07:15:51 <yoctozepto> let me check quickly
07:16:19 <suzhengwei> Cli # openstack service list --long
07:16:44 <jopdorp> where are the findings themselves?
07:17:03 <suzhengwei> Using 'disabled' is not conforming.
07:19:30 <yoctozepto> suzhengwei: well, using 'disabled' makes us conform to nova's practices (and I usually follow those) but indeed it seems there is not set-in-stone best practice as keystone is doing it differently
07:20:01 <yoctozepto> I am ok to continue with the current approach to avoid unnecessary extra work, thanks
07:20:15 <yoctozepto> jopdorp: agreeing too?
07:20:18 <jopdorp> yes
07:20:58 <yoctozepto> #agreed go with `enabled` for segments as there is no need to force ourselves to rewrite to `disabled` (no universal practice exists)
07:21:00 <yoctozepto> thanks
07:21:12 <yoctozepto> yoctozepto to switch masakari focus in launchpad from victoria to wallaby
07:21:13 <yoctozepto> I did
07:21:22 <yoctozepto> yoctozepto to clean teams up
07:21:26 <yoctozepto> I did (already announced)
07:21:33 <yoctozepto> yoctozepto to release stable branches
07:21:38 <yoctozepto> I did (already announced)
07:21:56 <yoctozepto> #topic CI status
07:23:12 <yoctozepto> it's green, just not much happening
07:23:23 <yoctozepto> #topic Backports pending reviews
07:25:02 <yoctozepto> there are none
07:26:09 <yoctozepto> #topic Release planning
07:26:19 <yoctozepto> #info Review action items from the Wallaby vPTG https://etherpad.opendev.org/p/masakari-wallaby-vptg
07:26:34 <yoctozepto> how is it going?
07:26:50 <jopdorp> I looked at the specs by suzhengwei
07:27:04 <jopdorp> and started going through the code
07:27:13 <jopdorp> for docs
07:27:14 <yoctozepto> thanks, I saw your contributions
07:27:21 <yoctozepto> verry nice
07:27:47 <jopdorp> it's turning out a bit different from what was discussed in the ptg
07:28:08 <jopdorp> but I needed to get some overview of the code first so went with code structure first
07:28:12 <jopdorp> I
07:28:23 <yoctozepto> what do you mean by 'different from what was discussed'?
07:28:33 <jopdorp> I'll do another iteration to look at the examples and correctness of the docs
07:29:11 <jopdorp> and maybe make some general recommendations on the docs
07:30:00 <jopdorp> i didn't write anything here yet
07:30:01 <jopdorp> https://etherpad.opendev.org/p/masakari-doc-inspection
07:32:02 <yoctozepto> jopdorp: that's ok; as long as it gets somewhere public
07:32:09 <jopdorp> yes
07:32:23 <jopdorp> i did make this spec also
07:32:24 <jopdorp> https://review.opendev.org/c/openstack/masakari-specs/+/762517
07:32:30 <jopdorp> it was a todo from the ptg
07:32:38 <yoctozepto> we should ideally follow the community-wise goal to have more standardized contributor docs
07:33:02 <jopdorp> I'm waiting for reviews on that one before starting on the next spec about migration of vm's back to hosts after they aren't in failed state anymore
07:33:17 <yoctozepto> I saw the spec, but I'm running in negative time space so could not react
07:33:24 <yoctozepto> please others review too
07:33:58 <suzhengwei> I will review it
07:34:03 <jopdorp> thanks
07:35:08 <jopdorp> yoctozepto: https://review.opendev.org/c/openstack/masakari/+/763035
07:35:31 <jopdorp> does that have to do with the standardization?
07:36:26 <yoctozepto> jopdorp: yeah, but it's very rudimentary cleanup :-)
07:36:38 <jopdorp> ok
07:37:20 <jopdorp> do you have a link to contributor docs guidelines?
07:37:43 <jopdorp> I'm fine with following some standard, but have no idea what it is
07:37:49 <yoctozepto> #link https://storyboard.openstack.org/#!/story/2007236
07:38:19 <yoctozepto> also, you can look at an example of how we did that for kolla
07:38:23 <yoctozepto> #link https://review.opendev.org/c/openstack/kolla/+/730589
07:38:41 <yoctozepto> likely you might want to see other projects, just follow the storyboard
07:40:04 <jopdorp> thanks
07:40:27 <yoctozepto> you are welcome
07:41:59 <jopdorp> \
07:42:01 <jopdorp> do you have a link to contributor docs guidelines?
07:42:03 <jopdorp> oops
07:42:07 <jopdorp> my son says hello
07:42:24 <jopdorp> regard those messages as unsent
07:43:17 <suzhengwei> ^-^
07:44:53 <yoctozepto> jopdorp: say hello to your son as well
07:45:02 <jopdorp> done!
07:45:02 <yoctozepto> jopdorp: already proficient in English :-)
07:45:17 <jopdorp> xD
07:46:10 <jopdorp> suzhengwei: could you also look at this one https://review.opendev.org/c/openstack/masakari/+/458793
07:47:04 <suzhengwei> I will
07:48:04 <jopdorp> Thanks
07:49:25 <suzhengwei> You are welcome.
07:50:47 <yoctozepto> jopdorp: have you checked whether it will now act like nova (or others) do?
07:51:00 <yoctozepto> I am not entirely sure about that redirect
07:51:21 <jopdorp> I did not check that
07:51:40 <jopdorp> Only implemented the way that was proposed in the comments
07:51:44 <yoctozepto> I see
07:51:52 <yoctozepto> please do, I'll do when I get to it for sure
07:52:01 <yoctozepto> ok, now for anything else you want to tell me (and the world
07:52:07 <yoctozepto> #topic Open discussion
07:55:25 <yoctozepto> nothin?
07:55:27 <yoctozepto> :D
07:55:41 <suzhengwei> I have nothing to disscuss.
07:55:46 <jopdorp> Haha
07:55:49 <jopdorp> Me neither
07:57:34 <yoctozepto> all righty
07:57:53 <yoctozepto> thank you for joining
07:57:59 <yoctozepto> #endmeeting