07:01:56 <yoctozepto> #startmeeting masakari
07:01:58 <openstack> Meeting started Tue Feb 23 07:01:56 2021 UTC and is due to finish in 60 minutes.  The chair is yoctozepto. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:01:59 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
07:02:01 <openstack> The meeting name has been set to 'masakari'
07:02:06 <yoctozepto> #topic Roll-call
07:02:09 <yoctozepto> \o/
07:02:11 <yoctozepto> morning jopdorp_
07:02:18 <jopdorp_> o/
07:02:19 <yoctozepto> morning suzhengwei_
07:02:42 <suzhengwei_> oo/
07:03:12 <yoctozepto> #topic Agenda
07:03:23 <yoctozepto> * Roll-call
07:03:23 <yoctozepto> * Agenda
07:03:23 <yoctozepto> * Announcements
07:03:23 <yoctozepto> * Review action items from the last meeting
07:03:23 <yoctozepto> * CI status
07:03:23 <yoctozepto> * Backports pending reviews
07:03:24 <yoctozepto> * Masakari CLI was deprecated in Stein already. https://docs.openstack.org/releasenotes/python-masakariclient/stein.html
07:03:25 <yoctozepto> ** We should confirm OSC has feature parity at the moment, e.g., no changes were merged that did not touch OSC side as well (if necessary).
07:03:25 <yoctozepto> * Release planning https://etherpad.opendev.org/p/masakari-wallaby-vptg
07:03:25 <yoctozepto> * Open discussion
07:03:40 <yoctozepto> #topic Announcements
07:03:45 <yoctozepto> I have none; anyone?
07:04:34 <jopdorp_> no
07:04:54 <yoctozepto> #topic Review action items from the last meeting
07:04:56 <suzhengwei_> It is difficulty to pull code from openstack gerrit recently. Do you?
07:05:04 <yoctozepto> there were none
07:05:05 <jopdorp_> i didn't
07:05:14 <yoctozepto> suzhengwei_: not difficulties I guess
07:05:18 <jopdorp_> didn't notice anything wrong
07:05:21 <yoctozepto> but it is slow
07:05:41 <yoctozepto> try to always fetch from opendev.org before going to review.opendev.org
07:06:09 <suzhengwei_> ok.
07:06:37 <yoctozepto> if you have serious issues with it, you should talk to the infra folks on #openstack-infra
07:06:59 <yoctozepto> #topic CI status
07:07:16 <yoctozepto> CI looks green
07:07:41 <yoctozepto> #topic Backports pending reviews
07:07:54 <yoctozepto> there are none
07:08:17 <yoctozepto> #topic Masakari CLI was deprecated in Stein already. https://docs.openstack.org/releasenotes/python-masakariclient/stein.html
07:08:26 <yoctozepto> ** We should confirm OSC has feature parity at the moment, e.g., no changes were merged that did not touch OSC side as well (if necessary).
07:08:39 <yoctozepto> this is something suzhengwei_ brought to my attention
07:09:27 <yoctozepto> are you willing to work on this aspect? I would love to see us drop the legacy command in this cycle to avoid further confusion
07:10:17 <yoctozepto> the plan would be to check whether the OSC client is able to perform all possible actions (that the legacy client can)
07:10:42 <yoctozepto> I guess it could boil down to comparing whether there were any changes to the legacy client from train till now
07:10:50 <yoctozepto> as that would mean the osc did not get them by mistake
07:11:16 <yoctozepto> more thorough analysis would be welcome
07:11:22 <yoctozepto> but this is a sane minimum I guess
07:11:46 <yoctozepto> (I pause now, please read the above messages and let me know)
07:12:25 <jopdorp_> I'm not sure how much work it would be
07:12:53 <jopdorp_> i guess I could have a look
07:12:58 <yoctozepto> jopdorp_: comparing since stein should be quick as I have not seen many changes
07:13:13 <yoctozepto> the thorough analysis would be a bit harder as it boils down to actually reading current code
07:13:29 <yoctozepto> still, our client is nothing compare to nova/neutron/whatever :D
07:13:34 <yoctozepto> compared*
07:13:36 <jopdorp_> hehe
07:13:41 <suzhengwei_> It just have 1.1 microverson since train.  for bp progress-details-recovery-workflows
07:14:16 <yoctozepto> yeah, but it is in OSC, no?
07:14:20 <jopdorp_> should i compare stein masakari cli to stein osc train to train etc?
07:14:45 <yoctozepto> ok, let me do a bit of an introduction
07:14:52 <yoctozepto> python-masakariclient is the repo
07:14:58 <jopdorp_> yes
07:15:10 <yoctozepto> in there the common code for interacting with masakari as a client lives
07:15:27 <yoctozepto> and it has both the legacy (standalone) client
07:15:34 <yoctozepto> and the OSC hooks
07:15:38 <jopdorp_> right
07:16:00 <yoctozepto> (I think it's called hooks, anyway, the other wording is that it implements an OSC plugin)
07:16:21 <yoctozepto> so the minimum goal is to inspect changes
07:16:27 <yoctozepto> happening after stein was released
07:16:37 <yoctozepto> (so for train, ussuri, victoria, wallaby [now])
07:17:22 <yoctozepto> and if they touched only common code - great, only OSC code - great, both frontends - great, only legacy - bad (unless it was just fixing the legacy for some purpose)
07:17:28 <suzhengwei_> It is 1.1 miscroversion in OSC.
07:17:43 <yoctozepto> suzhengwei_: yeah, that makes sense
07:17:53 <jopdorp_> ok
07:17:58 <yoctozepto> after either coverage analysis
07:18:07 <yoctozepto> we should finally enact the deprecation-cycle drop
07:18:14 <yoctozepto> and no longer provide the legacy client
07:18:29 <jopdorp_> what do you mean by coverage analysis?
07:18:41 <jopdorp_> compare to the api?
07:18:59 <jopdorp_> or compare legacy to osc?
07:19:06 <jopdorp_> or test coverage
07:19:09 <yoctozepto> jopdorp_: the thing I was talking about: either minimum via "what new has happened" or "really compare the two codes"
07:19:19 <jopdorp_> ok
07:19:35 <jopdorp_> i think i can d that
07:20:44 <yoctozepto> ok, I think it's possible that we 3 can do that by the next meeting
07:21:24 <yoctozepto> #action everybuddy to check whether we can drop the legacy client
07:21:43 <yoctozepto> #topic Release planning https://etherpad.opendev.org/p/masakari-wallaby-vptg
07:22:02 <yoctozepto> #link https://releases.openstack.org/wallaby/schedule.html
07:22:25 <yoctozepto> it's R-7 !
07:22:42 <yoctozepto> R-5 is feature freeze and final release of clients
07:23:15 <jopdorp_> ok
07:23:27 <yoctozepto> R-3 is RC1
07:23:47 <yoctozepto> how are we faring with the new changes?
07:23:57 <jopdorp_> i just went through my incoming reviews
07:24:09 <jopdorp_> added a couple of nits
07:24:36 <jopdorp_> and there was one line in https://review.opendev.org/c/openstack/masakari-monitors/+/761704
07:24:40 <yoctozepto> good
07:24:43 <jopdorp_> that i think wasn't in line with the spec
07:24:56 <yoctozepto> ack, I will check
07:25:24 <yoctozepto> I am now moving most of my extra time slots towards masakari
07:25:45 <yoctozepto> (I love the last minute stress lol)
07:25:51 <jopdorp_> haha
07:26:04 <yoctozepto> anyhow, let me check the queues
07:26:13 <yoctozepto> I think there is something we should merged
07:26:16 <yoctozepto> have*
07:26:17 <yoctozepto> asap
07:26:47 <yoctozepto> ah, yes
07:26:50 <yoctozepto> #link https://review.opendev.org/c/openstack/masakari/+/768022
07:26:54 <jopdorp_> i checked this one https://review.opendev.org/c/openstack/masakari/+/458793
07:26:57 <yoctozepto> jopdorp_, suzhengwei_: ^^
07:27:37 <jopdorp_> oooh, scary one
07:27:45 <yoctozepto> but we need to merge it
07:28:25 <jopdorp_> I didn't see it yet
07:29:47 <openstackgerrit> Radosław Piliszek proposed openstack/masakari master: Segment description allows multiline characters  https://review.opendev.org/c/openstack/masakari/+/574614
07:30:21 <suzhengwei_> I'm having bad network condiction in my workgroud.
07:30:57 <yoctozepto> suzhengwei_: ack, you can read the logs later then and let me know if you need me for something
07:31:36 <suzhengwei_> ok
07:33:03 <yoctozepto> ok, that's everything from me in here
07:33:07 <yoctozepto> #topic Open discussion
07:38:04 <jopdorp_> well\
07:43:04 <jopdorp_> i don't have anything to discuss
07:46:15 <yoctozepto> all right, let's close this session
07:46:17 <yoctozepto> thank you
07:46:23 <yoctozepto> and remember to review that one asap
07:46:34 <yoctozepto> #endmeeting