06:10:28 <yoctozepto> #startmeeting masakari
06:10:28 <opendevmeet> Meeting started Tue Aug 24 06:10:28 2021 UTC and is due to finish in 60 minutes.  The chair is yoctozepto. Information about MeetBot at http://wiki.debian.org/MeetBot.
06:10:28 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
06:10:28 <opendevmeet> The meeting name has been set to 'masakari'
06:10:30 <yoctozepto> \o/
06:10:45 <yoctozepto> (we need to reschedule or just accept this delay)
06:11:25 <yoctozepto> (the daylight time saving will go away soon though so I will change my habits anyhow, let's see then)
06:12:51 <yoctozepto> anyone else around?
06:13:50 <yoctozepto> suzhengwei, shenxinxin?
06:14:37 <yoctozepto> let me kickstart the meeting by a quick announcement
06:14:44 <suzhengwei> sorry, I am here
06:14:59 <yoctozepto> http://lists.openstack.org/pipermail/openstack-discuss/2021-August/024253.html
06:15:10 <yoctozepto> ^ I have nominated myself for the role of PTL for another cycle
06:17:50 <suzhengwei> ok
06:19:03 <shenxinxin> ok
06:20:25 <yoctozepto0> meh, internet issues it seems
06:20:55 <yoctozepto0> I was writing that
06:21:07 <yoctozepto0> you can still nominate yourself if any of you want to be the PTL
06:21:16 <yoctozepto0> I can help with the process
06:21:29 <yoctozepto0> anyhow, the project has its future secured for now
06:21:36 <yoctozepto0> let's start with the agenda
06:21:53 <yoctozepto0> * CI status
06:21:53 <yoctozepto0> * Important pending reviews (important bugfixes, backports)
06:21:53 <yoctozepto0> * Next release planning
06:21:53 <yoctozepto0> * Open discussion
06:21:57 <yoctozepto0> #topic CI status
06:22:49 <yoctozepto0> seems green
06:23:08 <yoctozepto0> I want to extend our CI coverage though, expect more jobs running around
06:23:37 <yoctozepto0> #topic Important pending reviews (important bugfixes, backports)
06:23:43 <yoctozepto0> I don't think we have any but let's check
06:26:26 <suzhengwei_> yes, none.
06:27:12 <yoctozepto> yes
06:27:22 <yoctozepto> my internet connection is lagging greatly
06:27:34 <yoctozepto> #topic Next release planning
06:27:45 <yoctozepto> ok, so I looked at the current situation
06:27:50 <yoctozepto> and we don't have much time left
06:28:07 <yoctozepto> I suggest we focus on a single feature for this cycle :-(
06:28:18 <suzhengwei_> agree
06:28:22 <yoctozepto> I think consul-based monitoring would be best
06:28:45 <yoctozepto> as it has the least of interdependencies and has been discussed the most
06:28:58 <yoctozepto> and it seems directly valuable to the community
06:29:54 <yoctozepto> what do you think?
06:30:27 <suzhengwei_> Let's try our best to complete Xena release.
06:31:41 <yoctozepto> indeed, but what should we focus on? I suggested consul
06:32:11 <suzhengwei_> Consul driverd hostmonitor is most potential.
06:32:22 <suzhengwei_> me too
06:32:28 <yoctozepto> ok, great
06:32:32 <yoctozepto> then we have consensus :-)
06:33:07 <yoctozepto> #agreed focus on consul-based hostmonitor as the flag feature of this cycle (xena)
06:33:58 <yoctozepto> ok, so, focusing on that... I see you have updated the spec, thanks
06:34:04 <yoctozepto> I see also it fails in CI
06:34:08 <yoctozepto> I will fix it
06:35:42 <suzhengwei_> a little weird. No file added or deleted.
06:36:02 <suzhengwei_> It passed last time but failed this time.
06:36:11 <yoctozepto> suzhengwei_: it just says "/home/zuul/src/opendev.org/openstack/masakari-specs/doc/source/specs/xena/approved/host-monitor-by-consul.rst:76:Blank line required after table."
06:36:15 <yoctozepto> so it's a simple fix ;-)
06:37:23 <suzhengwei_> It gives me misunderstood message.
06:37:43 <suzhengwei_> stderr: 'fatal: There is no path doc/source/specs/xena/approved/host-monitor-by-consul.rst in the commit
06:38:23 <opendevreview> Radosław Piliszek proposed openstack/masakari-specs master: host monitor by consul  https://review.opendev.org/c/openstack/masakari-specs/+/734017
06:38:58 <yoctozepto> suzhengwei_: nah, ignore that because zuul tries to match the ephemeral file to files in the commit
06:39:05 <yoctozepto> just read the job logs
06:39:16 <yoctozepto> if you click on the job that failed
06:39:21 <yoctozepto> you get to a screen with results
06:39:30 <suzhengwei_> thanks for your fix.
06:43:08 <yoctozepto> could you update the image?
06:43:32 <yoctozepto> if it's too hard, I can just write in text that it's inaccurate and should be interpreted differently
06:47:44 <suzhengwei_> It's really tough to edit the image.
06:48:55 <yoctozepto> ok
06:49:14 <yoctozepto> I will add a sufficient description and we can merge
06:49:32 <yoctozepto> how's the implementation? is it now following the current spec?
06:50:05 <suzhengwei_> yes, it follows the spec.
06:50:23 <yoctozepto> ok
06:51:10 <yoctozepto> we also need a way to deploy consul; I want to avoid the situation with current hostmonitor where it's not documented well nor tested thoroughly in CI
06:52:43 <suzhengwei_> I add a simple doc about consul usage.
06:53:35 <suzhengwei_> I would like to give some help to deploy guide in kolla or other tools.
06:54:57 <suzhengwei_> Would you like try to
06:54:58 <suzhengwei_> integrate it with Kolla?
06:55:09 <suzhengwei_> :)
06:57:42 <yoctozeptoclone> I have no idea if there were any replies nor if my messages went through
06:57:59 <yoctozeptoclone> the internet connection is a joke today
06:58:18 <yoctozeptoclone> my last message was:
06:58:19 <yoctozeptoclone> we also need a way to deploy consul; I want to avoid the situation with current hostmonitor where it's not documented well nor tested thoroughly in CI
06:59:12 <suzhengwei_> I add a simple doc about consul usage. I would like to give some deploy guide.
06:59:23 <yoctozepto9> ok, very well
06:59:34 <suzhengwei_> Would you like try to  integrate it with Kolla? :)
07:00:08 <yoctozepto9> yeah, I was planning to but I can't promise delivery in this cycle unless someone helps :-)
07:00:19 <yoctozepto9> ok, need to wrap up; the time is up
07:00:24 <yoctozepto> thank you for the discussion today
07:00:38 <yoctozepto> #endmeeting