15:00:36 <ad_rien_> #startmeeting massively_distributed_clouds
15:00:37 <openstack> Meeting started Wed Jan  4 15:00:36 2017 UTC and is due to finish in 60 minutes.  The chair is ad_rien_. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:40 <openstack> The meeting name has been set to 'massively_distributed_clouds'
15:00:43 <ad_rien_> #chair ad_rien_
15:00:44 <openstack> Current chairs: ad_rien_
15:00:47 <msimonin> o/
15:00:53 <serverascode> hi
15:00:54 <ad_rien_> agenda
15:01:09 <ad_rien_> #link https://etherpad.openstack.org/p/massively_distributed_ircmeetings_2017 line 15
15:01:24 <ansmith> o/
15:01:36 <ad_rien_> Hi folks
15:01:45 <ad_rien_> To start, I wish you all the best for 2017 ;)
15:02:02 <msimonin> thanks ad_rien_ :)
15:02:41 <denaitre_> o/
15:02:47 <ad_rien_> #topic previous meeting action items
15:03:10 <HeleneCoullon> o/
15:03:11 <ad_rien_> So regarding the last minute I cannot chair it unfortunately but I saw that you made few comments regarding the first slides we proposed
15:03:20 <ad_rien_> Hi HeleneCoullon denaitre_
15:03:49 <ad_rien_> I updated the slides in order to take into account the comments you made
15:04:38 <ad_rien_> ansmith:  I saw that you proposed to clarify the AMQP bricks in order to make a distinction between RabbitMQ/QPID/ZeroMq…
15:05:03 <ad_rien_> I just copied/pasted the slide and added a comment to ask you to update the figure according to the QPID bricks
15:05:09 <ansmith> ad_rein_: yes, the conversation was to have oslo.messaging be the service at the block level
15:05:27 <ansmith> and then show relationship to backend(s) at next level down
15:05:35 <ad_rien_> #link https://docs.google.com/presentation/d/1jJFZejZqgYDxu5FX4K8g3I5zQ87afnjYI4VSRSuCQ6U/edit#slide=id.p
15:05:49 <ad_rien_> so if you go on the slides
15:06:10 <ad_rien_> and you give a look at slides 2 and 3, you will see the comment.
15:06:26 <ad_rien_> May I ask you to update Slide 3 for QPID
15:06:28 <ad_rien_> ?
15:07:24 <ansmith> I will take the action to update the slide
15:07:54 <ad_rien_> ok great
15:08:08 <ansmith> ad_rien_: are you ok if I introduce oslo.messaging client/server blocks?
15:08:13 <ad_rien_> #action update slides for QPid and RabbitMQ
15:08:29 <ansmith> and then show relation to rabbit/amqp/zmq backends?
15:08:31 <ad_rien_> ansmith:  yes please feel free to propose a new slide
15:08:44 <ansmith> ad_rien_: perfect
15:08:52 <ad_rien_> you folks from redhat are probably the best one to propose such a vision
15:09:10 <ad_rien_> ok
15:10:14 <ad_rien_1> or does anyone wants to add something on the current deployment scenarios we identified
15:10:32 <ad_rien_1> (sorry I'm facing network issues)
15:11:09 <ad_rien_1> so the next topic is to try to identify the pros/cons on the different scenarios
15:11:33 <ad_rien_1> Joe Huang added  a comment in that direction this morning
15:11:42 <ad_rien_1> #topic Identify pros/cons of the different approaches
15:12:13 <ad_rien_1> So apart from the SPOF (single point of failure) of the current approach, do you see some issues ?
15:13:04 <ad_rien_1> From Inria, we are going to conduct performance experiments to identify network constraints in terms of latency/bandwidth
15:13:22 <ad_rien_1> for example in Scenario 1 (the simplest one)
15:13:51 <ad_rien_1> We would like to identify to what extent it is relevant from the network WAN constraint viewpoint.
15:14:32 <ad_rien_1> That is, we would like to see whether the network can be a strong constraint that can prevent such a deployment
15:14:46 <ad_rien_1> maybe latency issues, ....
15:15:02 <ad_rien_1> between nova-computes and services that are deployed on site 0
15:15:39 <msimonin> Like trying to  find what are the minimum bandwidth and latency requirements to operate compute nodes far from core services ?
15:15:55 <ad_rien_1> Exactly msimonin
15:16:10 <ad_rien_1> It would be great to identify other experiments we can do to identify weaknesses or confirm advantages
15:16:50 <ad_rien_1> so folks any idea?  ansmith? serverascode?
15:17:02 <serverascode> nothing from me, just lurking for now :)
15:17:07 <msimonin> :)
15:17:14 <ansmith> ad_rien_1: quick question on scenario 1, is nova-compute to services via L2 or L3?
15:17:51 <ansmith> e.g. any assumptions about openstack config
15:17:52 <ad_rien_1> L3 I would say
15:18:07 <ad_rien_1> since you go through the WAN
15:18:40 <msimonin> I guess we'll first experiment using the same L2 segment and try to figure out how to go through L3
15:19:11 <ad_rien_1> msimonin:  can you elaborate please ?
15:20:10 <msimonin> From the experimentation we'll first go on the same L2 segment with network constraints and then got over L3 in the next iteration
15:20:20 <msimonin> just suggesting :)
15:20:24 <ad_rien_1> ok thanks
15:20:35 <msimonin> ansmith: is there any known deployment over L3 ?
15:20:35 <ad_rien_1> Ok I took some notes on our pad
15:21:22 <ansmith> ad_rien_l: some stretch site models extend the l2, with l3, there may be more configuration to consider of openstack services
15:21:48 <ansmith> ad_rien_l: I don't have direct experience there
15:22:05 <ad_rien_1> ansmith:  I tried to write down this in the pad
15:22:13 <ad_rien_1> line 35
15:22:26 <msimonin> ansmith:  what services do you have in mind ?
15:23:58 <ansmith> msimonin: thinking more generally that if there is an "internal mgmt" subnet, that the openstack api and messaging services likely reside on it
15:24:31 <ansmith> msimonin: so if WAN is l2, everything should just "work"
15:24:41 <msimonin> ansmith: sure :)
15:24:51 <ad_rien_1> so we have an action that is to identify lack of functionality according to the different scenario
15:25:12 <msimonin> I guess here some feedback/experience from telecom network would be beneficial
15:25:15 <ad_rien_1> How can we do that ?
15:25:40 <msimonin> Nobody from orange here ? : )
15:26:02 <ad_rien_1> I mean we can at Inria take one or two scenarios and try to identify functional limitations (before performing performance experiments) but we need some helps for other scenarios
15:26:06 <ad_rien_1> That is the first possibility
15:26:31 <ad_rien_1> The second is to try to prioritize the different scenarios and start by focusing on the most important/representative/relevant one ?
15:26:57 <ad_rien_1> serverascode:  AFAIK, we did not finalize our choice in the telecom WG?
15:27:00 <ad_rien_1> did you ?
15:27:25 <serverascode> in terms of distributed clouds? no don't think we finalized anything
15:27:35 <ad_rien_1> #action Identify functional needs/limitations for each scenario
15:27:52 <ad_rien_1> I mean in terms of what can be the minimal NFV deployment
15:27:58 <ad_rien_1> ?
15:28:14 <msimonin> yes
15:28:16 <ad_rien_1> By merging our effort we can probably progress faster
15:28:34 <serverascode> ah ok, no we haven't finalized anything, just agreed to start working on a document to define it
15:28:40 <ad_rien_1> ok
15:28:49 <serverascode> in terms of a "generic NFV platform based on OpenStack"
15:28:58 <ad_rien_1> yepp
15:29:39 <ad_rien_1> We met some folks form create-net during the cloudcom conference in december
15:29:59 <ad_rien_1> the guys investigate the scenario 1 (i.e. slide 0) in a context of edge computing
15:30:10 <ad_rien_1> (i.e. they have a large cloud and few remote compute nodes).
15:30:22 <ad_rien_1> For the moment, they only performed paper works
15:30:59 <ad_rien_1> and told us that they are interested by following our progress. I hope they will join us. but once again, if we can combine our effort, it would be valuable for all of us
15:31:22 <ad_rien_1> for Fog/Edge scenario 1 looks to be the simplest
15:31:31 <ad_rien_1> I do not know whether it makes sense for NFV operators
15:33:00 <ad_rien_1> ok so getting back to my initial question: how can we move forward. Can we sort the different scenarios?
15:33:07 <ad_rien_1> and focus on the most important one?
15:33:49 <ad_rien_1> #action prioritize the different scenarios
15:34:11 <msimonin> if some people are interested in scenario 1 we should start by this one
15:34:37 <ad_rien_1> +1
15:34:37 <msimonin> => compute far from core services
15:35:02 <ad_rien_1> this will also enable the evaluation of other messaging solutions
15:35:24 <ad_rien_1> so let's focus on this first scenario. Is it ok for everyone?
15:35:29 <ansmith> +1
15:36:39 <ad_rien_1> #info everyone agrees to start with scenario 1
15:36:41 <kgiusti> +1
15:36:45 <msimonin> :)
15:37:00 <ad_rien_1> so let's move to the next topic
15:37:07 <ad_rien_1> #topic ENOS status
15:37:15 <msimonin> yeah !
15:37:26 <msimonin> so
15:37:45 <ad_rien_1> msimonin:  can you please briefly introduce what is ENOS and how it can be helpful to investigate the different scenarios ?
15:37:53 <ad_rien_1> I give you 3 minutes :)
15:38:04 <msimonin> thanks :)
15:38:19 <msimonin> #link https://github.com/beyondtheclouds/enos
15:38:38 <msimonin> we've build a tool to evaluate openstack in various connfiguration and topology
15:38:49 <msimonin> there is a white paper somewhere
15:38:53 <msimonin> let me find the link
15:39:36 * msimonin searching :)
15:39:56 <msimonin> #link https://hal.inria.fr/hal-01415522v2
15:40:01 <msimonin> found it :)
15:40:17 <msimonin> so we already made some scalability tests
15:40:23 <msimonin> presented at Barcelona
15:40:41 <msimonin> and we plan to extend to support multiregion deployment as well as
15:40:46 <msimonin> network constraints enforcement
15:41:08 <msimonin> so basically we'll be able to evaluate the different scenarios
15:41:14 <msimonin> (hopefully :) )
15:41:49 <msimonin> I think that's all for the overview ad_rien_1 :)
15:41:56 <ad_rien_1> thanks
15:42:21 <ad_rien_1> Just to complete, Scenario 1 can be evaluated, Scenario 2 is cells (for the moment we do not consider it as the cell v2 refactoring is under heavy development) and finally,  Scenarios 3 can be  evaluated.
15:42:25 <ad_rien_1> is it correct?
15:42:30 <msimonin> yes
15:42:37 <ad_rien_1> thanks
15:43:01 <ad_rien_1> so the next step regarding ENOS is to investigate how we can deploy other messaging solutions such as QPiD
15:43:30 <ad_rien_1> ansmith:  kgiusti: are there ansible playbooks to deploy QPID ?
15:43:42 <ad_rien_1> (actually ENOS is leveraging kolla and ansible)
15:44:03 <ansmith> ad_rien_l, msimonin: there is puppet module but ansible shouldnt take too much
15:44:34 <msimonin> could you link the puppet module ?
15:45:14 <ad_rien_1> or even better, if you can provide some ansible playbooks if doing the port is not too time consuming ;) ?
15:45:44 <ansmith> puppet module reference in etherpad
15:45:52 <msimonin> ansmith: ack
15:46:32 <ansmith> ad_rien_l: will assess ansible effort
15:46:38 <ad_rien_1> thanks
15:47:02 <ad_rien_1> #action ansmith will give a look to ansible playbooks for QPID
15:47:23 <ad_rien_1> is there any question regarding ENOS?
15:48:06 <ad_rien_1> ok so let's move to the next topic
15:48:39 <ad_rien_1> #topic expected capabilities for Massively distributed/Fog/Edge clouds
15:48:57 <ad_rien_1> as I mentioned I was not chairing the last meeting
15:49:09 <msimonin> Last time we started to discuss migration with someone from orange
15:49:17 <ad_rien_1> so based on the logs it looks like this point was not sufficiently discussed
15:49:22 <ad_rien_1> ok
15:49:31 * ad_rien_1 is looking for the logs.
15:49:40 <msimonin> but he seems not here today
15:50:54 <ad_rien_1> #action do not forget to discuss about migration between remote sites with Orange folks
15:52:04 <ad_rien_1> Can eveyone access the pad: https://etherpad.openstack.org/p/massively_distributed_ircmeetings_2017 ?
15:52:07 <ad_rien_1> #link https://etherpad.openstack.org/p/massively_distributed_ircmeetings_2017
15:52:33 <ad_rien_1> I just copied/pasted few ideas we have at Inria regarding this topic.
15:52:50 <ad_rien_1> can you go through the notes and put +1 if you believe it makes sense.
15:54:35 <ad_rien_1> We have 5 minutes before ending the meeting?
15:54:44 <ad_rien_1> any comments on the expected capabilities?
15:55:22 <ad_rien_1> it seems not so I propose to switch to the last topic.
15:55:34 <ad_rien_1> and we will come back on this point later.
15:55:39 <ad_rien_1> #topic Open Discussion
15:55:57 <ad_rien_1> So from my side, just two remarks (already written in the pad)
15:56:15 <ad_rien_1> 1./ We talked about folks from RedHat that are investigating Fog/Edge computing challenges.
15:56:35 <ad_rien_1> ansmith:  kgiusti any chance to talk with them during one of our meetings?
15:56:50 <ad_rien_1> I think it would be really great to exchange our point of views.
15:57:10 <ansmith> ad_rien_l: I reached out to them prior to break and they were very interested, I will follow up
15:57:39 <ad_rien_1> #action ansmith will check whether other folks from redhat can participate to the WG.
15:57:44 <ad_rien_1> thanks ansmith
15:57:52 <ad_rien_1> we can discuss my second point later
15:58:00 <ad_rien_1> we have just two more minutes.
15:58:09 <ad_rien_1> So I prefer to leave the floor to you guys
15:58:19 <ad_rien_1> anything from your side ?
15:58:34 <serverascode> nohting from me
15:58:55 <ad_rien_1> ok thanks for attending the meetinhg
15:59:04 <ad_rien_1> talk to you in two weeks.
15:59:13 <ad_rien_1> bye
15:59:22 <serverascode> thanks!
15:59:25 <ad_rien_1> #endmeeting
15:59:25 <ansmith> thanks
15:59:47 <ad_rien_> #endmeeting