15:01:32 <Menthos> #startmeeting massively_distributed_clouds
15:01:34 <openstack> Meeting started Wed Jan 18 15:01:32 2017 UTC and is due to finish in 60 minutes.  The chair is Menthos. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:37 <openstack> The meeting name has been set to 'massively_distributed_clouds'
15:02:17 <Menthos> Hi everyone
15:02:41 <Menthos> May I ask who's here?
15:02:56 <pramchan> #info pramchan
15:03:01 <ansmith> o/
15:03:07 <kgiusti> o/
15:03:08 <denaitre> hi o/
15:03:08 <mabderrahim> o/
15:03:26 <Menthos> #link https://etherpad.openstack.org/p/massively_distributed_ircmeetings_2017 Today's agenda (line 83)
15:03:29 <rcherrueau> o/
15:03:31 <msimonin> Menthos: o/
15:03:45 <Menthos> So as you may have noticed I will be chairing this meeting :-)
15:03:45 <dancn> Hello, I am Daniele P. from FBK, we will present our institution and work later
15:04:18 <Menthos> Hello dancn, thank you for joining us!
15:04:59 <Menthos> Okay so I guess we can start
15:05:10 <Menthos> #topic Announcements
15:05:25 <dsantoro> Hello, I'm Daniele S. working with Daniele P. in FBK institution
15:05:48 <Menthos> First I would like to remind you to put your name in the pad, line 85
15:05:58 <pramchan> #hello prakash from Futurewie Inc USA
15:06:04 <Menthos> Hello dsantoro
15:07:00 <Menthos> #undo
15:07:01 <openstack> Removing item from minutes: #topic Announcements
15:07:06 <Menthos> #topic Co-chairs
15:07:18 <Menthos> So the first topic is about chairing
15:07:34 <Menthos> Is anyone interested in co-chairing the meetings?
15:07:55 <Menthos> We think someone that is not from Inria would bring some diversity
15:07:59 <pramchan> #sure I can cochair pramchan add me
15:08:33 <Menthos> Thanks pramchan :-)
15:08:41 <Menthos> #chair pramchan
15:08:42 <openstack> Current chairs: Menthos pramchan
15:09:24 <Menthos> Anyone else?
15:09:37 <pramchan> #does anyone has any inputs from last meeting?
15:09:48 <Menthos> We can come back to this at the end of the meeting
15:09:59 <pramchan> OK
15:10:17 <Menthos> #link http://eavesdrop.openstack.org/meetings/massively_distributed_clouds/2017/massively_distributed_clouds.2017-01-04-15.00.html minutes from the last meeting
15:10:24 <Menthos> So let's move on
15:10:36 <Menthos> #topic New institution: FBK
15:11:04 <dsantoro> FBK is a research institution (http://www.fbk.eu/) based in Trento - Italy which is composed by several research centers. Our unit (DISCO, https://disco.fbk.eu/) is part of the CREATE-NET center (https://create-net.fbk.eu/).
15:11:10 <Menthos> dsantoro and dancn, would you like to take 5-10 minutes to introduce your institution?
15:11:27 <Menthos> And talk about your current use-cases?
15:11:45 <dsantoro> We used OpenStack during last two years and we did few customization in particular in the context of a EU founded research project called FIWARE (https://www.fiware.org/). In this project we support the maintenance of a multi region cloud based on OpenStack. In prticulat the activities about the monitoring of such infrastructure have been presented during 2016 within the OpenStack summit in Austin.
15:12:18 <dsantoro> In 2016 we started to work on edge/fog computing jointly with the unit specialized in IoT (https://openiot.fbk.eu/) and we presented a demo paper about our implementation during CloudCom 2016 in Luxemburg.
15:12:40 <dsantoro> Cloud4IoT, is a platform offering automatic deployment, orchestration and dynamic configuration of IoT support software components and data-intensive applications for data processing and analytics, thus enabling plug-and-play integration of new sensor objects and dynamic scalability of the workload. Cloud4IoT enables the concept of Infrastructure as Code in the IoT context: it empowers IoT operations with the flexibility
15:14:12 <dsantoro> and elasticity of Cloud services. Furthermore it shifts traditionally centralized Cloud architectures towards a more distributed and decentralized computation paradigm, as required by IoT technologies, bridging the gap between Cloud Computing and IoT ecosystems.
15:17:53 <Menthos> dsantoro: good thank you
15:18:07 <Menthos> I have a question but I will keep it for a next topic :-)
15:18:10 <dsantoro> We built a platform to manage IoT devices and related use cases on top of OpenStack and Kubernetes and we think that on the edge nodes OpenStack could be a good choice but we are still evaluating the limitation and how to overcome them.
15:18:18 <msimonin> dsantoro: I think most of us are interested :)
15:18:18 <dsantoro> We have some hardware and we are available to test our use cases (see paper) using OpenStack at the edge identifying possible requirements and limitation
15:19:56 <Menthos> This is the perfect transition to the next topic
15:19:59 <msimonin> :)
15:20:00 <dsantoro> We are still new in this WG and we will share appropriate resources later
15:20:12 <Menthos> Great
15:20:16 <pramchan> #info We had reviewed similar limitations in OpenStack for Edge cloudlet earlier and agree with FBK
15:20:53 <Menthos> okay let's move on to the next topic
15:20:56 <Menthos> #topic Deployment slides
15:21:05 <Menthos> #link https://docs.google.com/presentation/d/1jJFZejZqgYDxu5FX4K8g3I5zQ87afnjYI4VSRSuCQ6U/edit#slide=id.g19f88bc747_0_124
15:21:33 <Menthos> I see that someone added new slides
15:21:44 <Menthos> But that someone is anonymous
15:21:56 <Menthos> May they raise their hand?
15:22:15 <ansmith> I had the action to update scenario 1 for qpid
15:22:33 <ansmith> If you look at slide 8, it goes back to a discussion we had a few meetings back
15:22:53 <ansmith> For the granularity of the scenarios, we should show that oslo.messaging is the service
15:22:56 <Menthos> Yes I remember
15:23:03 <ansmith> and rabbit or qpid is a lower level detail
15:23:22 <ansmith> For background, see slide 9
15:23:46 <ansmith> An "openstack service" will utilize oslo.messaging
15:23:57 <ansmith> On a per service basis, it may be an rpc client or server
15:24:03 <ansmith> or notification client or server
15:24:40 <Menthos> Okay
15:25:03 <ansmith> oslo.messaging supports the concept of a transport_url that specifies what gets used for rpc and notifications
15:25:15 <pramchan> #slide 9 shows the oslo messaging logic
15:25:25 <Menthos> So we can consider that slide 8 is correct for any message bus?
15:25:37 <ansmith> yes
15:26:02 <ansmith> slide 10 shows predominant deployment, e.g. rabbit broker gets used for both rpc and notify
15:26:32 <ansmith> slide 11 shows alterrnative where rpc and notify use different backends
15:26:48 <ansmith> a brokerless direct messaging backend for rpc
15:26:55 <ansmith> and a store and forward broker for notifications
15:27:31 <ansmith> as we consider distributed cloud scenarios, the backend architecture will need to be considered
15:28:31 <ansmith> so proposal would be to depict oslo.messaging at the scenario level and then we can breakout the details and alternatives for the backend
15:28:39 <ansmith> e.g. amqp, kafka, zmq, etc.
15:29:38 <Menthos> I see
15:29:46 <Menthos> Sounds good :-)
15:29:56 <Menthos> dsantoro dancn of all the scenario (1 to 3), which one would be the closest to your requirements?
15:30:11 <pramchan> Now that means every site will have an oslo messaging connected to bus
15:30:13 <Menthos> Or do you have something completely different in mind?
15:31:10 <pramchan> #rpc and notify message buses or channels for back end are distinct
15:32:12 <dsantoro> Menthos sorry we did not evaluated the scenarios slide yet we need some time to review all the documents in your WG
15:32:37 <Menthos> Sure no problem
15:32:42 <pramchan> Also Notify is one way channel from infra to OpenStcak service
15:33:00 <Menthos> You can just look at it and tell us what you think next time
15:33:21 <dancn> sure!
15:33:27 <Menthos> Thanks :-)
15:33:30 <Menthos> #action dsantoro feedback on scenario slides
15:34:10 <Menthos> What about the functional needs and limitations?
15:34:25 <Menthos> Anyone made progress on this?
15:35:07 <Menthos> That's ad_rien WIP though, so let's throw it back to him
15:35:16 <Menthos> #nick ad_rien
15:35:20 <pramchan> #ok please add feedback to slides  by adding comments on the right window
15:35:25 <Menthos> #action ad_rien Identify functional needs/limitations for each scenario
15:36:41 <Menthos> Okay so let's move on
15:36:49 <Menthos> #topic Experiments
15:37:18 <Menthos> msimonin: can you tell us about the status/progress on the Enos side?
15:37:36 <msimonin> sure
15:37:56 <msimonin> #link https://github.com/BeyondTheClouds/enos
15:38:05 <Menthos> As a reminder, Enos allows to experiment multiple deployment topologies, run benchmarks, save metrics and more
15:38:24 <msimonin> exactly :)
15:39:10 <msimonin> We are starting to land new features
15:39:17 <msimonin> regarding multisite deployment
15:39:46 <pramchan> #Is there an Open access to test Enos you have installed?
15:39:50 <msimonin> for now we evaluated OpenStack in a single region scenario where all the nodes are close to each others using the tool
15:40:14 <msimonin> now we are moving towards experimenting OpenStack in a multisite/multiregion context
15:40:18 <Menthos> pramchan: no because an Enos deployment doesn't last very long
15:40:51 <msimonin> One new feature may be interesting for this WG
15:40:56 <Menthos> pramchan: basically just the time to deploy OpenStack and make some measurments. Then everything is destroyed
15:41:20 <msimonin> we can emulate bandwidth/latency constraints between nodes in order to reflect geographically distributed services
15:41:44 <msimonin> and rcherrueau: is working towards supporting multiregions
15:41:50 <pramchan> OK no access due to lifcycle limitations of enos experiment - Thanks
15:42:19 <msimonin> pramchan: there are two ways to use Enos
15:42:27 <Menthos> pramchan: but all the metrics are saved, so you can still get the raw data and analyze it
15:42:30 <msimonin> pramchan: either you request for a Grid'5000 account
15:42:38 <msimonin> #link https://www.grid5000.fr/mediawiki/index.php/Grid5000:Home
15:43:27 <msimonin> or you code your own ressource provider (grid'5000 is an implementation of what we call resource provider)
15:43:49 <Menthos> I don't think we'll have time to go into too much detail
15:44:08 <Menthos> Maybe you can discuss this after the meeting?
15:44:17 <msimonin> Menthos:  ack :)
15:44:33 <Menthos> msimonin: so does that mean you're close to start experimenting on a scenario?
15:45:00 <msimonin> yes
15:45:07 <msimonin> scenario 1 is supported
15:45:29 <Menthos> Great :-)
15:45:59 <Menthos> #topic Joint effort with the NFV/Performance WG
15:46:06 <msimonin> If there are particular thing to evaluate in this scenario I'll be glad to know :)
15:46:19 <Menthos> Yes
15:46:29 <Menthos> We need input regarding metrics/what to measure
15:46:39 <pramchan> Once we get scenraio analysis pros/cons then we can possibly look at next scenario
15:46:49 <Menthos> And I know ad_rien is trying to get input from the NFV WG
15:47:02 <Menthos> pramchan: +1
15:47:16 <pramchan> NFV WG as in ETSI?
15:47:26 <pramchan> or NFV WG in OpenStack?
15:47:43 <Menthos> in OpenStack
15:47:54 <pramchan> OK
15:48:35 <Menthos> #action Pro/cons of each scenario
15:48:52 <Menthos> #topic Ansible playbook for QPID
15:49:05 <Menthos> ansmith: do you have any news on that?
15:49:09 <ansmith> I took an action to scope the effort
15:49:32 <ansmith> currently we are focused on tripleo/puppet based deployments
15:49:50 <Menthos> Okay
15:49:55 <ansmith> ansible is next and planning for pike
15:50:19 <msimonin> ansmith: Kolla based deployment would be perfect :)
15:50:28 <ansmith> dispatch-router and openstack configuration for transport can be done now albeit manually
15:51:20 <pramchan> joehuang was intrested in tripleo and Kola may be will check with him
15:51:44 <Menthos> ka
15:51:47 <Menthos> Okay
15:52:02 <Menthos> We are close to the end so I think we should move on
15:52:18 <pramchan> #action prakash to verify with Joehuang if he wants to contribute to tripleo and Kola efforts
15:52:23 <Menthos> #topic Attracting more people
15:52:46 <Menthos> If anyone has an idea on who to invite, now is the time to express it!
15:53:35 <Menthos> 3
15:53:37 <Menthos> 2
15:53:39 <Menthos> 1
15:53:42 <Menthos> #topic Presentation for Boston summit
15:53:44 <msimonin> I heard barack obama is free
15:53:58 <pramchan> #I had some folks in Edge Cloud efforts which is stalled due to API I can see if any of those would like oto join this and will send them invites for this
15:54:03 <Menthos> I think this is more urgent because the deadline is in 2 weeks
15:54:15 <Menthos> Thanks for the heads-up msimonin ;-)
15:54:20 <Menthos> I'll ping him on Twitter
15:54:36 <pramchan> Deadline for ?
15:54:41 <Menthos> thanks pramchan that would be great
15:54:51 <Menthos> Presentation proposals for the Boston summit
15:55:12 <pramchan> OK will work with you folks to see what we can contribute
15:55:21 <Menthos> Somenone wrote a note about Tricircle and Kingbird on the pad
15:55:49 <pramchan> Must be Joehuang and will also ask him to see what he can contribute
15:56:04 <Menthos> pramchan: thanks
15:56:31 <Menthos> #action pramchan contact Joehuang for input
15:56:38 <Menthos> Anyone else?
15:57:02 <msimonin> experimentation result on scenario ?
15:57:30 <Menthos> Like a comparison of two scenarios?
15:57:38 <msimonin> could be
15:57:42 <Menthos> Or performance measures?
15:57:46 <Menthos> With Performance WG?
15:57:51 <msimonin> maybe we should check the work done by dsantoro first :)
15:57:52 <pramchan> #time to conclude in next 3 minutes
15:57:58 <Menthos> Yes
15:58:13 <msimonin> this coudl be a joined presentation after all ;)
15:58:15 <Menthos> #action Presentation proposition for Boston Summit
15:58:30 <Menthos> Ok thanks msimonin
15:58:40 <Menthos> #topic Closup
15:58:50 <Menthos> We have two minutes to talk about anything
15:58:50 <pramchan> Can also be panel dicussions if there is many folks ready to debae
15:58:55 <Menthos> Or just say goodbye
15:59:16 <msimonin> Let's have this discussion next week
15:59:18 <Menthos> #info Panel discussion for Boston summit?
15:59:20 <pramchan> OK lets correspond through emails
15:59:26 <Menthos> Yes let's talk about it next week
15:59:32 <pramchan> sure
15:59:34 <Menthos> pramchan: great :-)
15:59:44 <Menthos> Thanks for attending folks
15:59:48 <dsantoro> Next meeting will be next week or in two weeks ?
15:59:53 <Menthos> two weeks
15:59:53 <msimonin> thanks for chairing !
16:00:06 <dsantoro> thanks
16:00:07 <Menthos> So discussion about presentations should be email, I guess
16:00:13 <pramchan> thanks
16:00:25 <Menthos> See you all in two weeks
16:00:26 <Menthos> #endmeeting