15:00:06 <Menthos> #startmeeting massively_distributed_clouds
15:00:07 <openstack> Meeting started Wed Apr 12 15:00:06 2017 UTC and is due to finish in 60 minutes.  The chair is Menthos. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:11 <openstack> The meeting name has been set to 'massively_distributed_clouds'
15:00:22 <ad_rien_> #chair ad_rien_ Menthos
15:00:43 <Menthos> #chair ad_rien_
15:00:44 <openstack> Current chairs: Menthos ad_rien_
15:00:50 <Menthos> ;-)
15:00:53 <ad_rien_> ;)
15:01:01 <Menthos> Hello all!
15:01:07 <jamemcc> Hello
15:01:08 <ansmith> o/
15:01:11 <kgiusti> o/
15:01:18 <rcherrueau> o/
15:01:21 <mabderrahim> o/
15:01:28 <ad_rien_> #link https://etherpad.openstack.org/p/massively_distributed_ircmeetings_2017 Agenda line 445
15:02:00 <paul-andreraymon> Hello Everyone
15:02:46 <ad_rien_> let's wait just two more minutes
15:03:22 <ad_rien_> #topic Announcement
15:03:40 <ad_rien_> so nothing special from Inria side.
15:03:53 <ad_rien_> We are working on the WANWide Experiments
15:04:39 <ad_rien_> So we hope to have preliminary results by end of april
15:04:45 <rcherrueau> #link https://github.com/rcherrueau/performance-docs/commit/7b3387362c9f1c83ae1da098381aee22e04356d2
15:04:47 <ad_rien_> @rcherrueau can you copy/paste the link
15:04:49 <ad_rien_> ok thanks
15:05:32 <ad_rien_> And if I'm correct the slot to further discuss OSLO messaging related questions has been accepted (but I propose to discuss that point later).
15:05:51 <ad_rien_> Finally I would appreciate whether we can arrange a date for the ecomp presentation.
15:05:56 <kgiusti> +1
15:05:58 <ad_rien_> And that's all from our side
15:06:06 <ad_rien_> so the floor is yours ?
15:06:13 <paul-andreraymon> Is there any help we could provide to the WANWide experiements?
15:06:44 <ad_rien_> Right now we are performing some initial experiemnts
15:06:53 <rcherrueau> Yes, a full time engineer would be cool :)
15:06:58 <ad_rien_> so I don't think so but if you have something in mind ?
15:07:01 <ad_rien_> @rcherrueau ;)
15:07:09 <kgiusti> I'll add the forum meeting details to the etherpad...
15:07:19 <ad_rien_> maybe some feedback regarding the experiment protocol
15:07:24 <ad_rien_> that is described in the above link
15:07:47 <paul-andreraymon> I will look into both. Should I contact you by email.
15:07:52 <ad_rien_> sure
15:08:10 <ad_rien_> either me or rcherrueau
15:08:19 <ad_rien_> firstname.lastname@inria.fr
15:08:34 <ad_rien_> ok
15:08:43 <ad_rien_> any other news to be shared from your side ?
15:08:49 <ad_rien_> before jumping into the agenda ?
15:09:09 <ad_rien_> ok
15:09:24 <ad_rien_> so maybe before starting to discuss about technics, may we try to converge on the ecomp slot
15:09:34 <ad_rien_> jamemcc:  can you propose some slots on the fly ?
15:09:50 <ad_rien_> I know it is a bit hard....
15:10:02 <ad_rien_> so I apologize but it looks that doodle was not the best solution
15:10:02 <paul-andreraymon> Will we be able to record the session? Maybe we do not need to have everyone attend.
15:10:11 <ad_rien_> so let's try to arrange in real-time :-P
15:10:19 <ad_rien_> I hope this will help
15:10:54 <ad_rien_> jamemcc:  ?
15:11:04 <jamemcc> I beleive it was my fault we did not have the ECOMP/ONAP meeting yesterday as agreed.  Even for myself I did not ahve the meeting/logistics on my calendar.
15:11:38 <Menthos> #topic ECOMP
15:12:04 <jamemcc> On the topic of early confusion/timezones I also learned in Doiodle you have an option to show the users timezone
15:12:17 <jamemcc> I've tried to set one up that way here: https://doodle.com/poll/y7dmahbdfcuheqv6
15:12:21 <ad_rien_> yes I enabled it on my side but does not seems to run
15:12:29 <paul-andreraymon> jamecc: how about you set a time that is convenient for you and whoever can attend does?
15:12:49 <ad_rien_> 17th is eastern day
15:12:59 <ad_rien_> s/run/well functionning
15:13:25 <jamemcc> Good suggestion Paul I think if myself and Claude can't attend I won't put the option there
15:13:42 <ad_rien_> can you extend to thursday
15:14:01 <ad_rien_> thursday afternoon would be perfect ?
15:14:10 <ad_rien_> the 20th ?
15:14:36 <ad_rien_> 1 or 2 UTC ?
15:14:58 <ad_rien_> 1:00 or 2:00 o'clock UTC ?
15:15:20 <jamemcc> Yes to 1 and 2 UTC - seems to be the time we can meet
15:15:20 <paul-andreraymon> that would be 8 or 9 am Central for the us.
15:15:29 <jamemcc> yes
15:15:32 <ad_rien_> 1:00/2:00 PM
15:15:40 <ad_rien_> just to be clear enough and avoid confusions
15:15:44 <Menthos> works for me
15:15:49 <ad_rien_> +1
15:15:49 <paul-andreraymon> It works for me
15:15:58 <ad_rien_> redhat folks ?
15:16:07 <jamemcc> Ahh - sorry
15:16:15 <jamemcc> For Claude he is in Pacific time
15:16:26 <ansmith> +1
15:16:27 <jamemcc> So he request not to book before 2 UTC
15:16:37 <ad_rien_> 1 UTC or even sooner?
15:16:51 <paul-andreraymon> 2 to 3 pm UTC works for me
15:17:03 <kgiusti> I'll be traveling 4/20-23
15:17:26 <ad_rien_> jamemcc:  ?
15:18:01 <paul-andreraymon> Can we look at wednesday the 19th to accomodate kgiusti?
15:18:14 <ad_rien_> I'm travelling :(
15:18:21 <ad_rien_> but if the session can be recorded it is ok
15:18:25 <paul-andreraymon> :-(
15:18:28 <ad_rien_> I will give it a look after
15:18:34 <ad_rien_> ok we can do it the week after
15:18:37 <kgiusti> ansmith: what's your schedule look like?
15:18:52 <ansmith> works for me
15:18:55 <ad_rien_> on Monday 24th ?
15:19:05 <ad_rien_> 1:00 PM UTC ?
15:19:30 <kgiusti> +1 4/24
15:19:32 <ansmith> +1
15:19:40 <Menthos> 24th won't work for me but if the session can be recorded that's great
15:19:42 <ad_rien_> sorry 2 UTC to match Claude constraints
15:20:08 <rcherrueau> +1
15:20:14 <ad_rien_> Menthos I will give you a summary ;)
15:20:21 <jamemcc> Claude can do the 24th.  It is also a User Committee meeting but I can do both as that one will be IRC
15:20:34 <Menthos> ad_rien_: thanks
15:20:37 <ad_rien_> so for the moment If I'm correct we are on Monday 24th at 2UTC ?
15:20:55 <paul-andreraymon> +1
15:20:57 <jamemcc> Agreed will send invite soon or at least before end of day
15:21:01 <kgiusti> +1
15:21:19 <ad_rien_> #info ecomp presentation by webconf on Monday 24th 2:00 UTC
15:21:43 <ad_rien_> jamemcc:  do we need to install something special (plugins, addons) ?
15:21:58 <ad_rien_> or will we receive mandatory information by mail?
15:22:45 <jamemcc> It's a Skype for business meeting - so I think you can join with the normal skype client - how about I test with you first?
15:23:05 <ad_rien_> #action jamemcc will send invitations by mails. Please put your mail in the pad
15:23:16 <jamemcc> Want to make sure you can see the presentation and or whiteboard
15:23:23 <ad_rien_> ok great
15:23:25 <ad_rien_> thanks
15:23:33 <paul-andreraymon> jamescc: I would be happy to volunteer my zoom bridge if that works better.
15:23:50 <ad_rien_> so I guess this point is now closed (please do not forget to put your email in the pad for receiving the invitation).
15:23:54 <jamemcc> Ok Paul - IU've been wanting to try it
15:24:15 <ad_rien_> Ok can we switch to the next point  ?
15:24:15 <paul-andreraymon> I will email you offline.
15:24:35 <ad_rien_> #topic AMQP discussions
15:24:47 <kgiusti> hey now!
15:24:48 <ad_rien_> @rcherrueau @kgiusti
15:24:52 <ad_rien_> :D
15:25:03 <ad_rien_> please just go ahead
15:25:20 <kgiusti> I've updated the epad with some preliminary testing done here at redhat
15:25:48 <kgiusti> We're just getting started testing various o.m. backend deployments
15:26:09 <kgiusti> We're working on a summit preso to go along with this.
15:26:26 <kgiusti> I've also reached out to the other oslo.messenger backend devs to get involved.
15:26:32 <kgiusti> Sadly no response yet :(
15:26:51 <kgiusti> I need someone with kafka and zeromq expertise
15:27:04 <kgiusti> or I'm heading for a long learning curve :)
15:27:26 <kgiusti> For the next week we'll work on other testing scenarios and tuning.
15:27:47 <ad_rien_> so right now you are focusing on RabbitMQ vs QPID ?
15:27:51 <ad_rien_> is it correct ?
15:28:09 <kgiusti> To be specific
15:28:30 <kgiusti> 'Qpid' is the apache project, 'qpidd' is the C++ broker, qdrouterd is the router... so
15:28:39 <kgiusti> we're focusing now on rabbitmq + qdrouterd
15:28:50 <ad_rien_> Ok, thanks for claryfing this. From our side, we can open an action from our side to see with the performance team whether it is quite easy to deploy ZMQ.
15:29:13 <ad_rien_> since our framework is leveraging kolla
15:29:31 <ad_rien_> we should check what are the efforts to be able to deploy zmq instead of rabbit
15:29:32 <kgiusti> +1 to zmq testing
15:30:15 <kgiusti> frankly zmq is pretty low on the testing totem pole - due to scale lab resource constraints....
15:30:16 <ad_rien_> regarding qpid, if I'm right providing the ansible playbook is stil an open action?
15:30:46 <kgiusti> yes I believe so - ansmith?
15:31:04 <ansmith> yes, still open
15:31:11 <ad_rien_> with a possible milestone?
15:31:13 <ad_rien_> :-P
15:31:30 <ad_rien_> just try to see from our side how we can define a reachable roadmap.
15:31:55 <ansmith> targeted to get done with containerization work, likely post summit
15:32:07 <ad_rien_> until the summit, I think our effort will focus on vanilla openstack WAN evaluations
15:32:27 <ad_rien_> Then we may have some additional efforts with Orange folks to dive into the oslo messaging questions
15:32:48 <kgiusti> +1
15:32:52 <ad_rien_> @ansmith ack
15:33:07 <ad_rien_> ok
15:33:30 <ad_rien_> I don't know whether jfpeltier joined us ?
15:33:46 <ad_rien_> I don't think so but
15:33:59 <ad_rien_> you can find the presentation he gave us in the pad.
15:35:56 <ad_rien_> AFAIK, we have two pendings actions on that point
15:36:17 <ad_rien_> 1./ summary the current exchanges related to AMQP (@rcherrueau)
15:37:10 <rcherrueau> ad_rien_: yes, about that ... my first priority is finalising WAN experiements. So, I don't do my today's action.
15:37:12 <ad_rien_> 2./ have a summary of jfpeltier regarding his slides (and maybe to see what are the similarities w-r-t ombt
15:37:23 <ad_rien_> yes I know, do not worry ;)
15:37:49 <ad_rien_> maybe regarding this second point, kgiusti you already has an idea?
15:38:08 <ad_rien_> (BTW OSNoise is the AMQP stresser designed at Orange)
15:38:10 <ad_rien_> ?
15:38:28 <kgiusti> andy spent some time looking at the source
15:38:51 <kgiusti> and I think - though I have to confirm - that osnoise may only work with rabbitmq
15:38:56 <ad_rien_> ok
15:38:59 <kgiusti> due to the use of pika
15:39:02 <ad_rien_> that is an important news indeed
15:39:13 <kgiusti> but I need to confirm that - action item for me.
15:39:22 <ad_rien_> #action clarify the rabbitMQ dependence of OSNoise
15:39:32 <ad_rien_> ok thanks
15:39:52 <ad_rien_> anyway I think both works are probably valuable but we should try to avoid reinventing the wheel ;)
15:40:17 <ansmith> that is what I remember from a quick review
15:40:34 <ad_rien_> at least from our side, it would be great to see which is the best candidate to be integrated within the EnOS framework :-P
15:40:53 <kgiusti> +1
15:41:05 <ad_rien_> ok
15:41:11 <ad_rien_> anythink else regarding AMQP?
15:41:27 <kgiusti> not at this time
15:41:44 <ad_rien_> Do we need to prepare discussions for the forum session? (i.e. start to identify key questions?)
15:41:48 <rcherrueau> kgiusti: ansmith: If I am right, amqp stresser use pika wich is supposed to be AMQP implementation independant.
15:42:34 <kgiusti> mmmm - iirc pika only talks amqp 0-9 and 0-10, so no zmq and no qdrouterd
15:42:35 <rcherrueau> kgiusti: ansmith: but we could discuss about that next meeting
15:42:54 <kgiusti> +1
15:42:59 <ansmith> ombt uses oslo.messaging so would lend itself to swapping out backends
15:43:00 <rcherrueau> kgiusti: Oh! OK
15:43:38 <rcherrueau> ansmith: yes focusing on oslo.messaging is a good idea
15:43:50 <kgiusti> ad_rien_: to clarify - are you talking about the oslo.messaging forum?
15:44:01 <ad_rien_> yes
15:44:02 <ad_rien_> ?
15:44:09 <ad_rien_> the second slot?
15:44:09 <kgiusti> ad_rien_: ok
15:44:13 <kgiusti> yes
15:44:41 <kgiusti> the goal is to set out a plan by which we can come up with deployment recommendations
15:44:56 <ad_rien_> so should we iterate by mail to move forward on that point ?
15:45:04 <ad_rien_> maybe by going on the next thread?
15:45:13 <kgiusti> sure thing
15:45:21 <ad_rien_> @rcherrueau @paul-andreraymon @all; what do you think ?
15:46:18 <ad_rien_> ok so seems that we can go on by mail.
15:46:21 <ad_rien_> on that point.
15:46:31 <ad_rien_> anything else? can we move to the next topic?
15:46:48 <ad_rien_> #topic EnOS
15:47:04 <ad_rien_> So maybe find additional things regarding EnOS.
15:47:15 <ad_rien_> @rcherrueau suceeded to integrate OSProfiler
15:47:35 <ad_rien_> within EnOS. This means that now when we perform performance evaluations we also get OSProfiler traces
15:48:04 <rcherrueau> I am working on a tool that queries these traces
15:48:18 <ad_rien_> This is valuable as it gives us  lot of information in addition to delivering sequence diagrams (ie. exchange/interactions between core-serivces)
15:48:36 * ad_rien_ is looking for a link
15:49:33 <rcherrueau> The idea is to get information on the workflow, e.g., where RPC happens ...
15:49:40 <ad_rien_> #link https://docs.openstack.org/ops-guide/_images/provision-an-instance.png sequence diagram exemple
15:50:04 <ad_rien_> so right now it is not as fine as the figure I copied/pasted above but the idea is to get such diagrams.
15:50:31 <ad_rien_> This will help us to better understand/identify all messages. this is important for the WAN context
15:51:14 <ad_rien_> so we will be able to finely study the impact of the exchanges and try to elaborate what are the best deployment scenarios (if your remind we identify a few scenarios on google slides)
15:52:01 <ad_rien_> last but not the least as mentioned we are performing a few preliminary experiments. I hope we will have more information next time.
15:52:03 <ad_rien_> Ok
15:52:08 <ad_rien_> so let's move to the last topic
15:52:16 <ad_rien_> #topic Boston face to face meeting
15:52:27 <ad_rien_> I opened an etherpad
15:52:43 <ad_rien_> and I encourage you to add points that you would like to discuss during our session.
15:53:07 <ad_rien_> maybe it would be great to identify concrete actions/objectives for the R cycle?
15:54:02 <ad_rien_> I would also appreciate if you can add in the pad the presentation you think might be related to the massively distributed WG
15:54:58 <ad_rien_> so that's all from my side.
15:55:14 <ad_rien_> #topic open discussion
15:55:44 <ad_rien_> we have 5 minutes left?
15:55:52 <ad_rien_> should we raise something particular ?
15:56:09 <ad_rien_> looks not
15:56:16 <ad_rien_> so thanks for joining the meeting
15:56:25 <paul-andreraymon> Anyone has any thought on impact of MD on Nova scheduler?
15:56:37 <ad_rien_> and please do not forget to ammend/complete the etherpad in order to be more fruitful we can during the next summit
15:56:46 <ad_rien_> MD?
15:56:48 <ad_rien_> paul-andreraymon:  ?
15:56:53 <paul-andreraymon> MAssively distributed
15:56:56 <ad_rien_> ok
15:57:05 <ad_rien_> I can add that to the next agenda
15:57:13 <ad_rien_> there are ongoing activities at Orange
15:57:20 <ad_rien_> and IBM made a work using redis
15:57:42 <ad_rien_> (they should have presented this at the Barcelona summit but the presentation has been cancelled).
15:57:49 <ad_rien_> So let's add that to the agenda next time
15:57:51 <ad_rien_> ok ?
15:57:56 <paul-andreraymon> Great!
15:58:03 <ad_rien_> Maybe you also have some points in mind paul-andreraymon?
15:58:06 <ad_rien_> ideas ?
15:58:14 <ad_rien_> ok thanks
15:58:19 <ad_rien_> So let's conclude our meeting
15:58:35 <ad_rien_> #action add scheduling decision to the agenda
15:58:57 <Menthos> #endmeeting