15:00:11 <ad_rien_> #startmeeting massively_distributed_clouds
15:00:11 <openstack> Meeting started Wed Apr 26 15:00:11 2017 UTC and is due to finish in 60 minutes.  The chair is ad_rien_. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:16 <openstack> The meeting name has been set to 'massively_distributed_clouds'
15:00:18 <ad_rien_> #chair menthos
15:00:23 <openstack> Current chairs: ad_rien_ menthos
15:00:25 <ad_rien_> #info agenda
15:00:40 <Menthos> #link https://etherpad.openstack.org/p/massively_distributed_ircmeetings_2017 agenda line 528
15:00:51 <ad_rien_> #topic  announcement
15:01:06 <jamemcc> Hello
15:01:13 <ad_rien_> Hi
15:01:22 <rcherrueau> o/
15:01:25 <ansmith> o/
15:01:32 <Menthos> Hello
15:01:34 <maberrahim> Hi o/
15:01:36 <paul-andreraymon> hi
15:01:37 <ad_rien_> just wait two more minutes before dealing with news
15:01:59 <kgiusti> o/
15:02:14 <jamemcc> It's just hitting me: In a podcast you are very proud to announce how high the podcast count is.  Her we are very proud of the line number in the Etherpad.
15:02:42 <ad_rien_> ;)
15:03:25 <ad_rien_> Ok I don't know how many people will join today. Actually we are two weeks before the summit and I know that some of us are quite busy :-P
15:03:40 <ad_rien_> So I propose to start and maybe to finish a bit sooner today.
15:03:45 <ad_rien_> So regarding the news.
15:04:17 <ad_rien_> I had a telco yesterday afternoon (CET time) with people from the OpenStack foundation
15:04:40 <ad_rien_> they contacted us to get information related to the Fog/Edge use case and the massively distributed WG.
15:05:29 <ad_rien_> #link https://www.openstack.org/summit/boston-2017/summit-schedule/events/18823/taking-openstack-out-to-the-network-edges Verizon presentation
15:05:55 <ad_rien_> There will be a keynote on the Edge Computing made by Verizon
15:06:22 <ad_rien_> and they would like to highlight what are the on-going actions within the OpenStack ecosystem.
15:07:12 <ad_rien_> I tried to present the goal of the WG and the actions we are performing/targetting, in particular the AMQP investigations
15:07:25 <ad_rien_> So I don't know whether there will be some follow-ups
15:07:29 <ad_rien_> to this telco.
15:08:11 <kgiusti> ad_rien_: both ansmith and I will be at summit - we're available to meet if possible
15:08:22 <ad_rien_> but we discussed at the end that maybe it may make sense to organize a bird-of-feather session on massively distributed/fog/edge computing infrastructures/scenarios
15:08:33 <kgiusti> +1
15:08:46 <ad_rien_> so that is the main news from my side
15:09:01 <paul-andreraymon> How is that different from the session we already discussed?
15:09:33 <ad_rien_> Last time we made two face to face meeting sessions related to the MAssively distributed WG
15:10:09 <ad_rien_> during the first one we had lot of people that came just to see what we are talking about and we defined concrete actions during the second sessions (only key persons stay in the second session)
15:10:48 <ad_rien_> This time we have only one schedule session, I said yesterday that maybe it would be more fruitful for us to keep our face to face meeting to discuss concrete stuffs and organize another session for ''beginners''
15:11:15 <ad_rien_> Does it answer your question paul-andreraymon?
15:11:30 <paul-andreraymon> I am planning to be in Boston on Wednesday only. If there are two sessions can they both be on the same day?
15:11:53 <ad_rien_> I will mention that constraints but not sure whether I have lot of possibilities
15:12:15 <ad_rien_> #info Try to organize BoF on Wednesday morning if possible
15:12:29 <ad_rien_> so that's all from Inria side
15:12:42 <ad_rien_> the others news are related to EnoS so I prefer to keep them for later.
15:12:54 <ad_rien_> ok Any news from your side?
15:13:16 <kgiusti> I've updated the AMQP section in the epad
15:13:44 <kgiusti> We're starting load testing rabbitmq and message routing configurations
15:14:19 <kgiusti> But with redhat summit being next week it's unlikely we'll have anything to publish before Openstack Summit
15:14:28 <ad_rien_> kgiusti: ack
15:14:47 <ad_rien_> anyway it is nice to see that things are progressing
15:14:52 <ad_rien_> Ok any other news ?
15:15:07 <ad_rien_> (kgiusti I propose to keep questions related AMQP for later)
15:15:12 <kgiusti> +1
15:15:25 <ad_rien_> ok so let's move to eComp?
15:15:39 <ad_rien_> #topic eCOMP/ONAP
15:16:03 <jamemcc> We had a more detailed briefing this morning form AT&T and specifically Claude Noshpitz
15:16:19 <ad_rien_> yes please jamemcc ?
15:16:27 <jamemcc> I wanted that to be in the record since it was not done in IRC.
15:16:56 <ad_rien_> ok
15:17:12 <jamemcc> Of course if anyone would like to be included in following discussion, you can log your interest here in the Etherpad.
15:17:34 <jamemcc> We agreed to try to arrange more directed followup discussion at the Boston Forums.
15:17:40 <ad_rien_> #info a webconference on ONAP has been done from AT&T and specifically Claude Noshpitz
15:18:05 <jamemcc> I'll work to find the overlapping Forums and or arrange for informal discussion.  My action itme from this morning's meeting.
15:18:13 <ad_rien_> So I hope there will be a follow up but meanwhile I think we can prepare/ask questions directly in the pad
15:18:17 <jamemcc> I'll communicate that as well via the User Committee ML.
15:18:21 <ad_rien_> ok
15:18:24 <jamemcc> Yes - great
15:18:55 <ad_rien_> #action jamemcc Try to arrange a f2f meeting to discuss about ONAP.
15:19:18 <ad_rien_> #action all Prepare/put questions directly in the pad.
15:20:20 <ad_rien_> ok
15:20:29 <ad_rien_> any comments/questions on that?
15:22:22 <jamemcc> I think this pattern to have a briefing and then the regular meeting in IRC just after is a good one
15:22:41 <ad_rien_> maybe we should try to put 30 minutes between
15:22:48 <ad_rien_> just to be able to take a breath ;)
15:23:06 <jamemcc> Yes - understood
15:23:32 <ad_rien_> jamemcc:  can you send/put the slides somewhere?
15:23:37 <ad_rien_> so we can access them?
15:23:48 <jamemcc> Yes - I will send out the slides covered today
15:24:04 <ad_rien_> ok
15:24:10 <ad_rien_> so let's move to AMQP?
15:24:25 <ad_rien_> #topic AMQP
15:24:42 <ad_rien_> kgiusti:  ansmith: the floor is yours
15:25:00 <kgiusti> hi - so in addition to load testing
15:25:15 <kgiusti> we spent some time with the osnoise code
15:25:42 <kgiusti> The osnoise tool is a bit different in use than the ombt tool
15:26:08 <kgiusti> as ombt is designed to orchestrate a number of distributed traffic generators
15:26:25 <kgiusti> and gather the results to determine aggregate load
15:26:53 <kgiusti> but the biggest difference is that osnoise is built using the rabbitmq client (pika)
15:27:08 <kgiusti> so it will only load rabbitmq (as currently designed)
15:27:27 <ad_rien_> ok
15:27:28 <kgiusti> whereas ombt uses the oslo.messaging lib
15:27:40 <kgiusti> and can work against all supported message bus tech
15:28:01 <kgiusti> and... that's about all I have. ansmith?
15:28:02 <ad_rien_> ok
15:28:15 <ad_rien_> #info osnoise is rabbitMQ dependent
15:28:22 <ansmith> nothing to add
15:28:32 <ad_rien_> #info ombt has been developped on top oslo.messaging lib
15:28:45 <ad_rien_> any news regarding ansible/QPid?
15:29:10 <ansmith> created blueprint for kolla work
15:29:25 <ansmith> and should beging ansible work following summit
15:29:32 <ad_rien_> may I ask you the link?
15:29:47 <kgiusti> we haven't had the bandwidth to do much lately - we have two back to back summits starting next week :(
15:30:05 <ad_rien_> ok just want to take some notes.
15:30:13 <ad_rien_> I completely understood do not worry
15:30:20 <ad_rien_> ok
15:30:29 <ad_rien_> so let's switch to EnOS
15:30:34 <ansmith> https://blueprints.launchpad.net/kolla/+spec/dispatch-router-messaging-component
15:30:35 <ad_rien_> if there is no comments?
15:30:54 <ad_rien_> #link https://blueprints.launchpad.net/kolla/+spec/dispatch-router-messaging-component kolla/QPID blueprint
15:31:15 <ad_rien_> ok any comment on AMQP (If I'm correct jfpeltier is not there)
15:31:16 <ad_rien_> ?
15:31:25 <ad_rien_> #topic EnOS
15:31:40 <ad_rien_> @rcherrueau
15:31:41 <ad_rien_> ?
15:31:46 <paul-andreraymon> I have an action to provide feedback Enos. I have not completed that yet.
15:31:50 <rcherrueau> Everybody familiar with OSProfiler?
15:32:32 <rcherrueau> OSProfiler is an OpenStack tool developed into performance WG
15:32:34 <ad_rien_> #action paul-andreraymon feedback on EnOS for the next session
15:33:02 <rcherrueau> OSProfiler produces a trace of your OpenStack execution
15:33:04 <kgiusti> I know it's used here at RHAT
15:33:21 <rcherrueau> logging, rest/rpc and python call with arguments
15:33:22 <kgiusti> but by the O.S. dev team
15:33:51 <rcherrueau> So I'm working on a WIP to integrate this into Enos
15:33:59 <rcherrueau> #link https://github.com/BeyondTheClouds/enos/pull/123/files
15:34:00 <ad_rien_> kgiusti:  nice? Any links towards the work they do
15:34:21 <rcherrueau> Actually it works, but the code is not really neat
15:34:31 <kgiusti> ad_rien_: none that I'm aware of - I can poke around but I think the devs use it simply as a QA tool
15:34:57 <rcherrueau> So now you can deploy and run bench with Enos and at the same time produce execution trace
15:35:00 <kgiusti> ad_rien_: there *may* be presentations - I'll see what I can find.
15:35:09 <ad_rien_> kgiusti:  ack
15:35:25 <rcherrueau> We also developed a tool that automatically produce a sequence diagram based on the trace
15:35:57 <rcherrueau> Here is an example of the output of an VM boot
15:36:05 <rcherrueau> #link https://github.com/rcherrueau/osp-utils/blob/master/tests/rsc/out.svg
15:36:20 <rcherrueau> blue links are for rest call
15:36:21 <ad_rien_> Inkscape and zoom zoom zoom zoom zooom :)
15:36:28 <ad_rien_> but it is nice definitely
15:36:29 <rcherrueau> black one for python call
15:36:41 <rcherrueau> and green ones for oslo_messaging
15:36:54 <rcherrueau> The tool we use is available here
15:37:02 <rcherrueau> #link https://github.com/rcherrueau/osp-utils
15:37:27 <kgiusti> ooo - shiney!
15:37:38 <rcherrueau> It offers a small query language to query the trace and filter/fold/ ... trace
15:38:08 <rcherrueau> That's all for me
15:38:48 <ad_rien_> ok. Thanks
15:38:52 <ad_rien_> questions/comments ?
15:39:17 <ad_rien_> seems not thanks rcherrueau
15:39:56 <ad_rien_> maybe we can just add that WAN experiments are still on-going.
15:40:43 <ad_rien_> #topic Scheduling
15:41:21 <ad_rien_> paul-andreraymon:  ?
15:41:33 <ad_rien_> you want to highlight that point.
15:41:40 <ad_rien_> s/want/wanted
15:42:59 <ad_rien_> paul-andreraymon:  jgallard unfortunately cannot attend today but his work consisted in adding a level of regions (geographically speaking) in order to divide the scheduling problems
15:43:41 <paul-andreraymon> Thanks.
15:43:45 <ad_rien_> into sub problems.
15:43:58 <paul-andreraymon> Is there a reference to that work?
15:44:16 <ad_rien_> (i.e. instead of parsing the whole compute nodes, you will apply a filter that enables the scheduler to consider only a subset).
15:44:42 <ad_rien_> I will ask a link toward his slides he presented a few weeks ago.
15:44:58 <ad_rien_> #action Adrien Put the link toward Orange scheduling works
15:45:22 <ad_rien_> regarding IBM
15:45:38 <ad_rien_> I know they made a PoC with REDIS to evaluate the scalability of the scheduling
15:45:58 <ad_rien_> This should have been presented during the Barcelona summit
15:46:03 <ad_rien_> but finally it has been cancelled.
15:46:42 <ad_rien_> AFAIK, they discussed with Nova core developers and it seems that they did not give any follow up (I never suceeded to get additional information…. weird)
15:47:18 <ad_rien_> From the Discovery initiative group, we have a dedicated WG that works on the placement question in a massively geo-distributed infrastructures.
15:47:30 <paul-andreraymon> One question would be whether the scheduler can be centralized (and then we need filtering) or if it can best be distributed.
15:47:42 <ad_rien_> From the research viewpoint, a lot of works has been done (really a lot ;))
15:47:48 <ad_rien_> exactly
15:48:19 <paul-andreraymon> Is the result of that research in the public domain?
15:48:30 <ad_rien_> so a lot of academic works has been done in both directions.
15:49:26 <ad_rien_> the goal of this WG is to first identify what are the placement constraints that are particular to Fog/Edge infrastructures (i.e. something which is different than a large-scale DC)
15:49:46 <ad_rien_> basically you have performance (SLA/SLO) and functional constraints
15:49:59 <ad_rien_> for instance you want to prevent to put one master VM and its replica on the same machine,
15:50:02 <ad_rien_> etc...
15:50:32 <ad_rien_> we would like to understand how you can define finer constraints for instance to cope with latency QoS/requirements.
15:50:38 <ad_rien_> are you following me?
15:51:01 <paul-andreraymon> One aspect to take into account at the edge, is what access link the edge node connects to. In Nova, you can put filters against that in principle. But each filter takes a toll on performance.
15:51:16 <ad_rien_> (regarding centralized/distributed scheduling you can give a look to http://btrplace.org for instance or to DVMS http://beyondtheclouds.github.io/DVMS/ )
15:51:59 <ad_rien_> paul-andreraymon:  do you want to discuss another point? any comment?
15:52:02 <ad_rien_> others?
15:52:59 <paul-andreraymon> Nothing on my side for now.
15:53:02 <ad_rien_> ok thanks
15:53:07 <ad_rien_> #topic open discussion
15:53:38 <ad_rien_> from my side, I would like to invite you once again to put the points you would like to discuss during our f2f meeting  at Boston?
15:54:12 <ad_rien_> #link https://etherpad.openstack.org/p/Massively_distributed_wg_boston_summit boston forum F2F agenda
15:54:48 <ad_rien_> For instance, once you have made your schedule for the week, it would be nice to share the presentations you believe are linked to our WG in the pad
15:55:03 <ad_rien_> so we can benefit from each other.
15:55:29 <ad_rien_> I know for instance that I cannot attend one presentation on monday afternoon due to an overlapping with one of my presentation
15:55:48 <ad_rien_> so I hope that someone will be able to attend and give us some feedbacks.
15:55:55 <ad_rien_> Last but not the least from my side:
15:56:18 <ad_rien_> @kgiusti @ansmith will folls from redhat working on Edge computing attend the summit ?
15:56:29 <ad_rien_> can we try to catch them during ou f2f meeting?
15:57:03 <kgiusti> ad_rien_: I'm not aware of anyone - I'll ask around.
15:57:23 <ad_rien_> #action all, please fill the etherpad for our f2f agenda: https://etherpad.openstack.org/p/Massively_distributed_wg_boston_summit
15:57:44 <ad_rien_> any thing ?
15:58:07 <ad_rien_> ok thanks for attending the meeting and thanks once again jamemcc for the ONAP presentation.
15:58:16 <ad_rien_> Talk to you in Boston.Have a safe trip
15:58:17 <ad_rien_> Bye
15:58:28 <rcherrueau> bye
15:58:29 <Menthos> Bye
15:58:33 <kgiusti> bye
15:58:41 <ad_rien_> #endmeeting