15:00:54 <ad_rien_> #startmeeting massively_distributed_clouds
15:00:55 <openstack> Meeting started Wed May 24 15:00:54 2017 UTC and is due to finish in 60 minutes.  The chair is ad_rien_. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:56 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:58 <openstack> The meeting name has been set to 'massively_distributed_clouds'
15:01:01 <fungi> ad_rien_: the meetbot won't recognize commands prefixed with whitespace
15:01:03 <ad_rien_> #chair ad_rien_
15:01:11 <openstack> Current chairs: ad_rien_
15:01:13 <ad_rien_> #info agenda
15:01:32 <EmilienM> ad_rien_: you need to run #startmeeting again
15:01:37 <ad_rien_> #link https://etherpad.openstack.org/p/massively_distributed_ircmeetings_2017  Agenda Line 597
15:01:39 <msimonin> o/
15:01:47 <kgiusti> o/
15:02:00 <ad_rien_> EmilienM:  thanks, just a stupid C/P
15:02:00 <rcherrueau> o/
15:02:00 <mriedem> is it coincidental i was just pinged and also replying to emails in the ML about massively distributed something or other?
15:02:01 <ansmith> o/
15:02:03 <mabderrahim> o/
15:02:12 <ad_rien_> ok so roundtable as usual
15:02:19 <Menthos> o/
15:02:21 <jamemcc> Hi
15:02:21 <georgk> hi
15:02:23 <breton> parnexius: hi, please don't copypaste things like that
15:02:26 <ad_rien_> I just C/P the agenda  (line 597)
15:02:34 <serverascode> o/
15:02:35 <fungi> mriedem: there was some bot regurgitating the entire nicklist of lurkers into the channel just before this meeting started. so coincidence, yes
15:02:35 <parnexius> Sorry.... Fat fingers.
15:02:45 <claudiub> o/
15:02:51 <fungi> oh, not a bot!
15:02:51 <ad_rien_> Please add your nick/name in the pad thanks
15:03:33 <parnexius> It was just me hitting the wrong keys.... I apologize.
15:03:34 <ad_rien_> #topic announcement
15:04:10 <ad_rien_> Ok so from my side, the important news is related to the OpenDeV event the foundation is organizing next september close to San Francisco.
15:04:20 <ad_rien_> The event will focus on Fog/Edge challenge.
15:04:45 <banhgao> o/
15:04:51 <lhx__> o/
15:04:57 <ad_rien_> The foundation is trying to finalize who should be come (i.e. end-users for specifying use-cases, technical/developers for doing technical stuffs or both).
15:06:07 <ad_rien_> I do not have much information right now but we had a rather long discussion during the last day (people around the table was Verizon, Canonical, OpenEdge initiative, the person in charge of the Mobile Edge Computing standard at ETSI me  and I apologize for the ones I miss)
15:06:08 <parnexius> Were does this group falls in these categories?
15:06:28 <ad_rien_> Technical aspects right now
15:06:48 <ad_rien_> but during our F2F meeting some persons were interested to take the lead of the use-case specification questions
15:07:20 <parnexius> I would certainly be interested in participating with use cases..
15:07:26 <ad_rien_> The main idea was to identify the main differences in terms of requirements between the different use-cases (If I'm right Andrew was the person)
15:07:38 <ad_rien_> parnexius:  maybe it was you ;) ?
15:07:57 <parnexius> I did not make it to boston.... But I am interested.
15:08:00 <ad_rien_> parnexius:  is it you Paul Andre ?
15:08:06 <ad_rien_> ok sorry for the missunderstanding
15:08:16 <serverascode> is there a lot more work to be done on use cases? I feel like they are all pretty well identified, but we just call them all different names
15:08:25 <ad_rien_> ok if you want to lead such discussions please put your name in the pad.
15:08:26 <parnexius> Yes ... sorry for the nick change... parnexius = Paul-Andre
15:08:47 <ad_rien_> line 633, please
15:09:21 <ad_rien_> serverascode: yes that what I thought but it seems that people wants to have more formal documentations
15:09:48 <serverascode> ok
15:09:54 <ad_rien_> so for the ones that are interested by such discussions please put your name below the item: Identification of use-case differences
15:09:55 <ad_rien_> Thanks
15:10:08 <ad_rien_> Maybe we can find some collaborations with others WGs
15:10:30 <ad_rien_> from my side to be honest (i.e. Inria) we are more interested by technical questions as we spent a lot of times on this question
15:10:49 <ad_rien_> ok so that's all from my side
15:10:54 <ad_rien_> Any news guys from your side?
15:11:01 <ad_rien_> (the floor is yours)
15:11:28 <parnexius> ad_rien: there was a group under OPNFV called eNFV who had done some work on use cases.
15:11:43 <ad_rien_> yes I heard about that
15:12:04 <ad_rien_> We are discussing on the operator mailing list how we can improve our exchanges between all groups
15:12:21 <ad_rien_> I will add the link toward the thread in the ML
15:12:30 <parnexius> Thanks
15:12:47 <ad_rien_> you're welcome
15:12:48 <ad_rien_> ok
15:12:57 <ad_rien_> so can we move to the next topic?
15:13:16 <ad_rien_> #topic one additional chair
15:13:24 <ad_rien_> so the question is rather clear ;)
15:13:40 <ad_rien_> We need one more chair from another continent if possible.
15:13:45 <ad_rien_> So any candidate?
15:13:54 <parnexius> I am happy to volunteer
15:13:58 <ad_rien_> thanks
15:14:01 <pbressan> so do I
15:14:09 <ad_rien_> we have a candidate :)
15:14:11 <ad_rien_> not two
15:14:12 <ad_rien_> excellent
15:14:31 <ad_rien_> guys may I ask you where are you located ?
15:14:44 <parnexius> I am in USA (Virginia)
15:15:11 <parnexius> pbressan: aren't you in argentina?
15:15:12 <ad_rien_> pbressan ?
15:15:15 <pbressan> I'm working with Paul-Andre but located in Argentina (Cordoba)
15:15:43 <ad_rien_> ok
15:15:46 <ad_rien_> so I don't know
15:15:52 <ad_rien_> since both of you are working together
15:15:57 <ad_rien_> and we just need one co-chair
15:16:06 <ad_rien_> can you please tell us who should do the job :-P?
15:16:15 <parnexius> Put my name on. I will work offline with Pablo
15:16:24 <ad_rien_> ok thanks parnexius
15:16:55 <ad_rien_> the work will consist in preparing the agenda twice a month
15:17:07 <ad_rien_> and double check that either you or me can chair the discussion.
15:17:09 <ad_rien_> That's all
15:17:10 <ad_rien_> Thanks
15:17:19 <ad_rien_> any question?
15:17:25 <parnexius> I can't guarantee I will do it as well.
15:17:25 <ad_rien_> so let's move to the next topic
15:17:37 <serverascode> that's great, it's good to have two chairs :)
15:17:51 <ad_rien_> parnexius:  I'm sure you will ;)
15:18:01 <ad_rien_> ok so next topic
15:18:12 <ad_rien_> #topic roadmap
15:18:50 <ad_rien_> So although we already discussed two concrete actions (AMQP alternatives and cockroachDB), I would like to start with EnOS as rcherrueau should leave at 15:30
15:19:10 <ad_rien_> So regarding EnoS we plan to consolidate the framework but nothing more
15:19:29 <ad_rien_> we recently started a discussion regarding the OSProfiler traces and the sequence diagram
15:19:37 <ad_rien_> we can automatically generate.
15:19:51 <ad_rien_> People from Neutron seems to be interested to dive into details
15:20:09 <ad_rien_> georgk: rcherrueau please correct me If I'm wrong
15:20:27 <ad_rien_> (line 642 in the pad right now)
15:20:51 <georgk> well, I cannot consider myself a Neutron person, but I am interested
15:20:59 <ad_rien_> ok sorry georgk ;)
15:21:05 <ad_rien_> (good point :p)
15:21:21 <georgk> no problem, just want to clarify that I don´t work on Neutron upstream
15:21:23 <ad_rien_> anyway I think that we need inputs to know what can be valuable for this
15:21:57 <ad_rien_> i.e. how can we identify such ''stupid'' patterns
15:22:12 <ad_rien_> s/stupid/non efficient ;)
15:22:32 <ad_rien_> so if we can detect that by leveraging the OSProfiler traces it would be valuable
15:22:38 <ad_rien_> but not sure how we can do it.
15:22:45 <ad_rien_> and more precisely where we should look for.
15:22:57 <ad_rien_> Maybe by identifying specific rally scenarios?
15:23:16 <ad_rien_> remarks/comments welcome
15:23:32 <rcherrueau> I think osprofiler could help here, then we have to run some analysis of traces produced by OSProfiler. But, doing such analysis is not easy.
15:23:55 <ad_rien_> and time consuming, i.e. not sure whether we can handle this task at Inria.
15:24:16 <ad_rien_> georgk:  do you think you can investigate this question?
15:24:19 <parnexius> How can we help?
15:24:32 <ad_rien_> Maybe we can start to iterate by mail
15:24:35 <georgk> I am just getting started with the tools
15:24:39 <parnexius> Do you need help running the scenarios or just parsing traces.
15:24:41 <ad_rien_> as we did pour the OSLO message questions
15:24:51 <ad_rien_> and then see where this drives us
15:24:55 <ad_rien_> ?
15:25:03 <georgk> cannot promise much today, but I am planning to look a bit into this
15:25:03 <ad_rien_> do you think it is reasonable?
15:25:23 <msimonin> Actually
15:25:55 <ad_rien_> msimonin:  yes?
15:26:15 <msimonin> There is a review about integrating directly osprofiler in rally
15:26:48 <msimonin> This way if you know some scenario that can highlights sub-optimal messages exchanges between service
15:27:14 <msimonin> you should be able to trace everything using a dedicated scenario
15:27:22 <rcherrueau> Speaking about pattern analysis, One thing I have in mind is looking for many consecutive rpc calls between two identical services. Maybe we can fold all these calls into one and limit the number of communications
15:27:50 <msimonin> let me give some links
15:27:51 <msimonin> :)
15:27:51 <ad_rien_> maybe core-devs already know some weird scenarios. The sequence diagrams can help to confirm (or not) the issues.
15:28:14 <msimonin> #link http://enos.irisa.fr/html/seqdiag/v1/trace-boot-and-delete.yaml.html
15:28:52 <msimonin> is an example in which we can see many messages exchanges from compute to other services to update the vms states during a boot
15:29:01 <msimonin> or to neutron to get some network info
15:29:27 <msimonin> this can almost be generated automatically from the rally scenario
15:30:08 <ad_rien_> ok.
15:30:19 <ad_rien_> so I propose to start a thread
15:30:29 <ad_rien_> between people interested to move forward on that aspect.
15:30:32 <ad_rien_> is it ok?
15:30:39 <msimonin> +1
15:30:45 <ad_rien_> georgk:  ?
15:30:47 <parnexius> +1
15:30:49 <georgk> rcherrueau: yes, I agree, that´s one reasonabl;e approach
15:30:50 <georgk> +1
15:31:00 <rcherrueau> +1
15:31:09 <georgk> sorry, I was looking at sequence charts :-)
15:31:16 <ad_rien_> ok guys, as usual go in the pad and put your name if you are interested to follow how things move forward.
15:31:23 <ad_rien_> thanks.
15:31:28 <msimonin> georgk: don't lost yourself in those charts :)
15:32:06 <georgk> :-)
15:32:12 <ad_rien_> #action rcherrueau start a discussion to clarify sequence pattern detection thanks to Enos
15:32:59 <ad_rien_> no more from our side regarding EnoS, we plan to summarize what we did regarding the WAN experiments in a publication
15:33:23 <ad_rien_> as we have to publish as a research center. Paper will be available for the WG.
15:33:34 <ad_rien_> ok so next action.: AMQP alternatives
15:33:39 <ad_rien_> #info AMQP Alternatives.
15:33:51 <kgiusti> I've updated the epad with some status from BOS
15:33:54 <ad_rien_> So kgiusti and ansmith are leading the action
15:34:03 <ad_rien_> please folks the floor is yours
15:34:25 <ansmith> as noted in pad, dispatch-router added to kolla
15:34:38 <kgiusti> The take away from the BOS forum on oslo.messaging was which messaging backends will be supported going forward
15:34:43 <ad_rien_> \O/
15:35:07 <kgiusti> see epad re: details.  The one concern that may impact this WG effort is the stability of zeromq
15:35:14 <serverascode> what is qrouterd?
15:35:36 <serverascode> is that part of zeromq?
15:35:47 <kgiusti> we lost the zeromq contributors, and need to find a willing volunteer(s) to take over support of that
15:35:53 <ansmith> The qpid dispatch router is a direct messaging intermediary supported by the oslo.messaging amqp1.0 driver
15:35:54 <ad_rien_> serverascode:  no it is an alternative solution. I will copy the link toward the kgiusti presentation
15:35:54 <kgiusti> no, qdrouterd is the qpid dispatch router
15:36:01 <msimonin> serverascode: watch this https://www.openstack.org/videos/boston-2017/hybrid-messaging-solutions-for-large-scale-openstack-deployments :)
15:36:06 <ad_rien_> thanks msimonin
15:36:11 <serverascode> great thanks
15:36:29 <ad_rien_> ok kgiusti ansmith can we try to identify a roadmap
15:36:37 <ad_rien_> for this question of evaluation alternatives AMQP solutions
15:36:45 <ad_rien_> Inria can perform some experiments
15:36:59 <ad_rien_> especially if now qpid router is available within the kolla framework
15:37:11 <msimonin> I think I can put some time on qrouterd/kolla stuffs if needed
15:37:13 <kgiusti> ad_rien_: yes, that's important to us
15:37:30 <ad_rien_> As dicussed during the boston F2F meeting, Orange will provide some financial support, so we should be able to hire an engineer to conduct those experiments
15:37:30 <ansmith> investigating kolla-ansible work necessary now, we can target a roadmap by next meeting
15:37:31 <ad_rien_> soon
15:37:53 <ad_rien_> next meeting you mean 15 days ?
15:38:06 <ad_rien_> Can we try to define a complete roadmap
15:38:08 <ansmith> for "roadmap" yes
15:38:32 <ad_rien_> I think that deploying qpid within Kolla need some ansible code
15:38:37 <kgiusti> msimonin: that would be great
15:38:42 <ad_rien_> ok
15:38:43 <ad_rien_> sorry
15:38:49 <ad_rien_> you are talking about the roadmpa
15:39:02 <ad_rien_> that you can present by the next meeting?
15:39:06 <ad_rien_> yes did I correctly understand?
15:39:14 <ad_rien_> if so, I think it sounds great.
15:39:38 <ansmith> to clarify, by roadmap is meant work to support alternative messaging in kolla in support of Enos
15:39:43 <ansmith> framework
15:39:47 <ad_rien_> A good objective can be to target another ''performance oriented'' presentation for the next summit.
15:40:05 <kgiusti> ansmith: msimonin: let's take this up again once we have that roadmap and can partition any tasks among us
15:40:14 <ad_rien_> no I mean a roadmap to be able to submit a presentation and present real numbers to the community
15:40:25 <ad_rien_> so this means for instance
15:40:37 <msimonin> kgiusti: sure, keep us updated in the meantime :)
15:40:41 <ad_rien_> 1./ finalize the integration of QPidRouter in Kolla (and all the mandatory scripts)
15:40:53 <ad_rien_> 2./ meanwhile, investigate the current status of ZMQ
15:41:02 <ad_rien_> 3./ identify benchmarks and relevant scenarios
15:41:20 <ad_rien_> 4./ define experimental protocols at large scale? WanWide? with network disconnections?
15:41:24 <ad_rien_> 5./ do the experiments
15:41:33 <ad_rien_> 5./ gather metrics and analyse results.
15:41:37 <ad_rien_> something like that ;)
15:41:42 * ansmith is focusing on 1
15:41:42 <ad_rien_> with milestones
15:41:50 <msimonin> Regarding qpid dispatch router I have a technical question but don't know if it's the right time
15:41:57 <ad_rien_> that can be a cool presentation for the WG for the next summit
15:42:05 <kgiusti> #2 is in progress
15:42:13 <ad_rien_> msimonin:  please put it in the pad.
15:42:17 <ad_rien_> 15:42
15:42:25 <msimonin> ad_rien_: ack
15:42:25 <ad_rien_> already and we still have to discuss other points.
15:42:27 <kgiusti> ad_rien_: +1
15:42:33 <ad_rien_> just want to launch the different actions.
15:42:59 <kgiusti> serverascode: fyi https://www.openstack.org/videos/barcelona-2016/message-routing-a-next-generation-alternative-to-rabbitmq
15:43:11 <kgiusti> serverascode: a better deep dive of the router tech
15:43:15 <ad_rien_> kgiusti:  ansmith should we highlight other aspects regarding the AMQP evaluation question?
15:43:51 <ad_rien_> #action kgiusti ansmith prepare a complete roadmap for the evaluation of alternatives solutions (at the first sight Qpidrouter and ZMQ)
15:44:17 <ad_rien_> Anything more?
15:44:30 <kgiusti> ad_rien_: I'm a bit unclear - is there anything specific we should be covering aside from that task list?
15:45:05 <ad_rien_> I don't know. I mean I just put some items without really thinking whether I missed some.
15:45:29 <kgiusti> :)  I'm sure we'll come up with more...
15:45:39 <ad_rien_> I think the roadmap will be close to this list but it would be great to put milestones just to ensure that things are going smoothly
15:46:05 <ad_rien_> ok
15:46:16 <ad_rien_> so next topic: cockroach DB
15:46:17 <kgiusti> ad_rien_: +1 I like milestones - especially the sound they make as they whoosh by... :)
15:46:47 <jamemcc> Rollign on floor laughing
15:47:05 <ad_rien_> ;)
15:47:15 <ad_rien_> #info cockroach OpenStack
15:47:40 <ad_rien_> Ok so as discussed in Boston, Inria is interested by investigating the cockroach db question
15:48:27 <msimonin> anyone interested as well ?
15:48:28 <msimonin> :)
15:48:37 <ad_rien_> 1./ we would like to contact cockroach lab and see whether they are interested by this challenge
15:48:38 <serverascode> I would definitely like to help out in this area
15:48:44 <rcherrueau> me also
15:48:45 <ad_rien_> We believe it can be a win win action
15:49:30 <ad_rien_> For cockroachLab it will enable them to prove that their system is able to support OpenStack exchanges and from our WG, it will enable us to investigate the question of the performance as well as the scalability.
15:49:53 <ad_rien_> Among the drawback of our previous Reddis proposal was the question of the SQL API.
15:50:02 <ad_rien_> Using Cockroach we should be able to tacke this issue.
15:50:30 <rcherrueau> s/API/semantics
15:50:48 <msimonin> The idea was raised by Keystone people maybe this could be a start (keystone) ?
15:50:50 <ad_rien_> By combining an alternative AMQP solution as well as a scalable DB system, we can have a good opportunities to operate Massively Distributed Clouds.
15:50:55 <ad_rien_> rcherrueau:  thanks
15:51:40 <serverascode> so the first steps will be to talk with cockroachlabs?
15:51:43 <ad_rien_> yes
15:52:11 <ad_rien_> we start to informally exchanges with people. In particular to investigate the question related to the deprecation of the PostGres driver
15:52:38 <ad_rien_> it seems that the driver will not be deprecated for the moment but only marked as not supported/not tested.
15:52:42 <msimonin> +1 for involving cockroachlabs
15:53:03 <serverascode> yeah it sounds like the decision to deprecate has not quite been made, and doing some work with cockroachdb could help with that decision
15:53:21 <ad_rien_> we would like to investigate the development cost and whether we can get external support to develop the code that is mandatory to perform preliminary experiments at least.
15:53:22 <serverascode> is there any desire to do some basic initial testing?
15:53:48 <ad_rien_> you mean with cockroach or with postgres?
15:54:03 <serverascode> like start small and try keystone + cockroachdb
15:54:08 <ad_rien_> yes
15:54:08 <serverascode> just to see what explodes
15:54:26 <serverascode> I could put time into that if we would like to do some intitial testing in some form
15:54:32 <ad_rien_> I think we can try to define a roadmap (probably less ambitious than the AMQP one)
15:54:32 <serverascode> I juts don't know what that would look like
15:55:14 <ad_rien_> serverascode:  cool, just give us one week so we can gather enough information to start a real discussion.
15:55:25 <serverascode> ok
15:55:25 <ad_rien_> real in the sense we have at least key elements to start the discussion.
15:55:28 <ad_rien_> thanks
15:55:31 <ad_rien_> I'm taking the aciton
15:55:55 <ad_rien_> #action ad_rien_ Gather key informations regarding cockroach
15:56:00 <ad_rien_> ok that's all
15:56:24 <ad_rien_> any comment/remark regarding cockroach DB (or new SQL solution).
15:56:31 <ad_rien_> For instance someone proposed Vitess on the ML
15:56:45 <ad_rien_> but Vitess leverages a centralized server so it does not cope with our target.
15:56:52 <ad_rien_> ok
15:56:54 <ad_rien_> 4 minutes
15:56:58 <ad_rien_> let's move to the next topic
15:57:03 <ad_rien_> #topic open discussions.
15:57:14 <ad_rien_> ok guys
15:57:19 <ad_rien_> the floor is yours
15:57:26 <serverascode> I don't have anything to add today :)
15:57:32 <ad_rien_> jamemcc:  any important information to share from LCCO
15:57:33 <ad_rien_> ?
15:58:02 <ad_rien_> ok seems not
15:58:05 <ad_rien_> anyone?
15:58:31 <ad_rien_> ok
15:58:44 <ad_rien_> thanks everyone for attending this meeting
15:58:49 <msimonin> thanks
15:58:57 <serverascode> good meeting, I'm glad that there are enough people to have a second chair :)
15:59:03 <rcherrueau> thanks
15:59:08 <ad_rien_> and let's iterate by mail before our next meeting
15:59:09 <ad_rien_> ++
15:59:15 <pbressan> thanks
15:59:18 <ad_rien_> #endmeeting