15:00:03 <Menthos> #startmeeting massively_distributed_clouds
15:00:04 <openstack> Meeting started Wed Jun  7 15:00:03 2017 UTC and is due to finish in 60 minutes.  The chair is Menthos. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:07 <openstack> The meeting name has been set to 'massively_distributed_clouds'
15:00:07 <Menthos> #chair ad_rien_
15:00:08 <openstack> Current chairs: Menthos ad_rien_
15:00:19 <ad_rien_> Hi guys
15:00:22 <ad_rien_> #topic roll call
15:00:22 <Menthos> Hello guys
15:00:27 <msimonin> o/
15:00:37 <banhgao> o/
15:00:40 <ansmith> o/
15:00:43 <kgiusti> o/
15:00:46 <mabderrahim> o/
15:00:47 <ad_rien_> please add your name in the pad
15:01:06 <ad_rien_> #info agenda
15:01:06 <ad_rien_> #link https://etherpad.openstack.org/p/massively_distributed_ircmeetings_2017 675
15:02:01 <knikolla> o/
15:02:45 <ad_rien_> ok
15:02:49 <ad_rien_> so let's start
15:03:08 <ad_rien_> parnexius should join us soon
15:03:17 <ad_rien_> so I think we can move to the first item
15:03:24 <pbressan> he is on
15:03:32 <parnexius> goodday!
15:03:35 <ad_rien_> Just saw it yes
15:03:35 <georgk> #info Georg Kunz
15:03:38 <ad_rien_> Hi parnexius
15:03:43 <ad_rien_> #topic announcements
15:03:57 <ad_rien_> so from my side
15:04:26 <ad_rien_> we exchanged a few emails with the foundation and cockroach folks. We arranged a meeting
15:04:37 <ad_rien_> for June the 16th.
15:04:46 <ad_rien_> more information will be delivered later.
15:05:14 <ad_rien_> Then we exchanged also a couple of emails with other WG Chairs in order to see how we can improve cross collaborations.
15:05:29 <ad_rien_> jamemcc was in charge of finding the best slot. He opened a doodle.
15:05:51 <ad_rien_> But I don't know whether a final slot has been identified.
15:05:53 <ad_rien_> jamemcc:  ?
15:06:12 <ad_rien_> maybe you can give us a few details regarding this meeting
15:06:47 <ad_rien_> ok not sure jamemcc is available.
15:07:22 <parnexius> ad_rien: please let me know the details when you find out.
15:07:24 <ad_rien_> so last point I want to announce from my side is that we are going to change the tag for the emails from MassivelyDistributed to FEMDC
15:07:51 <ad_rien_> shorter and ….shorter
15:08:05 <msimonin> :)
15:08:07 <Menthos> #info email tag will now be FEMDC
15:08:08 <ad_rien_> so FEMDC for Fog / Edge / Massively Distributed Clouds
15:08:41 <ad_rien_> so I will make an emal to announce that on the ML and update the wiki page
15:09:10 <ad_rien_> #action ad_rien_ announce the new tag on the ML and on the wiki page
15:09:17 <ad_rien_> that's all from my side
15:09:33 <ad_rien_> so guys the floor is yours
15:10:02 <ad_rien_> ok
15:10:06 <ad_rien_> so seems not
15:10:09 <parnexius> Small update on my side:
15:10:13 <ad_rien_> ok sorry
15:10:20 <ad_rien_> please parnexius go on
15:10:29 <parnexius> Please note my new email address paul-andre.raymond@b-yond.com
15:10:53 <parnexius> I will keep the parnexius handle for now... but that may change in the future.
15:11:17 <ad_rien_> ok
15:11:26 <parnexius> When we get to use cases.... I will give updates on that topic.
15:11:31 <parnexius> that is all
15:11:32 <ad_rien_> ok
15:11:47 <ad_rien_> Could you please update the wikipage parnexius
15:11:48 <ad_rien_> ?
15:11:56 <ad_rien_> with your new nick and email
15:12:18 <parnexius> I will take the action.
15:12:35 <ad_rien_> ok
15:12:39 <ad_rien_> anything else ?
15:12:54 <ad_rien_> if not we can switch to the AMQP point.
15:12:59 <ad_rien_> 1, 2
15:13:01 <ad_rien_> … 3..
15:13:06 <ad_rien_> ok so let's move to AMQP
15:13:14 <ad_rien_> #topic Roadmap AMQP
15:13:17 <kgiusti> hey!  ansmith want to cover kolla status?
15:13:38 <ansmith> good progress on kolla front as recorded in etherpad
15:13:52 <ansmith> blueprints to enable separate messaging backends and a role for the qdrouterd
15:14:03 <ansmith> two reviews in progress
15:14:26 <Menthos> #chair parnexius
15:14:28 <openstack> Current chairs: Menthos ad_rien_ parnexius
15:14:36 <msimonin> ansmith: that's great !
15:14:58 <ansmith> we then went back to log from last meeting to build out deliverables/roadmap
15:15:06 <ad_rien_> ansmith:  which line  in the pad please?
15:15:17 <ansmith> #704
15:15:40 <kgiusti> still some Q's about goals/deliverables...
15:16:06 <kgiusti> esp. in terms of tests and metrics desired this cycle
15:16:30 <kgiusti> up to now, we've tested only the messaging layer (clients of oslo.messaging)
15:16:47 <kgiusti> for thruput/latency against various mb tech (at load).
15:17:04 <msimonin> with ombt ?
15:17:14 <kgiusti> these are fairly specific (and static) load tests - I would think not very useful for FEMDC
15:17:19 <kgiusti> msimonin: yep!
15:17:39 <ad_rien_> I'm seeing ombt as micro bench
15:17:43 <msimonin> Did you test several topology of qdrouterd topology  ?
15:17:47 <ad_rien_> whereas Rally/….. can be macrobenchs
15:17:50 <ad_rien_> so both are useful
15:18:01 <msimonin> I mean qdrouterd in network mode ?
15:18:23 <kgiusti> msimonin: in general no - just rpc throughput/latency wrt a rabbitmq deployment (non clustered)
15:19:01 <kgiusti> So both micro (ombt2) and macro (ralley/osprofiler) for different message bus topologies?
15:19:11 <ad_rien_> yes
15:19:23 <msimonin> kgiusti: yes different bus topologies are in the scope (I guess)
15:19:29 <ad_rien_> I think that should be our experimental protocol
15:19:30 <kgiusti> testing multi-hop effect of latency/thruput
15:19:43 <kgiusti> and failure/recovery aspects
15:19:56 <kgiusti> kewl.
15:20:08 <ad_rien_> yes.
15:20:18 <msimonin> kgiusti ansmith One question regarding kolla integration
15:20:32 <kgiusti> The other bit of news is still no new maintainers for zeromq - that may impact testing.
15:20:33 <ad_rien_> I think we can open a thread and iterate by mail to move forward on that protocol
15:20:53 <kgiusti> ad_rien_: +1 will email FEMDC
15:20:57 <msimonin> is it planned to enable the deployment of a network of qdrouterd ?
15:21:29 <ansmith> yes, kolla-ansible provides an all-in-one and multinode inventory
15:21:49 <ansmith> intend to support multinode, it is still on the punchlist for the qdrouterd role
15:21:54 <msimonin> yes sure but I saw that the qdrouterd was configured in a standalone mode
15:22:17 <ansmith> not reflected in the patch yet
15:22:33 <msimonin> That's maybe too much for this patch ;à
15:22:51 <ansmith> yes, it may follow once the qdrouterd role lands
15:23:00 <msimonin> ansmith: cool :)
15:23:24 <msimonin> because I guess that's one of the thing we would like to experiment
15:23:53 <ansmith> +1
15:24:28 <ad_rien_> regarding the jepsen test,
15:24:44 <ad_rien_> while I like the idea I think it will be rather focus on the bus itself
15:25:01 <ad_rien_> not sure whether this can help us for the FEDMC
15:25:10 <ad_rien_> i.e. we already have ombt (thanks guys ;))
15:25:21 <ad_rien_> so ombt  + rally/… should be sufficient.
15:25:28 <ansmith> sounds good
15:25:30 <ad_rien_> what was your idea guys ?
15:25:51 <ansmith> the idea for jepsen was to understand the behaviors of the backends themselves
15:25:58 <ansmith> with regard to resiliency, etc.
15:26:02 <ad_rien_> ok +1
15:26:04 <ad_rien_> good point
15:26:23 <ad_rien_> I don't know whether rally has some injection fault scenarios?
15:26:44 <ansmith> yes, it injects network faults, etc. to see how service recovers
15:26:44 <ad_rien_> rcherrueau:  and msimonin have discovered osfault
15:27:02 <msimonin> #link https://os-faults.readthedocs.io/en/latest/
15:27:20 <ad_rien_> also from their side but seems not kolla/docker ready
15:27:28 <kgiusti> ooooh  - new shiney!!!
15:27:43 <ad_rien_> so we should probably investigate more in the rally scenarios.
15:27:53 <ansmith> agree
15:28:09 <kgiusti> ad_rien_: yep - ombt2 + Rally in the near term.
15:28:18 <msimonin> +1
15:28:54 <ad_rien_> ok so to summarize
15:29:07 <ad_rien_> action 1: start a thread for defining the experimental protocol
15:29:45 <ad_rien_> action 2: Inria can give a first try to deploy qpid router with EnoS
15:30:01 <ad_rien_> guys do you see other actions?
15:30:07 <ad_rien_> that we can do in a short term?
15:30:33 <msimonin> network of qdrouterd ?
15:30:40 <ad_rien_> kgiusti: ansmith: if you are interested we can give you an open access to G5K
15:31:03 <ad_rien_> so you can perform some integration tests with EnOS also from your side (if it helps).
15:31:22 <kgiusti> msimonin: we should really focus on that - single router doesn't buy us much in terms of distribution and redundancy
15:31:29 <ansmith> that would be very helpful
15:31:32 <msimonin> kgiusti: +1
15:31:33 <kgiusti> ad_rien_: yes!
15:31:34 <ad_rien_> or if you have a testbed you can also use EnOS directly
15:31:51 <msimonin> kgiusti: how can we help ?
15:32:22 * ad_rien_ takes his Discovery/Inria chair hat
15:32:33 <parnexius> Is there more details on the high level use cases we are trying to test?
15:32:47 <ad_rien_> Please note that the engineer that will focus on AMQP experiments should not arrive before July
15:33:12 <kgiusti> parnexius: I think that's what we need to iron out first (via email thread)
15:33:42 <parnexius> Sounds good.
15:33:51 <kgiusti> parnexius: for example, what's a good topology for say nova?  router on controller, per conductor, per compute?
15:33:52 <ad_rien_> so to be honest, Inria will put significant efforts only when this engineer will be hired. Right now, we can only provided minimal support
15:34:08 <ad_rien_> s/provided/provide
15:34:28 <ad_rien_> just to be sure that we do not take too much commitments
15:34:33 <kgiusti> ad_rien_: np - we can define the test scenarios first, test the smaller ones here are rh
15:34:43 <ad_rien_> ok
15:34:46 <ad_rien_> maybe yes
15:34:54 <ad_rien_> 1./ test scenarios
15:35:03 <ad_rien_> 2./ required testbeds
15:35:09 <ad_rien_> 3./ divide and conquer
15:35:18 <ad_rien_> ok
15:35:31 <kgiusti> ad_rien_: +1
15:35:56 <ad_rien_> kgiusti would you agree to start the thread for identifying the scenarios
15:35:56 <ad_rien_> ?
15:36:07 <kgiusti> ad_rien_: certainly!
15:36:28 <ad_rien_> #action Inria give a try to deploy qpid with EnOS
15:36:57 <ad_rien_> #action kgiusti open a thread for identifying the experimental protocol
15:36:57 <ad_rien_> ok
15:37:06 <ad_rien_> anything else on that topic or we can switch to the next one ,
15:37:07 <ad_rien_> ?
15:37:17 <kgiusti> I'm done :)
15:37:42 <ad_rien_> msimonin:  s/#action Inria/#action msimonin
15:37:44 <ad_rien_> :-)
15:37:49 <msimonin> LOL
15:37:54 <ad_rien_> :-P
15:38:02 <ad_rien_> ok so next topic
15:38:51 <Menthos> ansmith: what about Strawman?
15:39:14 <ansmith> ah, it was a stab at putting some dates down
15:39:22 <ad_rien_> milestones?
15:39:25 <ad_rien_> :-)
15:39:37 <Menthos> ansmith: okay :-)
15:39:41 <ansmith> if we track 1. and 2. above it would help us assess progress towards milestonew
15:39:43 <ad_rien_> ok so next topic
15:40:38 <ad_rien_> #topic roadmap cockroach
15:40:54 <ad_rien_> ok so as I announced at the begining
15:41:07 <ad_rien_> we succeeded to get a positive reply from cockroach folks.
15:41:42 <ad_rien_> and we arranged a one hour meeting to present the use-case in general and to ask a few couples of questions
15:41:47 <ad_rien_> regarding cockroach internals
15:42:26 <ad_rien_> we copy/paste the question in the pad
15:42:32 <ad_rien_> these are general questions
15:42:38 <ad_rien_> if you have additional ideas please
15:42:45 <ad_rien_> feel free to complete it ;)
15:43:32 <ad_rien_> ok so that' s all on that point.
15:43:51 <ad_rien_> if there is no comment/questions then we can move to the next point;
15:44:13 <ad_rien_> #topic roadmap identification use-cases
15:44:21 <ad_rien_> parnexius: the floor is yours
15:44:38 <parnexius> Thanks.
15:44:56 <parnexius> The first point is that I would like to request for help.
15:45:23 <parnexius> Please let me know if you want to contribute to this effot.
15:45:49 <ad_rien_> there was a person in Boston
15:45:55 <ad_rien_> Andrew XXXX
15:46:10 <ad_rien_> but unfortunately I didn't find his contact.
15:46:26 <parnexius> I will look him up n the attendee list. There was just one andrew.
15:46:28 <ad_rien_> Maybe on can send an email on the ML
15:46:46 <ad_rien_> (dev, operator,…) and see whether we got some answer
15:47:02 <parnexius> Any Ukasick from ATT
15:47:14 <ad_rien_> something like. Ok for this cycle we agree to move forward on  (i) AMQP (ii)  and (iii) use-case identifications.
15:47:37 <jamemcc> Jamey (with AT&T hat on):  There was a Boston Talk somewhat on this topic in Boston.  I believe that the speaker - Kandan should want to participate - or more likely assign to participate.
15:47:43 <jamemcc> Looking for link to the talk
15:48:11 <parnexius> OK. I saw both talks by Kandan. Can you make an intro?
15:48:37 <ad_rien_> ok sounds great thanks jamemcc
15:48:51 <parnexius> Second question on logistics.
15:48:54 <jamemcc> Yes Paul
15:49:17 <parnexius> What is the best way to share information in this group?
15:49:29 <ad_rien_> mL
15:49:32 <ad_rien_> dev
15:49:45 <parnexius> I have some notes on powerpoint .... are you OK with attachments on the email List?
15:49:47 <ad_rien_> so we can make references to threads when relevant
15:49:54 <ad_rien_> put the link
15:50:00 <ad_rien_> and your slides online
15:50:02 <ad_rien_> ?
15:50:09 <ad_rien_> would it be a good solution from your side
15:50:28 <ad_rien_> ok sorry (back to US today so rather tired from my side)
15:50:31 <parnexius> What would be online ? Github? Slideshare?
15:50:45 <jamemcc> #link  https://www.youtube.com/watch?v=7DuKzaBaRwY Telco Edge Cloud Use Cases
15:50:51 <ad_rien_> I was saying that we should use the dev ML because then it enables us to make links towards relevant threads
15:51:14 <ad_rien_> when you want to attach some documents just put them online and add the link within the mail you will send on the ML
15:51:24 <ad_rien_> is it a good solution from your side parnexius ?
15:51:26 <parnexius> OK. Sounds good.
15:51:29 <parnexius> +1
15:51:32 <ad_rien_> ok
15:51:37 <parnexius> Last point.
15:51:40 <ad_rien_> please note that we changed the tag
15:51:54 <ad_rien_> [MassivelyDistributed] -> [FEDMC]
15:51:58 <parnexius> I have put some notes on etherpad about what I think some test use cases are.
15:52:30 <ad_rien_> ok
15:52:32 <ad_rien_> 5é
15:52:33 <parnexius> There may be other ways to think about use cases: (service scenarios, topology...)
15:52:35 <ad_rien_> 52min
15:52:43 <parnexius> I think we want to cover all.
15:52:50 <ad_rien_> would it be possible to discuss that deeper
15:52:53 <ad_rien_> during our next meeting
15:53:01 <ad_rien_> we will put it sooner in the agenda
15:53:23 <parnexius> I will start with a thread on the mailing list and report back next meeting.
15:53:28 <ad_rien_> I would appreciate to get some feedbacks from jamemcc regarding the last LCCO meeting and the extreme testing challenges.
15:53:35 <ad_rien_> ok thanks parnexius
15:53:46 <ad_rien_> can we move to the next topic?
15:53:55 <parnexius> I am done
15:53:57 <ad_rien_> ok thanks
15:54:20 <ad_rien_> #action parnexius start a thread on the ML: objective gather external/additional contributors
15:54:36 <ad_rien_> #action adrien send an email to the foundation to collect a few email addresses
15:55:05 <ad_rien_> #action jamey introduce Kandan to parnexius
15:55:06 <ad_rien_> ok
15:55:11 <ad_rien_> so let's move to the next topic
15:55:16 <ad_rien_> #topic EnoS
15:55:34 <ad_rien_> jamemcc:  can you please tell us
15:55:42 <ad_rien_> what is the current status regarding the discussion within the LCCO
15:55:43 <ad_rien_> ?
15:55:46 <jamemcc> For Extreme Testing - the main work is now going on in this Atlasssian Space - lke an Etherpad but with more join editign features: #link https://openstack-lcoo.atlassian.net/wiki/display/LCOO/Working+Space+for+Exteme+Testing+and+related+topics
15:55:48 <ad_rien_> did you make progress
15:56:30 <ad_rien_> so what is the idea (just 4 min left)
15:56:33 <ad_rien_> we read the page
15:56:36 <ad_rien_> and prepare questions?
15:56:43 <jamemcc> The section that mostly describes the work is in the Tasks section.  I can't really give better stytus on the tasks.
15:56:54 <ad_rien_> ok
15:57:00 <ad_rien_> maybe we can discuss deeper next time too?
15:57:03 <jamemcc> Yeah - I can try to bring a specialty team member to the next session
15:57:06 <ad_rien_> cool
15:57:21 <ad_rien_> the idea is to see whether we can combine our effort
15:57:34 <ad_rien_> ok
15:57:36 <jamemcc> OK good from our side
15:57:40 <ad_rien_> thanks
15:57:44 <ad_rien_> We have a todo from our side
15:57:56 <ad_rien_> but we will discuss next time too
15:57:57 <ad_rien_> sorry
15:57:59 <ad_rien_> for the timing today
15:58:06 <ad_rien_> I don't think we have time for opendiscussion
15:58:15 <ad_rien_> unless there is something really important
15:58:17 <ad_rien_> if not please
15:58:20 <ad_rien_> put it in the pad
15:58:21 <jamemcc> I'll put Cross WG info in the pad
15:58:26 <ad_rien_> we will discuss next time
15:58:29 <ad_rien_> thanks jamemcc
15:58:31 <ad_rien_> +1
15:58:38 <ad_rien_> ok thanks guys for attending the meeting
15:58:46 <parnexius> Thank you!
15:58:46 <ad_rien_> and for all your contributions
15:58:50 <msimonin> thanks ad_rien_
15:58:52 <ad_rien_> let's keep in touch by mail
15:58:55 <ad_rien_> lot of actions
15:58:57 <ad_rien_> ++
15:58:58 <ad_rien_> ;)
15:59:02 <Menthos> thanks all
15:59:03 <Menthos> #endmeeting