15:02:05 <ad_rien_> #startmeeting massively_distributed_clouds
15:02:06 <openstack> Meeting started Wed Jul  5 15:02:05 2017 UTC and is due to finish in 60 minutes.  The chair is ad_rien_. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:10 <openstack> The meeting name has been set to 'massively_distributed_clouds'
15:02:22 <ad_rien_> #chair ad_rien_
15:02:23 <openstack> Current chairs: ad_rien_
15:02:57 <ad_rien_> #chair par`
15:02:58 <openstack> Current chairs: ad_rien_ par`
15:03:08 <ad_rien_> #topic roll call
15:03:11 <ad_rien_> Hi guys
15:03:18 <ad_rien_> sorry for being late
15:03:20 <ad_rien_> so
15:03:28 <ad_rien_> Who is there today?
15:03:57 <rcherrueau> o/
15:04:02 <msimonin> o/
15:04:05 <mabderrahim> o/
15:04:15 <par`> o/
15:04:22 <ad_rien_> #info agenda
15:04:22 <ad_rien_> #link https://etherpad.openstack.org/p/massively_distributed_ircmeetings_2017  Agenda line 860
15:04:24 <ansmith> o/
15:04:25 <kgiusti> o/
15:05:08 <pbressan> o/
15:05:15 <ad_rien_> ok so before starting I would like to inform you that I will have to leave at 15:45 from my side
15:05:23 <ad_rien_> par`:  could you please end the meeting
15:05:24 <ad_rien_> ?
15:05:39 <par`> sure will
15:05:46 <ad_rien_> thanks
15:05:49 <banhgao> o/
15:05:52 <ad_rien_> #chair msimonin
15:05:53 <openstack> Current chairs: ad_rien_ msimonin par`
15:06:18 <ad_rien_> #chair @rcherrueau
15:06:19 <openstack> Warning: Nick not in channel: @rcherrueau
15:06:20 <openstack> Current chairs: @rcherrueau ad_rien_ msimonin par`
15:06:28 <ad_rien_> #chair rcherrueau
15:06:29 <openstack> Current chairs: @rcherrueau ad_rien_ msimonin par` rcherrueau
15:06:29 <ad_rien_> ok
15:06:41 <rcherrueau> wow just got promoted
15:06:41 <ad_rien_> so please remind to add your nick/name in the pad thanks
15:06:44 <ad_rien_> ;)
15:06:54 <ad_rien_> so regarding the announcement
15:07:02 <ad_rien_> #topic announcements
15:07:43 <ad_rien_> I do not have particular information apart be pleased to see folks from the FKB institution ;)
15:07:52 <ad_rien_> Welcome banhgao
15:08:11 <ad_rien_> Maybe you can introduce you a bit more and explain what are you doing ? and what is your target?
15:08:28 <ad_rien_> banhgao (Daniel ?)
15:08:47 <ad_rien_> do you want to tell us a bit more about fbk ?
15:09:06 <ad_rien_> and why you are there (I can do it if you prefer but I think you are the most relevant person to do that ;))
15:09:31 <ad_rien_> banhgao:  ?
15:09:37 <banhgao> Hello everybody
15:10:42 <ad_rien_> (FYI, I just add a smalll sentence in the pad line 875)
15:11:01 <banhgao> FBK is a research foundation in Trento (Italy). Our research unit is currently working on a fog computing platform.
15:11:04 <ad_rien_> dunno whether we should say more but if you want to, please the floor is yours
15:11:46 <ad_rien_> ok
15:11:57 <ad_rien_> so let's move forward.
15:12:20 <ad_rien_> Second announcement, I encourage you to go through the Openstack etherpad I put line 877
15:12:36 <ad_rien_> it is rather interesting to see what are the current technical challenges core developers are facing.
15:13:24 <ad_rien_> and that's all from my side
15:13:38 <ad_rien_> Does anyone want to announce something special ?
15:14:22 <par`> Do you have any insight in OPNFV?
15:14:44 <ad_rien_> not yet
15:14:49 <par`> I hear of a new group being started that relates to this.
15:14:55 <ad_rien_> I'm still waiting for some informations from jamemcc ?
15:15:08 <ad_rien_> I don't know whether he is online. I put this point in the open discussion.
15:15:23 <jamemcc> Hi
15:15:28 <jamemcc> JOined late
15:15:34 <ad_rien_> par`:  do you have some links related to this new group?
15:15:44 <ad_rien_> jamemcc:  Hi, good to see you online.
15:15:53 <jamemcc> THanks
15:16:00 <par`> give me min .... Bryan Sullivan from AT&T created a wiki on it.
15:16:09 <ad_rien_> We were asking whether you have some news regarding what's happen on the NFV/LCCO and the gross WG chair meeting ?
15:16:25 <jamemcc> No new group from my perspective - FYI - I am chair of the Large Contributing OpenStack Operators (LCOO) wG
15:16:55 <par`> here is the link I saw: https://wiki.opnfv.org/display/PROJ/Multi-Access+Edge
15:17:01 <ad_rien_> par`:  ack. jamemcc: do you have some news regarding the cross WG chair meeting?
15:17:25 <jamemcc> Yes - we ahve been working to get better communication channel going across the Workign Groups - incuging this one, Operators Telco NFV, LCOO and OPNFV
15:17:38 <ad_rien_> #link https://wiki.opnfv.org/display/PROJ/Multi-Access+Edge a new WG on the OPNFV side.
15:17:51 <jamemcc> User Committee want's to have it as part of User Committee Meetings so it was just a matter of when.
15:17:53 <ad_rien_> #action ad_rien_ should give a look to this new WG.
15:18:56 <jamemcc> We had a poll and the User Committee watend to query/urge a few more to participate and they have now and the proposal is for the first such cross WG meeting at User Committee to be July 19
15:18:57 <par`> jamecc: what is the next step from our perspective?
15:18:59 <ad_rien_> jamemcc:  I thought you opened a doodle to try to fix a final slot?
15:19:34 <ad_rien_> jamemcc:  ok. Did they send an official email/invitation? Can you please tell us the time on July, the 19th?
15:20:10 <jamemcc> This is mostly documented in User Committee ML: http://lists.openstack.org/pipermail/user-committee/2017-June/002183.html
15:20:41 <ad_rien_> #link http://lists.openstack.org/pipermail/user-committee/2017-June/002183.html first cross WG discussion
15:21:00 <jamemcc> Hmm - I see a issue - In the ML - I put JUly 17
15:21:12 <jamemcc> But it shoudl eb ealry on a Wednesday - So July 18
15:21:22 <jamemcc> July 19
15:21:54 <ad_rien_> ?
15:21:56 <jamemcc> If you can attend the User Committee next Monday July 10 to try to push this through, please do
15:22:07 <ad_rien_> I will be offline unfortunately
15:22:12 <ad_rien_> can you please keep us in touch?
15:22:23 <ad_rien_> just send me a mail if it is possible?
15:22:36 <jamemcc> Then watch for announcement for July 19 meeting and come prepared to listen to the other WG and offer your advice when co-topics come up
15:22:46 <ad_rien_> ok
15:22:57 <jamemcc> Will do
15:23:00 <ad_rien_> So I note July 19 5:00 UTC
15:23:02 <ad_rien_> ok ?
15:23:05 <jamemcc> Yes
15:23:09 <ad_rien_> ok thanks
15:23:15 <ad_rien_> so let's move forward in the agenda
15:23:22 <ad_rien_> #topic on-going actions
15:23:32 <ad_rien_> Last meeting we did not discuss the use-case
15:23:39 <ad_rien_> So I would propose to start by this item today
15:23:43 <ad_rien_> Is it ok for everyone ?
15:23:51 <ad_rien_> par`: the floor is yours
15:23:59 <par`> Thank you.
15:24:16 <par`> I have shared some slides on the mailing list yesterday.
15:24:29 <par`> It would be good for everyone to have a look and give feedback.
15:24:57 <par`> Use case is an ambiguous term.. and it encompasses many things that we have to address.
15:25:21 <par`> I suggest we agree on the aspects that need to be addressed for specific use cases.
15:25:40 <par`> 1- are we talking about edge cloud or about federated cloud?
15:25:59 <par`> 2- are we talking about IOT, or AR or another type of service
15:26:19 <par`> 3- How do we divide Openstack components among nodes.
15:26:23 <ad_rien_> edge is the priority of this WG. considering that an edge platform is an infrastructure composed of several edge data centers
15:26:32 <ad_rien_> 2./ can you please clarify what do you mean by AR ?
15:26:45 <par`> Augmented reality
15:26:47 <ad_rien_> 3./ this is the overall objective of this WG .)
15:26:50 <ad_rien_> ;)
15:26:57 <ad_rien_> of or 2./ I think we can consdier both
15:26:59 <ad_rien_> why not?
15:27:15 <ad_rien_> I mean the industrial internet and the Tactile internet are both leveraing IoT and AR.
15:27:18 * ad_rien_ is looking for a link
15:28:35 <par`> Agreed... I think they all are in scope. But wouldn't it be good to identify which one we focus on.... in terms of use case. So we can move forward on the technical tests
15:28:53 <banhgao> In our work at FBK we are working on mobile edge platform to support IoT devices. We can provide some use cases for that.
15:29:01 <ad_rien_> +1
15:29:06 <par`> +1
15:29:49 <par`> banhgao: do you already have an architecture in mind that we can use as a starting point?
15:29:56 <ad_rien_> Telcos with CRAN use-cases also need FEMDC infrastructures
15:31:03 <ad_rien_> They had a paper to the last IEEE CloudCom conference
15:31:14 <ad_rien_> that presents the architecture at coarse-grained
15:31:36 <banhgao> @par` By now we are using a single cloud with an intermediate fog level and gateways to connect to IoT devices. I can leave some links in the pad
15:31:43 <ad_rien_> unless I missunderstood, the idea was a central DC and several DCs deployed at the edge
15:32:04 <ad_rien_> banhgao:  can you please put the link in the pad.
15:32:27 <par`> That is definitely an interesting case for this group. If you can share the link, I will add it to the deck.
15:33:06 <par`> The last part of the use case would be the lifecycle operations we consider.
15:33:25 <par`> Are we looking at measuring how fast we can instantiate 1000 VMs?
15:33:43 <par`> Are we looking at measuring how easily we can do failure recovery ?
15:33:57 <par`> I have listed about a dozen such operations in the deck.
15:34:11 <ad_rien_> #link https://opentechdiary.wordpress.com/2015/07/22/part-5-a-walk-through-internet-of-things-iot-basics/ a view of IoT/Industrial Internet and Internel of skills (aka tactile internet)
15:34:34 <ad_rien_> OK so let's try to define concrete actions.
15:34:53 <ad_rien_> For the next time, every person interested by the use-case action should put his/her comments in the slides.
15:35:06 <ad_rien_> Do you think it is enough to move forward ?
15:35:43 <par`> How many use cases do we want to target? Should we start with just one? and then move forward?
15:36:13 <ad_rien_> Yes I think we should identify a few (let's say no more than 5)
15:36:27 <ad_rien_> and then try to identify which is the simplest and the most difficult/complex
15:36:35 <ad_rien_> in terms of scientific/technical challenges
15:36:49 <ad_rien_> I think that the use-case that is envisioned by FBK is something we can deliver
15:37:13 <ad_rien_> without involving important changes in OpenStack
15:37:30 <par`> actions would be to fully documeent the FBK use case for next week so we can vote on it.
15:37:37 <ad_rien_> more distributed scenarios (i.e. involving a huge number of DCs at the edge can become difficult)
15:37:42 <par`> and then to come to the meeting with additional use cases.
15:37:58 <ad_rien_> banhgao:  do you think it is feasible according to the vacation?
15:38:26 <ad_rien_> Can you consolidate informations in the current presentation
15:38:43 <ad_rien_> #link https://docs.google.com/presentation/d/1sBczuC2Wu1d_misBmPahLPdvyhOI4QuVy129EHunuUM/edit#slide=id.g1f7f1a38ce_2_95 current use-case presentation
15:39:00 <ad_rien_> for the next meeting (i.e. on July, the 19th if I'm right) ?
15:39:06 <par`> If people can edit the document, this is good. If not, please send updates to me and I will do the edit.
15:39:34 <ad_rien_> #action ad_rien_ go through the google use-case presentation and add comment (if not possible send it to par`)
15:39:49 <ad_rien_> #action all	 do the same ;)
15:40:25 <par`> ad_rien_: one last point.
15:40:53 <par`> I feel networking requires special attention.
15:41:21 <ad_rien_> please elaborate a bit more ?
15:41:26 <banhgao> We can provide detailed information about the platform and the use-cases for the next meeting.
15:41:27 <par`> So when people review and comment, it would be good if they shared thoughts on how to implement neutron or other networking solution at the edge.
15:41:43 <ad_rien_> #action banhgao will provide additional information related to the FBK use-case
15:41:55 <par`> e.g. should we use L2 or L3 networking at the edge.
15:42:05 <ad_rien_> banhgao:  thanks ack
15:42:19 <ad_rien_> par`:  +1
15:42:30 <par`> that is it for me.
15:42:32 <ad_rien_> but just to avoid missunderstanding
15:42:50 <ad_rien_> are you talking about control plane exchanges or data plane or both?
15:43:15 <par`> My initial focus was control plane.... but the deck does touch on user plane too.
15:43:26 <ad_rien_> FYI, there will be a new PhD applicant (starting next october) between Inria and Orange to deal with those challenges.
15:43:27 <ad_rien_> ok
15:43:29 <ad_rien_> so right
15:43:31 <ad_rien_> I agree
15:43:43 <ad_rien_> is this point already highlighted in your slides?
15:43:55 <ad_rien_> If yes great, if not, may I ask you to add  a note please?
15:44:12 <ad_rien_> ok I will have to go from my side.
15:44:22 <par`> #action par` to add a note to slides about networking.
15:44:29 <ad_rien_> Before leaving I just want to highlight an important point to discuss today
15:44:30 <ad_rien_> pelase
15:44:43 <ad_rien_> it is related to the deadline for submitting presentations to the next summit
15:44:53 <ad_rien_> so the questions that should be discussed are:
15:45:02 <ad_rien_> 1./ who plans to go to Sidney
15:45:08 <ad_rien_> 2./ who plans to submit a presentaion
15:45:26 <ad_rien_> 3./ will we be enough persons to have a f2f meeting in Sidney
15:45:35 <ad_rien_> thanks guys for addressing these questions please
15:45:51 <ad_rien_> thanks par` for chairing the end of the meeting
15:45:52 <ad_rien_> ++
15:46:07 <par`> thanks.
15:46:19 <par`> shoudl we move to the next topic?
15:47:02 <par`> AMQP alternatives
15:47:12 <kgiusti> hi - I put some details in the epad
15:47:15 <par`> #topic AMQP Alternatives
15:47:16 <kgiusti> quick summary:
15:47:30 <kgiusti> kolla-ansible patches complete and in review
15:47:54 <kgiusti> micro-benchmarks for the message bus are being worked on (see epad for link)
15:48:31 <kgiusti> Though in light of today's discussion, I propose we hold off on defining any system level topologies and tests until the use-cases are defined
15:49:12 <kgiusti> We need to define the message bus topology/configuration within the context of the use-case for the tests to have significant meaning IMHO
15:49:25 <kgiusti> that's all I have for today.
15:49:41 <par`> kgiusti: aren't there things we can move forward that are shared accross use cases?
15:50:03 <kgiusti> par`: certainly the messaging-level tests
15:50:24 <kgiusti> to get an understanding of the behaviors of different tech and topologies
15:51:07 <par`> So it does make sense to focus on messaging-level tests for now while we discuss use cases.
15:51:09 <kgiusti> and we can do some base line rally tests for sure
15:51:20 <kgiusti> par`: yeah, that's my inclination.
15:51:59 <par`> Are you taking that action?
15:52:09 <kgiusti> we can 'optimize' the message bus to the particular use case, then analyze that.
15:52:15 <kgiusti> par`: sure!
15:52:57 <par`> #action: kgiusti to focus on messaging-level tests and do some base line rally tests while work on use cases continue.
15:53:46 <par`> Can we move on to cockroach quickly before adjourning?
15:53:54 <par`> #topic Cockroach
15:54:02 <par`> Any updates?
15:54:03 <rcherrueau> I am working on that with a student
15:54:10 <rcherrueau> So, as expected ...
15:54:15 <rcherrueau> things don't work out of the box!
15:54:22 <rcherrueau> The first issue is applying all database migration computed by SQLAlchemy-migrate
15:54:27 <rcherrueau> To make things clear for everyone: Keystone relies on SQLAlchemy-migrate to deal with database schema changes
15:54:38 <rcherrueau> I don't look into the code of SQLAlchemy-migrate but I think it uses some "introspection/intercession magic" on database to gather information on the current state of the schema and then apply migration.
15:54:42 <rcherrueau> Of course, this magic stuff is not implemented by cockroachdb dialect.
15:54:56 <rcherrueau> I am currently working on a minimal example code to discuss with cockroachlab folks directly.
15:55:33 <rcherrueau> Fortunately, things are not stuck here.
15:55:46 <par`> Any specific action we should capture?
15:55:50 <rcherrueau> We are actually working on dumping pgsql into cockroachdb to bypass migration.
15:56:09 <rcherrueau> nothing special right now
15:56:27 <par`> OK thanks.
15:56:37 <par`> we have three minutes left.
15:56:43 <par`> any other comments?
15:57:03 <par`> #topic Open Discussion
15:57:58 <par`> Anyone remembers the command to end the IRC meeting?
15:58:07 <par`> I could use help here.
15:58:12 <rcherrueau> #endmeeting